source: projects/specs/trunk/g/gstreamer08/gstreamer08-vl.spec @ 521

Revision 521, 10.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define srcname gstreamer
2
3%define _glib2          2.4.7
4%define _libxml2        2.6.15
5
6## exclude arches that don't work for now.
7#ExcludeArch: x86_64 ia64 alpha s390 s390x
8
9Name: gstreamer08
10Version: 0.8.12
11# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
12%define major  0.8
13Release: 2%{?_dist_release}
14Summary: GStreamer streaming media framework runtime.
15Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
16Group: System Environment/Libraries
17License: LGPL
18URL: http://gstreamer.net/
19Source:http://gstreamer.freedesktop.org/src/gstreamer/%{srcname}-%{version}.tar.bz2
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21# alpha
22Patch10: gstreamer-0.6.3-alpha-noWerror.patch
23
24%define po_package %{srcname}-%{major}
25
26Requires: glib2 >= %_glib2
27Requires: libxml2 >= %_libxml2
28Requires: popt > 1.6
29BuildRequires: glib2-devel >= %_glib2
30BuildRequires: libxml2-devel >= %_libxml2
31BuildRequires: bison
32BuildRequires: gtk-doc >= 1.1
33BuildRequires: zlib-devel
34BuildRequires: popt-devel > 1.6
35BuildRequires: flex
36BuildRequires: ghostscript
37Obsoletes: gstreamer-tools
38Conflicts: gstreamer < 0.9
39
40### documentation requirements
41# documentaion build don't work well on 0.8.9
42# so, disabled following dependency
43#BuildRequires: openjade
44#BuildRequires: docbook-style-dsssl docbook-dtd31-sgml docbook-style-xsl
45#BuildRequires: docbook-utils
46#BuildRequires: transfig xfig
47
48%description
49GStreamer is a streaming-media framework, based on graphs of filters which
50operate on media data. Applications using this library can do anything
51from real-time sound processing to playing videos, and just about anything
52else media-related.  Its plugin-based architecture means that new data
53types or processing capabilities can be added simply by installing new
54plugins.
55
56%package devel
57Summary: Libraries/include files for GStreamer streaming media framework.
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: glib2-devel >= %_glib2
61Requires: libxml2-devel >= %_libxml2
62
63%description devel
64GStreamer is a streaming-media framework, based on graphs of filters which
65operate on media data. Applications using this library can do anything
66from real-time sound processing to playing videos, and just about anything
67else media-related.  Its plugin-based architecture means that new data
68types or processing capabilities can be added simply by installing new   
69plugins.
70
71This package contains the libraries and includes files necessary to develop
72applications and plugins for GStreamer.
73
74
75%prep
76%setup -q -n %{srcname}-%{version}
77%ifarch alpha
78%patch10 -p1
79%endif
80
81%build
82%configure \
83  --with-cachedir=%{_var}/cache/gstreamer-%{major} \
84  --with-configdir=/etc/gstreamer \
85  --disable-plugin-builddir \
86  --disable-tests --disable-examples \
87  --disable-docs-build \
88  --disable-static \
89  --with-html-dir=$RPM_BUILD_ROOT%{_datadir}/gtk-doc/html \
90  --disable-debug
91
92make %{?_smp_mflags}
93
94%install 
95[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
96
97%makeinstall
98
99mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
100
101/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.a
102/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
103/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
104/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
105
106%find_lang %{po_package}
107
108# remove gst-* provided by newer gstreamer
109for i in complete compprep feedback inspect launch md5sum register typefind xmlinspect xmllaunch ; do
110        %__rm -f %{buildroot}%{_bindir}/gst-$i
111done
112
113%clean
114[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
115
116%post
117/sbin/ldconfig
118env DISPLAY= %{_bindir}/gst-register-%{major} > /dev/null 2> /dev/null
119
120%postun -p /sbin/ldconfig
121
122%files -f %{po_package}.lang
123%defattr(-, root, root)
124%doc AUTHORS ChangeLog COPYING README NEWS
125%doc TODO ABOUT-NLS REQUIREMENTS DOCBUILDING
126%{_bindir}/*
127%dir %{_libdir}/gstreamer-%{major}
128%{_libdir}/gstreamer-%{major}/*.so*
129%{_libdir}/*.so.*
130%{_mandir}/man1/*
131%dir %{_var}/cache/gstreamer-%{major}
132
133%files devel
134%defattr(-, root, root)
135%dir %{_includedir}/%{srcname}-%{major}
136%{_includedir}/%{srcname}-%{major}/*
137#{_libdir}/*.a
138%{_libdir}/*.so
139%{_libdir}/pkgconfig/gstreamer*.pc
140%{_datadir}/aclocal/*.m4
141
142%changelog
143* Tue May  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-2
144- removed lib*.a files
145- changed Group to System Environment/Libraries
146
147* Wed Sep 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-1
148- new upstream release
149- applied new versioning policy
150- spec in UTF-8
151
152* Fri Jan 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
153- fix typo
154- add Conflicts: gstreamer < 0.9
155
156* Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
157- build for compatibility (gstreamer->gstreamer08)
158- remove %%{_bindir}/gst-* provided by newer gstreamer
159
160* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
161- new upstream release
162
163* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
164- new upstream release
165
166* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
167- new upstream release
168- removed dependancy related to documentaion build
169
170* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
171- new upstream release
172
173* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
174- new upstream release
175
176* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
177- update alpha-noWerror patch (Patch10)
178
179* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
180- new upstream release
181
182* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
183- new upstream release
184
185* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
186- new upstream release
187
188* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
189- build without -Werror on alpha (Patch10)
190
191* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
192- new upstream release
193
194* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
195- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
196
197* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
198- fix broken %files entries..
199
200* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
201- new upstream release
202
203* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
204- build for Vine Linux
205
206* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
207- Add patch1 to fix C++ plugins on ia64
208
209* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
210- %post -p was wrong
211
212* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
213- explicitly add %{_libdir}/libgstreamer-{major}.so
214- explicitly add %{_libdir}/libgstcontrol-{major}.so
215
216* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
217- bump release
218
219* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
220- move .so files out of -devel
221
222* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
223- new version 0.5.0
224- require docbook-style-xsl
225- add gstreamer-tools package too
226- New patch to use the right docbook prefix.
227
228* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
229- downgrade to a release candidate.  Should work better on other arches
230- build without Werror
231
232* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
233- update to new version.  Remove ExcludeArch
234
235* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
236- excludearch some arches
237
238* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
239- import into CVS and build "officially"
240- use smp_mflags
241- temporarily disable docs build, doesn't seem to work
242
243* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
244- 0.4.2
245
246* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
247- 0.4.1
248
249* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
250- minor cleanups
251
252* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
253- moved header location
254
255* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
256- added popt
257- removed .la
258
259* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
260- added release of gstreamer to req of gstreamer-devel
261- changed location of API docs to be in gtk-doc like other gtk-doc stuff
262- reordered SPEC file
263
264* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
265- moved html docs to gtk-doc standard directory
266
267* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
268- move version defines of glib2 and libxml2 to configure.ac
269- add BuildRequires for these two libs
270
271* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
272- put html docs in canonical place, avoiding %doc erasure
273- added devhelp support, current install of it is hackish
274
275* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
276- Added documentation to build
277
278* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
279- added libgstbasicscheduler
280- renamed libgst to libgstreamer
281
282* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
283- Added configdir parameter as it seems the configdir gets weird otherwise
284
285* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
286- split off gstreamer-editor from core
287- removed gstreamer-gnome-apps
288
289* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
290- Cleaned up the spec file for the gstreamer core/plug-ins split
291- Improve spec file
292
293* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
294- Split of more plugins from the core and put them into their own modules
295- Includes colorspace, xfree and wav
296- Improved package Require lines
297- Added mp3encode (lame based) to the SPEC
298
299* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
300- Thomas merged mpeg plugins into one
301* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
302- More minor cleanups including some fixed descriptions from Andrew Mitchell
303
304* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
305- Added logging to the make statement
306
307* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
308- Updated in preparation for 0.3.0 release
309
310* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
311- Updated for 0.2.1 release
312- Split out the GUI packages into their own RPM
313- added new plugins (FLAC, festival, quicktime etc.)
314
315* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
316- Visualisation plugins bundled out togheter
317- Moved files sections up close to their respective descriptions
318
319* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
320- Split the package into separate RPMS,
321  putting most plugins out by themselves.
322
323* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
324- Updated with change suggestions from Dennis Bjorklund
325
326* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
327- updated to build -devel package as well
328
329* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
330- first draft of spec file
331
Note: See TracBrowser for help on using the repository browser.