source: projects/specs/trunk/g/gstreamer-python/gstreamer-python-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch:    %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitelib:     %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4%define majorminor      0.10
5%define pkg_release     2%{?_dist_release}
6
7Summary:        Python bindings for GStreamer
8Summary(ja):    GStreamer の Python バインディング
9Name:           gstreamer-python
10Version:        0.10.17
11Release:        %{pkg_release}
12Source0:        http://gstreamer.freedesktop.org/src/gst-python/gst-python-%{version}.tar.bz2
13License:        LGPLv2+
14Group:          Development/Languages
15URL:            http://gstreamer.freedesktop.org/
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  python, python-devel
19BuildRequires:  pygtk2-devel
20BuildRequires:  gstreamer-devel
21BuildRequires:  gstreamer-plugins-base-devel
22BuildRequires:  pygobject-devel
23Requires:       python, pygtk2
24Requires:       gstreamer, gstreamer-plugins-base
25
26Vendor:         Project Vine
27Distribution:   Vine Linux
28
29%description
30This package contains a python bindings to the GStreamer
31streaming-media framework.
32
33%description -l ja
34このパッケージは GStreamer ストリーミングメディアフレームワーク
35向けの Python バインディングを含みます。
36
37%prep
38%setup -q -n gst-python-%{version}
39
40%build
41%configure
42%{__make} %{?_smp_mflags}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} install DESTDIR=${RPM_BUILD_ROOT}
47
48# remove unnecessary .la files
49find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
50
51
52%clean
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55
56%files
57%defattr(-,root,root)
58%doc AUTHORS COPYING ChangeLog INSTALL NEWS README RELEASE TODO
59%{_libdir}/gstreamer-%{majorminor}/lib*.so
60%{python_sitearch}/*.so
61#%{python_sitelib}/*.py*
62#%{python_sitelib}/pygst.p*
63#%{python_sitelib}/gst-%{majorminor}
64%{python_sitearch}/pygst.p*
65%{python_sitearch}/gst-%{majorminor}
66%{_datadir}/gst-python/%{majorminor}/defs/*.defs
67%{_datadir}/gst-python/%{majorminor}/examples
68%{_libdir}/pkgconfig/gst-python-%{majorminor}.pc
69
70
71%changelog
72* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.17-2
73- rebuild with python-2.6
74
75* Sun Nov 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.17-1
76- new upstream release
77
78* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-1
79- new upstream release
80
81* Wed Dec 31 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.13-2
82- changed python-lib directory to %%{python_sitearch}
83
84* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.13-1
85- initial build for Vine Linux
86
Note: See TracBrowser for help on using the repository browser.