source: projects/specs/trunk/g/gstreamer-plugins-base/gstreamer-plugins-base-vl.spec @ 5738

Revision 5738, 16.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python: add configure option
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 0.10
4
5%define _gst_ver        0.10.36
6%define _glib2_ver      2.28.8
7%define _gtk3_ver       3.0.0
8%define _gtk_doc_ver    1.3
9%define _qt4_ver        4.6
10%define _check_ver      0.9.2
11%define _python_ver     2.6
12%define _alsa_lib_ver   0.9.1
13%define _libogg_ver     1.0
14%define _libvorbis_ver  1.0
15%define _freetype2_ver  2.0.9
16
17%define po_package      gst-plugins-base-%{major}
18
19Summary:        GStreamer Streaming-media framework base plugins
20Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
21Name:           gstreamer-plugins-base
22Version:        0.10.36
23Release:        1%{?_dist_release}
24License:        LGPL
25Group:          System Environment/Libraries
26URL:            http://gstreamer.freedesktop.org/
27Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Requires:       gstreamer >= %{_gst_ver}
31Requires:       glib2 >= %{_glib2_ver}
32Requires:       alsa-lib >= %{_alsa_lib_ver}
33Requires:       pango
34Requires:       gnome-vfs2
35Requires:       libogg >= %{_libogg_ver}
36Requires:       libvorbis, libtheora >= %{_libvorbis_ver}
37
38BuildRequires:  gstreamer-devel >= %{_gst_ver}
39BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
40BuildRequires:  python >= %{_python_ver}, python-pyxml
41BuildRequires:  glib2-devel >= %{_glib2_ver}
42BuildRequires:  check >= %{_check_ver}
43BuildRequires:  gtk3-devel >= %{_gtk3_ver}
44BuildRequires:  qt4-devel >= %{_qt4_ver}
45BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
46BuildRequires:  cdparanoia-devel
47BuildRequires:  gnome-vfs2-devel
48BuildRequires:  libogg-devel >= %{_libogg_ver}
49BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
50BuildRequires:  pango-devel
51BuildRequires:  freetype2-devel >= %{_freetype2_ver}
52BuildRequires:  fontconfig-devel
53BuildRequires:  libX11-devel
54BuildRequires:  libXv-devel
55BuildRequires:  libvisual-devel
56BuildRequires:  orc-devel
57BuildRequires:  libgudev1-devel
58BuildRequires:  gobject-introspection-devel
59
60Obsoletes:      %{name}-gnomevfs < 0.10.5
61Obsoletes:      %{name}-ogg < 0.10.5
62
63Vendor:         Project Vine
64Distribution:   Vine Linux
65Packager:       inagaki, Takemikaduchi
66
67%description
68GStreamer is a streaming-media framework, based on graphs of filters which
69operate on media data. Applications using this library can do anything
70from real-time sound processing to playing videos, and just about anything
71else media-related.  Its plugin-based architecture means that new data
72types or processing capabilities can be added simply by installing new
73plugins.
74
75This package contains a set of well-maintained base plugins.
76
77%package devel
78Summary:        Libraries/include files for GStreamer base plugins
79Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
80Group:          Development/Libraries
81Requires:       %{name} = %{version}-%{release}
82Requires:       gstreamer-devel >= %{_gst_ver}
83
84%description devel
85GStreamer is a streaming-media framework, based on graphs of filters which
86operate on media data. Applications using this library can do anything
87from real-time sound processing to playing videos, and just about anything
88else media-related.  Its plugin-based architecture means that new data
89types or processing capabilities can be added simply by installing new
90plugins.
91
92This package contains GStreamer base plugins library depvelopment and header
93files.
94
95# compat32
96%package -n compat32-%{name}
97Summary:        GStreamer Streaming-media framework base plugins
98Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
99Group:          System Environment/Libraries
100Requires:       %{name} = %{version}-%{release}
101
102%description -n compat32-%{name}
103GStreamer is a streaming-media framework, based on graphs of filters which
104operate on media data. Applications using this library can do anything
105from real-time sound processing to playing videos, and just about anything
106else media-related.  Its plugin-based architecture means that new data
107types or processing capabilities can be added simply by installing new
108plugins.
109
110This package contains a set of well-maintained base plugins.
111
112%package -n compat32-%{name}-devel
113Summary:        Libraries/include files for GStreamer base plugins
114Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
115Group:          Development/Libraries
116Requires:       compat32-%{name} = %{version}-%{release}
117Requires:       %{name}-devel = %{version}-%{release}
118Requires:       compat32-gstreamer-devel >= %{_gst_ver}
119
120%description -n compat32-%{name}-devel
121GStreamer is a streaming-media framework, based on graphs of filters which
122operate on media data. Applications using this library can do anything
123from real-time sound processing to playing videos, and just about anything
124else media-related.  Its plugin-based architecture means that new data
125types or processing capabilities can be added simply by installing new
126plugins.
127
128This package contains GStreamer base plugins library depvelopment and header
129files.
130
131
132%prep
133%setup -q -n gst-plugins-base-%{version}
134
135%build
136%ifarch alpha
137%define optflags -O2 -mieee -fPIC
138%endif
139
140%configure \
141        --with-package-name='Vine Linux gstreamer-plugins-base package' \
142        --enable-gtk-doc \
143        --disable-static \
144        --disable-debug \
145        --enable-orc \
146        --with-gudev \
147        --enable-introspection=yes
148
149make %{?_smp_mflags}
150
151%install
152[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
153make install DESTDIR=$RPM_BUILD_ROOT
154
155# Clean out files that should not be part of the rpm.
156rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
157rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
158
159%find_lang %{po_package}
160
161%clean
162[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
163
164%post -p /sbin/ldconfig
165
166%postun -p /sbin/ldconfig
167
168%post -n compat32-%{name} -p /sbin/ldconfig
169
170%postun -n compat32-%{name} -p /sbin/ldconfig
171
172%files -f %{po_package}.lang
173%defattr(-,root,root)
174%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
175
176# helper programs
177%{_bindir}/gst-*
178%{_datadir}/gst-plugins-base/license-translations.dict
179%{_mandir}/man1/gst-*
180
181# libraries
182%{_libdir}/libgst*-%{major}.so.*
183%{_libdir}/girepository-1.0/*.typelib
184
185# base plugins without external dependencies
186%{_libdir}/gstreamer-%{major}/libgstadder.so
187%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
188%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
189%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
190%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
191%{_libdir}/gstreamer-%{major}/libgstapp.so
192%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
193%{_libdir}/gstreamer-%{major}/libgstdecodebin.so
194%{_libdir}/gstreamer-%{major}/libgstdecodebin2.so
195%{_libdir}/gstreamer-%{major}/libgstencodebin.so
196%{_libdir}/gstreamer-%{major}/libgstffmpegcolorspace.so
197%{_libdir}/gstreamer-%{major}/libgstgdp.so
198%{_libdir}/gstreamer-%{major}/libgstgio.so
199%{_libdir}/gstreamer-%{major}/libgstplaybin.so
200#{_libdir}/gstreamer-%{major}/libgstqueue2.so
201%{_libdir}/gstreamer-%{major}/libgstsubparse.so
202%{_libdir}/gstreamer-%{major}/libgsttcp.so
203%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
204#{_libdir}/gstreamer-%{major}/libgsturidecodebin.so
205#%{_libdir}/gstreamer-%{major}/libgstvideo4linux.so
206%{_libdir}/gstreamer-%{major}/libgstvideorate.so
207%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
208%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
209%{_libdir}/gstreamer-%{major}/libgstvolume.so
210%{_libdir}/gstreamer-%{major}/libgstximagesink.so
211%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
212
213# base plugins with external dependencies, but in the main package
214%{_libdir}/gstreamer-%{major}/libgstalsa.so
215%{_libdir}/gstreamer-%{major}/libgstpango.so
216%{_libdir}/gstreamer-%{major}/libgstgnomevfs.so
217%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
218%{_libdir}/gstreamer-%{major}/libgstogg.so
219%{_libdir}/gstreamer-%{major}/libgsttheora.so
220%{_libdir}/gstreamer-%{major}/libgstvorbis.so
221
222%files devel
223%defattr(-,root,root)
224%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
225%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
226%{_datadir}/gir-1.0/*.gir
227%{_includedir}/gstreamer-%{major}/gst/*
228%{_libdir}/pkgconfig/*.pc
229%{_libdir}/libgst*-%{major}.so
230
231# compat32
232%if %{build_compat32}
233%files -n compat32-%{name}
234%defattr(-,root,root)
235%{_libdir}/libgst*-%{major}.so.*
236%{_libdir}/gstreamer-%{major}/*.so
237
238%files -n compat32-%{name}-devel
239%defattr(-,root,root)
240%{_libdir}/libgst*-%{major}.so
241%{_libdir}/pkgconfig/*.pc
242%endif
243
244
245%changelog
246* Tue Feb 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-1
247- new upstream release
248- change BuildRequires: gtk3-devel instead of gtk2-devel
249- add BuildRequires: qt4-devel
250
251* Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-2
252- create compat32 sub packages
253
254* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
255- new upstream release
256
257* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
258- new upstream release
259
260* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
261- new upstream release
262
263* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
264- new upstream release
265- change BuildRequires: gobject-introspection-devel instead of gir-repository-devel
266- add configure option (--enable-introspection=yes)
267
268* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
269- build with rpm-4.8.1-1 for pkg-config file
270- add BuildRequires: gir-repository-devel
271
272* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
273- new upstream release
274- added BR: orc-devel, libgudev1-devel
275- removed liboil dependency
276
277* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.29-1
278- new upstream release
279
280* Wed Mar 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
281- new upstream release
282
283* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
284- new upstream release
285- built with new toolchain
286
287* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
288- new upstream release
289
290* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
291- new upstream release
292
293* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
294- new upstream release
295- added BR: libvisual-devel
296- added Packager tag
297
298* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
299- new upstream release
300
301* Mon Dec 29 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.21-1
302- add configure option --enable-experimental to enable giosink
303
304* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1
305- new upstream release
306- spec in UTF-8
307
308* Sun Jun 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1
309- new upstream release
310- updated build dependancies
311
312* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-2
313- build with xorg-x11-7.3
314  - remove XOrg/XOrg-devel deps
315  - add BuildRequires: libXv-devel, fontconfig-devel
316
317* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
318- new upstream release
319
320* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
321- new upstream release
322
323* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
324- new upstream release
325
326* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
327- new upstream release
328
329* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
330- new upstream release
331
332* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
333- new upstream release
334- update %%_gst_ver
335- add Vendor/Distribution tag
336- add '-with-package-name' option to %%configure
337- use more macros
338
339* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
340- new upstream release
341- update %%_gst_ver
342- update required version of liboil
343- add new plugin: libgstdecodebin2.so
344
345* Sat Nov 25 2006 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
346- new upstream release
347- update %%_gst_ver
348- changed Group to Applications/Multimedia
349
350* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
351- new upstream release
352- update %%_gst_ver
353
354* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
355- new upstream release
356- update %%_gst_ver
357
358* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.7-0vl1
359- new upstream release
360- update %%_gst_ver
361
362* Mon May  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.6-0vl1
363- new upstream release
364
365* Sun Mar 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl2
366- remove Obsoletes: gstreamer-plugins
367
368* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
369- new upstream release
370- update %%_gst_ver and liboil version
371- merge -gnomevfs,ogg into main package
372- add Obsoletes: %%{name}-gnomevfs, %%{name}-ogg < 0.10.5
373
374* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
375- new upstream release
376- update %%_gst_ver
377
378* Sun Jan 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl2
379- add Obsoletes: gstreamer-plugins < 0.9
380
381* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
382- initial package based on gstreamer-plugins
383- new upstream release
384  - change major to 0.10
385- update dependencies
386- update %%configure options
387- add subpackage: -gnomevfs, -ogg
388
389* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
390- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
391
392* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
393- added missing alsa plugin
394
395* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
396- new upstream release
397- added alsa and cairo plugins
398
399* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
400- new upstream release
401
402* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
403- new upstream release
404
405* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
406- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
407
408* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
409- added libgstcdparania.so for gnome-cd (gnome-media)
410- BuildRequires: cdparanoia-devel
411
412* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
413- drop BuildRequires: xmms-devel, Requires: xmms
414
415* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
416- libgstvideo4linux2.so temoporally omitted for ppc
417  (will be back later, I hope)
418
419* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
420- new upstream release
421- s/Copyright/License/
422- includes plugins depend on main package libraries only
423
424* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
425- new upstream release
426
427* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
428- new upstream release
429
430* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
431- new upstream release
432
433* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
434- new upstream release
435
436* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
437- build with -fPIC on alpha
438
439* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
440- modified scripts
441
442* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
443- new upstream release
444
445* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
446- disable some plugins.
447
448* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
449- new upstream release
450- initial build for Vine Linux
451
452* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
453- Include ia64
454- Add BuildRequires: autoconf automake
455
456* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
457- rebuild
458
459* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
460- rebuild
461
462* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
463- rebuild
464- disable tests
465
466* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
467- rebuild
468
469* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
470- fix libdir for ia64.
471
472* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
473- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
474- Add devel package
475
476* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
477- 0.5.0
478- apparently, festival-devel isn't needed.
479
480* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
481- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
482
483* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
484- excludearch the arches that can't build gstreamer cothreads
485- well it isn't really SMP-safe
486- add patch for including pthread.h when required
487- prereq gconftool
488- fix typo that broke schema installation in post
489
490* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
491- initial "official" import
492- munge tarball for legal cleanliness
493
494* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
495- 0.4.2
496
497* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
498- 0.4.1
499- install the gconf schema
500- use %%configure
501
502* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
503- update to 0.4.0
504- give explicit vorbis include path, don't run vorbis test
505
506* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
507- collapse into one package to preserve some sanity
508
509* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
510- added more BuildRequires and Requires
511- rearranged some plugins
512- added changelog ;)
Note: See TracBrowser for help on using the repository browser.