source: projects/specs/trunk/g/gstreamer-plugins-base/gstreamer-plugins-base-vl.spec @ 2219

Revision 2219, 13.7 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define major 0.10
2
3%define _gst_ver        0.10.30
4%define _glib2_ver      2.12.0
5%define _gtk2_ver       2.12.0
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9%define _alsa_lib_ver   0.9.1
10%define _libogg_ver     1.0
11%define _libvorbis_ver  1.0
12%define _freetype2_ver  2.0.9
13
14%define po_package      gst-plugins-base-%{major}
15
16Summary:        GStreamer Streaming-media framework base plugins
17Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
18Name:           gstreamer-plugins-base
19Version:        0.10.30.2
20Release:        1%{?_dist_release}
21License:        LGPL
22Group:          System Environment/Libraries
23URL:            http://gstreamer.freedesktop.org/
24Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.bz2
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Requires:       gstreamer >= %{_gst_ver}
28Requires:       glib2 >= %{_glib2_ver}
29Requires:       alsa-lib >= %{_alsa_lib_ver}
30Requires:       pango
31Requires:       gnome-vfs2
32Requires:       libogg >= %{_libogg_ver}
33Requires:       libvorbis, libtheora >= %{_libvorbis_ver}
34
35BuildRequires:  gstreamer-devel >= %{_gst_ver}
36BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
37BuildRequires:  python >= %{_python_ver}, python-pyxml
38BuildRequires:  glib2-devel >= %{_glib2_ver}
39BuildRequires:  check >= %{_check_ver}
40BuildRequires:  gtk2-devel >= %{_gtk2_ver}
41BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
42BuildRequires:  cdparanoia-devel
43BuildRequires:  gnome-vfs2-devel
44BuildRequires:  libogg-devel >= %{_libogg_ver}
45BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
46BuildRequires:  pango-devel
47BuildRequires:  freetype2-devel >= %{_freetype2_ver}
48BuildRequires:  fontconfig-devel
49BuildRequires:  libX11-devel
50BuildRequires:  libXv-devel
51BuildRequires:  libvisual-devel
52BuildRequires:  orc-devel
53BuildRequires:  libgudev1-devel
54BuildRequires:  gobject-introspection-devel
55
56Obsoletes:      %{name}-gnomevfs < 0.10.5
57Obsoletes:      %{name}-ogg < 0.10.5
58
59Vendor:         Project Vine
60Distribution:   Vine Linux
61Packager:       inagaki
62
63%description
64GStreamer is a streaming-media framework, based on graphs of filters which
65operate on media data. Applications using this library can do anything
66from real-time sound processing to playing videos, and just about anything
67else media-related.  Its plugin-based architecture means that new data
68types or processing capabilities can be added simply by installing new
69plugins.
70
71This package contains a set of well-maintained base plugins.
72
73%package devel
74Summary:        Libraries/include files for GStreamer base plugins
75Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
76Group:          Development/Libraries
77Requires:       %{name} = %{version}-%{release}
78Requires:       gstreamer-devel >= %{_gst_ver}
79
80%description devel
81GStreamer is a streaming-media framework, based on graphs of filters which
82operate on media data. Applications using this library can do anything
83from real-time sound processing to playing videos, and just about anything
84else media-related.  Its plugin-based architecture means that new data
85types or processing capabilities can be added simply by installing new
86plugins.
87
88This package contains GStreamer base plugins library depvelopment and header
89files.
90
91%prep
92%setup -q -n gst-plugins-base-%{version}
93
94%build
95%ifarch alpha
96%define optflags -O2 -mieee -fPIC
97%endif
98
99%configure \
100        --with-package-name='Vine Linux gstreamer-plugins-base package' \
101        --enable-gtk-doc \
102        --disable-static \
103        --disable-debug \
104        --enable-orc \
105        --with-gudev \
106        --enable-introspection=yes
107
108make %{?_smp_mflags}
109
110%install
111[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
112make install DESTDIR=$RPM_BUILD_ROOT
113
114# Clean out files that should not be part of the rpm.
115rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
116rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
117
118%find_lang %{po_package}
119
120%clean
121[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%files -f %{po_package}.lang
128%defattr(-,root,root)
129%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
130
131# helper programs
132%{_bindir}/gst-*
133%{_mandir}/man1/gst-*
134
135# libraries
136%{_libdir}/libgst*-%{major}.so.*
137%{_libdir}/girepository-1.0/*.typelib
138
139# base plugins without external dependencies
140%{_libdir}/gstreamer-%{major}/libgstadder.so
141%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
142%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
143%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
144%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
145%{_libdir}/gstreamer-%{major}/libgstapp.so
146%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
147%{_libdir}/gstreamer-%{major}/libgstdecodebin.so
148%{_libdir}/gstreamer-%{major}/libgstdecodebin2.so
149%{_libdir}/gstreamer-%{major}/libgstffmpegcolorspace.so
150%{_libdir}/gstreamer-%{major}/libgstgdp.so
151%{_libdir}/gstreamer-%{major}/libgstgio.so
152%{_libdir}/gstreamer-%{major}/libgstplaybin.so
153#{_libdir}/gstreamer-%{major}/libgstqueue2.so
154%{_libdir}/gstreamer-%{major}/libgstsubparse.so
155%{_libdir}/gstreamer-%{major}/libgsttcp.so
156%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
157#{_libdir}/gstreamer-%{major}/libgsturidecodebin.so
158%{_libdir}/gstreamer-%{major}/libgstvideo4linux.so
159%{_libdir}/gstreamer-%{major}/libgstvideorate.so
160%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
161%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
162%{_libdir}/gstreamer-%{major}/libgstvolume.so
163%{_libdir}/gstreamer-%{major}/libgstximagesink.so
164%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
165
166# base plugins with external dependencies, but in the main package
167%{_libdir}/gstreamer-%{major}/libgstalsa.so
168%{_libdir}/gstreamer-%{major}/libgstpango.so
169%{_libdir}/gstreamer-%{major}/libgstgnomevfs.so
170%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
171%{_libdir}/gstreamer-%{major}/libgstogg.so
172%{_libdir}/gstreamer-%{major}/libgsttheora.so
173%{_libdir}/gstreamer-%{major}/libgstvorbis.so
174
175%files devel
176%defattr(-,root,root)
177%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
178%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
179%{_datadir}/gir-1.0/*.gir
180%{_includedir}/gstreamer-%{major}/gst/*
181%{_libdir}/pkgconfig/*.pc
182%{_libdir}/libgst*-%{major}.so
183
184%changelog
185* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
186- new upstream release
187- change BuildRequires: gobject-introspection-devel instead of gir-repository-devel
188- add configure option (--enable-introspection=yes)
189
190* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
191- build with rpm-4.8.1-1 for pkg-config file
192- add BuildRequires: gir-repository-devel
193
194* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
195- new upstream release
196- added BR: orc-devel, libgudev1-devel
197- removed liboil dependency
198
199* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.29-1
200- new upstream release
201
202* Wed Mar 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
203- new upstream release
204
205* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
206- new upstream release
207- built with new toolchain
208
209* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
210- new upstream release
211
212* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
213- new upstream release
214
215* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
216- new upstream release
217- added BR: libvisual-devel
218- added Packager tag
219
220* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
221- new upstream release
222
223* Mon Dec 29 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.21-1
224- add configure option --enable-experimental to enable giosink
225
226* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1
227- new upstream release
228- spec in UTF-8
229
230* Sun Jun 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1
231- new upstream release
232- updated build dependancies
233
234* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-2
235- build with xorg-x11-7.3
236  - remove XOrg/XOrg-devel deps
237  - add BuildRequires: libXv-devel, fontconfig-devel
238
239* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
240- new upstream release
241
242* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
243- new upstream release
244
245* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
246- new upstream release
247
248* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
249- new upstream release
250
251* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
252- new upstream release
253
254* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
255- new upstream release
256- update %%_gst_ver
257- add Vendor/Distribution tag
258- add '-with-package-name' option to %%configure
259- use more macros
260
261* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
262- new upstream release
263- update %%_gst_ver
264- update required version of liboil
265- add new plugin: libgstdecodebin2.so
266
267* Sat Nov 25 2006 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
268- new upstream release
269- update %%_gst_ver
270- changed Group to Applications/Multimedia
271
272* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
273- new upstream release
274- update %%_gst_ver
275
276* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
277- new upstream release
278- update %%_gst_ver
279
280* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.7-0vl1
281- new upstream release
282- update %%_gst_ver
283
284* Mon May  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.6-0vl1
285- new upstream release
286
287* Sun Mar 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl2
288- remove Obsoletes: gstreamer-plugins
289
290* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
291- new upstream release
292- update %%_gst_ver and liboil version
293- merge -gnomevfs,ogg into main package
294- add Obsoletes: %%{name}-gnomevfs, %%{name}-ogg < 0.10.5
295
296* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
297- new upstream release
298- update %%_gst_ver
299
300* Sun Jan 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl2
301- add Obsoletes: gstreamer-plugins < 0.9
302
303* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
304- initial package based on gstreamer-plugins
305- new upstream release
306  - change major to 0.10
307- update dependencies
308- update %%configure options
309- add subpackage: -gnomevfs, -ogg
310
311* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
312- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
313
314* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
315- added missing alsa plugin
316
317* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
318- new upstream release
319- added alsa and cairo plugins
320
321* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
322- new upstream release
323
324* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
325- new upstream release
326
327* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
328- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
329
330* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
331- added libgstcdparania.so for gnome-cd (gnome-media)
332- BuildRequires: cdparanoia-devel
333
334* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
335- drop BuildRequires: xmms-devel, Requires: xmms
336
337* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
338- libgstvideo4linux2.so temoporally omitted for ppc
339  (will be back later, I hope)
340
341* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
342- new upstream release
343- s/Copyright/License/
344- includes plugins depend on main package libraries only
345
346* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
347- new upstream release
348
349* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
350- new upstream release
351
352* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
353- new upstream release
354
355* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
356- new upstream release
357
358* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
359- build with -fPIC on alpha
360
361* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
362- modified scripts
363
364* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
365- new upstream release
366
367* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
368- disable some plugins.
369
370* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
371- new upstream release
372- initial build for Vine Linux
373
374* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
375- Include ia64
376- Add BuildRequires: autoconf automake
377
378* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
379- rebuild
380
381* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
382- rebuild
383
384* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
385- rebuild
386- disable tests
387
388* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
389- rebuild
390
391* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
392- fix libdir for ia64.
393
394* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
395- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
396- Add devel package
397
398* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
399- 0.5.0
400- apparently, festival-devel isn't needed.
401
402* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
403- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
404
405* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
406- excludearch the arches that can't build gstreamer cothreads
407- well it isn't really SMP-safe
408- add patch for including pthread.h when required
409- prereq gconftool
410- fix typo that broke schema installation in post
411
412* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
413- initial "official" import
414- munge tarball for legal cleanliness
415
416* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
417- 0.4.2
418
419* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
420- 0.4.1
421- install the gconf schema
422- use %%configure
423
424* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
425- update to 0.4.0
426- give explicit vorbis include path, don't run vorbis test
427
428* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
429- collapse into one package to preserve some sanity
430
431* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
432- added more BuildRequires and Requires
433- rearranged some plugins
434- added changelog ;)
Note: See TracBrowser for help on using the repository browser.