source: projects/specs/trunk/g/gsoap/gsoap-vl.spec @ 10570

Revision 10570, 14.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary: Generator Tools for Coding SOAP/XML Web Services in C and C++
2Name: gsoap
3Version: 2.8.17
4Release: 3%{?_dist_release}
5# Bump the soversion when the new version is not backward compatiple
6%global soversion 5
7
8# gsoap is licensed both under the gSOAP public license and under GPL version
9# 2 or later with an OpenSSL linking exception.
10#
11# The gSOAP public license is a modified version of the Mozilla Public License.
12# Due to the modifications, the gSOAP public license is non-free. You can not
13# use gsoap under this license for software that you intend to contribute to
14# fedora. If you use gsoap in fedora you must use it under the GPL license,
15# possibly using the OpenSSL linking exception. The specific modification that
16# makes the license non-free is in section 3.2:
17#
18# 3.2. Availability of Source Code.
19# Any Modification created by You will be provided to the Initial Developer in
20# Source Code form and are subject to the terms of the License.
21License: GPLv2+ with exceptions
22Group: Development/Tools
23URL: http://gsoap2.sourceforge.net
24
25Source0: http://downloads.sourceforge.net/gsoap2/%{name}_%{version}.zip
26Source1: soapcpp2.1
27Source2: wsdl2h.1
28# Create shared libraries
29Patch0: %{name}-libtool.patch
30# https://sourceforge.net/p/gsoap2/patches/111/
31Patch1: %{name}-private-lm.patch
32# https://sourceforge.net/p/gsoap2/patches/110/
33Patch2: %{name}-pad.patch
34# https://sourceforge.net/p/gsoap2/bugs/966/
35Patch3: %{name}-ipv6.patch
36# https://sourceforge.net/p/gsoap2/patches/117/
37Patch4: %{name}-default-paths.patch
38# https://sourceforge.net/p/gsoap2/patches/118/
39Patch5: %{name}-cleanfiles.patch
40# https://sourceforge.net/p/gsoap2/bugs/959/
41Patch6: %{name}-ai-next.patch
42# https://sourceforge.net/p/gsoap2/patches/120/
43Patch7: %{name}-einprogress.patch
44
45BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
46BuildRequires: flex
47BuildRequires: bison
48BuildRequires: findutils
49BuildRequires: nkf
50BuildRequires: openssl-devel
51BuildRequires: zlib-devel
52BuildRequires: autoconf
53BuildRequires: automake
54BuildRequires: libtool
55
56Requires: gsoap-libs = %{version}-%{release}
57Requires: openssl
58
59
60%description
61The gSOAP Web services development toolkit offers an XML to C/C++
62language binding to ease the development of SOAP/XML Web services in C
63and C/C++.
64
65
66%package libs
67Summary: Runtime libraries fpr gSOAP
68Group: System Environment/Libraries
69
70%description libs
71gSOAP runtime libraries.
72
73
74%package devel
75Summary: Devel libraries and headers for linking with gSOAP generated stubs
76Group: Development/Libraries
77Requires: gsoap-libs = %{version}-%{release}
78Requires: openssl-devel
79Requires: zlib-devel
80Requires: pkgconfig
81
82%description devel
83gSOAP libraries, headers and generators for linking with and creating
84gSOAP generated stubs
85
86
87%package doc
88Summary: Documentation for gSOAP
89Group: Documentation
90Requires: %{name} = %{version}-%{release}
91BuildArch: noarch
92
93%description doc
94gSOAP documentation in html
95
96
97%prep
98%setup -q -n gsoap-2.8
99%patch0 -p1
100%patch1 -p1
101%patch2 -p1
102%patch3 -p1
103%patch4 -p1
104%patch5 -p1
105%patch6 -p1
106%patch7 -p1
107
108# a number of ~ files are distribute, but we do not want them
109find . -name "*~" -exec rm {} \;
110
111# we want all txt files to have unix end-of-line encoding
112nkf --unix --in-place README.txt LICENSE.txt NOTES.txt
113
114# remove .DS_Stores
115find . -name .DS_Store -exec rm {} ';'
116
117# remove stuff with gsoap license only - not GPL
118rm -rf gsoap/extras gsoap/mod_gsoap gsoap/Symbian
119sed 's!$(srcdir)/extras/\*!!' -i gsoap/Makefile.am
120
121# remove pre-compiled binaries
122rm -rf gsoap/bin
123rm -rf gsoap/ios_plugin/examples/*/build
124rm gsoap/samples/calc_vs2005/calc_vs2005/soapcpp2.exe
125rm gsoap/VisualStudio2005/wsdl2h/wsdl2h/soapcpp2.exe
126( cd gsoap/samples/link++ ; make distclean )
127( cd gsoap/samples/wcf/WS/DualHttp ; make distclean )
128
129%build
130# patches change autoconf and automake files, so we must reconfigure
131autoreconf --install --force
132
133%configure --disable-static --enable-ipv6
134
135# dependencies are not declared properly
136#make %{?_smp_mflags}
137make SOVERSION=%{soversion}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141make install SOVERSION=%{soversion} DESTDIR=$RPM_BUILD_ROOT
142rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
143
144mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
145install -m 644 -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/%{_mandir}/man1
146
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%check
152make check
153
154%post libs -p /sbin/ldconfig
155
156%postun libs -p /sbin/ldconfig
157
158%files
159%defattr(-,root,root,-)
160%doc README.txt NOTES.txt LICENSE.txt
161%{_bindir}/soapcpp2
162%{_bindir}/wsdl2h
163%dir %{_datadir}/gsoap
164%dir %{_datadir}/gsoap/import
165%{_datadir}/gsoap/import/c14n.h
166%{_datadir}/gsoap/import/dom.h
167%{_datadir}/gsoap/import/ds2.h
168%{_datadir}/gsoap/import/ds.h
169%{_datadir}/gsoap/import/README.txt
170%{_datadir}/gsoap/import/soap12.h
171%{_datadir}/gsoap/import/stldeque.h
172%{_datadir}/gsoap/import/stl.h
173%{_datadir}/gsoap/import/stllist.h
174%{_datadir}/gsoap/import/stlset.h
175%{_datadir}/gsoap/import/stlvector.h
176%{_datadir}/gsoap/import/wsa3.h
177%{_datadir}/gsoap/import/wsa4.h
178%{_datadir}/gsoap/import/wsa5.h
179%{_datadir}/gsoap/import/wsa.h
180%{_datadir}/gsoap/import/WS-example.c
181%{_datadir}/gsoap/import/WS-example.h
182%{_datadir}/gsoap/import/WS-Header.h
183%{_datadir}/gsoap/import/wsp.h
184%{_datadir}/gsoap/import/wsrp.h
185%{_datadir}/gsoap/import/wsse2.h
186%{_datadir}/gsoap/import/wsse.h
187%{_datadir}/gsoap/import/wsu.h
188%{_datadir}/gsoap/import/xlink.h
189%{_datadir}/gsoap/import/xmime4.h
190%{_datadir}/gsoap/import/xmime5.h
191%{_datadir}/gsoap/import/xmime.h
192%{_datadir}/gsoap/import/xml.h
193%{_datadir}/gsoap/import/xmlmime5.h
194%{_datadir}/gsoap/import/xmlmime.h
195%{_datadir}/gsoap/import/xop.h
196%dir %{_datadir}/gsoap/WS
197%{_datadir}/gsoap/WS/README.txt
198%{_datadir}/gsoap/WS/WS-Addressing.xsd
199%{_datadir}/gsoap/WS/WS-Addressing03.xsd
200%{_datadir}/gsoap/WS/WS-Addressing04.xsd
201%{_datadir}/gsoap/WS/WS-Addressing05.xsd
202%{_datadir}/gsoap/WS/WS-Discovery.wsdl
203%{_datadir}/gsoap/WS/WS-Enumeration.wsdl
204%{_datadir}/gsoap/WS/WS-Policy.xsd
205%{_datadir}/gsoap/WS/WS-Routing.xsd
206%{_datadir}/gsoap/WS/WS-typemap.dat
207%{_datadir}/gsoap/WS/discovery.xsd
208%{_datadir}/gsoap/WS/ds.xsd
209%{_datadir}/gsoap/WS/enumeration.xsd
210%{_datadir}/gsoap/WS/typemap.dat
211%{_datadir}/gsoap/WS/wsse.xsd
212%{_datadir}/gsoap/WS/wsu.xsd
213%dir %{_datadir}/gsoap/custom
214%{_datadir}/gsoap/custom/README.txt
215%{_datadir}/gsoap/custom/long_double.c
216%{_datadir}/gsoap/custom/long_double.h
217%{_datadir}/gsoap/custom/struct_timeval.c
218%{_datadir}/gsoap/custom/struct_timeval.h
219%{_datadir}/gsoap/custom/struct_tm.c
220%{_datadir}/gsoap/custom/struct_tm.h
221%dir %{_datadir}/gsoap/plugin
222%{_datadir}/gsoap/plugin/README.txt
223%{_datadir}/gsoap/plugin/cacerts.c
224%{_datadir}/gsoap/plugin/cacerts.h
225%{_datadir}/gsoap/plugin/httpda.c
226%{_datadir}/gsoap/plugin/httpda.h
227%{_datadir}/gsoap/plugin/httpdatest.c
228%{_datadir}/gsoap/plugin/httpdatest.h
229%{_datadir}/gsoap/plugin/httpform.c
230%{_datadir}/gsoap/plugin/httpform.h
231%{_datadir}/gsoap/plugin/httpget.c
232%{_datadir}/gsoap/plugin/httpget.h
233%{_datadir}/gsoap/plugin/httpgettest.c
234%{_datadir}/gsoap/plugin/httpgettest.h
235%{_datadir}/gsoap/plugin/httpmd5.c
236%{_datadir}/gsoap/plugin/httpmd5.h
237%{_datadir}/gsoap/plugin/httpmd5test.c
238%{_datadir}/gsoap/plugin/httpmd5test.h
239%{_datadir}/gsoap/plugin/httppost.c
240%{_datadir}/gsoap/plugin/httppost.h
241%{_datadir}/gsoap/plugin/logging.c
242%{_datadir}/gsoap/plugin/logging.h
243%{_datadir}/gsoap/plugin/md5evp.c
244%{_datadir}/gsoap/plugin/md5evp.h
245%{_datadir}/gsoap/plugin/plugin.c
246%{_datadir}/gsoap/plugin/plugin.h
247%{_datadir}/gsoap/plugin/smdevp.c
248%{_datadir}/gsoap/plugin/smdevp.h
249%{_datadir}/gsoap/plugin/threads.c
250%{_datadir}/gsoap/plugin/threads.h
251%{_datadir}/gsoap/plugin/wsaapi.c
252%{_datadir}/gsoap/plugin/wsaapi.h
253%{_datadir}/gsoap/plugin/wsse2api.c
254%{_datadir}/gsoap/plugin/wsse2api.h
255%{_datadir}/gsoap/plugin/wsseapi.c
256%{_datadir}/gsoap/plugin/wsseapi.h
257# Additions in 2.7.12-1
258%{_datadir}/gsoap/WS/WS-ReliableMessaging.wsdl
259%{_datadir}/gsoap/WS/WS-ReliableMessaging.xsd
260%{_datadir}/gsoap/WS/reference-1.1.xsd
261%{_datadir}/gsoap/WS/ws-reliability-1.1.xsd
262%{_datadir}/gsoap/import/ref.h
263%{_datadir}/gsoap/import/wsrm.h
264%{_datadir}/gsoap/import/wsrm4.h
265%{_datadir}/gsoap/import/wsrx.h
266# Additions in 2.7.13-1
267%{_datadir}/gsoap/import/stdstring.h
268%{_datadir}/gsoap/import/xsd.h
269%{_datadir}/gsoap/plugin/wsseapi.cpp
270# Additions in 2.7.16-1
271%{_datadir}/gsoap/custom/duration.c
272%{_datadir}/gsoap/custom/duration.h
273%{_datadir}/gsoap/plugin/httpposttest.c
274%{_datadir}/gsoap/plugin/httpposttest.h
275%{_datadir}/gsoap/plugin/wsrmapi.c
276%{_datadir}/gsoap/plugin/wsrmapi.h
277# Additions in 2.7.17-1
278%{_datadir}/gsoap/WS/WS-Policy12.xsd
279%{_datadir}/gsoap/WS/WS-SecurityPolicy.xsd
280%{_datadir}/gsoap/import/wsse11.h
281# Additions in 2.8.3-1
282%{_datadir}/gsoap/WS/xenc.xsd
283%{_datadir}/gsoap/import/xenc.h
284%{_datadir}/gsoap/plugin/mecevp.c
285%{_datadir}/gsoap/plugin/mecevp.h
286# Additions in 2.8.4-1
287%{_datadir}/gsoap/import/wsdd.h
288%{_datadir}/gsoap/import/wsdx.h
289%{_datadir}/gsoap/plugin/wsddapi.c
290%{_datadir}/gsoap/plugin/wsddapi.h
291# Additions in 2.8.7-1
292%{_datadir}/gsoap/import/wsdd10.h
293# Additions in 2.8.12-1
294%{_datadir}/gsoap/WS/WS-SecureConversation.xsd
295%{_datadir}/gsoap/WS/WS-Trust.wsdl
296%{_datadir}/gsoap/WS/WS-Trust.xsd
297%{_datadir}/gsoap/import/ser.h
298%{_datadir}/gsoap/import/wsc.h
299%{_datadir}/gsoap/import/wsrm5.h
300%{_datadir}/gsoap/import/wsrx5.h
301%{_datadir}/gsoap/import/wst.h
302%{_datadir}/gsoap/import/wstx.h
303# Additions in 2.8.16-1
304%{_datadir}/gsoap/import/wsc2.h
305%{_datadir}/gsoap/plugin/calcrest.h
306# Additions in 2.8.17-1
307%{_datadir}/gsoap/plugin/mq.c
308%{_datadir}/gsoap/plugin/mq.h
309%{_mandir}/man1/soapcpp2.1*
310%{_mandir}/man1/wsdl2h.1*
311
312%files libs
313%defattr(-,root,root,-)
314%doc README.txt NOTES.txt LICENSE.txt
315%{_libdir}/libgsoap.so.*
316%{_libdir}/libgsoap++.so.*
317%{_libdir}/libgsoapck.so.*
318%{_libdir}/libgsoapck++.so.*
319%{_libdir}/libgsoapssl.so.*
320%{_libdir}/libgsoapssl++.so.*
321
322%files devel
323%doc README.txt NOTES.txt LICENSE.txt
324%{_includedir}/stdsoap2.h
325%{_libdir}/libgsoap.so
326%{_libdir}/libgsoap++.so
327%{_libdir}/libgsoapck.so
328%{_libdir}/libgsoapck++.so
329%{_libdir}/libgsoapssl.so
330%{_libdir}/libgsoapssl++.so
331%{_libdir}/pkgconfig/gsoapck.pc
332%{_libdir}/pkgconfig/gsoapck++.pc
333%{_libdir}/pkgconfig/gsoap.pc
334%{_libdir}/pkgconfig/gsoap++.pc
335%{_libdir}/pkgconfig/gsoapssl.pc
336%{_libdir}/pkgconfig/gsoapssl++.pc
337
338%files doc
339%doc README.txt NOTES.txt LICENSE.txt gsoap/doc/*
340
341
342%changelog
343* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-3
344- rebuild with gcc-5.4.0
345
346* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.17-2
347- rebuild with openssl-1.0.2
348
349* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.8.17-1
350- updated to 2.8.17 based on fc
351- rebuilt with openssl-1.0.1j
352- added BR: zlib-devel
353- splitted runtime and documents to subpackage
354- moved main package to Development/Tools Group
355
356* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.7.12-2
357- rebuilt with rpm-4.8.1 for pkg-config
358
359* Sat May 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.12-1
360- initial build for Vine Linux
361
362* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.12-3
363- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
364
365* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 2.7.12-2
366- rebuild with new openssl
367
368* Wed Dec 24 2008  <matt@redhat> - 2.7.12-1
369- Updated to gsoap 2.7.12:
370-  Numerous bug fixes - xml:lang, maxOccurs="unbounded", SSL, xmlns="", ...
371-  New features, maintaining backward compatibility - MinGW, wsseapi, multi-endpoint connect, ...
372- Patches removed (incorporated upstream):
373-  datadir_importpath-2.7.10.patch
374-  install_soapcpp2_wsdl2h_aux-2.7.10.patch
375-  no_locale.patch as default off, enable by defining WITH_C_LOCALE
376- Patches added (sent upstream):
377-  unused_args.patch - eliminate many unused param warnings
378
379* Thu Feb 21 2008  <mfarrellee@redhat> - 2.7.10-4
380- Applied upd patch from upstream. It fixes glibc C locale issues,
381  hp-ux h_errno definition, and xsd:dateTime timezone processing for
382  WS-I
383- Removed tru64_hp_ux patches, they are present in upstream's upd
384  patch
385- Added no_locale.patch to stop configure from checking for locale
386  version of functions
387
388* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.7.10-3
389- Autorebuild for GCC 4.3
390
391* Mon Feb 18 2008  <mfarrellee@redhat> - 2.7.10-2
392- Removed --disable-namespaces from configure, result is code compiled
393  against gsoap does not need to call set_soap_namespaces
394
395* Sun Jan 27 2008  <mfarrellee@redhat> - 2.7.10-1
396- Upgraded to 2.7.10 release
397- Stopped hosting patches on grid.et.redhat.com
398- Removed import_dom_h patch, it was integrated
399- Removed large autotools patch, replaced with patch
400  (use_libtool-2.7.10.patch) changing configure.in, gsoap/Makefile.am
401  and gsoap/wsdl/Makefile.am, which enable libtool use, and a
402  call to autoreconf
403- Changed soapcpp2 references to gsoap as per new layout of source
404  distribution
405- Updated tru64_hp_up_c/pp patches to handle new source layout
406- Install of soapcpp2/import with cp removed in favor of a patch to
407  gsoap/Makefile.am (install_soapcpp2_wsdl2h_aux-2.7.10.patch)
408- No pre-generated Makefiles are distributed, no longer removing them
409- stdsoap2_cpp.cpp not in distribution, no longer removing it
410- Added datadir_importpath-2.7.10.patch to set SOAPCPP2_IMPORT_PATH
411  and WSDL2H_IMPORT_PATH, useful defaults, using ${datadir} instead of
412  `pwd`
413- Added autoconf, automake and libtool to BuildRequires, because
414  configure.in and gsoap/Makefile.am are patched
415- Added ?dist to Release
416
417* Fri Nov 30 2007  <mfarrellee@redhat> - 2.7.9-0.4.l
418- Added OpenSSL requirement
419
420* Tue Nov 27 2007  <mfarrellee@redhat> - 2.7.9-0.3.l
421- Decided soapcpp2/import/ files should be in /usr/share instead of
422  /usr/include because they are not really headers gcc can
423  process. Also, this is likely the location new versions of gsoap
424  will install the import headers. People should use -I
425  /usr/share/gsoap/import
426
427* Mon Nov 26 2007  <mfarrellee@redhat> - 2.7.9-0.2.l
428- Changed license tag to GPLv2+, which is more accurate
429- Resolved bz399761 by adding soapcpp2/import/*.h to the -devel
430  package as /usr/include/gsoap, users will need to add -I
431  /usr/include/gsoap to their soapcpp2 line
432
433* Sun Sep 30 2007  <mfarrellee@redhat> - 2.7.9-0.1.l
434- Updated to 2.7.9l (2.7.9k patches still apply)
435- Added patch for import/dom.h missing xsd__anyAttribute definitions
436- Removed removal of .deps directories and autom4te.cache
437
438* Mon Sep 24 2007  <mfarrellee@redhat> - 2.7.9-0.2.k
439- Moved pkgconfig requirement to -devel package
440
441* Tue Sep 11 2007  <mfarrellee@redhat> - 2.7.9-0.1.k
442- Initial release
443
Note: See TracBrowser for help on using the repository browser.