source: projects/specs/trunk/g/grubby/grubby-vl.spec @ 11186

Revision 11186, 4.7 KB checked in by iwamoto, 7 years ago (diff)

grubby: fix support dracut

Line 
1Name: grubby
2Version: 7.0.13
3Release: 5%{?_dist_release}
4Summary: Command line tool for updating bootloader configs
5Summary(ja): ブートローダの設定を更新するためのコマンドラインツール
6Group: System Environment/Base
7License: GPLv2+
8URL: http://git.fedorahosted.org/git/grubby.git
9# we only pull git snaps at the moment
10# git clone git://git.fedorahosted.org/git/grubby.git
11# git archive --format=tar --prefix=grubby-%{version}/ HEAD |bzip2 > grubby-%{version}.tar.bz2
12Source0: %{name}-%{version}.tar.bz2
13Patch10: %{name}-7.0.13-vine.patch
14Patch20: %{name}-7.0.13-tuxonice.patch
15Patch30: %{name}-7.0.13_dracut_vine.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig glib2-devel popt-devel
19BuildRequires: libblkid-devel
20%ifarch s390 s390x
21Requires: s390utils-base
22%endif
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28grubby  is  a command line tool for updating and displaying information about
29the configuration files for the grub, lilo, elilo (ia64),  yaboot (powerpc) 
30and zipl (s390) boot loaders. It is primarily designed to be used from scripts
31which install new kernels and need to find information about the current boot
32environment.
33
34%prep
35%setup -q
36%patch10 -p1 -b .vine
37%patch20 -p1 -b .tuxonice
38%patch30 -p1 -b .dracut
39
40%build
41make %{?_smp_mflags}
42
43%check
44make test
45
46%install
47rm -rf $RPM_BUILD_ROOT
48make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
49
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54
55%files
56%defattr(-,root,root,-)
57%doc COPYING
58/sbin/installkernel
59/sbin/new-kernel-pkg
60/sbin/grubby
61%{_mandir}/man8/grubby.8*
62
63
64%changelog
65* Sun Sep 17 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.0.13-5
66- add patch30 for support dracut
67
68* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.13-4
69- rebuild with VineSeed environment
70
71* Thu Mar 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.0.13-3
72- add Patch20 to support tuxonice
73
74* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.0.13-2
75- add Patch10 (ported from mkinitrd-5)
76
77* Tue Feb 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.0.13-1
78- initial build for Vine Linux
79
80* Thu Feb 11 2010 Peter Jones <pjones@redhat.com> - 7.0.13-1
81- Strip boot partition prefix from initrd path if present during --update.
82  Related: rhbz#557922
83- add host only support for local kernel compiles (airlied)
84
85* Mon Feb 08 2010 Peter Jones <pjones@redhat.com> - 7.0.12-1
86- compare rootdev using uuid instead of stat, for better btrfs support (josef)
87  Resolves: rhbz#530108
88
89* Mon Feb 08 2010 Peter Jones <pjones@redhat.com> - 7.0.11-1
90- Make it possible to update the initrd without any other change.
91  Related: rhbz#557922
92
93* Fri Feb 05 2010 Peter Jones <pjones@redhat.com> - 7.0.10-1
94- Make --update able to add an initramfs.
95  Related: rhbz#557922
96
97* Mon Nov 30 2009 Peter Jones <pjones@redhat.com> - 7.0.9-3
98- Use s390utils-base as the s390 dep, not s390utils
99  Related: rhbz#540565
100
101* Tue Nov 24 2009 Peter Jones <pjones@redhat.com> - 7.0.9-2
102- Add s390utils dep when on s390, since new-kernel-package needs it.
103  Resolves: rhbz#540565
104
105* Fri Oct 30 2009 Peter Jones <pjones@redhat.com> - 7.0.9-1
106- Add support for dracut to installkernel (notting)
107
108* Thu Oct  1 2009 Hans de Goede <hdegoede@redhat.com> - 7.0.8-1
109- Stop using nash
110
111* Fri Sep 11 2009 Hans de Goede <hdegoede@redhat.com> - 7.0.7-1
112- Remove writing rd_plytheme=$theme to kernel args in dracut mode (hansg)
113- Add a couple of test cases for extra initrds (rstrode)
114- Allow tmplLine to be NULL in getInitrdVal (rstrode)
115
116* Fri Sep 11 2009 Peter Jones <pjones@redhat.com> - 7.0.6-1
117- Fix test case breakage from 7.0.5 (rstrode)
118
119* Fri Sep 11 2009 Peter Jones <pjones@redhat.com> - 7.0.5-1
120- Add support for plymouth as a second initrd. (rstrode)
121  Resolves: rhbz#520515
122
123* Wed Sep 09 2009 Hans de Goede <hdegoede@redhat.com> - 7.0.4-1
124- Add --dracut cmdline argument for %post generation of dracut initrd
125
126* Wed Aug 26 2009 Hans de Goede <hdegoede@redhat.com> - 7.0.3-1
127- Silence error when no /etc/sysconfig/keyboard (#517187)
128
129* Fri Aug  7 2009 Hans de Goede <hdegoede@redhat.com> - 7.0.2-1
130- Add --add-dracut-args new-kernel-pkg cmdline option
131
132* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.0.1-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
134
135* Fri Jul 17 2009 Jeremy Katz <katzj@redhat.com> - 7.0.1-1
136- Fix blkid usage (#124246)
137
138* Wed Jun 24 2009 Jeremy Katz <katzj@redhat.com> - 7.0-1
139- BR libblkid-devel now instead of e2fsprogs-devel
140- Add bits to switch to using dracut for new-kernel-pkg
141
142* Wed Jun  3 2009 Jeremy Katz <katzj@redhat.com> - 6.0.86-2
143- add instructions for checking out from git
144
145* Tue Jun  2 2009 Jeremy Katz <katzj@redhat.com> - 6.0.86-1
146- initial build after splitting out from mkinitrd
147
Note: See TracBrowser for help on using the repository browser.