source: projects/specs/trunk/g/grep/grep-vl.spec @ 7001

Revision 7001, 12.1 KB checked in by daisuke, 12 years ago (diff)

grep: update to 2.14, build with pcre-8.31

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 2.14
5Release: 1%{?_dist_release}
6
7License: GPLv3+
8Group: System Environment/Base
9URL: http://www.gnu.org/software/grep/
10
11Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
12Source1: colorgrep.sh
13Source2: colorgrep.csh
14Source3: GREP_COLORS
15Patch1: grep-2.11-gnulib-tests-rm-f.patch
16Patch2: grep-2.14-man-fix-R.patch
17
18Requires(post): install-info
19Requires(preun): install-info
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: pcre-devel >= 8.31
22BuildRequires: texinfo, gettext, gzip
23BuildRequires: autoconf, automake
24
25%description
26The GNU versions of commonly used grep utilities.  Grep searches
27through textual input for lines which contain a match to a specified
28pattern and then prints the matching lines.  GNU's grep utilities
29include grep, egrep and fgrep.
30
31You should install grep on your system, because it is a very useful
32utility for searching through text.
33
34%description -l ja
35一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
36する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
37ティにはgrep, egrep, fgrepが入っています。
38
39テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
40してください。
41
42%prep
43%setup -q
44%patch1 -p1 -b .gnulib-tests-rm-f
45%patch2 -p1 -b .man-fix-R
46
47
48%build
49%configure \
50        --without-included-regex
51%__make %{?_smp_mflags}
52
53%install
54[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
55%__make DESTDIR=$RPM_BUILD_ROOT install
56gzip $RPM_BUILD_ROOT%{_infodir}/grep*
57rm -f $RPM_BUILD_ROOT%{_infodir}/dir
58mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
59install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
60install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
61mkdir -p $RPM_BUILD_ROOT/bin
62mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
63rm -rf $RPM_BUILD_ROOT%{_bindir}
64
65
66%find_lang %{name}
67
68%check
69make check
70
71%clean
72[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
73
74%post
75[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
76
77%preun
78if [ $1 = 0 ]; then
79        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
80fi
81
82%files -f %{name}.lang
83%defattr(-,root,root)
84%doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog COPYING
85/bin/*
86%config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
87%config(noreplace) %{_sysconfdir}/GREP_COLORS
88%{_infodir}/*.info.gz
89%{_mandir}/*/*
90
91%changelog
92* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-1
93- update to 2.14
94- build with pcre-8.31
95
96* Tue Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
97- new upstream release
98- drop unneeded old patches
99- add BR: pcre-devel
100
101* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
102- rebuilt against current toolchain
103- fix license tag
104- use CPPFLAGS= argument to configure to add an -I option.
105- Do not set LDFLAGS=-s for "make install".
106
107* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
108- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
109  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
110  - applied new versioning policy, spec in utf-8
111
112* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
113- rebuild for Vine Linux 4.x
114
115* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
116- add Patch100 to fix infinite loop with 'grep -F'
117  thanks to M.H (<BTS:484>)
118- based on Fedora devel 2.5.1-57
119  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
120  - Make preun scriptlet unconditionally succeed (bug #223697).
121  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
122  - Fixed count of patterns when the last is an empty string (bug #204255).
123  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
124  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
125  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
126  - rebuild
127  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
128  - Applied upstream patch to fix '-D skip' (bug #189580).
129  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
130  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
131  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
132  - bump again for double-long bug on ppc(64)
133  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
134  - rebuilt for new gcc4.1 snapshot and glibc changes
135  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
136  - Prevent 'grep -P' from segfaulting (bug #171379).
137
138* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
139- changed Group to System Environment/Base
140
141* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
142- based on Fedora development 2.5.1-50
143  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
144  - Futher fixing for bug #161700.
145  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
146  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
147  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
148  - Build requires recent pcre-devel (bug #154626).
149  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
150  - Run 'make check'.
151  - Fixed -w handling for EGexecute.  Now 'make check' passes.
152  - Cache MB_CUR_MAX value in egf-speedup patch.
153  - Fixed variable shadowing in egf-speedup patch.
154  - Removed redundant (and incorrect) code in prline.
155  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
156  - More -w tests from Jakub Jelinek.
157  - Rebased on 2.5.1a.
158  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
159  - More tests (Jakub Jelinek).
160  - Jakub Jelinek's much improved -Fi algorithm.
161  - Removed bogus part of grep-2.5.1-fgrep patch.
162  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
163  - Fixed -Fi for multibyte input (bug #143079).
164  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
165  - Bypass kwset matching when ignoring case and processing multibyte input
166    (bug #143079).
167  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
168  - Further UTF-8 processing avoided since a '\n' byte is always an
169    end-of-line character in that encoding.
170  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
171  - Fixed a busy loop in the egf-speedup patch (bug #140781).
172  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
173  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
174    (bug #138558).
175  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
176  - Fixed last patch.
177  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
178  - Applied patch from Karsten Hopp to fix background colour problems with
179    --color output (bug #138913).
180  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
181  - Prevent false matches when DFA is disabled (bug #138558).
182  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
183  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
184    environment variable overrides.
185  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
186  - Fixes to egf-speedup patch: now it does not change any functionality,
187    as intended.
188  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
189  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
190  - More improvements to egf-speedup patch (bug #138076).
191  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
192  - Small improvements to egf-speedup patch.
193  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
194  - Remove mb-caching hack.
195  - Better multibyte handling in EGexecute() and Fexecute().
196  - Don't need regex.c changes in grep-2.5-i18n.patch.
197  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
198  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
199    multibyte characters (bug #133932).
200  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
201  - Applied patch from Robert Scheck to tidy spec file and add a URL
202    tag (bug #135185).
203
204* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
205- based on Fedora development 2.5.1-29
206  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
207  - More build requirements (bug #125323).
208  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
209  - Fix dfa multibyte character class matching when -i is used (bug #123363).
210  - Use bracket patch before i18n patch to make it clear that the bug exists
211    upstream.
212  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
213  - Fix fgrep (bug #116909).
214  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
215  - Work around glibc bug #112869 (segfault in re_compile_pattern).
216  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
217  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
218  - Another multibyte efficiency bug-fix (bug #111800).
219  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
220  - Fixed [:alpha:]-type character classes (bug #108484).
221  - Fixed -o -i properly (bug #111489).
222  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
223  - Fixed 'fgrep -i' (bug #111614).
224  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
225  - Another two multibyte efficiency bug-fixes (bug #110524).
226  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
227  - Fixed a multibyte efficiency bug.
228  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
229  - Turn on multibyte efficiency patch again to shake out bugs.
230  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
231  - Fixed man page bug (bug #106267).
232  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
233  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
234  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
235  - Fix debuginfo package.
236  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
237  - Finally give up on making grep go fast. :-(
238  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
239  - Fixed grep -i bug introduced by cache.
240  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
241  - Redo the gofast patch (bug #97785).
242  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
243  - Fixed a bug in the gofast patch (bug #97266).
244  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
245  - Go faster (bug #69900).
246  - Fix man page.
247  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
248  - Use system regex again.
249  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
250  - Fixed bug in go-fast patch.
251  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
252  - Go fast (bug #69900).
253  - Run test suite.
254- rebuild with new toolchains
255- build with --disable-prel-regexp option
256
257* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
258- based on Rawhide 2.5.1-7
259  - Don't install /usr/share/info/dir.
260  - Fix -o -i (bug #72641).
261  - i18n patch.
262
263* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
264- 2.5-0vl1
265- update to 2.5
266- change i18n patch
267
268* Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
269- 2.5-0vl1
270- update to 2.5
271- change i18n patch
272
273* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
274- 2.4.2-4vl1
275- usr better macros (%%configure/%%makeinstall)
276
277* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
278- 2.4-3vl1
279- merge ja patch
280
281* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
282- gzip info pages (Bug #9035)
283
284* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
285- fix description
286
287* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
288- update to 2.4.
289
290* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
291- prereq install-info
292
293* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
294- auto rebuild in the new build environment (release 2)
295
296* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
297- upgraded to grep 2.3, added install-info %post/%preun for info
298
299* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
300- Injected new description and group.
301
302* Sat May 09 1998 Prospector System <bugs@redhat.com>
303- translations modified for de, fr, tr
304
305* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
306- updated to 2.2
307
308* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
309- updated from 2.0 to 2.1
310- spec file cleanups
311- added BuildRoot
312
313* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
314- built against glibc
Note: See TracBrowser for help on using the repository browser.