source: projects/specs/trunk/g/grep/grep-vl.spec @ 521

Revision 521, 12.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 2.5.1
5Release: 60%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}a.tar.bz2
9Patch0: grep-2.5.1-fgrep.patch
10Patch1: grep-2.5.1-bracket.patch
11Patch2: grep-2.5-i18n.patch
12Patch3: grep-2.5.1-oi.patch
13Patch4: grep-2.5.1-manpage.patch
14Patch5: grep-2.5.1-color.patch
15Patch6: grep-2.5.1-icolor.patch
16Patch10: grep-2.5.1-egf-speedup.patch
17Patch11: grep-2.5.1-dfa-optional.patch
18Patch12: grep-2.5.1-tests.patch
19Patch13: grep-2.5.1-w.patch
20Patch14: grep-P.patch
21Patch15: grep-mem-exhausted.patch
22Patch16: grep-empty-pattern.patch
23Patch100: grep-2.5.1-egf-non-utf8-null-break.patch
24URL: http://www.gnu.org/software/grep/
25Prereq: /sbin/install-info
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27Buildrequires: texinfo, gettext, gzip
28
29%description
30The GNU versions of commonly used grep utilities.  Grep searches
31through textual input for lines which contain a match to a specified
32pattern and then prints the matching lines.  GNU's grep utilities
33include grep, egrep and fgrep.
34
35You should install grep on your system, because it is a very useful
36utility for searching through text.
37
38%description -l ja
39一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
40する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
41ティにはgrep, egrep, fgrepが入っています。
42
43テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
44してください。
45
46%prep
47%setup -q -n %{name}-%{version}a
48%patch0 -p1 -b .fgrep
49%patch1 -p1 -b .bracket
50%patch2 -p1 -b .i18n
51%patch3 -p1 -b .oi
52%patch4 -p1 -b .manpage
53%patch5 -p1 -b .color
54%patch6 -p1 -b .icolor
55%patch10 -p1 -b .egf-speedup
56%patch11 -p1 -b .dfa-optional
57%patch12 -p1 -b .tests
58%patch13 -p1 -b .w
59%patch14 -p1 -b .P
60%patch15 -p1 -b .mem-exhausted
61%patch16 -p1 -b .empty-pattern
62%patch100 -p1 -b egf-non-utf8-null-break
63chmod a+x tests/fmbtest.sh
64
65%build
66[ ! -e configure ] && ./autogen.sh
67%configure CPPFLAGS="-I%{_includedir}/pcre" \
68        --prefix=%{_prefix} \
69        --disable-perl-regexp \
70        --without-included-regex
71make
72
73%install
74[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
75
76%makeinstall prefix=$RPM_BUILD_ROOT%{_prefix} exec_prefix=$RPM_BUILD_ROOT
77%ifos Linux
78mkdir -p $RPM_BUILD_ROOT/bin
79mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin
80rm -rf $RPM_BUILD_ROOT%{_prefix}/bin
81%endif
82gzip -9f $RPM_BUILD_ROOT%{_infodir}/grep*
83rm -f $RPM_BUILD_ROOT%{_infodir}/dir
84
85# Use symlinks for egrep and fgrep
86ln -sf grep $RPM_BUILD_ROOT/bin/egrep
87ln -sf grep $RPM_BUILD_ROOT/bin/fgrep
88
89%find_lang %{name}
90
91%check
92make check
93
94%clean
95[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
96
97%post
98[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
99
100%preun
101if [ $1 = 0 ]; then
102        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
103fi
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog
108
109%ifos Linux
110/bin/*
111%else
112%{_prefix}/bin/*
113%endif
114%{_infodir}/*.info.gz
115%{_mandir}/*/*
116
117%changelog
118* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
119- rebuilt against current toolchain
120- fix license tag
121- use CPPFLAGS= argument to configure to add an -I option.
122- Do not set LDFLAGS=-s for "make install".
123
124* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
125- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
126  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
127  - applied new versioning policy, spec in utf-8
128
129* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
130- rebuild for Vine Linux 4.x
131
132* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
133- add Patch100 to fix infinite loop with 'grep -F'
134  thanks to M.H (<BTS:484>)
135- based on Fedora devel 2.5.1-57
136  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
137  - Make preun scriptlet unconditionally succeed (bug #223697).
138  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
139  - Fixed count of patterns when the last is an empty string (bug #204255).
140  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
141  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
142  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
143  - rebuild
144  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
145  - Applied upstream patch to fix '-D skip' (bug #189580).
146  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
147  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
148  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
149  - bump again for double-long bug on ppc(64)
150  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
151  - rebuilt for new gcc4.1 snapshot and glibc changes
152  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
153  - Prevent 'grep -P' from segfaulting (bug #171379).
154
155* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
156- changed Group to System Environment/Base
157
158* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
159- based on Fedora development 2.5.1-50
160  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
161  - Futher fixing for bug #161700.
162  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
163  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
164  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
165  - Build requires recent pcre-devel (bug #154626).
166  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
167  - Run 'make check'.
168  - Fixed -w handling for EGexecute.  Now 'make check' passes.
169  - Cache MB_CUR_MAX value in egf-speedup patch.
170  - Fixed variable shadowing in egf-speedup patch.
171  - Removed redundant (and incorrect) code in prline.
172  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
173  - More -w tests from Jakub Jelinek.
174  - Rebased on 2.5.1a.
175  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
176  - More tests (Jakub Jelinek).
177  - Jakub Jelinek's much improved -Fi algorithm.
178  - Removed bogus part of grep-2.5.1-fgrep patch.
179  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
180  - Fixed -Fi for multibyte input (bug #143079).
181  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
182  - Bypass kwset matching when ignoring case and processing multibyte input
183    (bug #143079).
184  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
185  - Further UTF-8 processing avoided since a '\n' byte is always an
186    end-of-line character in that encoding.
187  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
188  - Fixed a busy loop in the egf-speedup patch (bug #140781).
189  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
190  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
191    (bug #138558).
192  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
193  - Fixed last patch.
194  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
195  - Applied patch from Karsten Hopp to fix background colour problems with
196    --color output (bug #138913).
197  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
198  - Prevent false matches when DFA is disabled (bug #138558).
199  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
200  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
201    environment variable overrides.
202  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
203  - Fixes to egf-speedup patch: now it does not change any functionality,
204    as intended.
205  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
206  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
207  - More improvements to egf-speedup patch (bug #138076).
208  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
209  - Small improvements to egf-speedup patch.
210  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
211  - Remove mb-caching hack.
212  - Better multibyte handling in EGexecute() and Fexecute().
213  - Don't need regex.c changes in grep-2.5-i18n.patch.
214  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
215  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
216    multibyte characters (bug #133932).
217  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
218  - Applied patch from Robert Scheck to tidy spec file and add a URL
219    tag (bug #135185).
220
221* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
222- based on Fedora development 2.5.1-29
223  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
224  - More build requirements (bug #125323).
225  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
226  - Fix dfa multibyte character class matching when -i is used (bug #123363).
227  - Use bracket patch before i18n patch to make it clear that the bug exists
228    upstream.
229  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
230  - Fix fgrep (bug #116909).
231  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
232  - Work around glibc bug #112869 (segfault in re_compile_pattern).
233  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
234  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
235  - Another multibyte efficiency bug-fix (bug #111800).
236  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
237  - Fixed [:alpha:]-type character classes (bug #108484).
238  - Fixed -o -i properly (bug #111489).
239  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
240  - Fixed 'fgrep -i' (bug #111614).
241  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
242  - Another two multibyte efficiency bug-fixes (bug #110524).
243  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
244  - Fixed a multibyte efficiency bug.
245  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
246  - Turn on multibyte efficiency patch again to shake out bugs.
247  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
248  - Fixed man page bug (bug #106267).
249  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
250  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
251  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
252  - Fix debuginfo package.
253  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
254  - Finally give up on making grep go fast. :-(
255  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
256  - Fixed grep -i bug introduced by cache.
257  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
258  - Redo the gofast patch (bug #97785).
259  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
260  - Fixed a bug in the gofast patch (bug #97266).
261  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
262  - Go faster (bug #69900).
263  - Fix man page.
264  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
265  - Use system regex again.
266  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
267  - Fixed bug in go-fast patch.
268  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
269  - Go fast (bug #69900).
270  - Run test suite.
271- rebuild with new toolchains
272- build with --disable-prel-regexp option
273
274* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
275- based on Rawhide 2.5.1-7
276  - Don't install /usr/share/info/dir.
277  - Fix -o -i (bug #72641).
278  - i18n patch.
279
280* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
281- 2.5-0vl1
282- update to 2.5
283- change i18n patch
284
285* Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
286- 2.5-0vl1
287- update to 2.5
288- change i18n patch
289
290* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
291- 2.4.2-4vl1
292- usr better macros (%%configure/%%makeinstall)
293
294* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
295- 2.4-3vl1
296- merge ja patch
297
298* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
299- gzip info pages (Bug #9035)
300
301* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
302- fix description
303
304* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
305- update to 2.4.
306
307* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
308- prereq install-info
309
310* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
311- auto rebuild in the new build environment (release 2)
312
313* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
314- upgraded to grep 2.3, added install-info %post/%preun for info
315
316* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
317- Injected new description and group.
318
319* Sat May 09 1998 Prospector System <bugs@redhat.com>
320- translations modified for de, fr, tr
321
322* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
323- updated to 2.2
324
325* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
326- updated from 2.0 to 2.1
327- spec file cleanups
328- added BuildRoot
329
330* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
331- built against glibc
Note: See TracBrowser for help on using the repository browser.