source: projects/specs/trunk/g/grep/grep-vl.spec @ 12336

Revision 12336, 12.5 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

gawk-5.0.1-1

grep-3.4-1

keyutils-1.6-1

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 3.4
5Release: 1%{?_dist_release}
6Group: System Environment/Base
7
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License: GPLv3+
12URL: http://www.gnu.org/software/grep/
13Source: https://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
14Source1: colorgrep.sh
15Source2: colorgrep.csh
16Source3: GREP_COLORS
17# upstream ticket 39444
18Patch0: grep-3.33-man-fix-gs.patch
19# upstream ticket 39445
20Patch1: grep-3.33-help-align.patch
21
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: pcre-devel >= 8.31
24BuildRequires: texinfo, gettext, gzip
25BuildRequires: autoconf, automake
26Requires(post): install-info
27Requires(preun): install-info
28
29
30%description
31The GNU versions of commonly used grep utilities.  Grep searches
32through textual input for lines which contain a match to a specified
33pattern and then prints the matching lines.  GNU's grep utilities
34include grep, egrep and fgrep.
35
36You should install grep on your system, because it is a very useful
37utility for searching through text.
38
39%description -l ja
40一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
41する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
42ティにはgrep, egrep, fgrepが入っています。
43
44テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
45してください。
46
47%prep
48%setup -q
49%patch0 -p1 -b .man-fix-gs
50%patch1 -p1 -b .help-align
51
52%build
53%configure \
54        --without-included-regex
55%__make %{?_smp_mflags}
56
57%install
58[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
59%__make DESTDIR=$RPM_BUILD_ROOT install
60gzip $RPM_BUILD_ROOT%{_infodir}/grep*
61rm -f $RPM_BUILD_ROOT%{_infodir}/dir
62mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
63install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
64install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
65mkdir -p $RPM_BUILD_ROOT/bin
66mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
67rm -rf $RPM_BUILD_ROOT%{_bindir}
68
69
70%find_lang %{name}
71
72%check
73make check
74
75%clean
76[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
77
78%post
79[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
80
81%preun
82if [ $1 = 0 ]; then
83        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
84fi
85
86%files -f %{name}.lang
87%defattr(-,root,root)
88%license COPYING
89%doc AUTHORS THANKS TODO NEWS README ChangeLog
90/bin/*
91%config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
92%config(noreplace) %{_sysconfdir}/GREP_COLORS
93%{_infodir}/*.info.gz
94%{_mandir}/*/*
95
96%changelog
97* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
98- new upstream release.
99- updated patches.
100
101* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22-1
102- updated to 2.22
103
104* Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.21-1
105- updated to 2.21
106- dropt patch2 which was merged into upstream
107
108* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-1
109- update to 2.14
110- build with pcre-8.31
111
112* Thu Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
113- new upstream release
114- drop unneeded old patches
115- add BR: pcre-devel
116
117* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
118- rebuilt against current toolchain
119- fix license tag
120- use CPPFLAGS= argument to configure to add an -I option.
121- Do not set LDFLAGS=-s for "make install".
122
123* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
124- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
125  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
126  - applied new versioning policy, spec in utf-8
127
128* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
129- rebuild for Vine Linux 4.x
130
131* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
132- add Patch100 to fix infinite loop with 'grep -F'
133  thanks to M.H (<BTS:484>)
134- based on Fedora devel 2.5.1-57
135  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
136  - Make preun scriptlet unconditionally succeed (bug #223697).
137  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
138  - Fixed count of patterns when the last is an empty string (bug #204255).
139  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
140  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
141  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
142  - rebuild
143  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
144  - Applied upstream patch to fix '-D skip' (bug #189580).
145  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
146  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
147  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
148  - bump again for double-long bug on ppc(64)
149  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
150  - rebuilt for new gcc4.1 snapshot and glibc changes
151  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
152  - Prevent 'grep -P' from segfaulting (bug #171379).
153
154* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
155- changed Group to System Environment/Base
156
157* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
158- based on Fedora development 2.5.1-50
159  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
160  - Futher fixing for bug #161700.
161  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
162  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
163  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
164  - Build requires recent pcre-devel (bug #154626).
165  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
166  - Run 'make check'.
167  - Fixed -w handling for EGexecute.  Now 'make check' passes.
168  - Cache MB_CUR_MAX value in egf-speedup patch.
169  - Fixed variable shadowing in egf-speedup patch.
170  - Removed redundant (and incorrect) code in prline.
171  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
172  - More -w tests from Jakub Jelinek.
173  - Rebased on 2.5.1a.
174  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
175  - More tests (Jakub Jelinek).
176  - Jakub Jelinek's much improved -Fi algorithm.
177  - Removed bogus part of grep-2.5.1-fgrep patch.
178  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
179  - Fixed -Fi for multibyte input (bug #143079).
180  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
181  - Bypass kwset matching when ignoring case and processing multibyte input
182    (bug #143079).
183  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
184  - Further UTF-8 processing avoided since a '\n' byte is always an
185    end-of-line character in that encoding.
186  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
187  - Fixed a busy loop in the egf-speedup patch (bug #140781).
188  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
189  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
190    (bug #138558).
191  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
192  - Fixed last patch.
193  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
194  - Applied patch from Karsten Hopp to fix background colour problems with
195    --color output (bug #138913).
196  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
197  - Prevent false matches when DFA is disabled (bug #138558).
198  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
199  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
200    environment variable overrides.
201  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
202  - Fixes to egf-speedup patch: now it does not change any functionality,
203    as intended.
204  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
205  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
206  - More improvements to egf-speedup patch (bug #138076).
207  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
208  - Small improvements to egf-speedup patch.
209  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
210  - Remove mb-caching hack.
211  - Better multibyte handling in EGexecute() and Fexecute().
212  - Don't need regex.c changes in grep-2.5-i18n.patch.
213  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
214  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
215    multibyte characters (bug #133932).
216  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
217  - Applied patch from Robert Scheck to tidy spec file and add a URL
218    tag (bug #135185).
219
220* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
221- based on Fedora development 2.5.1-29
222  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
223  - More build requirements (bug #125323).
224  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
225  - Fix dfa multibyte character class matching when -i is used (bug #123363).
226  - Use bracket patch before i18n patch to make it clear that the bug exists
227    upstream.
228  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
229  - Fix fgrep (bug #116909).
230  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
231  - Work around glibc bug #112869 (segfault in re_compile_pattern).
232  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
233  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
234  - Another multibyte efficiency bug-fix (bug #111800).
235  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
236  - Fixed [:alpha:]-type character classes (bug #108484).
237  - Fixed -o -i properly (bug #111489).
238  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
239  - Fixed 'fgrep -i' (bug #111614).
240  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
241  - Another two multibyte efficiency bug-fixes (bug #110524).
242  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
243  - Fixed a multibyte efficiency bug.
244  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
245  - Turn on multibyte efficiency patch again to shake out bugs.
246  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
247  - Fixed man page bug (bug #106267).
248  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
249  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
250  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
251  - Fix debuginfo package.
252  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
253  - Finally give up on making grep go fast. :-(
254  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
255  - Fixed grep -i bug introduced by cache.
256  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
257  - Redo the gofast patch (bug #97785).
258  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
259  - Fixed a bug in the gofast patch (bug #97266).
260  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
261  - Go faster (bug #69900).
262  - Fix man page.
263  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
264  - Use system regex again.
265  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
266  - Fixed bug in go-fast patch.
267  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
268  - Go fast (bug #69900).
269  - Run test suite.
270- rebuild with new toolchains
271- build with --disable-prel-regexp option
272
273* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
274- based on Rawhide 2.5.1-7
275  - Don't install /usr/share/info/dir.
276  - Fix -o -i (bug #72641).
277  - i18n patch.
278
279* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
280- 2.5-0vl1
281- update to 2.5
282- change i18n patch
283
284* Sun Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
285- 2.5-0vl1
286- update to 2.5
287- change i18n patch
288
289* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
290- 2.4.2-4vl1
291- usr better macros (%%configure/%%makeinstall)
292
293* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
294- 2.4-3vl1
295- merge ja patch
296
297* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
298- gzip info pages (Bug #9035)
299
300* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
301- fix description
302
303* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
304- update to 2.4.
305
306* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
307- prereq install-info
308
309* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
310- auto rebuild in the new build environment (release 2)
311
312* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
313- upgraded to grep 2.3, added install-info %post/%preun for info
314
315* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
316- Injected new description and group.
317
318* Sat May 09 1998 Prospector System <bugs@redhat.com>
319- translations modified for de, fr, tr
320
321* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
322- updated to 2.2
323
324* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
325- updated from 2.0 to 2.1
326- spec file cleanups
327- added BuildRoot
328
329* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
330- built against glibc
Note: See TracBrowser for help on using the repository browser.