source: projects/specs/trunk/g/grep/grep-vl.spec @ 9800

Revision 9800, 12.3 KB checked in by Takemikaduchi, 8 years ago (diff)

R, glabels: rebuild
others: new upstream release

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 2.22
5Release: 1%{?_dist_release}
6
7License: GPLv3+
8Group: System Environment/Base
9URL: http://www.gnu.org/software/grep/
10
11Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
12Source1: colorgrep.sh
13Source2: colorgrep.csh
14Source3: GREP_COLORS
15Patch1: grep-2.11-gnulib-tests-rm-f.patch
16Patch2: grep-2.14-man-fix-R.patch
17
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: pcre-devel >= 8.31
20BuildRequires: texinfo, gettext, gzip
21BuildRequires: autoconf, automake
22Requires(post): install-info
23Requires(preun): install-info
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27
28%description
29The GNU versions of commonly used grep utilities.  Grep searches
30through textual input for lines which contain a match to a specified
31pattern and then prints the matching lines.  GNU's grep utilities
32include grep, egrep and fgrep.
33
34You should install grep on your system, because it is a very useful
35utility for searching through text.
36
37%description -l ja
38一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
39する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
40ティにはgrep, egrep, fgrepが入っています。
41
42テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
43してください。
44
45%prep
46%setup -q
47%patch1 -p1 -b .gnulib-tests-rm-f
48#patch2 -p1 -b .man-fix-R
49
50
51%build
52%configure \
53        --without-included-regex
54%__make %{?_smp_mflags}
55
56%install
57[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
58%__make DESTDIR=$RPM_BUILD_ROOT install
59gzip $RPM_BUILD_ROOT%{_infodir}/grep*
60rm -f $RPM_BUILD_ROOT%{_infodir}/dir
61mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
62install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
63install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
64mkdir -p $RPM_BUILD_ROOT/bin
65mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
66rm -rf $RPM_BUILD_ROOT%{_bindir}
67
68
69%find_lang %{name}
70
71%check
72make check
73
74%clean
75[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
76
77%post
78[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
79
80%preun
81if [ $1 = 0 ]; then
82        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
83fi
84
85%files -f %{name}.lang
86%defattr(-,root,root)
87%doc AUTHORS THANKS TODO NEWS README ChangeLog COPYING
88/bin/*
89%config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
90%config(noreplace) %{_sysconfdir}/GREP_COLORS
91%{_infodir}/*.info.gz
92%{_mandir}/*/*
93
94%changelog
95* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22-1
96- updated to 2.22
97
98* Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.21-1
99- updated to 2.21
100- dropt patch2 which was merged into upstream
101
102* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-1
103- update to 2.14
104- build with pcre-8.31
105
106* Tue Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
107- new upstream release
108- drop unneeded old patches
109- add BR: pcre-devel
110
111* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
112- rebuilt against current toolchain
113- fix license tag
114- use CPPFLAGS= argument to configure to add an -I option.
115- Do not set LDFLAGS=-s for "make install".
116
117* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
118- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
119  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
120  - applied new versioning policy, spec in utf-8
121
122* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
123- rebuild for Vine Linux 4.x
124
125* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
126- add Patch100 to fix infinite loop with 'grep -F'
127  thanks to M.H (<BTS:484>)
128- based on Fedora devel 2.5.1-57
129  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
130  - Make preun scriptlet unconditionally succeed (bug #223697).
131  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
132  - Fixed count of patterns when the last is an empty string (bug #204255).
133  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
134  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
135  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
136  - rebuild
137  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
138  - Applied upstream patch to fix '-D skip' (bug #189580).
139  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
140  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
141  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
142  - bump again for double-long bug on ppc(64)
143  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
144  - rebuilt for new gcc4.1 snapshot and glibc changes
145  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
146  - Prevent 'grep -P' from segfaulting (bug #171379).
147
148* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
149- changed Group to System Environment/Base
150
151* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
152- based on Fedora development 2.5.1-50
153  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
154  - Futher fixing for bug #161700.
155  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
156  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
157  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
158  - Build requires recent pcre-devel (bug #154626).
159  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
160  - Run 'make check'.
161  - Fixed -w handling for EGexecute.  Now 'make check' passes.
162  - Cache MB_CUR_MAX value in egf-speedup patch.
163  - Fixed variable shadowing in egf-speedup patch.
164  - Removed redundant (and incorrect) code in prline.
165  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
166  - More -w tests from Jakub Jelinek.
167  - Rebased on 2.5.1a.
168  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
169  - More tests (Jakub Jelinek).
170  - Jakub Jelinek's much improved -Fi algorithm.
171  - Removed bogus part of grep-2.5.1-fgrep patch.
172  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
173  - Fixed -Fi for multibyte input (bug #143079).
174  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
175  - Bypass kwset matching when ignoring case and processing multibyte input
176    (bug #143079).
177  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
178  - Further UTF-8 processing avoided since a '\n' byte is always an
179    end-of-line character in that encoding.
180  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
181  - Fixed a busy loop in the egf-speedup patch (bug #140781).
182  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
183  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
184    (bug #138558).
185  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
186  - Fixed last patch.
187  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
188  - Applied patch from Karsten Hopp to fix background colour problems with
189    --color output (bug #138913).
190  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
191  - Prevent false matches when DFA is disabled (bug #138558).
192  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
193  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
194    environment variable overrides.
195  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
196  - Fixes to egf-speedup patch: now it does not change any functionality,
197    as intended.
198  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
199  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
200  - More improvements to egf-speedup patch (bug #138076).
201  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
202  - Small improvements to egf-speedup patch.
203  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
204  - Remove mb-caching hack.
205  - Better multibyte handling in EGexecute() and Fexecute().
206  - Don't need regex.c changes in grep-2.5-i18n.patch.
207  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
208  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
209    multibyte characters (bug #133932).
210  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
211  - Applied patch from Robert Scheck to tidy spec file and add a URL
212    tag (bug #135185).
213
214* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
215- based on Fedora development 2.5.1-29
216  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
217  - More build requirements (bug #125323).
218  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
219  - Fix dfa multibyte character class matching when -i is used (bug #123363).
220  - Use bracket patch before i18n patch to make it clear that the bug exists
221    upstream.
222  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
223  - Fix fgrep (bug #116909).
224  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
225  - Work around glibc bug #112869 (segfault in re_compile_pattern).
226  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
227  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
228  - Another multibyte efficiency bug-fix (bug #111800).
229  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
230  - Fixed [:alpha:]-type character classes (bug #108484).
231  - Fixed -o -i properly (bug #111489).
232  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
233  - Fixed 'fgrep -i' (bug #111614).
234  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
235  - Another two multibyte efficiency bug-fixes (bug #110524).
236  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
237  - Fixed a multibyte efficiency bug.
238  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
239  - Turn on multibyte efficiency patch again to shake out bugs.
240  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
241  - Fixed man page bug (bug #106267).
242  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
243  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
244  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
245  - Fix debuginfo package.
246  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
247  - Finally give up on making grep go fast. :-(
248  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
249  - Fixed grep -i bug introduced by cache.
250  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
251  - Redo the gofast patch (bug #97785).
252  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
253  - Fixed a bug in the gofast patch (bug #97266).
254  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
255  - Go faster (bug #69900).
256  - Fix man page.
257  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
258  - Use system regex again.
259  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
260  - Fixed bug in go-fast patch.
261  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
262  - Go fast (bug #69900).
263  - Run test suite.
264- rebuild with new toolchains
265- build with --disable-prel-regexp option
266
267* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
268- based on Rawhide 2.5.1-7
269  - Don't install /usr/share/info/dir.
270  - Fix -o -i (bug #72641).
271  - i18n patch.
272
273* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
274- 2.5-0vl1
275- update to 2.5
276- change i18n patch
277
278* Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
279- 2.5-0vl1
280- update to 2.5
281- change i18n patch
282
283* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
284- 2.4.2-4vl1
285- usr better macros (%%configure/%%makeinstall)
286
287* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
288- 2.4-3vl1
289- merge ja patch
290
291* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
292- gzip info pages (Bug #9035)
293
294* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
295- fix description
296
297* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
298- update to 2.4.
299
300* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
301- prereq install-info
302
303* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
304- auto rebuild in the new build environment (release 2)
305
306* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
307- upgraded to grep 2.3, added install-info %post/%preun for info
308
309* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
310- Injected new description and group.
311
312* Sat May 09 1998 Prospector System <bugs@redhat.com>
313- translations modified for de, fr, tr
314
315* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
316- updated to 2.2
317
318* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
319- updated from 2.0 to 2.1
320- spec file cleanups
321- added BuildRoot
322
323* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
324- built against glibc
Note: See TracBrowser for help on using the repository browser.