source: projects/specs/trunk/g/grantlee/grantlee-vl.spec @ 2773

Revision 2773, 3.6 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, grantlee, kdegames3, kde-l10n, kde-i18n-ja, oxygen-icon-theme
NEW: grantlee

Line 
1%define apidocs 0
2
3# apidocs disabled until we agree on a standard path.
4
5Name:           grantlee
6Summary:        Qt string template engine based on the Django template system
7Version:        0.1.8
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.gitorious.org/grantlee/pages/Home
13Source0:        http://downloads.%{name}.org/%{name}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  qt4-devel cmake
17
18%if 0%{?apidocs}   
19BuildRequires:  doxygen
20%endif
21
22%description
23Grantlee is a plug-in based String Template system written
24using the Qt framework. The goals of the project are to make it easier for
25application developers to separate the structure of documents from the
26data they contain, opening the door for theming.
27
28The syntax is intended to follow the syntax of the Django template system,
29and the design of Django is reused in Grantlee.
30Django is covered by a BSD style license.
31
32Part of the design of both is that application developers can extend
33the syntax by implementing their own tags and filters. For details of
34how to do that, see the API documentation.
35
36For template authors, different applications using Grantlee will present
37the same interface and core syntax for creating new themes. For details of
38how to write templates, see the documentation.
39
40%package        devel
41Summary:        Development files for %{name}
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description    devel
46The %{name}-devel package contains libraries and header files for
47developing applications that use %{name}.
48
49%package apidocs
50Group: Documentation
51Summary: Grantlee API documentation
52BuildArch: noarch
53
54%description apidocs
55This package includes the Grantlee API documentation in HTML
56format for easy browsing.
57
58%prep
59%setup -q -n %{name}-%{version}
60
61sed -i 's,${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX},%{_libdir},' CMakeLists.txt
62
63%build
64mkdir -p %{_target_platform}
65pushd %{_target_platform}
66%cmake .. -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=%{_prefix}
67popd
68
69make %{?_smp_mflags} -C %{_target_platform}
70
71%if 0%{?apidocs}
72make docs -C %{_target_platform}
73%endif
74
75%install
76rm -rf %{buildroot}
77make install -C %{_target_platform} DESTDIR=%{buildroot}
78
79%if 0%{?apidocs}
80mkdir -p %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
81cp -prf %{_target_platform}/apidocs/html/* %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
82%endif
83
84%clean
85rm -rf %{buildroot}
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHORS CHANGELOG COPYING.LIB README GOALS
94%{_libdir}/lib%{name}*.so.*
95%{_libdir}/%{name}
96
97%files devel
98%defattr(-,root,root,-)
99%{_includedir}/%{name}
100%{_includedir}/%{name}_core.h
101%{_includedir}/%{name}_templates.h
102%{_libdir}/lib%{name}*.so
103
104# %files apidocs
105# %{_docdir}/HTML/en/grantlee-apidocs
106
107%changelog
108* Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.8-1
109- Initial build for VineSeed
110
111* Mon Sep 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.6-1
112- grantlee 0.1.6
113
114* Fri Aug 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.5-1
115- grantlee 0.1.5
116
117* Sun Jul 04 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.2-1
118- grantlee 0.1.2
119
120* Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-3
121- disabled apidocs until we find a standard path
122
123* Tue May 11 2010 Jaroslav Reznik <jreznik@redhat.com> 0.1.1-2
124- added -apidocs subpackage
125
126* Sun May 09 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-1
127- grantlee 0.1.1
128- fixed Group
129
130* Thu Apr 15 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.0-1
131- initial fedora release
Note: See TracBrowser for help on using the repository browser.