source: projects/specs/trunk/g/gpsd/gpsd-vl.spec @ 9715

Revision 9715, 10.0 KB checked in by Takemikaduchi, 9 years ago (diff)

thunderbird: fix branding
gnu-efi: NEW PACKAGE
others: new upstream release

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
3
4Summary: Service daemon for mediating access to a GPS
5Summary(ja): GPS にアクセスするためのサービスデーモン
6
7Name: gpsd
8Version: 3.15
9Release: 1%{?_dist_release}
10
11Group: System Environment/Daemons
12License: BSD
13URL: http://www.catb.org/gpsd/
14Source0: http://download-mirror.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.gz
15Source10: gpsd.init
16Source11: gpsd.sysconfig
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19BuildRequires: scons
20BuildRequires: chrpath
21BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
22BuildRequires: libusb1-devel desktop-file-utils
23BuildRequires: eudev-libudev-devel
24
25Requires: udev
26Requires(post): /sbin/ldconfig
27Requires(post): /sbin/chkconfig
28Requires(preun): initscripts
29Requires(preun): /sbin/chkconfig
30Requires(postun): /sbin/ldconfig
31
32%description
33gpsd is a service daemon that mediates access to a GPS sensor
34connected to the host computer by serial or USB interface, making its
35data on the location/course/velocity of the sensor available to be
36queried on TCP port 2947 of the host computer.  With gpsd, multiple
37GPS client applications (such as navigational and wardriving software)
38can share access to a GPS without contention or loss of data.  Also,
39gpsd responds to queries with a format that is substantially easier to
40parse than NMEA 0183. 
41
42%package devel
43Summary: Client libraries in C and Python for talking to a running gpsd or GPS
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47
48%description devel
49This package provides C header files and python modules for the gpsd shared
50libraries that manage access to a GPS for applications
51
52%package clients
53Summary: Clients for gpsd
54Summary(ja): gpsd 用クライアント
55Group: Applications/System
56
57%description clients
58xgps is a simple test client for gpsd with an X interface. It displays
59current GPS position/time/velocity information and (for GPSes that
60support the feature) the locations of accessible satellites.
61
62xgpsspeed is a speedometer that uses position information from the GPS.
63It accepts an -h option and optional argument as for gps, or a -v option
64to dump the package version and exit. Additionally, it accepts -rv
65(reverse video) and -nc (needle color) options.
66
67cgps resembles xgps, but without the pictorial satellite display.  It
68can run on a serial terminal or terminal emulator.
69
70
71%prep
72%setup -q
73
74
75%build
76scons %{_smp_mflags}                    \
77        prefix=%{_prefix}                       \
78        bindir=%{_bindir}                       \
79        includedir=%{_includedir}       \
80        libdir=%{_libdir}                       \
81        sbindir=%{_sbindir}                     \
82        mandir=%{_mandir}                       \
83        docdir=%{_docdir}                       \
84        pkgconfigdir=%{_libdir}/pkgconfig
85
86scons build
87
88%install
89rm -rf $RPM_BUILD_ROOT
90export DESTDIR=$RPM_BUILD_ROOT
91scons install
92
93# init scripts
94%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
95%{__install} -p -m 0755 %{SOURCE10} \
96        %{buildroot}%{_sysconfdir}/init.d/gpsd
97
98%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
99%{__install} -p -m 0644 %{SOURCE11} \
100        %{buildroot}%{_sysconfdir}/sysconfig/gpsd
101
102# udev rules
103%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/udev/rules.d
104%{__install} -p -m 0644 gpsd.rules \
105        %{buildroot}%{_sysconfdir}/udev/rules.d/99-gpsd.rules
106
107# hotplug script
108%{__install} -d -m 0755 %{buildroot}/lib/udev
109%{__install} -p -m 0755 gpsd.hotplug %{buildroot}/lib/udev
110
111# remove .la files
112find %{buildroot} -name '*.la' -exec rm -f {} ';'
113
114# fix non-executable python script
115%{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
116
117# Install the .desktop files
118desktop-file-install \
119        --dir %{buildroot}%{_datadir}/applications \
120        packaging/X11/xgps.desktop
121desktop-file-install \
122        --dir %{buildroot}%{_datadir}/applications \
123        packaging/X11/xgpsspeed.desktop
124
125# Install logo icon for .desktop files
126%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
127%{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
128
129
130%clean
131rm -rf %{buildroot}
132
133%post
134/sbin/ldconfig
135/sbin/chkconfig --add %{name}
136
137%preun
138if [ $1 = 0 ]; then
139        /sbin/service %{name} stop > /dev/null 2>&1 || true
140        /sbin/chkconfig --del %{name}
141fi
142
143%postun -p /sbin/ldconfig
144
145
146%files
147%defattr(-,root,root,-)
148%doc README INSTALL COPYING
149%config(noreplace) %{_sysconfdir}/init.d/%{name}
150%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
151%config(noreplace) %{_sysconfdir}/udev/rules.d/*
152%{_sbindir}/gpsd
153%{_sbindir}/gpsdctl
154%{_bindir}/gegps
155%{_bindir}/gpsprof
156%{_bindir}/gpsmon
157%{_bindir}/gpsctl
158%{_bindir}/ntpshmmon
159%{_libdir}/libgps*.so.*
160/lib/udev/gpsd*
161%{python_sitearch}/gps*
162%exclude %{python_sitearch}/gps/fake*
163%{_mandir}/man8/gpsd.8*
164%{_mandir}/man8/gpsdctl.8*
165%{_mandir}/man8/gpsinit.8*
166%{_mandir}/man1/gegps.1*
167%{_mandir}/man1/gpsprof.1*
168%{_mandir}/man1/gpsmon.1*
169%{_mandir}/man1/gpsctl.1*
170%{_mandir}/man1/ntpshmmon.1*
171
172%files devel
173%defattr(-,root,root,-)
174%doc TODO
175%{_bindir}/gpsfake
176%{_libdir}/libgps*.so
177%{_libdir}/pkgconfig/*.pc
178%{python_sitearch}/gps/fake*
179%{_includedir}/gps.h
180%{_includedir}/libgpsmm.h
181%{_mandir}/man1/gpsfake.1*
182%{_mandir}/man3/libQgpsmm.3*
183%{_mandir}/man3/libgps.3*
184%{_mandir}/man3/libgpsmm.3*
185%{_mandir}/man5/gpsd_json.5*
186%{_mandir}/man5/srec.5*
187
188%files clients
189%defattr(-,root,root,-)
190%{_bindir}/cgps
191%{_bindir}/gps2udp
192%{_bindir}/gpscat
193%{_bindir}/gpsdecode
194%{_bindir}/gpspipe
195%{_bindir}/gpxlogger
196%{_bindir}/lcdgps
197%{_bindir}/xgps
198%{_bindir}/xgpsspeed
199%{_mandir}/man1/gps.1*
200%{_mandir}/man1/gps2udp.1*
201%{_mandir}/man1/gpsdecode.1*
202%{_mandir}/man1/gpspipe.1*
203%{_mandir}/man1/lcdgps.1*
204%{_mandir}/man1/xgps.1*
205%{_mandir}/man1/xgpsspeed.1*
206%{_mandir}/man1/cgps.1*
207%{_mandir}/man1/gpscat.1*
208%{_datadir}/applications/*.desktop
209%dir %{_datadir}/gpsd
210%{_datadir}/gpsd/gpsd-logo.png
211
212
213%changelog
214* Sat Aug 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15-1
215- new upstream release
216
217* Sat Dec 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11-1
218- new upstream release
219- change BuildRequires: eudev-libudev-devel instead of libudev-devel
220
221* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
222- new upstream release
223
224* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.7-1
225- update to 3.7
226- remove old patches
227- add BuildRequires: scons, chrpath
228
229* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-3
230- rebuild with python-2.7.2
231
232* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.95-2
233- rebuilt with rpm-4.8.1 for pkg-config
234
235* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
236- new upstream release
237- merge spec, patch, source from fedora
238
239* Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
240- add BuildRequires: libXp-devel
241
242* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
243- rebuilt with python-2.6.4
244
245* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
246- initial build for Vine Linux
247
248* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
249- Rebuild for Python 2.6
250
251* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
252- moving gpspacket.so python lib to main package
253- adding zero.patch to make ZEROIZE error go away on fedora 7
254
255* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
256- update to 2.37
257- removed install-gpsd_config.h.patch
258- installed pkgconfig files in devel package
259- added patch to install python modules in sitearch
260- removing rpath from inclucded libtool
261- moving X11 app-defaults to datadir
262- using macros for commands in install; using install instead of cp and mkdir
263- cleaning up spaces/tabs for rpmlint
264
265* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
266- Autorebuild for GCC 4.3
267
268* Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
269- Patch Makefile to also install gpsd_config.h as needed by
270  libgpsmm.h.  Redhat BZ 253433.
271
272* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
273- Make sure the logo is actually included (via the spec file).
274  I need to wake up before I try even trivial updates. 
275
276* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
277- Learn how to use search and replace (aka fix all instances of
278  gpsd-logo.png spelled incorrectly as gspd-logo.png).
279
280* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
281- Fix desktop file and logo file name.
282
283* Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
284- Include icon for .desktop files per BZ 241428
285
286* Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
287- Bump release for FE5 -> Fedora 7 upgrade path.
288
289* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
290- BR python-devel instead of python to make it build. 
291
292* Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
293- Upgrade to 2.34.
294- Get rid of %%makeinstall (which was never needed).
295- Possibly fix hotplug issuses (BZ 219750).
296- Use %%python_sitelib for python site-files stuff.
297
298* Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
299- Rebuild to pull in new version of python.
300
301* Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
302- Remove openmotif requirment, and switch to lesstif.
303
304* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
305- Bump release for rebuild in prep. for FC6.
306
307* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
308- Actually, was a missing BR glib-dbus-devel. Ooops.
309
310* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
311- Missing BR glib-devel
312
313* Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
314- Update to version 2.33
315
316* Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
317- Don't --enable-tnt in build as it causes some gpses to not work
318  properly with sattelite view mode.  See bugzilla bug 189220.
319
320* Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
321- Add dbus-glib to BuildRequires as needed for build.
322
323* Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
324- Include xmlto and python in buildrequires so things build right.
325- Don't package static library file. 
326
327* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
328- Use ye olde %%{?dist} tag.
329
330* Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
331- Initial Fedora Extras specfile
Note: See TracBrowser for help on using the repository browser.