source: projects/specs/trunk/g/gpm/gpm-vl.spec @ 521

Revision 521, 14.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A mouse server for the Linux console.
4Summary(ja):    Linux コンソール用マウスサーバ
5
6Name:           gpm
7Version:        1.20.6
8Release:        2%{?_dist_release}
9License:        GPL
10Group:          System Environment/Daemons
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source:         ftp://ftp.systemy.it/pub/develop/%{name}-%{version}.tar.gz
17Source1:        gpm.init
18Patch1:         gpm-1.20.6-multilib.patch
19Patch2:         gpm-1.20.1-lib-silent.patch
20Patch3:         gpm-1.20.3-gcc4.3.patch
21Patch4:         gpm-1.20.5-close-fds.patch
22Patch6:         gpm-1.20.6-libtool.patch
23Patch100:       gpm-1.20.1-kterm.patch
24Patch101:       gpm-1.20.1-miscterm.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildPrereq: sed gawk texinfo bison ncurses-devel
28%if %{build_compat32}
29BuildRequires: compat32-ncurses-devel
30%endif
31Prereq: chkconfig install-info
32Requires: bash >= 2.0
33Requires: gpm-libs = %{version}
34
35# this defines the library version that this package builds.
36%define LIBVER 2.1.0
37
38%description
39Gpm provides mouse support to text-based Linux applications like the
40Emacs editor and the Midnight Commander file management system.  Gpm
41also provides console cut-and-paste operations using the mouse and
42includes a program to allow pop-up menus to appear at the click of a
43mouse button.
44
45Gpm should be installed if you intend to use a mouse with your Vine Linux
46system.
47
48%description -l ja
49Gpm は Emacs エディタや Midnight Commander のようなテキストベースの
50Linux アプリケーションにマウスサポートを提供します。また Gpm はマウスを
51使ったコンソール上でのカット&ペーストをできるようにしたり、マウスボタン
52をクリックしてポップアップメニューを表示できるようにしたりします。
53
54Vine Linux システムのコンソール上でマウスを使用したい場合は Gpm を
55インストールしてください。
56
57
58%package libs
59Summary:        shared libraries for gpm
60Summary(ja):    gpm 用の共有ライブラリ
61Group:          System Environment/Libraries
62
63%description libs
64gpm-libs package provides shared libraries for gpm.
65
66%description -l ja libs
67gpm-libs パッケージは gpm 用の共有ライブラリを提供します。
68
69
70%package devel
71Summary:        Libraries and header files for developing mouse driven programs.
72Summary(ja):    マウスで操作されるプログラムの開発に必要なライブラリとヘッダファイル
73Group:          Development/Libraries
74Requires:       %{name} = %{version}
75
76%description devel
77Gpm provides mouse support to text-based Linux applications like the
78Emacs editor and the Midnight Commander file management system.  Gpm
79also provides console cut-and-paste operations using the mouse and
80includes a program to allow pop-up menus to appear at the click of a
81mouse button.
82
83%description -l ja devel
84Gpm は Emacs エディタや Midnight Commander のようなテキストベースの
85Linux アプリケーションにマウスサポートを提供します。また Gpm はマウスを
86使ったコンソール上でのカット&ペーストをできるようにしたり、マウスボタン
87をクリックしてポップアップメニューを表示できるようにしたりします。
88
89%package static
90Requires: %{name} = %{version}-%{release}
91Summary: Static development files for the gpm library
92Summary(ja): gpm ライブラリのスタティックライブラリ
93Group: Development/Libraries
94
95%description static
96The gpm-static package includes static libraries of gpm. The gpm
97provides mouse support to text-based Linux applications.
98
99%package -n compat32-%{name}-libs
100Summary:        shared libraries for gpm
101Summary(ja):    gpm 用の共有ライブラリ
102Group:          System Environment/Libraries
103
104%description -n compat32-%{name}-libs
105gpm-libs package provides shared libraries for gpm.
106
107%description -l ja -n compat32-%{name}-libs
108gpm-libs パッケージは gpm 用の共有ライブラリを提供します。
109
110
111%package -n compat32-%{name}-devel
112Summary:        Libraries and header files for developing mouse driven programs.
113Summary(ja):    マウスで操作されるプログラムの開発に必要なライブラリとヘッダファイル
114Group:          Development/Libraries
115Requires:       compat32-%{name}-libs = %{version}
116Requires:       %{name}-devel = %{version}
117
118%description -n compat32-%{name}-devel
119Gpm provides mouse support to text-based Linux applications like the
120Emacs editor and the Midnight Commander file management system.  Gpm
121also provides console cut-and-paste operations using the mouse and
122includes a program to allow pop-up menus to appear at the click of a
123mouse button.
124
125%description -l ja -n compat32-%{name}-devel
126Gpm は Emacs エディタや Midnight Commander のようなテキストベースの
127Linux アプリケーションにマウスサポートを提供します。また Gpm はマウスを
128使ったコンソール上でのカット&ペーストをできるようにしたり、マウスボタン
129をクリックしてポップアップメニューを表示できるようにしたりします。
130
131
132%prep
133%setup -q
134%patch1 -p1 -b .multilib
135%patch2 -p1 -b .lib-silent
136%patch3 -p1 -b .gcc4.3
137%patch4 -p1 -b .close-fds
138%patch6 -p1 -b .libtool
139%patch100 -p1 -b .kterm
140%patch101 -p1 -b .miscterm
141
142%build
143%if %{build_compat32}
144export CC="%__cc -m32"
145%endif
146
147autoreconf -f -i
148CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS" \
149    lispdir=%{buildroot}%{_datadir}/emacs/site-lisp \
150    %configure
151make
152
153%install
154rm -rf %{buildroot}
155mkdir -p %{buildroot}/etc
156
157PATH=/sbin:$PATH:/usr/sbin:$PATH
158
159mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp
160%makeinstall lispdir=%{buildroot}%{_datadir}/emacs/site-lisp
161
162chmod 0755 %{buildroot}/%{_libdir}/libgpm.so.%{LIBVER}
163ln -sf libgpm.so.%{LIBVER} %{buildroot}/%{_libdir}/libgpm.so
164
165%ifnarch s390 s390x
166install -m644 doc/gpm-root.1 %{buildroot}%{_mandir}/man1
167install -m644 conf/gpm-root.conf %{buildroot}/etc
168install -s -m755 src/prog/hltest %{buildroot}%{_bindir}
169%else
170rm -f $RPM_BUILD_ROOT%{_bindir}/{mev,gpm-root}
171%endif
172
173%ifnarch s390 s390x
174mkdir -p %{buildroot}/etc/rc.d/init.d 
175install -m 755 $RPM_SOURCE_DIR/gpm.init %{buildroot}/etc/rc.d/init.d/gpm
176%endif
177
178mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
179cat >$RPM_BUILD_ROOT/etc/sysconfig/gpm <<EOF
180# Additional options for gpm (e.g. acceleration), device
181OPTIONS=""
182DEVICE="/dev/mouse"
183EOF
184
185# remove stuff from the buildroot that we aren't shipping
186rm -f $RPM_BUILD_ROOT%{_bindir}/disable-paste
187rm -f $RPM_BUILD_ROOT%{_mandir}/man1/mouse-test.1*
188%ifarch s390 s390x
189rm -f $RPM_BUILD_ROOT/usr/sbin/gpm
190rm -f $RPM_BUILD_ROOT/usr/bin/hltest
191rm -f $RPM_BUILD_ROOT/usr/bin/mouse-test
192rm -rf $RPM_BUILD_ROOT/%{_mandir}
193%endif
194
195%clean
196rm -rf %{buildroot}
197
198%post
199%ifnarch s390 s390x
200/sbin/chkconfig --add gpm
201%endif
202/sbin/install-info %{_infodir}/gpm.info.gz %{_infodir}/dir
203
204%preun
205if [ $1 = 0 ]; then
206    /sbin/install-info %{_infodir}/gpm.info.gz --delete %{_infodir}/dir
207%ifnarch s390 s390x   
208    /etc/rc.d/init.d/gpm stop >/dev/null 2>&1
209    /sbin/chkconfig --del gpm
210%endif
211fi
212
213%postun
214%ifnarch s390 s390x
215if [ "$1" -ge "1" ]; then
216  /etc/rc.d/init.d/gpm condrestart >/dev/null 2>&1
217fi
218%endif
219
220%post libs -p /sbin/ldconfig
221
222%postun libs -p /sbin/ldconfig
223
224%post -n compat32-%{name}-libs -p /sbin/ldconfig
225
226%postun -n compat32-%{name}-libs -p /sbin/ldconfig
227
228%if ! %{build_compat32}
229%files
230%defattr(-,root,root)
231%ifnarch s390 s390x
232%config %{_sysconfdir}/gpm-root.conf
233%config %{_sysconfdir}/rc.d/init.d/gpm
234%{_bindir}/*
235%{_sbindir}/*
236%{_mandir}/man?/*
237%endif
238%{_infodir}/gpm.info*
239%config %{_sysconfdir}/sysconfig/gpm
240
241%files libs
242%defattr(-,root,root)
243%{_libdir}/libgpm.so.*
244
245%files devel
246%defattr(-,root,root)
247%{_includedir}/*
248%{_libdir}/libgpm.so
249
250%files static
251%defattr(-,root,root)
252%{_libdir}/libgpm.a
253%endif
254
255%if %{build_compat32}
256%files -n compat32-%{name}-libs
257%defattr(-,root,root)
258%{_libdir}/libgpm.so.*
259
260%files -n compat32-%{name}-devel
261%defattr(-,root,root)
262%{_libdir}/libgpm.so
263%endif
264
265%changelog
266* Fri May 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.6-2
267- Release tag missed the actual number (1) on 1.20.6-1; bumped the release no.
268
269* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  1.20.6-1
270- new upstream release
271- spec in utf-8
272- new versioning policy
273- split static library to -static subpackage
274
275* Sun Sep 10 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.20.1-35vl8
276- change gpm Group to System Environment/Daemons. <BTS:VineLinux:163>
277
278* Sat Aug 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.20.1-35vl7
279- fix typo in changelog
280- oops, add BuildRequires: emacsen
281
282* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-35vl6
283- fixed Group typo
284
285* Thu Aug 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.20.1-35vl5
286- add BuildRequires: emacsen
287- add Requires: %%{name}-libs for %%{name}-devel instead of gpm
288- added compat32-* packages for x86_64 architecture support
289  - add CC="%%__cc -m32" if compat32 is enabled
290
291* Fri Jul 14 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.20.1-35vl4
292- add patch 101 to fix error with alsaconf on VT. <BTS:VineLinux:85>
293- add japanese summary and description.
294- change gpm group to System Enviroment/Services.
295
296* Thu Dec 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20.1-35vl3
297- split shared libraries to gpm-libs sub package.
298
299* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20.1-35vl2
300- rebuild witn new environment
301- add patch20 to disable 'possibly I die' message.
302- add patch100 to recognize kterm as xterm.
303
304* Fri Jul  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-35vl1
305- rebuild with new toolchains
306- based on Redhat Rawhide 1.20.1-35
307  - Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 1.19.13-27
308  - ship libraries on s390/s390x
309
310* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
311- 1.19.3-0.6vl4
312- rebuild for VineSeed
313
314* Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaing.org>
315- 1.19.3-0.6vl3
316- rebuild with ncurses >= 5.0
317
318* Thu Sep 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaing.org>
319- 1.19.3-0.6vl2
320- oops, fixed %install section for installing elisps
321
322* Tue Sep 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
323- 1.19.3-0.6vl1
324- rebuild for Vine-2.x based on 1.19.3-0.6x from RH6.2/updates
325  (http://www.redhat.com/support/errata/RHSA-2000-045-01.html)
326- modified %install section to be compatible with rpm <= 3.0.3
327
328* Tue Jul 25 2000 Preston Brown <pbrown@redhat.com>
329- backport to 6.2 for errata
330
331* Sat Jul 22 2000 Florian La Roche <Florian.LaRoche@redhat.de>
332- update to 1.19.3
333
334* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
335- move initscript back
336
337* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
338- automatic rebuild
339
340* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
341- use sysconf(_SC_OPEN_MAX)
342
343* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
344- don't prereq, only require initscripts
345
346* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
347- fix up and move initscript
348- prereq initscripts >= 5.20
349
350* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
351- fix %config tag for initscript
352
353* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
354- move it back
355
356* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
357- move init script
358
359* Wed Jun 14 2000 Preston Brown <pbrown@redhat.com>
360- security patch on socket descriptor from Chris Evans.  Thanks Chris.
361- include limits.h for OPEN_MAX
362
363* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
364- 1.19.2, fix up root (setuid) patch
365- FHS paths
366
367* Thu Apr  6 2000 Jakub Jelinek <jakub@redhat.com>
368- 1.19.1
369- call initgroups in gpm-root before spawning command as user
370- make gpm-root work on big endian
371
372* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
373- call ldconfig directly in postun
374
375* Wed Mar 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
376- rebuild with new libncurses
377
378* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
379- 1.19.0
380- fix build on systems that don't have emacs
381  (configure built t-mouse* only if emacs was installed)
382
383* Tue Feb 29 2000 Preston Brown <pbrown@redhat.com>
384- important fix: improperly buildrooted for /usr/share/emacs/site-lisp, fixed.
385
386* Tue Feb 15 2000 Jakub Jelinek <jakub@redhat.com>
387- avoid cluttering of syslog with gpm No data messages
388
389* Mon Feb 14 2000 Preston Brown <pbrown@redhat.com>
390- disable-paste and mouse-test removed, they seem broken.
391
392* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
393- updated gpm.init to have better shutdown and descriptive messages
394- strip lib
395
396* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
397- fix description
398- man pages are compressed
399
400* Wed Jan 12 2000 Preston Brown <pbrown@redhat.com>
401- 1.18.1.
402
403* Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
404- upgraded to 1.18, hopefully fixes sparc protocol issues
405
406* Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
407- install-info sucks, and then you die.
408
409* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
410- chkconfig --del in %preun, not %postun
411
412* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
413- upgrade to 1.17.9
414- the maintainers are taking care of .so version now, removed patch
415
416* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
417- initscript munging
418
419* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
420- disable-paste need not be setuid root in Red Hat 6.0 (#2654)
421
422* Tue May 18 1999 Michael K. Johnson <johnsonm@redhat.com>
423- gpm.init had wrong pidfile name in comments; confused linuxconf
424
425* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
426- make sure all binaries are stripped, make init stuff more chkconfig style
427- removed sparc-specific mouse stuff
428- bumped libver to 1.17.5
429- fixed texinfo source
430
431* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
432- auto rebuild in the new build environment (release 2)
433
434* Thu Mar  4 1999 Matt Wilson <msw@redhat.com>
435- updated to 1.75.5
436
437* Tue Feb 16 1999 Cristian Gafton <gafton@redhat.com>
438- avoid using makedev for internal functions (it is a #define in the system
439  headers)
440
441* Wed Jan 13 1999 Preston Brown <pbrown@redhat.com>
442- upgrade to 1.17.2.
443
444* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
445- enforce the use of -D_GNU_SOURCE so that it will compile on the ARM
446- build against glibc 2.1
447
448* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
449- build root
450
451* Thu May 07 1998 Prospector System <bugs@redhat.com>
452- translations modified for de, fr, tr
453
454* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
455- enhanced initscript
456
457* Fri Apr 10 1998 Cristian Gafton <gafton@redhat.com>
458- recompiled for manhattan
459
460* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
461- updated to 1.13
462
463* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
464- added patch from Richard to get things to build on the SPARC
465
466* Tue Oct 28 1997 Donnie Barnes <djb@redhat.com>
467- fixed the emacs patch to install the emacs files in the right
468  place (hopefully).
469
470* Mon Oct 13 1997 Erik Troan <ewt@redhat.com>
471- added chkconfig support
472- added install-info
473
474* Thu Sep 11 1997 Donald Barnes <djb@redhat.com>
475- upgraded from 1.10 to 1.12
476- added status/restart functionality to init script
477- added define LIBVER 1.11
478
479* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
480- built against glibc
Note: See TracBrowser for help on using the repository browser.