source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _gnupg_ver              1.3.0
2%define _libgpg_error_ver       1.4
3
4Summary:        GPGME - GnuPG Made Easy
5Summary(ja):    GPGME - GnuPG Made Easy
6Name:           gpgme
7Version:        1.1.4
8Release:        2%{?_dist_release}
9License:        LGPL
10Group:          System Environment/Libraries
11Source:         ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
12URL:            http://www.gnupg.org/related_software/gpgme/
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14PreReq:         ldconfig
15Requires:       gnupg >= %{_gnupg_ver}, libgpg-error >= %{_libgpg_error_ver}
16BuildRequires:  gnupg >= %{_gnupg_ver}
17BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
18Obsoletes:      gpgme10
19Provides:       gpgme10
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%description
24GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
25for applications. It provides a High-Level Crypto API for encryption,
26decryption, signing, signature verification and key management. Currently it
27uses GnuPG as it's backend but the API isn't restricted to this engine; in
28fact it is planned to add other backends to it.
29
30%description -l ja
31GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
32るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
33ための高レベルの暗号 API を提供します。
34現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
35定されません。実際、他のバックエンドを追加することが計画されています。
36
37%package devel
38Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
39Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
40Group:          Development/Libraries
41PreReq:         install-info
42Requires:       %{name} = %{version}, libgpg-error-devel >= 0.5
43Obsoletes:      %{name} < 0.3.16-0vl2, gpgme10-devel
44Provides:       gpgme10-devel
45
46%description devel
47GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
48for applications.
49
50Install this package if you want to develop applications that will use the
51gpgme library.
52
53%description -l ja devel
54GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
55るように設計されたライブラリです。
56
57GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
58ジをインストールしてください。
59
60%prep
61%setup -q
62
63%build
64%configure --without-gpgsm
65%__make
66
67%install
68%__rm -rf %{buildroot}
69%{makeinstall}
70
71# remove unneeded files
72%__rm -rf %{buildroot}%{_datadir}/common-lisp
73%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
74
75%clean
76%__rm -rf %{buildroot}
77
78%post
79/sbin/ldconfig
80
81%postun
82/sbin/ldconfig
83
84%triggerun -- %{name} < 0.3.16-0vl2
85/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
86
87%post devel
88/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
89
90%preun devel
91if [ "$1" = 0 ] ; then
92        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
93fi
94
95%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
96/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
97
98%files
99%defattr(-,root,root)
100%doc AUTHORS COPYING* ChangeLog INSTALL NEWS README THANKS TODO
101%{_libdir}/libgpgme*.so.*
102
103%files devel
104%defattr(-,root,root)
105%{_bindir}/gpgme-config
106%{_libdir}/libgpgme*.so
107%{_datadir}/aclocal/gpgme.m4
108%{_includedir}/*
109%{_infodir}/*
110
111%changelog
112* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
113- removed *.la
114- spec in utf-8
115
116* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
117- applied new versioning policy
118
119* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
120- upstream release
121- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
122- update %%_gnupg_ver to 1.3.0
123- update %%_libgpg_error_ver to 1.4
124
125* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
126- upstream release
127
128* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
129- add Obsoletes/Provides: gpgme10{,-devel}
130
131* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
132- fix spec file's encoding from iso-2022-jp to euc-jp
133- add PreReq: ldconfig
134- add PreReq: install-info (devel)
135- change group to System Environment/Libraries (main)
136- add poor Japanese description
137
138* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
139- upstream release
140- change license from GPL to LGPL
141- update {Build,}Requires for GnuPG (>= 1.2.2)
142- add (Build)Requires: libgpg-error(-devel) >= 0.5
143- add docs
144- run ldconfig at post/postun
145- separate devel package
146  - Requires: libgpg-error-devel
147  - Obsoletes: gpgme <= 0.3.16
148
149* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
150- update to 0.3.16
151- s/Copyright/License/
152- update URL
153
154* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
155- update to 0.3.15
156- update {Build,}Requires for GnuPG
157
158* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
159- update to 0.3.11
160- added {Build,}Requires: gnupg = 1.0.7
161- added info files
162- added %%post and %%preun section for info files
163- fixed %%install section (executing rm command)
164
165* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
166- initial release
167
Note: See TracBrowser for help on using the repository browser.