source: projects/specs/trunk/g/gpgme/gpgme-vl.spec @ 12353

Revision 12353, 7.2 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

gpgme-1.13.1-1

mozjs60-60.9.0-7

p11-kit-0.23.20-1

Line 
1%define _gnupg_ver              1.4.0
2%define _libgpg_error_ver       1.4
3
4%define _unpackaged_files_terminate_build 1
5
6Name:           gpgme
7Summary:        GPGME - GnuPG Made Easy
8Summary(ja):    GPGME - GnuPG Made Easy
9Version:        1.13.1
10Release:        1%{?_dist_release}
11Group:          System Environment/Libraries
12
13License:        LGPL
14URL:            https://gnupg.org/software/gpgme/index.html
15Source:         https://gnupg.org/ftp/gcrypt/gpgme/%{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  gnupg >= %{_gnupg_ver}
19BuildRequires:  libgpg-error-devel >= %{_libgpg_error_ver}
20BuildRequires:  libassuan-devel >= 2.0.2
21BuildRequires:  chrpath
22BuildRequires:  swig
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25BuildRequires:  python-rpm-macros
26BuildRequires:  python3-devel
27BuildRequires:  python3-setuptools
28BuildRequires:  python3-rpm-macros
29
30Requires:       gnupg >= %{_gnupg_ver}
31Requires:       libgpg-error >= %{_libgpg_error_ver}
32
33Obsoletes:      gpgme10
34Provides:       gpgme10
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38
39%description
40GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
41for applications. It provides a High-Level Crypto API for encryption,
42decryption, signing, signature verification and key management. Currently it
43uses GnuPG as it's backend but the API isn't restricted to this engine; in
44fact it is planned to add other backends to it.
45
46%description -l ja
47GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
48るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
49ための高レベルの暗号 API を提供します。
50現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
51定されません。実際、他のバックエンドを追加することが計画されています。
52
53%package devel
54Summary:        GnuPG Made Easy (GPGME) Header files and libraries for development
55Summary(ja):    GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
56Group:          Development/Libraries
57Requires:       %{name} = %{version}
58Requires:       libgpg-error-devel >= 0.5
59Requires:       libassuan-devel >= 2.0.2
60Requires(post): install-info
61Requires(preun): install-info
62Obsoletes:      %{name} < 0.3.16-0vl2
63Obsoletes:      gpgme10-devel
64Provides:       gpgme10-devel
65
66%description devel
67GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
68for applications.
69
70Install this package if you want to develop applications that will use the
71gpgme library.
72
73%description -l ja devel
74GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
75るように設計されたライブラリです。
76
77GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
78ジをインストールしてください。
79
80%package -n python-gpg
81Summary:        %{name} bindings for Python 2
82%{?python_provide:%python_provide python2-gpg}
83Requires:       %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
84
85%description -n python-gpg
86%{summary}.
87
88%package -n python3-gpg
89Summary:        %{name} bindings for Python 3
90%{?python_provide:%python_provide python3-gpg}
91Requires:       %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
92
93%description -n python3-gpg
94%{summary}.
95
96
97%prep
98%setup -q
99
100%build
101%configure --disable-gpgsm-test
102%__make
103
104%install
105%__rm -rf %{buildroot}
106%{makeinstall}
107
108# remove unneeded files
109%__rm -rf %{buildroot}%{_datadir}/common-lisp
110%__rm -f %{buildroot}%{_libdir}/*.la
111%__rm -f %{buildroot}%{_infodir}/dir
112
113chrpath -d %{buildroot}%{_bindir}/%{name}-tool
114chrpath -d %{buildroot}%{_libdir}/lib%{name}*.so*
115
116# autofoo installs useless stuff for uninstall
117rm -vf %{buildroot}%{python2_sitelib}/gpg/install_files.txt
118rm -vf %{buildroot}%{python3_sitelib}/gpg/install_files.txt
119
120%clean
121%__rm -rf %{buildroot}
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%triggerun -- %{name} < 0.3.16-0vl2
128/sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
129
130%post devel
131/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
132
133%preun devel
134if [ "$1" = 0 ] ; then
135        /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
136fi
137
138%triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
139/sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
140
141%files
142%defattr(-,root,root)
143%license COPYING*
144%doc AUTHORS ChangeLog NEWS README* THANKS TODO VERSION
145%{_bindir}/gpgme-json
146%{_libdir}/libgpgme*.so.*
147
148%files devel
149%defattr(-,root,root)
150%{_bindir}/gpgme-config
151%{_bindir}/gpgme-tool
152%{_libdir}/libgpgme*.so
153%{_libdir}/cmake/*
154%{_libdir}/pkgconfig/*
155%{_datadir}/aclocal/gpgme.m4
156%{_includedir}/*
157%{_infodir}/*
158
159%files -n python-gpg
160%doc lang/python/README
161%{python_sitearch}/gpg-*.egg-info
162%{python_sitearch}/gpg/
163
164%files -n python3-gpg
165%doc lang/python/README
166%{python3_sitearch}/gpg-*.egg-info
167%{python3_sitearch}/gpg/
168
169%changelog
170* Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.1-1
171- new upstream release.
172
173* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
174- enabled python{2,3} bindings.
175
176* Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
177- new upstream release.
178
179* Fri Jul 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
180- new upstream release.
181
182* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
183- new upstream release
184- add BuildRequires: libassuan-devel >= 2
185- add Requires: libassuan-devel >= 2 for devel subpackage
186- update GnuPG min version
187
188* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
189- new upstream release
190
191* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
192- removed *.la
193- spec in utf-8
194
195* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
196- applied new versioning policy
197
198* Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
199- upstream release
200- add new macros: %%_gnupg_ver, %%_libgpg_error_ver
201- update %%_gnupg_ver to 1.3.0
202- update %%_libgpg_error_ver to 1.4
203
204* Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
205- upstream release
206
207* Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
208- add Obsoletes/Provides: gpgme10{,-devel}
209
210* Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
211- fix spec file's encoding from iso-2022-jp to euc-jp
212- add PreReq: ldconfig
213- add PreReq: install-info (devel)
214- change group to System Environment/Libraries (main)
215- add poor Japanese description
216
217* Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
218- upstream release
219- change license from GPL to LGPL
220- update {Build,}Requires for GnuPG (>= 1.2.2)
221- add (Build)Requires: libgpg-error(-devel) >= 0.5
222- add docs
223- run ldconfig at post/postun
224- separate devel package
225  - Requires: libgpg-error-devel
226  - Obsoletes: gpgme <= 0.3.16
227
228* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
229- update to 0.3.16
230- s/Copyright/License/
231- update URL
232
233* Fri Mar  7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
234- update to 0.3.15
235- update {Build,}Requires for GnuPG
236
237* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
238- update to 0.3.11
239- added {Build,}Requires: gnupg = 1.0.7
240- added info files
241- added %%post and %%preun section for info files
242- fixed %%install section (executing rm command)
243
244* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
245- initial release
246
Note: See TracBrowser for help on using the repository browser.