source: projects/specs/trunk/g/gperftools/gperftools-vl.spec @ 6995

Revision 6995, 4.0 KB checked in by daisuke, 11 years ago (diff)

rebuild with libunwind-1.0.1

Line 
1Name:           gperftools
2Version:        2.0
3Release:        2%{?_dist_release}
4License:        BSD
5Group:          Development/Tools
6Summary:        Very fast malloc and performance analysis tools
7Summary(ja):    超高速な malloc と性能分析ツール
8URL:            http://code.google.com/p/gperftools/
9Source0:        http://gperftools.googlecode.com/files/%{name}-%{version}.tar.gz
10# http://code.google.com/p/gperftools/issues/detail?id=444
11Patch0:         gperftools-2.0-glibc216.patch
12# ppc64 still broken, bz 238390
13ExclusiveArch:  %{ix86} x86_64 ppc %{arm}
14%ifnarch ppc ppc64
15BuildRequires:  libunwind-devel >= 1.0.1
16%endif
17
18%description
19Perf Tools is a collection of performance analysis tools, including a
20high-performance multi-threaded malloc() implementation that works
21particularly well with threads and STL, a thread-friendly heap-checker,
22a heap profiler, and a cpu-profiler.
23
24%package devel
25Summary:        Development libraries and headers for gperftools
26Summary(ja):    gperftools の開発用ライブラリとヘッダ
27Group:          Development/Libraries
28Requires:       %{name}-libs = %{version}-%{release}
29Provides:       google-perftools-devel = %{version}-%{release}
30Obsoletes:      google-perftools-devel < 2.0
31
32%description devel
33Libraries and headers for developing applications that use gperftools.
34
35%package libs
36Summary:        Libraries provided by gperftools
37Summary(ja):    gperftools ライブラリ
38Provides:       google-perftools = %{version}-%{release}
39Obsoletes:      google-perftools < 2.0
40
41%description libs
42Libraries provided by gperftools, including libtcmalloc and libprofiler.
43
44%package -n pprof
45Summary:        CPU and Heap Profiler tool
46Summary(ja):    CPU および Heap プロファイルツール
47Requires:       gv, graphviz
48BuildArch:      noarch
49Provides:       google-perftools = %{version}-%{release}
50Obsoletes:      google-perftools < 2.0
51
52%description -n pprof
53Pprof is a heap and CPU profiler tool, part of the gperftools suite.
54
55%prep
56%setup -q
57%patch0 -p1 -b .glibc216
58
59# Fix end-of-line encoding
60sed -i 's/\r//' README_windows.txt
61
62# No need to have exec permissions on source code
63chmod -x src/sampler.h src/sampler.cc
64
65%build
66CXXFLAGS=`echo $RPM_OPT_FLAGS -DTCMALLOC_LARGE_PAGES| sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g'`
67%configure --disable-static
68
69# Bad rpath!
70sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
71sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
72# Can't build with smp_mflags
73make
74
75%install
76make DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}-%{version}/ install
77find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
78
79# Zero files
80rm -rf %{buildroot}%{_docdir}/%{name}-%{version}/NEWS
81
82# Delete useless files
83rm -rf %{buildroot}%{_docdir}/%{name}-%{version}/INSTALL
84
85%check
86# http://code.google.com/p/google-perftools/issues/detail?id=153
87%ifnarch ppc
88# Their test suite is junk. Disabling.
89# LD_LIBRARY_PATH=./.libs make check
90%endif
91
92%post libs -p /sbin/ldconfig
93%postun libs -p /sbin/ldconfig
94
95%files -n pprof
96%{_bindir}/pprof
97%{_mandir}/man1/*
98
99%files devel
100%{_docdir}/%{name}-%{version}/
101%{_includedir}/google/
102%{_includedir}/gperftools/
103%{_libdir}/*.so
104%{_libdir}/pkgconfig/*.pc
105
106%files libs
107%{_libdir}/*.so.*
108
109%changelog
110* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  2.0-2
111- rebuild with libunwind-1.0.1
112
113* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  2.0-1
114- update to 2.0, rename to gperftools
115
116* Wed Oct 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
117- new upstream release
118
119* Tue Jun 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.91-0vl1
120- initial build for Vine Linux
121
122* Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-3
123- The tests work fine for me locally, but some of them fail inside mock.
124
125* Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-2
126- no support for ppc yet
127
128* Mon Apr 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-1
129- alright, lets see if this works now.
130
131* Wed Oct 13 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-2
132- change group to Development/Tools
133
134* Mon Oct 10 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-1
135- initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.