source: projects/specs/trunk/g/gpaste/gpaste-vl.spec @ 7782

Revision 7782, 5.3 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%global alt_name GPaste
2
3Name:           gpaste
4Version:        3.0.2
5Release:        1%{?_dist_release}
6Summary:        Clipboard management system
7Summary(ja):    クリップボード管理システム
8
9Group:          User Interface/Desktops
10License:        GPLv3+
11URL:            https://github.com/Keruspe/GPaste
12Source0:        https://github.com/downloads/Keruspe/%{alt_name}/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires: chrpath
17BuildRequires: dbus-devel
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: glib2-devel >= 2.30
21BuildRequires: gobject-introspection-devel
22BuildRequires: gtk3-devel
23BuildRequires: intltool >= 0.40.0
24BuildRequires: libxml2-devel
25BuildRequires: libXtst-devel
26BuildRequires: vala-devel >= 0.14
27BuildRequires: vala-tools >= 0.14
28BuildRequires: xcb-util-keysyms-devel
29
30Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
31
32%description
33gpasted is a clipboard management daemon with DBus interface. gpaste is its CLI
34client and gpaste-settings is a tool to edit gpasted settings.
35
36
37%package libs
38Summary:        Library to manage the clipboard history
39Group:          System Environment/Libraries
40
41%description libs
42libgpaste is a library to manage the clipboard history (used by gpasted).
43
44
45%package devel
46Summary:        Development files for %{name}
47Summary(ja):    %{name} の開発ファイル
48Group:          Development/Libraries
49Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
50
51%description devel
52The %{name}-devel package contains libraries and header files for
53developing applications that use %{name}.
54
55
56%package -n gnome-shell-extensions-%{name}
57Summary:        GNOME Shell extension for GPaste
58Summary(ja):    GPaste 用の Gnome Shell 機能拡張
59Group:          User Interface/Desktops
60Requires:       gnome-shell >= 3.3.5
61Requires:       %{name} = %{version}-%{release}
62BuildArch:      noarch
63
64%description -n gnome-shell-extensions-%{name}
65%{summary}.
66
67
68%prep
69%setup -q
70
71%build
72./autogen.sh
73# Applet disabled since it is unusable in GNOME 3
74%configure \
75  --disable-applet \
76  --disable-schemas-compile
77make %{?_smp_mflags}
78
79
80%install
81make install DESTDIR=$RPM_BUILD_ROOT
82
83rm $RPM_BUILD_ROOT%{_libdir}/*.la
84
85# Fix Rpath issues
86chrpath --delete $RPM_BUILD_ROOT%{_libexecdir}/%{name}/gpasted
87chrpath --delete $RPM_BUILD_ROOT%{_libexecdir}/%{name}/gpaste-settings
88
89# Install bash/zsh completion support
90install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
91install -pm 0644 data/completions/%{name} -t $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
92install -d $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions/
93install -pm 0644 data/completions/_%{name} -t $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions/
94
95desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-settings.desktop
96
97%find_lang %{alt_name}
98
99
100%post libs -p /sbin/ldconfig
101
102
103%postun libs -p /sbin/ldconfig
104
105
106%postun
107if [ $1 -eq 0 ]; then
108  /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
109fi
110
111%posttrans
112/usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
113
114
115%files -f %{alt_name}.lang
116%defattr(-,root,root,-)
117%doc AUTHORS ChangeLog COPYING NEWS THANKS TODO
118%{_bindir}/%{name}
119%{_libexecdir}/%{name}/
120%{_datadir}/applications/%{name}-settings.desktop
121%{_datadir}/dbus-1/services/*.service
122%{_datadir}/glib-2.0/schemas/*.xml
123%{_datadir}/vala/vapi/*
124%{_datadir}/zsh/
125%{_mandir}/man1/%{name}.1.*
126%{_sysconfdir}/bash_completion.d/
127
128
129%files libs
130%defattr(-,root,root,-)
131%{_libdir}/girepository-1.0/%{alt_name}-1.0.typelib
132%{_libdir}/*.so.*
133
134
135%files devel
136%defattr(-,root,root,-)
137%{_datadir}/gir-1.0/*.gir
138%{_includedir}/%{name}/
139%{_libdir}/*.so
140%{_libdir}/pkgconfig/*.pc
141
142
143%files -n gnome-shell-extensions-%{name}
144%defattr(-,root,root,-)
145%{_datadir}/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org/
146
147
148%changelog
149* Sat Aug 31 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
150- initial build for VineSeed
151
152* Sat May 19 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.8.1-1
153- Update to 2.8.1
154
155* Thu May 03 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.8-1
156- Update to 2.8
157
158* Sun Apr 08 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.5-2
159- Fix Group and Requires tags in subpackages
160
161* Fri Mar 30 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.5-1
162- Update to 2.5
163
164* Sat Jan 07 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.2.1-1
165- Update to 2.2.1
166
167* Fri Dec 09 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.1-1
168- Update to 2.1
169
170* Tue Nov 29 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 2.0-1
171- Update to 2.0
172
173* Sun Sep 25 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.6-1
174- Update to 1.6
175- Remove no longer needed gpaste-1.5-DOS.patch patch
176
177* Wed Sep 14 2011 Mohamed El Morabity <melmorabity@fedorapeople.org> - 1.5-1
178- Update to 1.5
179- Remove gpaste-1.3-remove_applet_refs.patch patch (there is no more reference
180  to the GNOME 2 applet in documentation and completion files)
181- Add gpaste-1.5-DSO.patch to fix DSO linking
182
183* Sat Sep 03 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.3-1
184- Update to 1.3
185
186* Sun Jul 10 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.2-1
187- Update to 1.2
188
189* Sat Jun 25 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.99-1.17dd47git
190- Initial RPM release
Note: See TracBrowser for help on using the repository browser.