source: projects/specs/trunk/g/google-gadgets/google-gadgets-vl.spec @ 4670

Revision 4670, 8.8 KB checked in by yasumichi, 13 years ago (diff)

NetworkManager-0.9.0 でビルドできるようにした。

Line 
1#define svnrev   1449
2#define alphatag 20090430svn%{svnrev}
3
4Name:           google-gadgets
5Summary:        Google Gadgets platform for Linux
6Version:        0.11.2
7Release:        3%{?_dist_release}
8
9Group:          User Interface/Desktops
10License:        ASL 2.0
11URL:            http://code.google.com/p/google-gadgets-for-linux/
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       inagaki,yasumichi
16
17Source0:        http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
18#Source0:        %{name}-%{version}-r%{svnrev}.tar.bz2
19Patch0:         NM-0.9.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires:  curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
24# still needed even if we're not buliding gtkmoz element, for JavaScript
25#%%if %{?_dist_release} == "vl5"
26#BuildRequires:  xulrunner-devel-unstable
27#%%else
28#BuildRequires:  xulrunner-devel
29#%%endif
30BuildRequires:  WebKit-gtk-devel
31BuildRequires:  dbus-devel gstreamer-devel gstreamer-plugins-base-devel
32BuildRequires:  cairo-devel gtk2-devel librsvg2-devel
33BuildRequires:  qt4-devel zip
34# Desktop integration
35BuildRequires:  NetworkManager-devel startup-notification-devel
36# libxml2-devel needed for desktop file generation
37BuildRequires:  libxml2-devel desktop-file-utils
38BuildRequires:  pkgconfig
39Requires:       %{name}-frontend = %{version}-%{release}
40Requires:       hicolor-icon-theme
41
42%description
43Google Gadgets for Linux provides a platform for running desktop
44gadgets under Linux, catering to the unique needs of Linux users. It
45can run, without modification, many Google Desktop gadgets as well as
46the Universal Gadgets on iGoogle.
47
48
49%package        gtk
50Summary:        GTK+ front-end for %{name}
51Summary(ja):    Google Gadgets の GTK+ 版フロントエンド
52Group:          User Interface/Desktops
53Requires:       %{name} = %{version}-%{release}
54Provides:       %{name}-frontend = %{version}-%{release}
55
56%description    gtk
57The %{name}-gtk package contains the GTK+ front-end for %{name}.
58
59
60%package        qt
61Summary:        Qt front-end for %{name}
62Summary(ja):    Google Gadgets の Qt 版フロントエンド
63Group:          User Interface/Desktops
64Requires:       %{name} = %{version}-%{release}
65Provides:       %{name}-frontend = %{version}-%{release}
66
67%description    qt
68The %{name}-qt package contains the Qt front-end for %{name}.
69
70
71%package        devel
72Summary:        Development files for %{name}
73Summary(ja):    %{name} の開発用ファイル
74Group:          Development/Libraries
75Requires:       %{name} = %{version}-%{release}
76Requires:       pkgconfig dbus-devel gtk2-devel qt4-devel
77Requires:       %{name}-gtk
78Requires:       %{name}-qt
79
80%description    devel
81The %{name}-devel package contains libraries and header files for
82developing applications that use %{name}.
83
84
85%prep
86%setup -q -n %{name}-for-linux-%{version}
87%patch0 -p1
88# Permission fixes
89chmod -x ggadget/qt/utilities.h
90# Fix invalid desktop file MIME type
91# http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
92for f in hosts/*/ggl-*.desktop.in; do
93    sed -i 's|;app/gg;|;|' $f
94done
95
96
97%build
98#autotools/bootstrap.sh
99#ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
100
101%configure --disable-static \
102           --with-browser-plugins-dir=%{_libdir}/mozilla/plugins \
103           --disable-gtkmoz-browser-element --disable-smjs-script-runtime
104
105# Rpath fix by Mamoru Tasaka
106# we don't want to obliterate all RPATHs, since it is used during build
107# Add library search path
108sed -i.libdir_syssearch -e \
109 '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
110 configure
111# Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
112sed -i.extra_R -e \
113 's|-R\$(libdir)||' \
114 hosts/*/Makefile.in
115
116# default compile flags are impossibly strict
117make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
118
119# Remove quotes from .pc files
120find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
121
122
123%install
124rm -rf $RPM_BUILD_ROOT
125make install DESTDIR=$RPM_BUILD_ROOT \
126     INSTALL="install -p" CPPROG="cp -p"
127find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
128
129# reinstall desktop files
130for i in gtk qt; do
131  desktop-file-install \
132    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
133    --delete-original \
134    $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
135done
136
137# wipe prematurely-generated MIME info
138rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
139rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post
146/sbin/ldconfig
147touch --no-create %{_datadir}/icons/hicolor || :
148
149%postun
150/sbin/ldconfig
151if [ $1 -eq 0 ] ; then
152    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
153    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
154fi
155
156%posttrans
157gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
158
159%post gtk
160/sbin/ldconfig
161update-desktop-database &> /dev/null || :
162
163%postun gtk
164/sbin/ldconfig
165update-desktop-database &> /dev/null || :
166
167%post qt
168/sbin/ldconfig
169update-desktop-database &> /dev/null || :
170
171%postun qt
172/sbin/ldconfig
173update-desktop-database &> /dev/null || :
174
175
176%files
177%defattr(-,root,root,-)
178%doc AUTHORS COPYING README
179%{_libdir}/google-gadgets
180#%%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
181%exclude %{_libdir}/google-gadgets/modules/gtk*.so
182%exclude %{_libdir}/google-gadgets/modules/qt*.so
183%exclude %{_libdir}/google-gadgets/include
184%{_libdir}/lib*.so.*
185%exclude %{_libdir}/lib*gtk*
186%exclude %{_libdir}/lib*qt*
187%{_datadir}/google-gadgets
188%{_datadir}/pixmaps/google-gadgets.png
189%{_datadir}/icons/hicolor/*/*/*.png
190
191%files gtk
192%defattr(-,root,root,-)
193%{_bindir}/ggl-gtk
194%{_libdir}/libggadget-gtk*.so.*
195#%%{_libdir}/google-gadgets/gtkmoz-browser-child
196%{_libdir}/google-gadgets/modules/gtk*.so
197%{_datadir}/applications/*gtk.desktop
198%{_datadir}/applications/*designer.desktop
199
200%files qt
201%defattr(-,root,root,-)
202%{_bindir}/ggl-qt
203%{_libdir}/libggadget-qt*.so.*
204%{_libdir}/google-gadgets/modules/qt*.so
205%{_datadir}/applications/*qt.desktop
206
207%files devel
208%defattr(-,root,root,-)
209%{_includedir}/google-gadgets
210%{_libdir}/lib*.so
211%{_libdir}/google-gadgets/include
212%{_libdir}/pkgconfig/*.pc
213
214
215%changelog
216* Sat Aug 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-3
217- add patch for building with NetworkManager-0.9.0
218- add Vendor, Distribution and Packager tag
219
220* Thu Aug 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-2
221- not work with xulrunner 2.0, remove from BR.
222- add --disable-gtkmoz-browser-element , --disable-smjs-script-runtime
223
224* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
225- new upstream release
226- built with rpm-4.8.1 for pkg-config
227- dropt Patch0
228- added BR: WebKit-gtk-devel
229- removed invalid MIME entry from .desktop files
230
231* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
232- new upstream release
233
234* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
235- Initial build for Vine Linux
236
237* Wed Jul  1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
238- Update to 0.11.0
239
240* Sat May  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
241- Update to SVN checkout, for xulrunner 1.9.1 compatibility
242
243* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
244- Rebuild against newer gecko
245
246* Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
247- Rebuild against newer gecko
248
249* Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
250- Rebuild against newer gecko
251
252* Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
253- Rebuild against newer gecko
254
255* Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
256- 0.10.5, req'd by kde
257
258* Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
259- BR: Network-Manager-devel, startup-notification-devel
260- Pass the browser plugin directory to ./configure
261- Move designer desktop entry to -gtk subpackage
262
263* Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
264- Update to 0.10.4 (#477251)
265- -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
266- BR: pkgconfig (automatic pkgconfig deps)
267
268* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
269- Update to 0.10.3
270
271* Sat Nov  8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
272- s/qt-devel/qt4-devel/
273- -qt: fix summary
274
275* Tue Sep  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
276- Unquote version strings in .pc files
277
278* Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
279- RPATH and timestamp fixes from Mamoru Tasaka
280
281* Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
282- Fix desktop file creation
283
284* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
285- Update to 0.10.1
286
287* Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
288- Update to 0.10.0
289- Add missing dependencies for -devel subpackage
290
291* Sun Jul  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
292- Update to 0.9.3
293
294* Fri Jun  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
295- Initial package
Note: See TracBrowser for help on using the repository browser.