source: projects/specs/trunk/g/google-gadgets/google-gadgets-vl.spec @ 10784

Revision 10784, 8.8 KB checked in by ara_t, 8 years ago (diff)

gauche 0.9.5-1

Line 
1Name:           google-gadgets
2Summary:        Google Gadgets platform for Linux
3Version:        0.11.2
4Release:        5%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        ASL 2.0
8URL:            http://code.google.com/p/google-gadgets-for-linux/
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12Packager:       inagaki,yasumichi
13
14Source0:        http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
15# Vine Patches
16Patch0:         NM-0.9.patch
17Patch1:         nm-mobile-devtypes.patch
18Patch2:         glib-2.32.patch
19Patch3:         gcc-4.7.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22BuildRequires:  WebKit-gtk-devel
23BuildRequires:  cairo-devel
24BuildRequires:  curl-devel
25BuildRequires:  dbus-devel
26BuildRequires:  desktop-file-utils
27BuildRequires:  gstreamer-devel
28BuildRequires:  gstreamer-plugins-base-devel
29BuildRequires:  gtk2-devel
30BuildRequires:  librsvg2-devel
31BuildRequires:  libtool-ltdl-devel
32BuildRequires:  libxml2-devel
33BuildRequires:  pkgconfig
34BuildRequires:  qt4-devel
35BuildRequires:  zip
36BuildRequires:  zlib-devel
37# Desktop integration
38BuildRequires:  NetworkManager-devel
39BuildRequires:  startup-notification-devel
40#Requires:       %{name}-frontend = %{version}-%{release}
41Requires:       hicolor-icon-theme
42
43%description
44Google Gadgets for Linux provides a platform for running desktop
45gadgets under Linux, catering to the unique needs of Linux users. It
46can run, without modification, many Google Desktop gadgets as well as
47the Universal Gadgets on iGoogle.
48
49
50%package        gtk
51Summary:        GTK+ front-end for %{name}
52Summary(ja):    Google Gadgets の GTK+ 版フロントエンド
53Group:          User Interface/Desktops
54Requires:       %{name} = %{version}-%{release}
55Provides:       %{name}-frontend = %{version}-%{release}
56
57%description    gtk
58The %{name}-gtk package contains the GTK+ front-end for %{name}.
59
60
61%package        qt
62Summary:        Qt front-end for %{name}
63Summary(ja):    Google Gadgets の Qt 版フロントエンド
64Group:          User Interface/Desktops
65Requires:       %{name} = %{version}-%{release}
66Provides:       %{name}-frontend = %{version}-%{release}
67
68%description    qt
69The %{name}-qt package contains the Qt front-end for %{name}.
70
71
72%package        devel
73Summary:        Development files for %{name}
74Summary(ja):    %{name} の開発用ファイル
75Group:          Development/Libraries
76Requires:       %{name} = %{version}-%{release}
77Requires:       pkgconfig dbus-devel gtk2-devel qt4-devel
78Requires:       %{name}-gtk
79Requires:       %{name}-qt
80
81%description    devel
82The %{name}-devel package contains libraries and header files for
83developing applications that use %{name}.
84
85
86%prep
87%setup -q -n %{name}-for-linux-%{version}
88%patch0 -p1
89%patch1 -p1
90%patch2 -p1
91%patch3 -p1
92
93# Permission fixes
94chmod -x ggadget/qt/utilities.h
95# Fix invalid desktop file MIME type
96# http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
97for f in hosts/*/ggl-*.desktop.in; do
98    sed -i 's|;app/gg;|;|' $f
99done
100
101
102%build
103%configure --disable-static \
104           --with-browser-plugins-dir=%{_libdir}/mozilla/plugins \
105           --disable-gtkmoz-browser-element --disable-smjs-script-runtime
106
107# Rpath fix by Mamoru Tasaka
108# we don't want to obliterate all RPATHs, since it is used during build
109# Add library search path
110sed -i.libdir_syssearch -e \
111 '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
112 configure
113# Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
114sed -i.extra_R -e \
115 's|-R\$(libdir)||' \
116 hosts/*/Makefile.in
117
118# default compile flags are impossibly strict
119make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
120
121# Remove quotes from .pc files
122find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
123
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install DESTDIR=$RPM_BUILD_ROOT \
128     INSTALL="install -p" CPPROG="cp -p"
129find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
130
131# reinstall desktop files
132for i in gtk qt; do
133  desktop-file-install \
134    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
135    --delete-original \
136    $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
137done
138
139# wipe prematurely-generated MIME info
140rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
141rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146
147%post
148/sbin/ldconfig
149touch --no-create %{_datadir}/icons/hicolor || :
150
151%postun
152/sbin/ldconfig
153if [ $1 -eq 0 ] ; then
154    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
155    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
156fi
157
158%posttrans
159gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
160
161%post gtk
162/sbin/ldconfig
163update-desktop-database &> /dev/null || :
164
165%postun gtk
166/sbin/ldconfig
167update-desktop-database &> /dev/null || :
168
169%post qt
170/sbin/ldconfig
171update-desktop-database &> /dev/null || :
172
173%postun qt
174/sbin/ldconfig
175update-desktop-database &> /dev/null || :
176
177
178%files
179%defattr(-,root,root,-)
180%doc AUTHORS COPYING README
181%{_libdir}/google-gadgets
182#%%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
183%exclude %{_libdir}/google-gadgets/modules/gtk*.so
184%exclude %{_libdir}/google-gadgets/modules/qt*.so
185%exclude %{_libdir}/google-gadgets/include
186%{_libdir}/lib*.so.*
187%exclude %{_libdir}/lib*gtk*
188%exclude %{_libdir}/lib*qt*
189%{_datadir}/google-gadgets
190%{_datadir}/pixmaps/google-gadgets.png
191%{_datadir}/icons/hicolor/*/*/*.png
192
193%files gtk
194%defattr(-,root,root,-)
195%{_bindir}/ggl-gtk
196%{_libdir}/libggadget-gtk*.so.*
197#%%{_libdir}/google-gadgets/gtkmoz-browser-child
198%{_libdir}/google-gadgets/modules/gtk*.so
199%{_datadir}/applications/*gtk.desktop
200%{_datadir}/applications/*designer.desktop
201
202%files qt
203%defattr(-,root,root,-)
204%{_bindir}/ggl-qt
205%{_libdir}/libggadget-qt*.so.*
206%{_libdir}/google-gadgets/modules/qt*.so
207%{_datadir}/applications/*qt.desktop
208
209%files devel
210%defattr(-,root,root,-)
211%{_includedir}/google-gadgets
212%{_libdir}/lib*.so
213%{_libdir}/google-gadgets/include
214%{_libdir}/pkgconfig/*.pc
215
216
217%changelog
218* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 0.11.2-5
219- rebuild with gcc-5.4.0
220
221* Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.11.2-4
222- added Patch1, 2 and 3
223
224* Sat Aug 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-3
225- add patch for building with NetworkManager-0.9.0
226- add Vendor, Distribution and Packager tag
227
228* Thu Aug 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-2
229- not work with xulrunner 2.0, remove from BR.
230- add --disable-gtkmoz-browser-element , --disable-smjs-script-runtime
231
232* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
233- new upstream release
234- built with rpm-4.8.1 for pkg-config
235- dropt Patch0
236- added BR: WebKit-gtk-devel
237- removed invalid MIME entry from .desktop files
238
239* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
240- new upstream release
241
242* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
243- Initial build for Vine Linux
244
245* Wed Jul  1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
246- Update to 0.11.0
247
248* Sat May  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
249- Update to SVN checkout, for xulrunner 1.9.1 compatibility
250
251* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
252- Rebuild against newer gecko
253
254* Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
255- Rebuild against newer gecko
256
257* Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
258- Rebuild against newer gecko
259
260* Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
261- Rebuild against newer gecko
262
263* Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
264- 0.10.5, req'd by kde
265
266* Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
267- BR: Network-Manager-devel, startup-notification-devel
268- Pass the browser plugin directory to ./configure
269- Move designer desktop entry to -gtk subpackage
270
271* Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
272- Update to 0.10.4 (#477251)
273- -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
274- BR: pkgconfig (automatic pkgconfig deps)
275
276* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
277- Update to 0.10.3
278
279* Sat Nov  8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
280- s/qt-devel/qt4-devel/
281- -qt: fix summary
282
283* Tue Sep  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
284- Unquote version strings in .pc files
285
286* Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
287- RPATH and timestamp fixes from Mamoru Tasaka
288
289* Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
290- Fix desktop file creation
291
292* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
293- Update to 0.10.1
294
295* Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
296- Update to 0.10.0
297- Add missing dependencies for -devel subpackage
298
299* Sun Jul  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
300- Update to 0.9.3
301
302* Fri Jun  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
303- Initial package
Note: See TracBrowser for help on using the repository browser.