source: projects/specs/trunk/g/gobject-introspection/gobject-introspection-vl.spec @ 4812

Revision 4812, 6.4 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           gobject-introspection
5Version:        1.30.0
6Release:        1%{?_dist_release}
7Summary:        Introspection system for GObject-based libraries
8
9Group:          Development/Libraries
10License:        GPLv2+, LGPLv2+, MIT
11URL:            http://live.gnome.org/GObjectIntrospection
12Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/1.30/%{name}-%{version}.tar.xz
13Source1:        glib-2.0.c
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17Obsoletes:     gir-repository < 0.6.6
18
19BuildRequires:  glib2-devel
20BuildRequires:  python-devel >= 2.5
21BuildRequires:  gettext
22BuildRequires:  intltool
23BuildRequires:  gtk-doc
24BuildRequires:  flex
25BuildRequires:  bison
26BuildRequires:  libffi-devel
27BuildRequires:  mesa-libGL-devel
28BuildRequires:  cairo-devel >= 1.10.0
29BuildRequires:  libxml2-devel
30BuildRequires:  libXfixes-devel
31BuildRequires:  libX11-devel
32BuildRequires:  fontconfig-devel
33BuildRequires:  libXft-devel
34BuildRequires:  freetype2-devel
35BuildRequires:  gnome-common
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: Takemikaduchi
40
41%description
42GObject Introspection can scan C header and source files in order to
43generate introspection "typelib" files.  It also provides an API to examine
44typelib files, useful for creating language bindings among other
45things.
46
47%package devel
48Summary: Libraries and headers for gobject-introspection
49Summary(ja): %{name} の開発用ファイル
50Group: Development/Libraries
51Requires: %name = %{version}-%{release}
52Requires: glib2-devel
53Requires: libffi-devel
54Requires: pkgconfig
55Obsoletes: gir-repository-devel < 0.6.6
56
57%description devel
58Libraries and headers for gobject-introspection
59
60%prep
61%setup -q
62
63# From Ubuntu:
64# Roll back to gir/glib-2.0 as of before upstream commit 6d30588c1.
65# Later commits have a GVariant which current pygobject does not
66# deal with. This is fixed in the invoke-rewrite branch of
67# pygobject, so until this lands we need the older annotations.
68pushd gir
69        rm -rf glib-2.0.c
70        cp %{SOURCE1} .
71popd
72
73
74%build
75(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
76 %configure $CONFIGFLAGS)
77make V=1 %{?_smp_mflags}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81make install DESTDIR=$RPM_BUILD_ROOT
82
83# Die libtool, die.
84find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
85find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94%files
95%defattr(-,root,root,-)
96%doc COPYING
97
98%{_libdir}/lib*.so.*
99%dir %{_libdir}/girepository-1.0
100%{_libdir}/girepository-1.0/*.typelib
101
102%files devel
103%defattr(-,root,root)
104%{_libdir}/lib*.so
105%dir %{_libdir}/gobject-introspection
106%{_libdir}/gobject-introspection/*
107%{_libdir}/pkgconfig/*
108%{_includedir}/*
109%{_bindir}/g-ir-*
110%{_datadir}/gir-1.0
111%{_datadir}/aclocal/introspection.m4
112%{_datadir}/gobject-introspection-1.0/Makefile.introspection
113%{_datadir}/gobject-introspection-1.0/tests
114%{_datadir}/gobject-introspection-1.0/gdump.c
115%{_datadir}/gtk-doc/html/gi/*
116%{_mandir}/man1/*.gz
117
118%changelog
119* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
120- new upstream release
121
122* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.17-1
123- new upstream release
124- remove Patch0
125
126* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-2
127- add Source1 (glib-2.0.c)
128- add Patch0 (gobject-introspection-fix-link.patch)
129
130* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-1
131- new upstream release
132
133* Sat May 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.8-1
134- new upstream release
135
136* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.3-1
137- new upstream release
138
139* Wed Feb 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.2-1
140- new upstream release
141
142* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
143- new upstream release
144
145* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
146- new upstream release
147
148* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8-1
149- new upstream release
150- add Obsoletes: gir-repository < 0.6.6
151- fix %files
152
153* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-3
154- delete Patch0
155
156* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.14-2
157- build with rpm-4.8.1-1 for pkg-config file
158
159* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-1
160- new upstream release
161
162* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.10-1
163- new upstream release
164
165* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.9-1
166- new upstream release
167- add Requires: libffi-devel (devel package)
168
169* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.8-1
170- new upstream release
171
172* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.7-1
173- new upstream release
174- add Patch0 for ppc
175
176* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.5-2
177- rebuilt with python-2.6.4
178
179* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
180- initial build for Vine Linux
181
182* Fri Sep 11 2009 Colin Walters <walters@verbum.org> - 0.6.5-1
183- New upstream
184- Drop libtool dep
185
186* Fri Aug 28 2009 Colin Walters <walters@verbum.org> - 0.6.4-2
187- Add dep on libtool temporarily
188
189* Mon Aug 26 2009 Colin Walters <walters@verbum.org> - 0.6.4-1
190- New upstream 0.6.4
191- Drop upstreamed build fix patch
192
193* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
194- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
195
196* Mon Jul  6 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-4
197- Add upstream patch to fix a build crash
198
199* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-3
200- Add -ggdb temporarily so it compiles on ppc64
201
202* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-2
203- Add the new source file
204
205* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-1
206- Update to 0.6.3
207
208* Mon Jun  1 2009 Dan Williams <dcbw@redhat.com> - 0.6.2-1
209- Update to 0.6.2
210
211* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
213
214* Thu Dec 11 2008 Colin Walters <walters@verbum.org> - 0.6.1-1
215- Update to 0.6.1
216
217* Fri Oct 31 2008 Colin Walters <walters@verbum.org> - 0.6.0-1
218- Create spec goo
Note: See TracBrowser for help on using the repository browser.