source: projects/specs/trunk/g/gobject-introspection/gobject-introspection-vl.spec @ 4616

Revision 4616, 6.2 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           gobject-introspection
5Version:        1.29.16
6Release:        2%{?_dist_release}
7Summary:        Introspection system for GObject-based libraries
8
9Group:          Development/Libraries
10License:        GPLv2+, LGPLv2+, MIT
11URL:            http://live.gnome.org/GObjectIntrospection
12Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/1.29/%{name}-%{version}.tar.xz
13Source1:        glib-2.0.c
14
15Patch0:         gobject-introspection-fix-link.patch
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18Obsoletes:     gir-repository < 0.6.6
19
20BuildRequires:  glib2-devel
21BuildRequires:  python-devel >= 2.5
22BuildRequires:  gettext
23BuildRequires:  intltool
24BuildRequires:  gtk-doc
25BuildRequires:  flex
26BuildRequires:  bison
27BuildRequires:  libffi-devel
28BuildRequires:  mesa-libGL-devel
29BuildRequires:  cairo-devel >= 1.10.0
30BuildRequires:  libxml2-devel
31BuildRequires:  libXfixes-devel
32BuildRequires:  libX11-devel
33BuildRequires:  fontconfig-devel
34BuildRequires:  libXft-devel
35BuildRequires:  freetype2-devel
36BuildRequires:  gnome-common
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Takemikaduchi
41
42%description
43GObject Introspection can scan C header and source files in order to
44generate introspection "typelib" files.  It also provides an API to examine
45typelib files, useful for creating language bindings among other
46things.
47
48%package devel
49Summary: Libraries and headers for gobject-introspection
50Summary(ja): %{name} の開発用ファイル
51Group: Development/Libraries
52Requires: %name = %{version}-%{release}
53Requires: glib2-devel
54Requires: libffi-devel
55Requires: pkgconfig
56Obsoletes: gir-repository-devel < 0.6.6
57
58%description devel
59Libraries and headers for gobject-introspection
60
61%prep
62%setup -q
63%patch0 -p1 -b .fix-link
64
65# From Ubuntu:
66# Roll back to gir/glib-2.0 as of before upstream commit 6d30588c1.
67# Later commits have a GVariant which current pygobject does not
68# deal with. This is fixed in the invoke-rewrite branch of
69# pygobject, so until this lands we need the older annotations.
70pushd gir
71        rm -rf glib-2.0.c
72        cp %{SOURCE1} .
73popd
74
75
76%build
77(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
78 %configure $CONFIGFLAGS)
79make V=1 %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=$RPM_BUILD_ROOT
84
85# Die libtool, die.
86find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
87find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc COPYING
99
100%{_libdir}/lib*.so.*
101%dir %{_libdir}/girepository-1.0
102%{_libdir}/girepository-1.0/*.typelib
103
104%files devel
105%defattr(-,root,root)
106%{_libdir}/lib*.so
107%dir %{_libdir}/gobject-introspection
108%{_libdir}/gobject-introspection/*
109%{_libdir}/pkgconfig/*
110%{_includedir}/*
111%{_bindir}/g-ir-*
112%{_datadir}/gir-1.0
113%{_datadir}/aclocal/introspection.m4
114%{_datadir}/gobject-introspection-1.0/Makefile.introspection
115%{_datadir}/gobject-introspection-1.0/tests
116%{_datadir}/gobject-introspection-1.0/gdump.c
117%{_datadir}/gtk-doc/html/gi/*
118%{_mandir}/man1/*.gz
119
120%changelog
121* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-2
122- add Source1 (glib-2.0.c)
123- add Patch0 (gobject-introspection-fix-link.patch)
124
125* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-1
126- new upstream release
127
128* Sat May 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.8-1
129- new upstream release
130
131* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.3-1
132- new upstream release
133
134* Wed Feb 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.2-1
135- new upstream release
136
137* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
138- new upstream release
139
140* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
141- new upstream release
142
143* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8-1
144- new upstream release
145- add Obsoletes: gir-repository < 0.6.6
146- fix %files
147
148* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-3
149- delete Patch0
150
151* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.14-2
152- build with rpm-4.8.1-1 for pkg-config file
153
154* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-1
155- new upstream release
156
157* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.10-1
158- new upstream release
159
160* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.9-1
161- new upstream release
162- add Requires: libffi-devel (devel package)
163
164* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.8-1
165- new upstream release
166
167* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.7-1
168- new upstream release
169- add Patch0 for ppc
170
171* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.5-2
172- rebuilt with python-2.6.4
173
174* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
175- initial build for Vine Linux
176
177* Fri Sep 11 2009 Colin Walters <walters@verbum.org> - 0.6.5-1
178- New upstream
179- Drop libtool dep
180
181* Fri Aug 28 2009 Colin Walters <walters@verbum.org> - 0.6.4-2
182- Add dep on libtool temporarily
183
184* Mon Aug 26 2009 Colin Walters <walters@verbum.org> - 0.6.4-1
185- New upstream 0.6.4
186- Drop upstreamed build fix patch
187
188* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
190
191* Mon Jul  6 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-4
192- Add upstream patch to fix a build crash
193
194* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-3
195- Add -ggdb temporarily so it compiles on ppc64
196
197* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-2
198- Add the new source file
199
200* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-1
201- Update to 0.6.3
202
203* Mon Jun  1 2009 Dan Williams <dcbw@redhat.com> - 0.6.2-1
204- Update to 0.6.2
205
206* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
208
209* Thu Dec 11 2008 Colin Walters <walters@verbum.org> - 0.6.1-1
210- Update to 0.6.1
211
212* Fri Oct 31 2008 Colin Walters <walters@verbum.org> - 0.6.0-1
213- Create spec goo
Note: See TracBrowser for help on using the repository browser.