source: projects/specs/trunk/g/gobject-introspection/gobject-introspection-vl.spec @ 8084

Revision 8084, 6.4 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release or rebuild

RevLine 
[521]1Name:           gobject-introspection
[7938]2Version:        1.38.0
[8084]3Release:        2%{?_dist_release}
[521]4Summary:        Introspection system for GObject-based libraries
5
[7938]6Group:                  Development/Libraries
[521]7License:        GPLv2+, LGPLv2+, MIT
8URL:            http://live.gnome.org/GObjectIntrospection
[7938]9Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/1.38/%{name}-%{version}.tar.xz
[4616]10
[521]11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
[2041]13Obsoletes:     gir-repository < 0.6.6
14
[521]15BuildRequires:  glib2-devel
16BuildRequires:  python-devel >= 2.5
17BuildRequires:  gettext
18BuildRequires:  intltool
19BuildRequires:  gtk-doc
20BuildRequires:  flex
21BuildRequires:  bison
22BuildRequires:  libffi-devel
23BuildRequires:  mesa-libGL-devel
[2041]24BuildRequires:  cairo-devel >= 1.10.0
[521]25BuildRequires:  libxml2-devel
26BuildRequires:  libXfixes-devel
27BuildRequires:  libX11-devel
28BuildRequires:  fontconfig-devel
29BuildRequires:  libXft-devel
30BuildRequires:  freetype2-devel
[2041]31BuildRequires:  gnome-common
[521]32
[4616]33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: Takemikaduchi
36
[521]37%description
38GObject Introspection can scan C header and source files in order to
39generate introspection "typelib" files.  It also provides an API to examine
40typelib files, useful for creating language bindings among other
41things.
42
43%package devel
44Summary: Libraries and headers for gobject-introspection
45Summary(ja): %{name} の開発用ファイル
46Group: Development/Libraries
47Requires: %name = %{version}-%{release}
48Requires: glib2-devel
[805]49Requires: libffi-devel
[521]50Requires: pkgconfig
[2041]51Obsoletes: gir-repository-devel < 0.6.6
[521]52
53%description devel
54Libraries and headers for gobject-introspection
55
56%prep
57%setup -q
58
59%build
[7633]60(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
61 %configure --enable-gtk-doc)
[2041]62make V=1 %{?_smp_mflags}
[521]63
64%install
65rm -rf $RPM_BUILD_ROOT
66make install DESTDIR=$RPM_BUILD_ROOT
67
68# Die libtool, die.
69find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
70find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76
77%postun -p /sbin/ldconfig
78
79%files
80%defattr(-,root,root,-)
81%doc COPYING
82
83%{_libdir}/lib*.so.*
84%dir %{_libdir}/girepository-1.0
85%{_libdir}/girepository-1.0/*.typelib
86
87%files devel
88%defattr(-,root,root)
89%{_libdir}/lib*.so
[2041]90%dir %{_libdir}/gobject-introspection
91%{_libdir}/gobject-introspection/*
[521]92%{_libdir}/pkgconfig/*
93%{_includedir}/*
94%{_bindir}/g-ir-*
95%{_datadir}/gir-1.0
96%{_datadir}/aclocal/introspection.m4
[926]97%{_datadir}/gobject-introspection-1.0/Makefile.introspection
[2041]98%{_datadir}/gobject-introspection-1.0/tests
[2219]99%{_datadir}/gobject-introspection-1.0/gdump.c
100%{_datadir}/gtk-doc/html/gi/*
[521]101%{_mandir}/man1/*.gz
102
103%changelog
[8084]104* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.0-2
105- rebuild with VineSeed environment
106
[7938]107* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.0-1
108- new upstream release
109
[7633]110* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
111- new upstream release
112
[7119]113* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.2-1
114- new upstream release
115
[6951]116* Thu Oct 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
117- new upstream release
118
[6890]119* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
120- new upstream release
121
[6011]122* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
123- new upstream release
[6078]124- remove Source1
[6011]125
[4812]126* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
127- new upstream release
128
[4704]129* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.17-1
130- new upstream release
131- remove Patch0
132
[4616]133* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-2
134- add Source1 (glib-2.0.c)
135- add Patch0 (gobject-introspection-fix-link.patch)
136
137* Sat Jul 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.16-1
138- new upstream release
139
140* Sat May 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.8-1
141- new upstream release
142
[2762]143* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.3-1
144- new upstream release
145
[2665]146* Wed Feb 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.2-1
147- new upstream release
148
[2566]149* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
150- new upstream release
151
[2219]152* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
153- new upstream release
154
[2041]155* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8-1
156- new upstream release
157- add Obsoletes: gir-repository < 0.6.6
158- fix %files
159
[1897]160* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-3
161- delete Patch0
162
[1856]163* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.14-2
164- build with rpm-4.8.1-1 for pkg-config file
165
[1443]166* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-1
167- new upstream release
168
[926]169* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.10-1
170- new upstream release
171
[805]172* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.9-1
173- new upstream release
174- add Requires: libffi-devel (devel package)
175
[623]176* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.8-1
[521]177- new upstream release
[623]178
179* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.7-1
180- new upstream release
[521]181- add Patch0 for ppc
182
183* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.5-2
184- rebuilt with python-2.6.4
185
186* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
187- initial build for Vine Linux
188
189* Fri Sep 11 2009 Colin Walters <walters@verbum.org> - 0.6.5-1
190- New upstream
191- Drop libtool dep
192
193* Fri Aug 28 2009 Colin Walters <walters@verbum.org> - 0.6.4-2
194- Add dep on libtool temporarily
195
[7633]196* Wed Aug 26 2009 Colin Walters <walters@verbum.org> - 0.6.4-1
[521]197- New upstream 0.6.4
198- Drop upstreamed build fix patch
199
200* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203* Mon Jul  6 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-4
204- Add upstream patch to fix a build crash
205
206* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-3
207- Add -ggdb temporarily so it compiles on ppc64
208
209* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-2
210- Add the new source file
211
212* Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-1
213- Update to 0.6.3
214
215* Mon Jun  1 2009 Dan Williams <dcbw@redhat.com> - 0.6.2-1
216- Update to 0.6.2
217
218* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
220
221* Thu Dec 11 2008 Colin Walters <walters@verbum.org> - 0.6.1-1
222- Update to 0.6.1
223
224* Fri Oct 31 2008 Colin Walters <walters@verbum.org> - 0.6.0-1
225- Create spec goo
Note: See TracBrowser for help on using the repository browser.