source: projects/specs/trunk/g/gnutls2/gnutls2-vl.spec @ 8263

Revision 8263, 10.4 KB checked in by iwamoto, 10 years ago (diff)

gnutls2: add compat package

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define source_name    gnutls
3
4Summary:        GNU TLS Library
5Summary(ja):    GNU TLS ライブラリ
6Name:           gnutls2
7Version:        2.12.23
8Release:        3%{?_dist_release}
9License:        GPLv3+ and LGPLv2+
10# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
11Group:          System Environment/Libraries
12URL:            http://www.gnutls.org/
13#Source0:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
14#Source1:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
15# XXX patent tainted SRP code removed.
16Source0:        %{source_name}-%{version}.tar.bz2
17Source1:        libgnutls-config
18
19#patches from fedora development
20Patch1: gnutls-2.12.11-rpath.patch
21Patch2: gnutls-2.8.6-link-libgcrypt.patch
22# Remove nonexisting references from texinfo file
23Patch3: gnutls-2.12.2-nosrp.patch
24# Skip tests that are expected to fail on libgcrypt build
25Patch4: gnutls-2.12.7-dsa-skiptests.patch
26
27Patch100: fix_denial_of_service.patch
28Patch110: gnutls-2.12.23_CVE-2014-1959.patch
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32BuildRequires: libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
33BuildRequires: gettext readline-devel libtool
34BuildRequires: guile-devel >= 1.8.6
35BuildRequires: lzo-devel
36BuildRequires: p11-kit-devel >= 0.11
37Requires:       libgcrypt >= 1.2.2, zlib
38Requires:       lzo
39
40Requires(post):   ldconfig
41Requires(postun): ldconfig
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45
46%description
47GnuTLS is a project that aims to develop a library which provides a secure
48layer, over a reliable transport layer. Currently the GnuTLS library implements
49the proposed standards by the IETF's TLS working group.
50#'
51
52%package -n compat32-%{name}
53Summary:        GNU TLS Library
54Summary(ja):    GNU TLS ライブラリ
55Group:          System Environment/Libraries
56Requires:       compat32-%{name} = %{version}-%{release}
57
58%description -n compat32-%{name}
59GnuTLS is a project that aims to develop a library which provides a secure
60layer, over a reliable transport layer. Currently the GnuTLS library implements
61the proposed standards by the IETF's TLS working group.
62#'
63
64%prep
65%setup -q -n gnutls-%{version}
66%patch1 -p1 -b .rpath
67%patch2 -p1 -b .link
68%patch3 -p1 -b .nosrp
69%patch4 -p1 -b .skiptests
70
71%patch100 -p1 -b .denial
72%patch110 -p1 -b .CVE-2014-1959
73
74for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
75    touch lib/$i
76done
77
78%build
79#autoreconf
80%configure --with-libtasn1-prefix=%{_prefix} \
81        --with-lzo \
82        --with-included-libcfg \
83        --disable-openssl-compatibility \
84        --disable-srp-authentication \
85        --disable-static \
86        --disable-srp-authentication \
87        --disable-rpath \
88        --with-libgcrypt
89#       --with-included-libtasn1 \
90#       --with-included-opencdk \
91#       --with-included-lzo \
92make
93cp lib/COPYING COPYING.LIB
94
95%install
96%__rm -rf %{buildroot}
97%makeinstall
98
99rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
100rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
101# replace libgnutls*-config
102%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
103%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
104
105rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
106rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
107rm -f $RPM_BUILD_ROOT%{_infodir}/dir
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
110
111# remove unneeded files
112%__rm -f %{buildroot}%{_libdir}/*.la
113
114%find_lang libgnutls
115
116%check
117make check
118
119%clean
120rm -rf %{buildroot}
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%post -n compat32-%{name} -p /sbin/ldconfig
127
128%postun -n compat32-%{name} -p /sbin/ldconfig
129
130%files -f libgnutls.lang
131%defattr(-,root,root,-)
132%{_libdir}/libgnutls.so.*
133%{_libdir}/libgnutls-extra.so.*
134%doc COPYING COPYING.LIB README AUTHORS
135
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr(-,root,root,-)
139%{_libdir}/libgnutls*.so.*
140%endif
141
142%changelog
143* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.12.23-3
144- add patch110 for fix CVE-2014-1959
145- compat package gnutls2
146
147* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
148- added Patch100 from upstream to fix CVE-2013-2116
149
150* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
151- new upstream release
152- fixed a day of the week in %%changelog
153
154* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
155- new upstream release
156
157* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
158- new upstream release
159
160* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
161- new upstream release
162
163* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
164- new upstream release
165
166* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
167- new upstream release
168- changed BuildRequires: p11-kit-devel >= 0.11
169
170* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
171- new upstream release
172
173* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
174- new upstream release
175
176* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
177- added BuildRequires: p11-kit-devel
178
179* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
180- deleted BuildRequires: nettle-devel
181  - mistake.. fixed.
182
183* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
184- new upstream release
185- synced Fedora development package
186- add new sub-package: c++
187
188* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
189- add Requires: libtasn1-devel for devel subpackage
190
191* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
192- new upstream release
193
194* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
195- new upstream release
196
197* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
198- new upstream release
199- dropt patch1
200
201* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
202- new upstream release
203- added patch1,2,3,4 from Fedora development
204- added BuildRequires: gettext readline-devel libtool
205- added configure option
206  --disable-static,--disable-srp-authentication
207  - dropt *.a files from -devel package again
208
209* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
210- build with rpm-4.8.1-1 for pkg-config file
211
212* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
213- new upstream release
214- applied new naming policy to spec
215
216* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
217- new upstream release
218
219* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
220- new upstream release
221
222* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
223- new upstream release
224
225* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
226- new upstream release with security fix (handling X.509 CN or SAN fields)
227
228* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
229- added compat32 package for x86_64 arch support
230
231* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
232- new upstream release
233- added autoreconf
234- deleted libguile*.a
235- dropt Patch3
236- added %post guile, %postun guile
237
238* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
239- drop *.a files from -devel package
240- build with system lzo
241
242* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
243- new upstream release with security fixes (CVE-2009-1415,1416,1417)
244
245* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
246- update to 2.6.5
247
248* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
249- spec in UTF-8
250
251* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
252- update to 2.6.4
253- modifeid Source0
254
255* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
256- add BuildRequires: guile-devel >= 1.8.6
257
258* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
259- update to 2.6.3
260- import from fedora developing's 2.6.3
261  - License tag fixed
262- dropped patch0, patch1, patch2
263- added patch3
264- added BuildRequires: gmp-devel
265- add new sub-package: guile
266  - added %package guile, %description guile, %files guile
267
268* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
269- used %%{?_dist_release} macro
270
271* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
272- update to 1.6.3 (use no-SRP source)
273- import from fedora core's 1.6.3-2
274  - nosrc.tar.bz2 (source0)
275  - license tag fix
276- build with system libtasn1
277
278* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
279- update to 1.4.5 (use no-SRP source)
280- import from fedora core's 1.4.5-1
281  - nosrc.tar.bz2 (source0)
282- drop obsolete cve-2006-4790.patch (patch3)
283
284* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
285- [SECURITY] update to 1.4.1 (use no-SRP source)
286- import from fedora core's 1.4.1-2
287  - nosrp.tar.bz2 (source0)
288  - libgnutls-config (source1)
289  - nosrc.patch (patch0)
290  - enable-psk.patch (patch1)
291  - cve-2006-4790.patch (patch3)
292- update required version of libgcrypt (>= 1.2.2)
293- add Requires: pkgconfig to -devel package
294- add %%check section
295- update %%files
296- add new sub-package: utils
297
298* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
299- [SECURITY FIX] upstream release
300  - record packet parsing denial of service (CAN-2005-1431)
301
302* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
303- initial build for Vine Linux
304- upstream release
305
306* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
307- gcc4 rebuild
308
309* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
310- add gnutls Requires zlib-devel (#144069)
311
312* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
313- Make gnutls-devel Require libgcrypt-devel
314
315* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
316- rebuild with release++, otherwise unchanged.
317
318* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
319- patent tainted SRP code removed.
320
321* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
322- update to 1.0.20.
323- add --with-included-opencdk --with-included-libtasn1
324- add --with-included-libcfg --with-included-lzo
325- add --disable-srp-authentication.
326- do "make check" after build.
327
328* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
329- upgrade to 0.9.2
330
331* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
332- update to 0.4.4.
333
334* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
338- update to 0.4.3.
339
340* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
341- update to 0.4.2.
342- change license to LGPL.
343- include splint annotations patch.
344
345* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
346- update to 0.4.0
347
348* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
349- update to 0.3.2
350
351* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
352- add a URL
353
354* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
355- initial package
Note: See TracBrowser for help on using the repository browser.