source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 9926

Revision 9926, 16.1 KB checked in by iwamoto, 8 years ago (diff)

gnutls: update to 3.4.y

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.4.7
7Release:        2%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20# Patch100: gnutls-3.2.10_guile_build.patch
21# Security fixes
22# Nothing...
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  libtasn1-devel >= 4.3
26BuildRequires:  gmp-devel
27BuildRequires:  gettext readline-devel libtool
28BuildRequires:  guile-devel >= 1.8.6
29BuildRequires:  p11-kit-devel >= 0.21.3
30BuildRequires:  nettle-devel >= 3.1.1
31BuildRequires:  texinfo, autogen
32BuildRequires:  zlib-devel
33Requires:      zlib
34
35Requires(post):   ldconfig
36Requires(postun): ldconfig
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40
41%description
42GnuTLS is a project that aims to develop a library which provides a secure
43layer, over a reliable transport layer. Currently the GnuTLS library implements
44the proposed standards by the IETF's TLS working group.
45#'
46
47%package devel
48Summary:        Development files for the GnuTLS package.
49Summary(ja):    GnuTLS の開発用ファイル
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       libgcrypt-devel, zlib-devel, pkgconfig
53Requires:       libtasn1-devel, nettle-devel
54Requires(post,preun): /sbin/install-info
55
56%description devel
57GnuTLS is a project that aims to develop a library which provides a secure
58layer, over a reliable transport layer. Currently the GnuTLS library implements
59the proposed standards by the IETF's TLS working group.
60
61This package contains files needed for developing applications with the GnuTLS
62library.
63#'
64
65%package utils
66Summary:        Command line tools for TLS protocol.
67Summary(ja):    GnuTLS のコマンドラインツール
68Group:          Applications/System
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72GnuTLS is a project that aims to develop a library which provides a secure
73layer, over a reliable transport layer. Currently the GnuTLS library implements
74the proposed standards by the IETF's TLS working group.
75
76This package contains command line TLS client and server and certificate
77manipulation tools.
78#'
79
80%package guile
81Summary: Guile bindings for the GNUTLS library
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: guile
85
86%description guile
87GnuTLS is a project that aims to develop a library which provides a secure
88layer, over a reliable transport layer. Currently the GnuTLS library implements
89the proposed standards by the IETF's TLS working group.
90This package contains Guile bindings for the library.
91#'
92
93%package c++
94Summary: The C++ interface to GnuTLS
95Group: System Environment/Libraries
96Requires: %{name} = %{version}-%{release}
97
98%description c++
99GnuTLS is a project that aims to develop a library which provides a secure
100layer, over a reliable transport layer. Currently the GnuTLS library implements
101the proposed standards by the IETF's TLS working group.
102This package contains the C++ interface for the GnuTLS library.
103#'
104
105%package -n compat32-%{name}
106Summary:        GNU TLS Library
107Summary(ja):    GNU TLS ライブラリ
108Group:          System Environment/Libraries
109Requires:       %{name} = %{version}-%{release}
110
111%description -n compat32-%{name}
112GnuTLS is a project that aims to develop a library which provides a secure
113layer, over a reliable transport layer. Currently the GnuTLS library implements
114the proposed standards by the IETF's TLS working group.
115#'
116
117%package -n compat32-%{name}-devel
118Summary:        Development files for the GnuTLS package.
119Summary(ja):    GnuTLS の開発用ファイル
120Group:          Development/Libraries
121Requires:       compat32-%{name} = %{version}-%{release}
122Requires:       %{name}-devel = %{version}-%{release}
123Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
124Requires(post,preun): /sbin/install-info
125
126%description -n compat32-%{name}-devel
127GnuTLS is a project that aims to develop a library which provides a secure
128layer, over a reliable transport layer. Currently the GnuTLS library implements
129the proposed standards by the IETF's TLS working group.
130
131This package contains files needed for developing applications with the GnuTLS
132library.
133#'
134
135%package -n compat32-%{name}-guile
136Summary: Guile bindings for the GNUTLS library
137Group: Development/Libraries
138Requires: compat32-%{name} = %{version}-%{release}
139Requires: %{name}-guile = %{version}-%{release}
140
141%description -n compat32-%{name}-guile
142GnuTLS is a project that aims to develop a library which provides a secure
143layer, over a reliable transport layer. Currently the GnuTLS library implements
144the proposed standards by the IETF's TLS working group.
145This package contains Guile bindings for the library.
146#'
147
148%prep
149%setup -q
150
151%patch1 -p1 -b .rpath
152%patch3 -p1 -b .nosrp
153
154# %patch100 -p1
155# %patch1000 -p1 -b .SA-2015-3
156
157%build
158export LDFLAGS="-Wl,--no-add-needed"
159# autoreconf -fi
160%configure \
161        --disable-openssl-compatibility \
162        --disable-srp-authentication \
163        --disable-static \
164        --disable-srp-authentication \
165        --disable-non-suiteb-curves \
166        --disable-rpath \
167        --enable-guile
168#       --with-libgcrypt
169#       --with-lzo \
170#       --with-included-libcfg \
171#       --with-libtasn1-prefix=%{_prefix} \
172#       --with-included-libtasn1 \
173#       --with-included-opencdk \
174#       --with-included-lzo \
175make %{?_smp_mflags}
176# cp lib/COPYING COPYING.LIB
177
178%install
179%__rm -rf %{buildroot}
180# makeinstall macro causes build error, why?
181make install DESTDIR=%{buildroot}
182
183rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
184rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
185rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
186# replace libgnutls*-config
187%__install -d %{buildroot}%{_bindir}
188%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
189# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
190
191rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
192rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
193rm -f $RPM_BUILD_ROOT%{_infodir}/dir
194rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
195rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
196rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
197
198# remove unneeded files
199%__rm -f %{buildroot}%{_libdir}/*.la
200%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
201
202%find_lang gnutls
203
204%check
205make check
206
207%clean
208rm -rf %{buildroot}
209
210%post -p /sbin/ldconfig
211
212%postun -p /sbin/ldconfig
213
214%post devel
215if [ -f %{_infodir}/gnutls.info.gz ]; then
216    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
217fi
218
219%preun devel
220if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
221   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
222fi
223
224%post guile -p /sbin/ldconfig
225
226%postun guile -p /sbin/ldconfig
227
228%post -n compat32-%{name} -p /sbin/ldconfig
229
230%postun -n compat32-%{name} -p /sbin/ldconfig
231
232%post -n compat32-%{name}-guile -p /sbin/ldconfig
233
234%postun -n compat32-%{name}-guile -p /sbin/ldconfig
235
236%files -f gnutls.lang
237%defattr(-,root,root,-)
238%{_libdir}/libgnutls.so.30*
239# %{_libdir}/libgnutls-xssl.so.0*
240%doc README AUTHORS NEWS THANKS
241
242%files devel
243%defattr(-,root,root,-)
244%{_bindir}/libgnutls*-config
245%{_includedir}/*
246%{_libdir}/libgnutls*.so
247%{_libdir}/pkgconfig/*.pc
248%{_mandir}/man3/*
249%{_infodir}/gnutls*
250%{_infodir}/pkcs11-vision.png.gz
251
252%files utils
253%defattr(-,root,root,-)
254%{_bindir}/certtool
255%{_bindir}/psktool
256%{_bindir}/p11tool
257%{_bindir}/ocsptool
258%{_bindir}/gnutls*
259%{_mandir}/man1/*
260%doc doc/certtool.cfg
261
262%files guile
263%defattr(-,root,root,-)
264%{_libdir}/guile/2.0/guile*.so*
265%{_datadir}/guile/site/gnutls
266%{_datadir}/guile/site/gnutls.scm
267
268%files c++
269%{_libdir}/libgnutlsxx.so.*
270
271%if %{build_compat32}
272%files -n compat32-%{name}
273%defattr(-,root,root,-)
274%{_libdir}/libgnutls.so.30*
275# %{_libdir}/libgnutls-xssl.so.0*
276
277%files -n compat32-%{name}-devel
278%defattr(-,root,root,-)
279#%{_libdir}/libgnutls*.a
280%{_libdir}/libgnutls*.so
281%{_libdir}/pkgconfig/*.pc
282
283%files -n compat32-%{name}-guile
284%defattr(-,root,root,-)
285%{_libdir}/guile/2.0/guile*.so*
286%endif
287
288%changelog
289* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
290- rebuilt to marge changelog
291
292* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
293- new upstream release 3.4.7
294
295* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
296- rebuild with nettls-3.1.1
297
298* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
299- BR: libtasn1-devel >= 3.9
300
301* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
302- built for release
303
304* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
305- rm libgnutls-xssl.so.0* in files list
306
307* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
308- for test
309
310* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
311- add patch1000 for fix SA-2015-3
312
313* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
314- rebuilt with guile 2.0.11
315
316* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
317- new upstream release with security fix   
318
319* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
320- new upstream release with security fix 
321
322* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
323- new upstream release with security fix
324
325* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
326- new upstream release with security fix
327
328* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
329- fix R: in compat32
330
331* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
332- fix BR:, R: (drop unneeded dependency)
333
334* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
335- new upstream release 3.2.10
336- update patches / drop old patches
337- add BR: nettle
338
339* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
340- added Patch100 from upstream to fix CVE-2013-2116
341
342* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
343- new upstream release
344- fixed a day of the week in %%changelog
345
346* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
347- new upstream release
348
349* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
350- new upstream release
351
352* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
353- new upstream release
354
355* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
356- new upstream release
357
358* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
359- new upstream release
360- changed BuildRequires: p11-kit-devel >= 0.11
361
362* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
363- new upstream release
364
365* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
366- new upstream release
367
368* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
369- added BuildRequires: p11-kit-devel
370
371* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
372- deleted BuildRequires: nettle-devel
373  - mistake.. fixed.
374
375* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
376- new upstream release
377- synced Fedora development package
378- add new sub-package: c++
379
380* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
381- add Requires: libtasn1-devel for devel subpackage
382
383* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
384- new upstream release
385
386* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
387- new upstream release
388
389* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
390- new upstream release
391- dropt patch1
392
393* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
394- new upstream release
395- added patch1,2,3,4 from Fedora development
396- added BuildRequires: gettext readline-devel libtool
397- added configure option
398  --disable-static,--disable-srp-authentication
399  - dropt *.a files from -devel package again
400
401* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
402- build with rpm-4.8.1-1 for pkg-config file
403
404* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
405- new upstream release
406- applied new naming policy to spec
407
408* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
409- new upstream release
410
411* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
412- new upstream release
413
414* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
415- new upstream release
416
417* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
418- new upstream release with security fix (handling X.509 CN or SAN fields)
419
420* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
421- added compat32 package for x86_64 arch support
422
423* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
424- new upstream release
425- added autoreconf
426- deleted libguile*.a
427- dropt Patch3
428- added %post guile, %postun guile
429
430* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
431- drop *.a files from -devel package
432- build with system lzo
433
434* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
435- new upstream release with security fixes (CVE-2009-1415,1416,1417)
436
437* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
438- update to 2.6.5
439
440* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
441- spec in UTF-8
442
443* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
444- update to 2.6.4
445- modifeid Source0
446
447* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
448- add BuildRequires: guile-devel >= 1.8.6
449
450* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
451- update to 2.6.3
452- import from fedora developing's 2.6.3
453  - License tag fixed
454- dropped patch0, patch1, patch2
455- added patch3
456- added BuildRequires: gmp-devel
457- add new sub-package: guile
458  - added %package guile, %description guile, %files guile
459
460* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
461- used %%{?_dist_release} macro
462
463* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
464- update to 1.6.3 (use no-SRP source)
465- import from fedora core's 1.6.3-2
466  - nosrc.tar.bz2 (source0)
467  - license tag fix
468- build with system libtasn1
469
470* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
471- update to 1.4.5 (use no-SRP source)
472- import from fedora core's 1.4.5-1
473  - nosrc.tar.bz2 (source0)
474- drop obsolete cve-2006-4790.patch (patch3)
475
476* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
477- [SECURITY] update to 1.4.1 (use no-SRP source)
478- import from fedora core's 1.4.1-2
479  - nosrp.tar.bz2 (source0)
480  - libgnutls-config (source1)
481  - nosrc.patch (patch0)
482  - enable-psk.patch (patch1)
483  - cve-2006-4790.patch (patch3)
484- update required version of libgcrypt (>= 1.2.2)
485- add Requires: pkgconfig to -devel package
486- add %%check section
487- update %%files
488- add new sub-package: utils
489
490* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
491- [SECURITY FIX] upstream release
492  - record packet parsing denial of service (CAN-2005-1431)
493
494* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
495- initial build for Vine Linux
496- upstream release
497
498* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
499- gcc4 rebuild
500
501* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
502- add gnutls Requires zlib-devel (#144069)
503
504* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
505- Make gnutls-devel Require libgcrypt-devel
506
507* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
508- rebuild with release++, otherwise unchanged.
509
510* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
511- patent tainted SRP code removed.
512
513* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
514- update to 1.0.20.
515- add --with-included-opencdk --with-included-libtasn1
516- add --with-included-libcfg --with-included-lzo
517- add --disable-srp-authentication.
518- do "make check" after build.
519
520* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
521- upgrade to 0.9.2
522
523* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
524- update to 0.4.4.
525
526* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
527- automated rebuild
528
529* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
530- update to 0.4.3.
531
532* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
533- update to 0.4.2.
534- change license to LGPL.
535- include splint annotations patch.
536
537* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
538- update to 0.4.0
539
540* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
541- update to 0.3.2
542
543* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
544- add a URL
545
546* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
547- initial package
Note: See TracBrowser for help on using the repository browser.