source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 9711

Revision 9711, 15.5 KB checked in by iwamoto, 9 years ago (diff)

gnutls: fix SA-2015-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.2.20
7Release:        3%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20Patch100: gnutls-3.2.10_guile_build.patch
21
22# Security
23Patch1000: gnutls-3.2.20_SA-2015-3.patch
24
25# Security fixes
26# Nothing...
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29BuildRequires:  libtasn1-devel >= 3.1
30BuildRequires:  gmp-devel
31BuildRequires:  gettext readline-devel libtool
32BuildRequires:  guile-devel >= 1.8.6
33BuildRequires:  p11-kit-devel >= 0.11
34BuildRequires:  nettle-devel >= 2.7
35BuildRequires:  texinfo, autogen
36BuildRequires:  zlib-devel
37Requires:      zlib
38
39Requires(post):   ldconfig
40Requires(postun): ldconfig
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44
45%description
46GnuTLS is a project that aims to develop a library which provides a secure
47layer, over a reliable transport layer. Currently the GnuTLS library implements
48the proposed standards by the IETF's TLS working group.
49#'
50
51%package devel
52Summary:        Development files for the GnuTLS package.
53Summary(ja):    GnuTLS の開発用ファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       libgcrypt-devel, zlib-devel, pkgconfig
57Requires:       libtasn1-devel, nettle-devel
58Requires(post,preun): /sbin/install-info
59
60%description devel
61GnuTLS is a project that aims to develop a library which provides a secure
62layer, over a reliable transport layer. Currently the GnuTLS library implements
63the proposed standards by the IETF's TLS working group.
64
65This package contains files needed for developing applications with the GnuTLS
66library.
67#'
68
69%package utils
70Summary:        Command line tools for TLS protocol.
71Summary(ja):    GnuTLS のコマンドラインツール
72Group:          Applications/System
73Requires:       %{name} = %{version}-%{release}
74
75%description utils
76GnuTLS is a project that aims to develop a library which provides a secure
77layer, over a reliable transport layer. Currently the GnuTLS library implements
78the proposed standards by the IETF's TLS working group.
79
80This package contains command line TLS client and server and certificate
81manipulation tools.
82#'
83
84%package guile
85Summary: Guile bindings for the GNUTLS library
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: guile
89
90%description guile
91GnuTLS is a project that aims to develop a library which provides a secure
92layer, over a reliable transport layer. Currently the GnuTLS library implements
93the proposed standards by the IETF's TLS working group.
94This package contains Guile bindings for the library.
95#'
96
97%package c++
98Summary: The C++ interface to GnuTLS
99Group: System Environment/Libraries
100Requires: %{name} = %{version}-%{release}
101
102%description c++
103GnuTLS is a project that aims to develop a library which provides a secure
104layer, over a reliable transport layer. Currently the GnuTLS library implements
105the proposed standards by the IETF's TLS working group.
106This package contains the C++ interface for the GnuTLS library.
107#'
108
109%package -n compat32-%{name}
110Summary:        GNU TLS Library
111Summary(ja):    GNU TLS ライブラリ
112Group:          System Environment/Libraries
113Requires:       %{name} = %{version}-%{release}
114
115%description -n compat32-%{name}
116GnuTLS is a project that aims to develop a library which provides a secure
117layer, over a reliable transport layer. Currently the GnuTLS library implements
118the proposed standards by the IETF's TLS working group.
119#'
120
121%package -n compat32-%{name}-devel
122Summary:        Development files for the GnuTLS package.
123Summary(ja):    GnuTLS の開発用ファイル
124Group:          Development/Libraries
125Requires:       compat32-%{name} = %{version}-%{release}
126Requires:       %{name}-devel = %{version}-%{release}
127Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
128Requires(post,preun): /sbin/install-info
129
130%description -n compat32-%{name}-devel
131GnuTLS is a project that aims to develop a library which provides a secure
132layer, over a reliable transport layer. Currently the GnuTLS library implements
133the proposed standards by the IETF's TLS working group.
134
135This package contains files needed for developing applications with the GnuTLS
136library.
137#'
138
139%package -n compat32-%{name}-guile
140Summary: Guile bindings for the GNUTLS library
141Group: Development/Libraries
142Requires: compat32-%{name} = %{version}-%{release}
143Requires: %{name}-guile = %{version}-%{release}
144
145%description -n compat32-%{name}-guile
146GnuTLS is a project that aims to develop a library which provides a secure
147layer, over a reliable transport layer. Currently the GnuTLS library implements
148the proposed standards by the IETF's TLS working group.
149This package contains Guile bindings for the library.
150#'
151
152%prep
153%setup -q
154
155%patch1 -p1 -b .rpath
156%patch3 -p1 -b .nosrp
157
158# %patch100 -p1
159%patch1000 -p1 -b .SA-2015-3
160
161%build
162export LDFLAGS="-Wl,--no-add-needed"
163# autoreconf -fi
164%configure \
165        --disable-openssl-compatibility \
166        --disable-srp-authentication \
167        --disable-static \
168        --disable-srp-authentication \
169        --disable-non-suiteb-curves \
170        --disable-rpath \
171        --enable-guile
172#       --with-libgcrypt
173#       --with-lzo \
174#       --with-included-libcfg \
175#       --with-libtasn1-prefix=%{_prefix} \
176#       --with-included-libtasn1 \
177#       --with-included-opencdk \
178#       --with-included-lzo \
179make %{?_smp_mflags}
180# cp lib/COPYING COPYING.LIB
181
182%install
183%__rm -rf %{buildroot}
184# makeinstall macro causes build error, why?
185make install DESTDIR=%{buildroot}
186
187rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
188rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
189rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
190# replace libgnutls*-config
191%__install -d %{buildroot}%{_bindir}
192%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
193# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
194
195rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
196rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
197rm -f $RPM_BUILD_ROOT%{_infodir}/dir
198rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
199rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
200rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
201
202# remove unneeded files
203%__rm -f %{buildroot}%{_libdir}/*.la
204%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
205
206%find_lang gnutls
207
208%check
209make check
210
211%clean
212rm -rf %{buildroot}
213
214%post -p /sbin/ldconfig
215
216%postun -p /sbin/ldconfig
217
218%post devel
219if [ -f %{_infodir}/gnutls.info.gz ]; then
220    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
221fi
222
223%preun devel
224if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
225   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
226fi
227
228%post guile -p /sbin/ldconfig
229
230%postun guile -p /sbin/ldconfig
231
232%post -n compat32-%{name} -p /sbin/ldconfig
233
234%postun -n compat32-%{name} -p /sbin/ldconfig
235
236%post -n compat32-%{name}-guile -p /sbin/ldconfig
237
238%postun -n compat32-%{name}-guile -p /sbin/ldconfig
239
240%files -f gnutls.lang
241%defattr(-,root,root,-)
242%{_libdir}/libgnutls.so.28*
243%{_libdir}/libgnutls-xssl.so.0*
244%doc README AUTHORS NEWS THANKS
245
246%files devel
247%defattr(-,root,root,-)
248%{_bindir}/libgnutls*-config
249%{_includedir}/*
250%{_libdir}/libgnutls*.so
251%{_libdir}/pkgconfig/*.pc
252%{_mandir}/man3/*
253%{_infodir}/gnutls*
254%{_infodir}/pkcs11-vision.png.gz
255
256%files utils
257%defattr(-,root,root,-)
258%{_bindir}/certtool
259%{_bindir}/psktool
260%{_bindir}/p11tool
261%{_bindir}/ocsptool
262%{_bindir}/gnutls*
263%{_mandir}/man1/*
264%doc doc/certtool.cfg
265
266%files guile
267%defattr(-,root,root,-)
268%{_libdir}/guile/2.0/guile*.so*
269%{_datadir}/guile/site/gnutls
270%{_datadir}/guile/site/gnutls.scm
271
272%files c++
273%{_libdir}/libgnutlsxx.so.*
274
275%if %{build_compat32}
276%files -n compat32-%{name}
277%defattr(-,root,root,-)
278%{_libdir}/libgnutls.so.28*
279%{_libdir}/libgnutls-xssl.so.0*
280
281%files -n compat32-%{name}-devel
282%defattr(-,root,root,-)
283#%{_libdir}/libgnutls*.a
284%{_libdir}/libgnutls*.so
285%{_libdir}/pkgconfig/*.pc
286
287%files -n compat32-%{name}-guile
288%defattr(-,root,root,-)
289%{_libdir}/guile/2.0/guile*.so*
290%endif
291
292%changelog
293* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
294- add patch1000 for fix SA-2015-3
295
296* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
297- rebuilt with guile 2.0.11
298
299* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
300- new upstream release with security fix   
301
302* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
303- new upstream release with security fix 
304
305* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
306- new upstream release with security fix
307
308* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
309- new upstream release with security fix
310
311* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
312- fix R: in compat32
313
314* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
315- fix BR:, R: (drop unneeded dependency)
316
317* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
318- new upstream release 3.2.10
319- update patches / drop old patches
320- add BR: nettle
321
322* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
323- added Patch100 from upstream to fix CVE-2013-2116
324
325* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
326- new upstream release
327- fixed a day of the week in %%changelog
328
329* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
330- new upstream release
331
332* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
333- new upstream release
334
335* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
336- new upstream release
337
338* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
339- new upstream release
340
341* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
342- new upstream release
343- changed BuildRequires: p11-kit-devel >= 0.11
344
345* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
346- new upstream release
347
348* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
349- new upstream release
350
351* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
352- added BuildRequires: p11-kit-devel
353
354* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
355- deleted BuildRequires: nettle-devel
356  - mistake.. fixed.
357
358* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
359- new upstream release
360- synced Fedora development package
361- add new sub-package: c++
362
363* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
364- add Requires: libtasn1-devel for devel subpackage
365
366* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
367- new upstream release
368
369* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
370- new upstream release
371
372* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
373- new upstream release
374- dropt patch1
375
376* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
377- new upstream release
378- added patch1,2,3,4 from Fedora development
379- added BuildRequires: gettext readline-devel libtool
380- added configure option
381  --disable-static,--disable-srp-authentication
382  - dropt *.a files from -devel package again
383
384* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
385- build with rpm-4.8.1-1 for pkg-config file
386
387* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
388- new upstream release
389- applied new naming policy to spec
390
391* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
392- new upstream release
393
394* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
395- new upstream release
396
397* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
398- new upstream release
399
400* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
401- new upstream release with security fix (handling X.509 CN or SAN fields)
402
403* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
404- added compat32 package for x86_64 arch support
405
406* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
407- new upstream release
408- added autoreconf
409- deleted libguile*.a
410- dropt Patch3
411- added %post guile, %postun guile
412
413* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
414- drop *.a files from -devel package
415- build with system lzo
416
417* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
418- new upstream release with security fixes (CVE-2009-1415,1416,1417)
419
420* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
421- update to 2.6.5
422
423* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
424- spec in UTF-8
425
426* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
427- update to 2.6.4
428- modifeid Source0
429
430* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
431- add BuildRequires: guile-devel >= 1.8.6
432
433* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
434- update to 2.6.3
435- import from fedora developing's 2.6.3
436  - License tag fixed
437- dropped patch0, patch1, patch2
438- added patch3
439- added BuildRequires: gmp-devel
440- add new sub-package: guile
441  - added %package guile, %description guile, %files guile
442
443* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
444- used %%{?_dist_release} macro
445
446* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
447- update to 1.6.3 (use no-SRP source)
448- import from fedora core's 1.6.3-2
449  - nosrc.tar.bz2 (source0)
450  - license tag fix
451- build with system libtasn1
452
453* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
454- update to 1.4.5 (use no-SRP source)
455- import from fedora core's 1.4.5-1
456  - nosrc.tar.bz2 (source0)
457- drop obsolete cve-2006-4790.patch (patch3)
458
459* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
460- [SECURITY] update to 1.4.1 (use no-SRP source)
461- import from fedora core's 1.4.1-2
462  - nosrp.tar.bz2 (source0)
463  - libgnutls-config (source1)
464  - nosrc.patch (patch0)
465  - enable-psk.patch (patch1)
466  - cve-2006-4790.patch (patch3)
467- update required version of libgcrypt (>= 1.2.2)
468- add Requires: pkgconfig to -devel package
469- add %%check section
470- update %%files
471- add new sub-package: utils
472
473* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
474- [SECURITY FIX] upstream release
475  - record packet parsing denial of service (CAN-2005-1431)
476
477* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
478- initial build for Vine Linux
479- upstream release
480
481* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
482- gcc4 rebuild
483
484* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
485- add gnutls Requires zlib-devel (#144069)
486
487* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
488- Make gnutls-devel Require libgcrypt-devel
489
490* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
491- rebuild with release++, otherwise unchanged.
492
493* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
494- patent tainted SRP code removed.
495
496* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
497- update to 1.0.20.
498- add --with-included-opencdk --with-included-libtasn1
499- add --with-included-libcfg --with-included-lzo
500- add --disable-srp-authentication.
501- do "make check" after build.
502
503* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
504- upgrade to 0.9.2
505
506* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
507- update to 0.4.4.
508
509* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
510- automated rebuild
511
512* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
513- update to 0.4.3.
514
515* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
516- update to 0.4.2.
517- change license to LGPL.
518- include splint annotations patch.
519
520* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
521- update to 0.4.0
522
523* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
524- update to 0.3.2
525
526* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
527- add a URL
528
529* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
530- initial package
Note: See TracBrowser for help on using the repository browser.