source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 9100

Revision 9100, 15.4 KB checked in by iwamoto, 9 years ago (diff)

gnutls: update to 3.2.20

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.2.20
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20Patch100: gnutls-3.2.10_guile_build.patch
21
22# Security fixes
23# Nothing...
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27# BuildRequires: libgcrypt-devel >= 1.2.2
28BuildRequires: libtasn1-devel >= 3.1
29BuildRequires: gmp-devel, zlib-devel
30BuildRequires: gettext readline-devel libtool
31BuildRequires: guile-devel >= 1.8.6
32# BuildRequires: lzo-devel
33BuildRequires: p11-kit-devel >= 0.11
34BuildRequires: nettle-devel >= 2.7
35BuildRequires: texinfo, autogen
36# Requires:     libgcrypt >= 1.2.2, zlib
37Requires:      zlib
38# Requires:     lzo
39
40Requires(post):   ldconfig
41Requires(postun): ldconfig
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45
46%description
47GnuTLS is a project that aims to develop a library which provides a secure
48layer, over a reliable transport layer. Currently the GnuTLS library implements
49the proposed standards by the IETF's TLS working group.
50#'
51
52%package devel
53Summary:        Development files for the GnuTLS package.
54Summary(ja):    GnuTLS の開発用ファイル
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57Requires:       libgcrypt-devel, zlib-devel, pkgconfig
58Requires:       libtasn1-devel, nettle-devel
59Requires(post,preun): /sbin/install-info
60
61%description devel
62GnuTLS is a project that aims to develop a library which provides a secure
63layer, over a reliable transport layer. Currently the GnuTLS library implements
64the proposed standards by the IETF's TLS working group.
65
66This package contains files needed for developing applications with the GnuTLS
67library.
68#'
69
70%package utils
71Summary:        Command line tools for TLS protocol.
72Summary(ja):    GnuTLS のコマンドラインツール
73Group:          Applications/System
74Requires:       %{name} = %{version}-%{release}
75
76%description utils
77GnuTLS is a project that aims to develop a library which provides a secure
78layer, over a reliable transport layer. Currently the GnuTLS library implements
79the proposed standards by the IETF's TLS working group.
80
81This package contains command line TLS client and server and certificate
82manipulation tools.
83#'
84
85%package guile
86Summary: Guile bindings for the GNUTLS library
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: guile
90
91%description guile
92GnuTLS is a project that aims to develop a library which provides a secure
93layer, over a reliable transport layer. Currently the GnuTLS library implements
94the proposed standards by the IETF's TLS working group.
95This package contains Guile bindings for the library.
96#'
97
98%package c++
99Summary: The C++ interface to GnuTLS
100Group: System Environment/Libraries
101Requires: %{name} = %{version}-%{release}
102
103%description c++
104GnuTLS is a project that aims to develop a library which provides a secure
105layer, over a reliable transport layer. Currently the GnuTLS library implements
106the proposed standards by the IETF's TLS working group.
107This package contains the C++ interface for the GnuTLS library.
108#'
109
110%package -n compat32-%{name}
111Summary:        GNU TLS Library
112Summary(ja):    GNU TLS ライブラリ
113Group:          System Environment/Libraries
114Requires:       %{name} = %{version}-%{release}
115
116%description -n compat32-%{name}
117GnuTLS is a project that aims to develop a library which provides a secure
118layer, over a reliable transport layer. Currently the GnuTLS library implements
119the proposed standards by the IETF's TLS working group.
120#'
121
122%package -n compat32-%{name}-devel
123Summary:        Development files for the GnuTLS package.
124Summary(ja):    GnuTLS の開発用ファイル
125Group:          Development/Libraries
126Requires:       compat32-%{name} = %{version}-%{release}
127Requires:       %{name}-devel = %{version}-%{release}
128Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
129Requires(post,preun): /sbin/install-info
130
131%description -n compat32-%{name}-devel
132GnuTLS is a project that aims to develop a library which provides a secure
133layer, over a reliable transport layer. Currently the GnuTLS library implements
134the proposed standards by the IETF's TLS working group.
135
136This package contains files needed for developing applications with the GnuTLS
137library.
138#'
139
140%package -n compat32-%{name}-guile
141Summary: Guile bindings for the GNUTLS library
142Group: Development/Libraries
143Requires: compat32-%{name} = %{version}-%{release}
144Requires: %{name}-guile = %{version}-%{release}
145
146%description -n compat32-%{name}-guile
147GnuTLS is a project that aims to develop a library which provides a secure
148layer, over a reliable transport layer. Currently the GnuTLS library implements
149the proposed standards by the IETF's TLS working group.
150This package contains Guile bindings for the library.
151#'
152
153%prep
154# %setup -q -n %{name}-3.2.12
155%setup
156
157%patch1 -p1 -b .rpath
158%patch3 -p1 -b .nosrp
159
160# %patch100 -p1
161
162%build
163export LDFLAGS="-Wl,--no-add-needed"
164# autoreconf -fi
165%configure \
166        --disable-openssl-compatibility \
167        --disable-srp-authentication \
168        --disable-static \
169        --disable-srp-authentication \
170        --disable-non-suiteb-curves \
171        --disable-rpath \
172        --enable-guile
173#       --with-libgcrypt
174#       --with-lzo \
175#       --with-included-libcfg \
176#       --with-libtasn1-prefix=%{_prefix} \
177#       --with-included-libtasn1 \
178#       --with-included-opencdk \
179#       --with-included-lzo \
180make %{?_smp_mflags}
181# cp lib/COPYING COPYING.LIB
182
183%install
184%__rm -rf %{buildroot}
185# makeinstall macro causes build error, why?
186make install DESTDIR=%{buildroot}
187
188rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
189rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
190rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
191# replace libgnutls*-config
192%__install -d %{buildroot}%{_bindir}
193%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
194# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
195
196rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
197rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
198rm -f $RPM_BUILD_ROOT%{_infodir}/dir
199rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
200rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
201rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
202
203# remove unneeded files
204%__rm -f %{buildroot}%{_libdir}/*.la
205%__rm -f %{buildroot}%{_libdir}/guile/1.8/*.la
206
207%find_lang gnutls
208
209%check
210make check
211
212%clean
213rm -rf %{buildroot}
214
215%post -p /sbin/ldconfig
216
217%postun -p /sbin/ldconfig
218
219%post devel
220if [ -f %{_infodir}/gnutls.info.gz ]; then
221    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
222fi
223
224%preun devel
225if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
226   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
227fi
228
229%post guile -p /sbin/ldconfig
230
231%postun guile -p /sbin/ldconfig
232
233%post -n compat32-%{name} -p /sbin/ldconfig
234
235%postun -n compat32-%{name} -p /sbin/ldconfig
236
237%post -n compat32-%{name}-guile -p /sbin/ldconfig
238
239%postun -n compat32-%{name}-guile -p /sbin/ldconfig
240
241%files -f gnutls.lang
242%defattr(-,root,root,-)
243%{_libdir}/libgnutls.so.28*
244%{_libdir}/libgnutls-xssl.so.0*
245%doc README AUTHORS NEWS THANKS
246
247%files devel
248%defattr(-,root,root,-)
249%{_bindir}/libgnutls*-config
250%{_includedir}/*
251%{_libdir}/libgnutls*.so
252%{_libdir}/pkgconfig/*.pc
253%{_mandir}/man3/*
254%{_infodir}/gnutls*
255%{_infodir}/pkcs11-vision.png.gz
256
257%files utils
258%defattr(-,root,root,-)
259%{_bindir}/certtool
260%{_bindir}/psktool
261%{_bindir}/p11tool
262%{_bindir}/ocsptool
263%{_bindir}/gnutls*
264%{_mandir}/man1/*
265%doc doc/certtool.cfg
266
267%files guile
268%defattr(-,root,root,-)
269%{_libdir}/guile/1.8/guile*.so*
270%{_datadir}/guile/site/gnutls
271%{_datadir}/guile/site/gnutls.scm
272
273%files c++
274%{_libdir}/libgnutlsxx.so.*
275
276%if %{build_compat32}
277%files -n compat32-%{name}
278%defattr(-,root,root,-)
279%{_libdir}/libgnutls.so.28*
280%{_libdir}/libgnutls-xssl.so.0*
281
282%files -n compat32-%{name}-devel
283%defattr(-,root,root,-)
284#%{_libdir}/libgnutls*.a
285%{_libdir}/libgnutls*.so
286%{_libdir}/pkgconfig/*.pc
287
288%files -n compat32-%{name}-guile
289%defattr(-,root,root,-)
290%{_libdir}/guile/1.8/guile*.so*
291%endif
292
293%changelog
294* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
295- new upstream release with security fix   
296
297* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
298- new upstream release with security fix 
299
300* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
301- new upstream release with security fix
302
303* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
304- new upstream release with security fix
305
306* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
307- fix R: in compat32
308
309* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
310- fix BR:, R: (drop unneeded dependency)
311
312* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
313- new upstream release 3.2.10
314- update patches / drop old patches
315- add BR: nettle
316
317* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
318- added Patch100 from upstream to fix CVE-2013-2116
319
320* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
321- new upstream release
322- fixed a day of the week in %%changelog
323
324* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
325- new upstream release
326
327* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
328- new upstream release
329
330* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
331- new upstream release
332
333* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
334- new upstream release
335
336* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
337- new upstream release
338- changed BuildRequires: p11-kit-devel >= 0.11
339
340* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
341- new upstream release
342
343* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
344- new upstream release
345
346* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
347- added BuildRequires: p11-kit-devel
348
349* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
350- deleted BuildRequires: nettle-devel
351  - mistake.. fixed.
352
353* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
354- new upstream release
355- synced Fedora development package
356- add new sub-package: c++
357
358* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
359- add Requires: libtasn1-devel for devel subpackage
360
361* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
362- new upstream release
363
364* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
365- new upstream release
366
367* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
368- new upstream release
369- dropt patch1
370
371* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
372- new upstream release
373- added patch1,2,3,4 from Fedora development
374- added BuildRequires: gettext readline-devel libtool
375- added configure option
376  --disable-static,--disable-srp-authentication
377  - dropt *.a files from -devel package again
378
379* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
380- build with rpm-4.8.1-1 for pkg-config file
381
382* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
383- new upstream release
384- applied new naming policy to spec
385
386* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
387- new upstream release
388
389* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
390- new upstream release
391
392* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
393- new upstream release
394
395* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
396- new upstream release with security fix (handling X.509 CN or SAN fields)
397
398* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
399- added compat32 package for x86_64 arch support
400
401* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
402- new upstream release
403- added autoreconf
404- deleted libguile*.a
405- dropt Patch3
406- added %post guile, %postun guile
407
408* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
409- drop *.a files from -devel package
410- build with system lzo
411
412* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
413- new upstream release with security fixes (CVE-2009-1415,1416,1417)
414
415* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
416- update to 2.6.5
417
418* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
419- spec in UTF-8
420
421* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
422- update to 2.6.4
423- modifeid Source0
424
425* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
426- add BuildRequires: guile-devel >= 1.8.6
427
428* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
429- update to 2.6.3
430- import from fedora developing's 2.6.3
431  - License tag fixed
432- dropped patch0, patch1, patch2
433- added patch3
434- added BuildRequires: gmp-devel
435- add new sub-package: guile
436  - added %package guile, %description guile, %files guile
437
438* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
439- used %%{?_dist_release} macro
440
441* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
442- update to 1.6.3 (use no-SRP source)
443- import from fedora core's 1.6.3-2
444  - nosrc.tar.bz2 (source0)
445  - license tag fix
446- build with system libtasn1
447
448* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
449- update to 1.4.5 (use no-SRP source)
450- import from fedora core's 1.4.5-1
451  - nosrc.tar.bz2 (source0)
452- drop obsolete cve-2006-4790.patch (patch3)
453
454* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
455- [SECURITY] update to 1.4.1 (use no-SRP source)
456- import from fedora core's 1.4.1-2
457  - nosrp.tar.bz2 (source0)
458  - libgnutls-config (source1)
459  - nosrc.patch (patch0)
460  - enable-psk.patch (patch1)
461  - cve-2006-4790.patch (patch3)
462- update required version of libgcrypt (>= 1.2.2)
463- add Requires: pkgconfig to -devel package
464- add %%check section
465- update %%files
466- add new sub-package: utils
467
468* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
469- [SECURITY FIX] upstream release
470  - record packet parsing denial of service (CAN-2005-1431)
471
472* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
473- initial build for Vine Linux
474- upstream release
475
476* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
477- gcc4 rebuild
478
479* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
480- add gnutls Requires zlib-devel (#144069)
481
482* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
483- Make gnutls-devel Require libgcrypt-devel
484
485* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
486- rebuild with release++, otherwise unchanged.
487
488* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
489- patent tainted SRP code removed.
490
491* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
492- update to 1.0.20.
493- add --with-included-opencdk --with-included-libtasn1
494- add --with-included-libcfg --with-included-lzo
495- add --disable-srp-authentication.
496- do "make check" after build.
497
498* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
499- upgrade to 0.9.2
500
501* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
502- update to 0.4.4.
503
504* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
505- automated rebuild
506
507* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
508- update to 0.4.3.
509
510* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
511- update to 0.4.2.
512- change license to LGPL.
513- include splint annotations patch.
514
515* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
516- update to 0.4.0
517
518* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
519- update to 0.3.2
520
521* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
522- add a URL
523
524* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
525- initial package
Note: See TracBrowser for help on using the repository browser.