source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 8299

Revision 8299, 15.1 KB checked in by iwamoto, 10 years ago (diff)

gnutls: 3.2.12.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.2.12.1
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20Patch100: gnutls-3.2.10_guile_build.patch
21
22# Security fixes
23# Nothing...
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27# BuildRequires: libgcrypt-devel >= 1.2.2
28BuildRequires: libtasn1-devel >= 3.1
29BuildRequires: gmp-devel, zlib-devel
30BuildRequires: gettext readline-devel libtool
31BuildRequires: guile-devel >= 1.8.6
32# BuildRequires: lzo-devel
33BuildRequires: p11-kit-devel >= 0.11
34BuildRequires: nettle-devel >= 2.7
35BuildRequires: texinfo, autogen
36# Requires:     libgcrypt >= 1.2.2, zlib
37Requires:      zlib
38# Requires:     lzo
39
40Requires(post):   ldconfig
41Requires(postun): ldconfig
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45
46%description
47GnuTLS is a project that aims to develop a library which provides a secure
48layer, over a reliable transport layer. Currently the GnuTLS library implements
49the proposed standards by the IETF's TLS working group.
50#'
51
52%package devel
53Summary:        Development files for the GnuTLS package.
54Summary(ja):    GnuTLS の開発用ファイル
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57Requires:       libgcrypt-devel, zlib-devel, pkgconfig
58Requires:       libtasn1-devel, nettle-devel
59Requires(post,preun): /sbin/install-info
60
61%description devel
62GnuTLS is a project that aims to develop a library which provides a secure
63layer, over a reliable transport layer. Currently the GnuTLS library implements
64the proposed standards by the IETF's TLS working group.
65
66This package contains files needed for developing applications with the GnuTLS
67library.
68#'
69
70%package utils
71Summary:        Command line tools for TLS protocol.
72Summary(ja):    GnuTLS のコマンドラインツール
73Group:          Applications/System
74Requires:       %{name} = %{version}-%{release}
75
76%description utils
77GnuTLS is a project that aims to develop a library which provides a secure
78layer, over a reliable transport layer. Currently the GnuTLS library implements
79the proposed standards by the IETF's TLS working group.
80
81This package contains command line TLS client and server and certificate
82manipulation tools.
83#'
84
85%package guile
86Summary: Guile bindings for the GNUTLS library
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: guile
90
91%description guile
92GnuTLS is a project that aims to develop a library which provides a secure
93layer, over a reliable transport layer. Currently the GnuTLS library implements
94the proposed standards by the IETF's TLS working group.
95This package contains Guile bindings for the library.
96#'
97
98%package c++
99Summary: The C++ interface to GnuTLS
100Group: System Environment/Libraries
101Requires: %{name} = %{version}-%{release}
102
103%description c++
104GnuTLS is a project that aims to develop a library which provides a secure
105layer, over a reliable transport layer. Currently the GnuTLS library implements
106the proposed standards by the IETF's TLS working group.
107This package contains the C++ interface for the GnuTLS library.
108#'
109
110%package -n compat32-%{name}
111Summary:        GNU TLS Library
112Summary(ja):    GNU TLS ライブラリ
113Group:          System Environment/Libraries
114Requires:       %{name} = %{version}-%{release}
115
116%description -n compat32-%{name}
117GnuTLS is a project that aims to develop a library which provides a secure
118layer, over a reliable transport layer. Currently the GnuTLS library implements
119the proposed standards by the IETF's TLS working group.
120#'
121
122%package -n compat32-%{name}-devel
123Summary:        Development files for the GnuTLS package.
124Summary(ja):    GnuTLS の開発用ファイル
125Group:          Development/Libraries
126Requires:       compat32-%{name} = %{version}-%{release}
127Requires:       %{name}-devel = %{version}-%{release}
128Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
129Requires(post,preun): /sbin/install-info
130
131%description -n compat32-%{name}-devel
132GnuTLS is a project that aims to develop a library which provides a secure
133layer, over a reliable transport layer. Currently the GnuTLS library implements
134the proposed standards by the IETF's TLS working group.
135
136This package contains files needed for developing applications with the GnuTLS
137library.
138#'
139
140%package -n compat32-%{name}-guile
141Summary: Guile bindings for the GNUTLS library
142Group: Development/Libraries
143Requires: compat32-%{name} = %{version}-%{release}
144Requires: %{name}-guile = %{version}-%{release}
145
146%description -n compat32-%{name}-guile
147GnuTLS is a project that aims to develop a library which provides a secure
148layer, over a reliable transport layer. Currently the GnuTLS library implements
149the proposed standards by the IETF's TLS working group.
150This package contains Guile bindings for the library.
151#'
152
153%prep
154%setup -q -n %{name}-3.2.12
155
156%patch1 -p1 -b .rpath
157%patch3 -p1 -b .nosrp
158
159# %patch100 -p1
160
161%build
162export LDFLAGS="-Wl,--no-add-needed"
163# autoreconf -fi
164%configure \
165        --disable-openssl-compatibility \
166        --disable-srp-authentication \
167        --disable-static \
168        --disable-srp-authentication \
169        --disable-non-suiteb-curves \
170        --disable-rpath \
171        --enable-guile
172#       --with-libgcrypt
173#       --with-lzo \
174#       --with-included-libcfg \
175#       --with-libtasn1-prefix=%{_prefix} \
176#       --with-included-libtasn1 \
177#       --with-included-opencdk \
178#       --with-included-lzo \
179make %{?_smp_mflags}
180# cp lib/COPYING COPYING.LIB
181
182%install
183%__rm -rf %{buildroot}
184# makeinstall macro causes build error, why?
185make install DESTDIR=%{buildroot}
186
187rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
188rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
189rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
190# replace libgnutls*-config
191%__install -d %{buildroot}%{_bindir}
192%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
193# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
194
195rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
196rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
197rm -f $RPM_BUILD_ROOT%{_infodir}/dir
198rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
199rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
200rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
201
202# remove unneeded files
203%__rm -f %{buildroot}%{_libdir}/*.la
204%__rm -f %{buildroot}%{_libdir}/guile/1.8/*.la
205
206%find_lang gnutls
207
208%check
209make check
210
211%clean
212rm -rf %{buildroot}
213
214%post -p /sbin/ldconfig
215
216%postun -p /sbin/ldconfig
217
218%post devel
219if [ -f %{_infodir}/gnutls.info.gz ]; then
220    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
221fi
222
223%preun devel
224if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
225   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
226fi
227
228%post guile -p /sbin/ldconfig
229
230%postun guile -p /sbin/ldconfig
231
232%post -n compat32-%{name} -p /sbin/ldconfig
233
234%postun -n compat32-%{name} -p /sbin/ldconfig
235
236%post -n compat32-%{name}-guile -p /sbin/ldconfig
237
238%postun -n compat32-%{name}-guile -p /sbin/ldconfig
239
240%files -f gnutls.lang
241%defattr(-,root,root,-)
242%{_libdir}/libgnutls.so.28*
243%{_libdir}/libgnutls-xssl.so.0*
244%doc README AUTHORS NEWS THANKS
245
246%files devel
247%defattr(-,root,root,-)
248%{_bindir}/libgnutls*-config
249%{_includedir}/*
250%{_libdir}/libgnutls*.so
251%{_libdir}/pkgconfig/*.pc
252%{_mandir}/man3/*
253%{_infodir}/gnutls*
254%{_infodir}/pkcs11-vision.png.gz
255
256%files utils
257%defattr(-,root,root,-)
258%{_bindir}/certtool
259%{_bindir}/psktool
260%{_bindir}/p11tool
261%{_bindir}/ocsptool
262%{_bindir}/gnutls*
263%{_mandir}/man1/*
264%doc doc/certtool.cfg
265
266%files guile
267%defattr(-,root,root,-)
268%{_libdir}/guile/1.8/guile*.so*
269%{_datadir}/guile/site/gnutls
270%{_datadir}/guile/site/gnutls.scm
271
272%files c++
273%{_libdir}/libgnutlsxx.so.*
274
275%if %{build_compat32}
276%files -n compat32-%{name}
277%defattr(-,root,root,-)
278%{_libdir}/libgnutls.so.28*
279%{_libdir}/libgnutls-xssl.so.0*
280
281%files -n compat32-%{name}-devel
282%defattr(-,root,root,-)
283#%{_libdir}/libgnutls*.a
284%{_libdir}/libgnutls*.so
285%{_libdir}/pkgconfig/*.pc
286
287%files -n compat32-%{name}-guile
288%defattr(-,root,root,-)
289%{_libdir}/guile/1.8/guile*.so*
290%endif
291
292%changelog
293* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
294- new upstream release with security fix
295
296* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
297- new upstream release with security fix
298
299* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
300- fix R: in compat32
301
302* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
303- fix BR:, R: (drop unneeded dependency)
304
305* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
306- new upstream release 3.2.10
307- update patches / drop old patches
308- add BR: nettle
309
310* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
311- added Patch100 from upstream to fix CVE-2013-2116
312
313* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
314- new upstream release
315- fixed a day of the week in %%changelog
316
317* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
318- new upstream release
319
320* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
321- new upstream release
322
323* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
324- new upstream release
325
326* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
327- new upstream release
328
329* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
330- new upstream release
331- changed BuildRequires: p11-kit-devel >= 0.11
332
333* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
334- new upstream release
335
336* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
337- new upstream release
338
339* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
340- added BuildRequires: p11-kit-devel
341
342* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
343- deleted BuildRequires: nettle-devel
344  - mistake.. fixed.
345
346* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
347- new upstream release
348- synced Fedora development package
349- add new sub-package: c++
350
351* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
352- add Requires: libtasn1-devel for devel subpackage
353
354* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
355- new upstream release
356
357* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
358- new upstream release
359
360* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
361- new upstream release
362- dropt patch1
363
364* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
365- new upstream release
366- added patch1,2,3,4 from Fedora development
367- added BuildRequires: gettext readline-devel libtool
368- added configure option
369  --disable-static,--disable-srp-authentication
370  - dropt *.a files from -devel package again
371
372* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
373- build with rpm-4.8.1-1 for pkg-config file
374
375* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
376- new upstream release
377- applied new naming policy to spec
378
379* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
380- new upstream release
381
382* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
383- new upstream release
384
385* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
386- new upstream release
387
388* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
389- new upstream release with security fix (handling X.509 CN or SAN fields)
390
391* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
392- added compat32 package for x86_64 arch support
393
394* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
395- new upstream release
396- added autoreconf
397- deleted libguile*.a
398- dropt Patch3
399- added %post guile, %postun guile
400
401* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
402- drop *.a files from -devel package
403- build with system lzo
404
405* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
406- new upstream release with security fixes (CVE-2009-1415,1416,1417)
407
408* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
409- update to 2.6.5
410
411* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
412- spec in UTF-8
413
414* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
415- update to 2.6.4
416- modifeid Source0
417
418* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
419- add BuildRequires: guile-devel >= 1.8.6
420
421* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
422- update to 2.6.3
423- import from fedora developing's 2.6.3
424  - License tag fixed
425- dropped patch0, patch1, patch2
426- added patch3
427- added BuildRequires: gmp-devel
428- add new sub-package: guile
429  - added %package guile, %description guile, %files guile
430
431* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
432- used %%{?_dist_release} macro
433
434* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
435- update to 1.6.3 (use no-SRP source)
436- import from fedora core's 1.6.3-2
437  - nosrc.tar.bz2 (source0)
438  - license tag fix
439- build with system libtasn1
440
441* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
442- update to 1.4.5 (use no-SRP source)
443- import from fedora core's 1.4.5-1
444  - nosrc.tar.bz2 (source0)
445- drop obsolete cve-2006-4790.patch (patch3)
446
447* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
448- [SECURITY] update to 1.4.1 (use no-SRP source)
449- import from fedora core's 1.4.1-2
450  - nosrp.tar.bz2 (source0)
451  - libgnutls-config (source1)
452  - nosrc.patch (patch0)
453  - enable-psk.patch (patch1)
454  - cve-2006-4790.patch (patch3)
455- update required version of libgcrypt (>= 1.2.2)
456- add Requires: pkgconfig to -devel package
457- add %%check section
458- update %%files
459- add new sub-package: utils
460
461* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
462- [SECURITY FIX] upstream release
463  - record packet parsing denial of service (CAN-2005-1431)
464
465* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
466- initial build for Vine Linux
467- upstream release
468
469* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
470- gcc4 rebuild
471
472* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
473- add gnutls Requires zlib-devel (#144069)
474
475* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
476- Make gnutls-devel Require libgcrypt-devel
477
478* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
479- rebuild with release++, otherwise unchanged.
480
481* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
482- patent tainted SRP code removed.
483
484* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
485- update to 1.0.20.
486- add --with-included-opencdk --with-included-libtasn1
487- add --with-included-libcfg --with-included-lzo
488- add --disable-srp-authentication.
489- do "make check" after build.
490
491* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
492- upgrade to 0.9.2
493
494* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
495- update to 0.4.4.
496
497* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
498- automated rebuild
499
500* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
501- update to 0.4.3.
502
503* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
504- update to 0.4.2.
505- change license to LGPL.
506- include splint annotations patch.
507
508* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
509- update to 0.4.0
510
511* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
512- update to 0.3.2
513
514* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
515- add a URL
516
517* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
518- initial package
Note: See TracBrowser for help on using the repository browser.