source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 3274

Revision 3274, 12.3 KB checked in by iwaim, 13 years ago (diff)

gnutls-2.10.5-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        2.10.5
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12#Source0:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
13#Source1:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
14# XXX patent tainted SRP code removed.
15Source0:        %{name}-%{version}.tar.bz2
16Source1:        libgnutls-config
17
18#patches from fedora development
19#Patch1: gnutls-2.10.2-rpath.patch
20Patch2: gnutls-2.8.6-link-libgcrypt.patch
21# Remove nonexisting references from texinfo file
22Patch3: gnutls-2.10.1-nosrp.patch
23# Backport from upstream git
24Patch4: gnutls-2.10.1-handshake-errors.patch
25
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires:  libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
30BuildRequires:  gettext readline-devel libtool
31BuildRequires:  guile-devel >= 1.8.6
32BuildRequires:  lzo-devel
33Requires:       libgcrypt >= 1.2.2, zlib
34Requires:       lzo
35
36Requires(post):   ldconfig
37Requires(postun): ldconfig
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41
42%description
43GnuTLS is a project that aims to develop a library which provides a secure
44layer, over a reliable transport layer. Currently the GnuTLS library implements
45the proposed standards by the IETF's TLS working group.
46#'
47
48%package devel
49Summary:        Development files for the GnuTLS package.
50Summary(ja):    GnuTLS の開発用ファイル
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       libgcrypt-devel, zlib-devel, pkgconfig
54Requires(post,preun): /sbin/install-info
55
56%description devel
57GnuTLS is a project that aims to develop a library which provides a secure
58layer, over a reliable transport layer. Currently the GnuTLS library implements
59the proposed standards by the IETF's TLS working group.
60
61This package contains files needed for developing applications with the GnuTLS
62library.
63#'
64
65%package utils
66Summary:        Command line tools for TLS protocol.
67Summary(ja):    GnuTLS のコマンドラインツール
68Group:          Applications/System
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72GnuTLS is a project that aims to develop a library which provides a secure
73layer, over a reliable transport layer. Currently the GnuTLS library implements
74the proposed standards by the IETF's TLS working group.
75
76This package contains command line TLS client and server and certificate
77manipulation tools.
78#'
79
80%package guile
81Summary: Guile bindings for the GNUTLS library
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: guile
85
86%description guile
87GnuTLS is a project that aims to develop a library which provides a secure
88layer, over a reliable transport layer. Currently the GnuTLS library implements
89the proposed standards by the IETF's TLS working group.
90This package contains Guile bindings for the library.
91#'
92
93%package -n compat32-%{name}
94Summary:        GNU TLS Library
95Summary(ja):    GNU TLS ライブラリ
96Group:          System Environment/Libraries
97Requires:       compat32-%{name} = %{version}-%{release}
98
99%description -n compat32-%{name}
100GnuTLS is a project that aims to develop a library which provides a secure
101layer, over a reliable transport layer. Currently the GnuTLS library implements
102the proposed standards by the IETF's TLS working group.
103#'
104
105%package -n compat32-%{name}-devel
106Summary:        Development files for the GnuTLS package.
107Summary(ja):    GnuTLS の開発用ファイル
108Group:          Development/Libraries
109Requires:       compat32-%{name} = %{version}-%{release}
110Requires:       %{name}-devel = %{version}-%{release}
111Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
112Requires(post,preun): /sbin/install-info
113
114%description -n compat32-%{name}-devel
115GnuTLS is a project that aims to develop a library which provides a secure
116layer, over a reliable transport layer. Currently the GnuTLS library implements
117the proposed standards by the IETF's TLS working group.
118
119This package contains files needed for developing applications with the GnuTLS
120library.
121#'
122
123%package -n compat32-%{name}-guile
124Summary: Guile bindings for the GNUTLS library
125Group: Development/Libraries
126Requires: compat32-%{name} = %{version}-%{release}
127Requires: %{name}-guile = %{version}-%{release}
128
129%description -n compat32-%{name}-guile
130GnuTLS is a project that aims to develop a library which provides a secure
131layer, over a reliable transport layer. Currently the GnuTLS library implements
132the proposed standards by the IETF's TLS working group.
133This package contains Guile bindings for the library.
134#'
135
136%prep
137%setup -q
138#%patch1 -p1 -b .rpath
139%patch2 -p1 -b .link
140%patch3 -p1 -b .nosrp
141%patch4 -p1 -b .errors
142
143for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
144    touch lib/$i
145done
146
147%build
148autoreconf
149%configure \
150        --with-lzo \
151        --with-included-libcfg \
152        --disable-srp-authentication \
153        --disable-static \
154        --disable-srp-authentication
155#       --with-included-libtasn1 \
156#       --with-included-opencdk \
157#       --with-included-lzo \
158make
159cp lib/COPYING COPYING.LIB
160
161%install
162%__rm -rf %{buildroot}
163%makeinstall
164
165rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
166rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
167# replace libgnutls*-config
168%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
169%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
170
171rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
172rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
173rm -f $RPM_BUILD_ROOT%{_infodir}/dir
174rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
175rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
176
177# remove unneeded files
178%__rm -f %{buildroot}%{_libdir}/*.la
179
180%find_lang libgnutls
181
182%check
183make check
184
185%clean
186rm -rf %{buildroot}
187
188%post -p /sbin/ldconfig
189
190%postun -p /sbin/ldconfig
191
192%post devel
193if [ -f %{_infodir}/gnutls.info.gz ]; then
194    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
195fi
196
197%preun devel
198if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
199   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
200fi
201
202%post guile -p /sbin/ldconfig
203
204%postun guile -p /sbin/ldconfig
205
206%post -n compat32-%{name} -p /sbin/ldconfig
207
208%postun -n compat32-%{name} -p /sbin/ldconfig
209
210%post -n compat32-%{name}-guile -p /sbin/ldconfig
211
212%postun -n compat32-%{name}-guile -p /sbin/ldconfig
213
214%files -f libgnutls.lang
215%defattr(-,root,root,-)
216%{_libdir}/libgnutls*.so.*
217%doc COPYING COPYING.LIB README AUTHORS
218
219%files devel
220%defattr(-,root,root,-)
221%{_bindir}/libgnutls*-config
222%{_includedir}/*
223#%{_libdir}/libgnutls*.a
224%{_libdir}/libgnutls*.so
225%{_libdir}/pkgconfig/*.pc
226%{_mandir}/man3/*
227%{_infodir}/gnutls*
228
229%files utils
230%defattr(-,root,root,-)
231%{_bindir}/certtool
232%{_bindir}/psktool
233%{_bindir}/gnutls*
234%{_mandir}/man1/*
235%doc doc/certtool.cfg
236
237%files guile
238%defattr(-,root,root,-)
239%{_libdir}/libguile*.so*
240%{_datadir}/guile/site/gnutls
241%{_datadir}/guile/site/gnutls.scm
242
243%if %{build_compat32}
244%files -n compat32-%{name}
245%defattr(-,root,root,-)
246%{_libdir}/libgnutls*.so.*
247
248%files -n compat32-%{name}-devel
249%defattr(-,root,root,-)
250#%{_libdir}/libgnutls*.a
251%{_libdir}/libgnutls*.so
252%{_libdir}/pkgconfig/*.pc
253
254%files -n compat32-%{name}-guile
255%defattr(-,root,root,-)
256%{_libdir}/libguile*.so*
257%endif
258
259%changelog
260* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
261- new upstream release
262
263* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
264- new upstream release
265
266* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
267- new upstream release
268- dropt patch1
269
270* Sun Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
271- new upstream release
272- added patch1,2,3,4 from Fedora development
273- added BuildRequires: gettext readline-devel libtool
274- added configure option
275  --disable-static,--disable-srp-authentication
276  - dropt *.a files from -devel package again
277
278* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
279- build with rpm-4.8.1-1 for pkg-config file
280
281* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
282- new upstream release
283- applied new naming policy to spec
284
285* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
286- new upstream release
287
288* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
289- new upstream release
290
291* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
292- new upstream release
293
294* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
295- new upstream release with security fix (handling X.509 CN or SAN fields)
296
297* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
298- added compat32 package for x86_64 arch support
299
300* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
301- new upstream release
302- added autoreconf
303- deleted libguile*.a
304- dropt Patch3
305- added %post guile, %postun guile
306
307* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
308- drop *.a files from -devel package
309- build with system lzo
310
311* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
312- new upstream release with security fixes (CVE-2009-1415,1416,1417)
313
314* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.6-1vl5
315- update to 2.6.5
316
317* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
318- spec in UTF-8
319
320* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
321- update to 2.6.4
322- modifeid Source0
323
324* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
325- add BuildRequires: guile-devel >= 1.8.6
326
327* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
328- update to 2.6.3
329- import from fedora developing's 2.6.3
330  - License tag fixed
331- dropped patch0, patch1, patch2
332- added patch3
333- added BuildRequires: gmp-devel
334- add new sub-package: guile
335  - added %package guile, %description guile, %files guile
336
337* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
338- used %%{?_dist_release} macro
339
340* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
341- update to 1.6.3 (use no-SRP source)
342- import from fedora core's 1.6.3-2
343  - nosrc.tar.bz2 (source0)
344  - license tag fix
345- build with system libtasn1
346
347* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
348- update to 1.4.5 (use no-SRP source)
349- import from fedora core's 1.4.5-1
350  - nosrc.tar.bz2 (source0)
351- drop obsolete cve-2006-4790.patch (patch3)
352
353* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
354- [SECURITY] update to 1.4.1 (use no-SRP source)
355- import from fedora core's 1.4.1-2
356  - nosrp.tar.bz2 (source0)
357  - libgnutls-config (source1)
358  - nosrc.patch (patch0)
359  - enable-psk.patch (patch1)
360  - cve-2006-4790.patch (patch3)
361- update required version of libgcrypt (>= 1.2.2)
362- add Requires: pkgconfig to -devel package
363- add %%check section
364- update %%files
365- add new sub-package: utils
366
367* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
368- [SECURITY FIX] upstream release
369  - record packet parsing denial of service (CAN-2005-1431)
370
371* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
372- initial build for Vine Linux
373- upstream release
374
375* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
376- gcc4 rebuild
377
378* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
379- add gnutls Requires zlib-devel (#144069)
380
381* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
382- Make gnutls-devel Require libgcrypt-devel
383
384* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
385- rebuild with release++, otherwise unchanged.
386
387* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
388- patent tainted SRP code removed.
389
390* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
391- update to 1.0.20.
392- add --with-included-opencdk --with-included-libtasn1
393- add --with-included-libcfg --with-included-lzo
394- add --disable-srp-authentication.
395- do "make check" after build.
396
397* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
398- upgrade to 0.9.2
399
400* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
401- update to 0.4.4.
402
403* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
404- automated rebuild
405
406* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
407- update to 0.4.3.
408
409* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
410- update to 0.4.2.
411- change license to LGPL.
412- include splint annotations patch.
413
414* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
415- update to 0.4.0
416
417* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
418- update to 0.3.2
419
420* Wed Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
421- add a URL
422
423* Wed Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
424- initial package
Note: See TracBrowser for help on using the repository browser.