source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 641

Revision 641, 11.2 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        2.8.6
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12#Source0:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
13#Source1:       ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
14# XXX patent tainted SRP code removed.
15Source0:        %{name}-%{version}.tar.bz2
16Source1:        libgnutls-config
17
18#Patch3:        gnutls-2.6.2-nosrp.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
23BuildRequires:  guile-devel >= 1.8.6
24BuildRequires:  lzo-devel
25Requires:       libgcrypt >= 1.2.2, zlib
26Requires:       lzo
27
28Requires(post):   ldconfig
29Requires(postun): ldconfig
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33
34%description
35GnuTLS is a project that aims to develop a library which provides a secure
36layer, over a reliable transport layer. Currently the GnuTLS library implements
37the proposed standards by the IETF's TLS working group.
38#'
39
40%package devel
41Summary:        Development files for the GnuTLS package.
42Summary(ja):    GnuTLS の開発用ファイル
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45Requires:       libgcrypt-devel, zlib-devel, pkgconfig
46Requires(post,preun): /sbin/install-info
47
48%description devel
49GnuTLS is a project that aims to develop a library which provides a secure
50layer, over a reliable transport layer. Currently the GnuTLS library implements
51the proposed standards by the IETF's TLS working group.
52
53This package contains files needed for developing applications with the GnuTLS
54library.
55#'
56
57%package utils
58Summary:        Command line tools for TLS protocol.
59Summary(ja):    GnuTLS のコマンドラインツール
60Group:          Applications/System
61Requires:       %{name} = %{version}-%{release}
62
63%description utils
64GnuTLS is a project that aims to develop a library which provides a secure
65layer, over a reliable transport layer. Currently the GnuTLS library implements
66the proposed standards by the IETF's TLS working group.
67
68This package contains command line TLS client and server and certificate
69manipulation tools.
70#'
71
72%package guile
73Summary: Guile bindings for the GNUTLS library
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: guile
77
78%description guile
79GnuTLS is a project that aims to develop a library which provides a secure
80layer, over a reliable transport layer. Currently the GnuTLS library implements
81the proposed standards by the IETF's TLS working group.
82This package contains Guile bindings for the library.
83#'
84
85%package -n compat32-%{name}
86Summary:        GNU TLS Library
87Summary(ja):    GNU TLS ライブラリ
88Group:          System Environment/Libraries
89Requires:       compat32-%{name} = %{version}-%{release}
90
91%description -n compat32-%{name}
92GnuTLS is a project that aims to develop a library which provides a secure
93layer, over a reliable transport layer. Currently the GnuTLS library implements
94the proposed standards by the IETF's TLS working group.
95#'
96
97%package -n compat32-%{name}-devel
98Summary:        Development files for the GnuTLS package.
99Summary(ja):    GnuTLS の開発用ファイル
100Group:          Development/Libraries
101Requires:       compat32-%{name} = %{version}-%{release}
102Requires:       %{name}-devel = %{version}-%{release}
103Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
104Requires(post,preun): /sbin/install-info
105
106%description -n compat32-%{name}-devel
107GnuTLS is a project that aims to develop a library which provides a secure
108layer, over a reliable transport layer. Currently the GnuTLS library implements
109the proposed standards by the IETF's TLS working group.
110
111This package contains files needed for developing applications with the GnuTLS
112library.
113#'
114
115%package -n compat32-%{name}-guile
116Summary: Guile bindings for the GNUTLS library
117Group: Development/Libraries
118Requires: compat32-%{name} = %{version}-%{release}
119Requires: %{name}-guile = %{version}-%{release}
120
121%description -n compat32-%{name}-guile
122GnuTLS is a project that aims to develop a library which provides a secure
123layer, over a reliable transport layer. Currently the GnuTLS library implements
124the proposed standards by the IETF's TLS working group.
125This package contains Guile bindings for the library.
126#'
127
128%prep
129%setup -q
130
131#%patch3 -p1
132
133for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
134    touch lib/$i
135done
136
137%build
138autoreconf
139%configure \
140        --with-lzo \
141        --with-included-libcfg \
142        --disable-srp-authentication
143#       --with-included-libtasn1 \
144#       --with-included-opencdk \
145#       --with-included-lzo \
146make
147cp lib/COPYING COPYING.LIB
148
149%install
150%__rm -rf %{buildroot}
151%makeinstall
152
153rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
154rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
155# replace libgnutls*-config
156%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
157%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
158
159rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
160rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
161rm -f $RPM_BUILD_ROOT%{_infodir}/dir
162rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
163rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
164
165# remove unneeded files
166%__rm -f %{buildroot}%{_libdir}/*.la
167
168%find_lang libgnutls
169
170%check
171make check
172
173%clean
174rm -rf %{buildroot}
175
176%post -p /sbin/ldconfig
177
178%postun -p /sbin/ldconfig
179
180%post devel
181if [ -f %{_infodir}/gnutls.info.gz ]; then
182    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
183fi
184
185%preun devel
186if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
187   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
188fi
189
190%post guile -p /sbin/ldconfig
191
192%postun guile -p /sbin/ldconfig
193
194%post -n compat32-%{name} -p /sbin/ldconfig
195
196%postun -n compat32-%{name} -p /sbin/ldconfig
197
198%post -n compat32-%{name}-guile -p /sbin/ldconfig
199
200%postun -n compat32-%{name}-guile -p /sbin/ldconfig
201
202%files -f libgnutls.lang
203%defattr(-,root,root,-)
204%{_libdir}/libgnutls*.so.*
205%doc COPYING COPYING.LIB README AUTHORS
206
207%files devel
208%defattr(-,root,root,-)
209%{_bindir}/libgnutls*-config
210%{_includedir}/*
211%{_libdir}/libgnutls*.a
212%{_libdir}/libgnutls*.so
213%{_libdir}/pkgconfig/*.pc
214%{_mandir}/man3/*
215%{_infodir}/gnutls*
216
217%files utils
218%defattr(-,root,root,-)
219%{_bindir}/certtool
220%{_bindir}/psktool
221%{_bindir}/gnutls*
222%{_mandir}/man1/*
223%doc doc/certtool.cfg
224
225%files guile
226%defattr(-,root,root,-)
227%{_libdir}/libguile*.so*
228%{_datadir}/guile/site/gnutls
229%{_datadir}/guile/site/gnutls.scm
230
231%if %{build_compat32}
232%files -n compat32-%{name}
233%defattr(-,root,root,-)
234%{_libdir}/libgnutls*.so.*
235
236%files -n compat32-%{name}-devel
237%defattr(-,root,root,-)
238%{_libdir}/libgnutls*.a
239%{_libdir}/libgnutls*.so
240%{_libdir}/pkgconfig/*.pc
241
242%files -n compat32-%{name}-guile
243%defattr(-,root,root,-)
244%{_libdir}/libguile*.so*
245%endif
246
247%changelog
248* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
249- new upstream release
250- applied new naming policy to spec
251
252* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
253- new upstream release
254
255* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
256- new upstream release
257
258* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
259- new upstream release
260
261* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
262- new upstream release with security fix (handling X.509 CN or SAN fields)
263
264* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
265- added compat32 package for x86_64 arch support
266
267* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
268- new upstream release
269- added autoreconf
270- deleted libguile*.a
271- dropt Patch3
272- added %post guile, %postun guile
273
274* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
275- drop *.a files from -devel package
276- build with system lzo
277
278* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
279- new upstream release with security fixes (CVE-2009-1415,1416,1417)
280
281* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.6-1vl5
282- update to 2.6.5
283
284* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
285- spec in UTF-8
286
287* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
288- update to 2.6.4
289- modifeid Source0
290
291* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
292- add BuildRequires: guile-devel >= 1.8.6
293
294* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
295- update to 2.6.3
296- import from fedora developing's 2.6.3
297  - License tag fixed
298- dropped patch0, patch1, patch2
299- added patch3
300- added BuildRequires: gmp-devel
301- add new sub-package: guile
302  - added %package guile, %description guile, %files guile
303
304* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
305- used %%{?_dist_release} macro
306
307* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
308- update to 1.6.3 (use no-SRP source)
309- import from fedora core's 1.6.3-2
310  - nosrc.tar.bz2 (source0)
311  - license tag fix
312- build with system libtasn1
313
314* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
315- update to 1.4.5 (use no-SRP source)
316- import from fedora core's 1.4.5-1
317  - nosrc.tar.bz2 (source0)
318- drop obsolete cve-2006-4790.patch (patch3)
319
320* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
321- [SECURITY] update to 1.4.1 (use no-SRP source)
322- import from fedora core's 1.4.1-2
323  - nosrp.tar.bz2 (source0)
324  - libgnutls-config (source1)
325  - nosrc.patch (patch0)
326  - enable-psk.patch (patch1)
327  - cve-2006-4790.patch (patch3)
328- update required version of libgcrypt (>= 1.2.2)
329- add Requires: pkgconfig to -devel package
330- add %%check section
331- update %%files
332- add new sub-package: utils
333
334* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
335- [SECURITY FIX] upstream release
336  - record packet parsing denial of service (CAN-2005-1431)
337
338* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
339- initial build for Vine Linux
340- upstream release
341
342* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
343- gcc4 rebuild
344
345* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
346- add gnutls Requires zlib-devel (#144069)
347
348* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
349- Make gnutls-devel Require libgcrypt-devel
350
351* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
352- rebuild with release++, otherwise unchanged.
353
354* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
355- patent tainted SRP code removed.
356
357* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
358- update to 1.0.20.
359- add --with-included-opencdk --with-included-libtasn1
360- add --with-included-libcfg --with-included-lzo
361- add --disable-srp-authentication.
362- do "make check" after build.
363
364* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
365- upgrade to 0.9.2
366
367* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
368- update to 0.4.4.
369
370* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
371- automated rebuild
372
373* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
374- update to 0.4.3.
375
376* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
377- update to 0.4.2.
378- change license to LGPL.
379- include splint annotations patch.
380
381* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
382- update to 0.4.0
383
384* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
385- update to 0.3.2
386
387* Wed Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
388- add a URL
389
390* Wed Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
391- initial package
Note: See TracBrowser for help on using the repository browser.