source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 12199

Revision 12199, 17.9 KB checked in by tomop, 5 years ago (diff)

updated guile and pkgs depends on guile

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%global guile_shortver %(guile-config --version 2>&1 | sed -e 's/^guile-config.*version //' -e ' s/\.[0-9]*$//')
3
4Summary:        GNU TLS Library
5Summary(ja):    GNU TLS ライブラリ
6Name:           gnutls
7Version:        3.6.9
8Release:        1%{?_dist_release}
9License:        GPLv3+ and LGPLv2+
10# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
11Group:          System Environment/Libraries
12URL:            http://www.gnutls.org/
13%global         shortver %(echo "%{version}" | sed -e 's/\.[0-9]*$//')
14Source0:        https://www.gnupg.org/ftp/gcrypt/gnutls/v%{shortver}/%{name}-%{version}.tar.xz
15Source1:        libgnutls-config
16
17#patches from fedora development
18Patch1: gnutls-3.2.7-rpath.patch
19Patch2: gnutls-3.6.7-no-now-guile.patch
20
21# Vine Patches
22# Nothing...
23
24# Security fixes
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  libtasn1-devel >= 4.13
28Requires:               libtasn1 >= 4.13
29BuildRequires:  libunistring-devel
30BuildRequires:  datefudge >= 1.22
31BuildRequires:  gmp-devel
32BuildRequires:  gettext readline-devel libtool
33BuildRequires:  guile-devel >= 1.8.6
34BuildRequires:  p11-kit-devel >= 0.21.3
35BuildRequires:  nettle-devel >= 3.4
36Requires:               nettle >= 3.4
37BuildRequires:  texinfo, autogen
38BuildRequires:  unbound-devel unbound-libs
39BuildRequires:  zlib-devel
40Requires:               zlib
41# for tests
42BuildRequires:  net-tools
43
44Requires(post): ldconfig
45Requires(postun):       ldconfig
46
47Vendor:         Project Vine
48Distribution:   Vine Linux
49
50%description
51GnuTLS is a project that aims to develop a library which provides a secure
52layer, over a reliable transport layer. Currently the GnuTLS library implements
53the proposed standards by the IETF's TLS working group.
54#'
55
56%package devel
57Summary:        Development files for the GnuTLS package.
58Summary(ja):    GnuTLS の開発用ファイル
59Group:          Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61Requires:       libgcrypt-devel, zlib-devel, pkgconfig
62Requires:       libtasn1-devel, nettle-devel
63Requires(post,preun): /sbin/install-info
64
65%description devel
66GnuTLS is a project that aims to develop a library which provides a secure
67layer, over a reliable transport layer. Currently the GnuTLS library implements
68the proposed standards by the IETF's TLS working group.
69
70This package contains files needed for developing applications with the GnuTLS
71library.
72#'
73
74%package utils
75Summary:        Command line tools for TLS protocol.
76Summary(ja):    GnuTLS のコマンドラインツール
77Group:          Applications/System
78Requires:       %{name} = %{version}-%{release}
79
80%description utils
81GnuTLS is a project that aims to develop a library which provides a secure
82layer, over a reliable transport layer. Currently the GnuTLS library implements
83the proposed standards by the IETF's TLS working group.
84
85This package contains command line TLS client and server and certificate
86manipulation tools.
87#'
88
89%package guile
90Summary: Guile bindings for the GNUTLS library
91Group: Development/Libraries
92Requires: %{name} = %{version}-%{release}
93Requires: guile
94
95%description guile
96GnuTLS is a project that aims to develop a library which provides a secure
97layer, over a reliable transport layer. Currently the GnuTLS library implements
98the proposed standards by the IETF's TLS working group.
99This package contains Guile bindings for the library.
100#'
101
102%package c++
103Summary: The C++ interface to GnuTLS
104Group: System Environment/Libraries
105Requires: %{name} = %{version}-%{release}
106
107%description c++
108GnuTLS is a project that aims to develop a library which provides a secure
109layer, over a reliable transport layer. Currently the GnuTLS library implements
110the proposed standards by the IETF's TLS working group.
111This package contains the C++ interface for the GnuTLS library.
112#'
113
114%package -n compat32-%{name}
115Summary:        GNU TLS Library
116Summary(ja):    GNU TLS ライブラリ
117Group:          System Environment/Libraries
118Requires:       %{name} = %{version}-%{release}
119
120%description -n compat32-%{name}
121GnuTLS is a project that aims to develop a library which provides a secure
122layer, over a reliable transport layer. Currently the GnuTLS library implements
123the proposed standards by the IETF's TLS working group.
124#'
125
126%package -n compat32-%{name}-devel
127Summary:        Development files for the GnuTLS package.
128Summary(ja):    GnuTLS の開発用ファイル
129Group:          Development/Libraries
130Requires:       compat32-%{name} = %{version}-%{release}
131Requires:       %{name}-devel = %{version}-%{release}
132Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
133Requires(post,preun): /sbin/install-info
134
135%description -n compat32-%{name}-devel
136GnuTLS is a project that aims to develop a library which provides a secure
137layer, over a reliable transport layer. Currently the GnuTLS library implements
138the proposed standards by the IETF's TLS working group.
139
140This package contains files needed for developing applications with the GnuTLS
141library.
142#'
143
144%package -n compat32-%{name}-guile
145Summary: Guile bindings for the GNUTLS library
146Group: Development/Libraries
147Requires: compat32-%{name} = %{version}-%{release}
148Requires: %{name}-guile = %{version}-%{release}
149
150%description -n compat32-%{name}-guile
151GnuTLS is a project that aims to develop a library which provides a secure
152layer, over a reliable transport layer. Currently the GnuTLS library implements
153the proposed standards by the IETF's TLS working group.
154This package contains Guile bindings for the library.
155#'
156
157%prep
158%autosetup -p1
159
160sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/lib /usr/lib %{_libdir}|g' configure
161rm -f lib/minitasn1/*.c lib/minitasn1/*.h
162rm -f src/libopts/*.c src/libopts/*.h src/libopts/compat/*.c src/libopts/compat/*.h
163
164echo "SYSTEM=NORMAL" >> tests/system.prio
165
166%build
167export LDFLAGS="-Wl,--no-add-needed"
168# autoreconf -fi
169%configure \
170        --enable-sha1-support \
171        --disable-static \
172        --disable-openssl-compatibility \
173        --disable-non-suiteb-curves \
174        --enable-guile \
175        --with-unbound-root-key-file=/var/lib/unbound/root.key \
176        --enable-dane \
177        --disable-rpath \
178        %{nil}
179#       --with-libgcrypt
180#       --with-lzo \
181#       --with-included-libcfg \
182#       --with-libtasn1-prefix=%{_prefix} \
183#       --with-included-libtasn1 \
184#       --with-included-opencdk \
185#       --with-included-lzo \
186make %{?_smp_mflags}
187# cp lib/COPYING COPYING.LIB
188
189%install
190%__rm -rf %{buildroot}
191# makeinstall macro causes build error, why?
192make install DESTDIR=%{buildroot}
193
194rm -f %{buildroot}%{_infodir}/dir
195rm -f %{buildroot}%{_libdir}/*.la
196rm -f %{buildroot}%{_libdir}/libguile*.a
197rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/*.la
198rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/extensions/*.la
199rm -f %{buildroot}%{_libdir}/gnutls/libpkcs11mock1.*
200rm -rf %{buildroot}%{_docdir}/gnutls
201
202%find_lang gnutls
203
204%check
205make check %{?_smp_mflags}
206
207%clean
208rm -rf %{buildroot}
209
210%post -p /sbin/ldconfig
211
212%postun -p /sbin/ldconfig
213
214%post devel
215if [ -f %{_infodir}/gnutls.info.gz ]; then
216    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
217fi
218
219%preun devel
220if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
221   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
222fi
223
224%post guile -p /sbin/ldconfig
225
226%postun guile -p /sbin/ldconfig
227
228%post -n compat32-%{name} -p /sbin/ldconfig
229
230%postun -n compat32-%{name} -p /sbin/ldconfig
231
232%post -n compat32-%{name}-guile -p /sbin/ldconfig
233
234%postun -n compat32-%{name}-guile -p /sbin/ldconfig
235
236%files -f gnutls.lang
237%defattr(-,root,root,-)
238%{_libdir}/libgnutls.so.30*
239%{_libdir}/libgnutls-dane.so.*
240# %{_libdir}/libgnutls-xssl.so.0*
241%doc README* AUTHORS NEWS THANKS
242
243%files devel
244%defattr(-,root,root,-)
245%{_includedir}/*
246%{_libdir}/libgnutls*.so
247%{_libdir}/pkgconfig/*.pc
248%{_mandir}/man3/*
249%{_infodir}/gnutls*
250%{_infodir}/pkcs11-vision.png.gz
251
252%files utils
253%defattr(-,root,root,-)
254%{_bindir}/certtool
255%{_bindir}/danetool
256%{_bindir}/psktool
257%{_bindir}/p11tool
258%{_bindir}/ocsptool
259%{_bindir}/srptool
260%{_bindir}/gnutls*
261%{_mandir}/man1/*
262%doc doc/certtool.cfg
263
264%files guile
265%defattr(-,root,root,-)
266%{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
267%{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
268%{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
269%{_datadir}/guile/site/%{guile_shortver}/gnutls
270%{_datadir}/guile/site/%{guile_shortver}/gnutls.scm
271
272%files c++
273%{_libdir}/libgnutlsxx.so.*
274
275%if %{build_compat32}
276%files -n compat32-%{name}
277%defattr(-,root,root,-)
278%{_libdir}/libgnutls.so.30*
279%{_libdir}/libgnutls-dane.so.*
280# %{_libdir}/libgnutls-xssl.so.0*
281
282%files -n compat32-%{name}-devel
283%defattr(-,root,root,-)
284#%{_libdir}/libgnutls*.a
285%{_libdir}/libgnutls*.so
286%{_libdir}/pkgconfig/*.pc
287
288%files -n compat32-%{name}-guile
289%defattr(-,root,root,-)
290%{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
291%{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
292%{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
293%endif
294
295%changelog
296* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.9-1
297- new upstream release.
298
299* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.7-1
300- new upstream release.
301- updated Patch2.
302- dropped Patch3.
303
304* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
305- new upstream release.
306- dropped Patch2-3,1001 and 2001.
307- imported Patch2-3 from rawhide.
308- enabled DANE support.
309
310* Sat Jan 28 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-3
311- fix CVE-2017-5337, CVE-2017-5334, CVE-2017-5336, CVE-2017-5335
312 - add Patch3001 from Fedora 24 gnutls-3.4.17-2.fc24
313
314* Thu Jan 12 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-2
315- fix CVE-2016-7444; OCSP validation issue
316 - add Patch2001
317- add BR: net-tools; for test
318
319* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.14-1
320- new upstream release 3.4.14.
321- dropped Patch100.
322- added BR: datefudge.
323
324* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
325- new upstream release 3.4.13.
326- added Patch100: workaround of failing cert-test (The certificate was expired).
327
328* Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
329- new upstream release 3.4.9
330
331* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
332- rebuilt to marge changelog
333
334* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
335- new upstream release 3.4.7
336
337* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
338- rebuild with nettls-3.1.1
339
340* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
341- BR: libtasn1-devel >= 3.9
342
343* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
344- built for release
345
346* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
347- rm libgnutls-xssl.so.0* in files list
348
349* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
350- for test
351
352* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
353- add patch1000 for fix SA-2015-3
354
355* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
356- rebuilt with guile 2.0.11
357
358* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
359- new upstream release with security fix   
360
361* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
362- new upstream release with security fix 
363
364* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
365- new upstream release with security fix
366
367* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
368- new upstream release with security fix
369
370* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
371- fix R: in compat32
372
373* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
374- fix BR:, R: (drop unneeded dependency)
375
376* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
377- new upstream release 3.2.10
378- update patches / drop old patches
379- add BR: nettle
380
381* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
382- added Patch100 from upstream to fix CVE-2013-2116
383
384* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
385- new upstream release
386- fixed a day of the week in %%changelog
387
388* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
389- new upstream release
390
391* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
392- new upstream release
393
394* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
395- new upstream release
396
397* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
398- new upstream release
399
400* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
401- new upstream release
402- changed BuildRequires: p11-kit-devel >= 0.11
403
404* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
405- new upstream release
406
407* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
408- new upstream release
409
410* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
411- added BuildRequires: p11-kit-devel
412
413* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
414- deleted BuildRequires: nettle-devel
415  - mistake.. fixed.
416
417* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
418- new upstream release
419- synced Fedora development package
420- add new sub-package: c++
421
422* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
423- add Requires: libtasn1-devel for devel subpackage
424
425* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
426- new upstream release
427
428* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
429- new upstream release
430
431* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
432- new upstream release
433- dropt patch1
434
435* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
436- new upstream release
437- added patch1,2,3,4 from Fedora development
438- added BuildRequires: gettext readline-devel libtool
439- added configure option
440  --disable-static,--disable-srp-authentication
441  - dropt *.a files from -devel package again
442
443* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
444- build with rpm-4.8.1-1 for pkg-config file
445
446* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
447- new upstream release
448- applied new naming policy to spec
449
450* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
451- new upstream release
452
453* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
454- new upstream release
455
456* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
457- new upstream release
458
459* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
460- new upstream release with security fix (handling X.509 CN or SAN fields)
461
462* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
463- added compat32 package for x86_64 arch support
464
465* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
466- new upstream release
467- added autoreconf
468- deleted libguile*.a
469- dropt Patch3
470- added %post guile, %postun guile
471
472* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
473- drop *.a files from -devel package
474- build with system lzo
475
476* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
477- new upstream release with security fixes (CVE-2009-1415,1416,1417)
478
479* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
480- update to 2.6.5
481
482* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
483- spec in UTF-8
484
485* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
486- update to 2.6.4
487- modifeid Source0
488
489* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
490- add BuildRequires: guile-devel >= 1.8.6
491
492* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
493- update to 2.6.3
494- import from fedora developing's 2.6.3
495  - License tag fixed
496- dropped patch0, patch1, patch2
497- added patch3
498- added BuildRequires: gmp-devel
499- add new sub-package: guile
500  - added %package guile, %description guile, %files guile
501
502* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
503- used %%{?_dist_release} macro
504
505* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
506- update to 1.6.3 (use no-SRP source)
507- import from fedora core's 1.6.3-2
508  - nosrc.tar.bz2 (source0)
509  - license tag fix
510- build with system libtasn1
511
512* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
513- update to 1.4.5 (use no-SRP source)
514- import from fedora core's 1.4.5-1
515  - nosrc.tar.bz2 (source0)
516- drop obsolete cve-2006-4790.patch (patch3)
517
518* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
519- [SECURITY] update to 1.4.1 (use no-SRP source)
520- import from fedora core's 1.4.1-2
521  - nosrp.tar.bz2 (source0)
522  - libgnutls-config (source1)
523  - nosrc.patch (patch0)
524  - enable-psk.patch (patch1)
525  - cve-2006-4790.patch (patch3)
526- update required version of libgcrypt (>= 1.2.2)
527- add Requires: pkgconfig to -devel package
528- add %%check section
529- update %%files
530- add new sub-package: utils
531
532* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
533- [SECURITY FIX] upstream release
534  - record packet parsing denial of service (CAN-2005-1431)
535
536* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
537- initial build for Vine Linux
538- upstream release
539
540* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
541- gcc4 rebuild
542
543* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
544- add gnutls Requires zlib-devel (#144069)
545
546* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
547- Make gnutls-devel Require libgcrypt-devel
548
549* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
550- rebuild with release++, otherwise unchanged.
551
552* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
553- patent tainted SRP code removed.
554
555* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
556- update to 1.0.20.
557- add --with-included-opencdk --with-included-libtasn1
558- add --with-included-libcfg --with-included-lzo
559- add --disable-srp-authentication.
560- do "make check" after build.
561
562* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
563- upgrade to 0.9.2
564
565* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
566- update to 0.4.4.
567
568* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
569- automated rebuild
570
571* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
572- update to 0.4.3.
573
574* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
575- update to 0.4.2.
576- change license to LGPL.
577- include splint annotations patch.
578
579* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
580- update to 0.4.0
581
582* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
583- update to 0.3.2
584
585* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
586- add a URL
587
588* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
589- initial package
Note: See TracBrowser for help on using the repository browser.