source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 10546

Revision 10546, 16.4 KB checked in by tomop, 8 years ago (diff)

gnutls-3.4.13-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.4.13
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20Patch100: gnutls-3.4-disable-test-with-expired-cert.patch
21
22# Security fixes
23# Nothing...
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  libtasn1-devel >= 4.3
27BuildRequires:  gmp-devel
28BuildRequires:  gettext readline-devel libtool
29BuildRequires:  guile-devel >= 1.8.6
30BuildRequires:  p11-kit-devel >= 0.21.3
31BuildRequires:  nettle-devel >= 3.1.1
32BuildRequires:  texinfo, autogen
33BuildRequires:  zlib-devel
34Requires:      zlib
35
36Requires(post):   ldconfig
37Requires(postun): ldconfig
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41
42%description
43GnuTLS is a project that aims to develop a library which provides a secure
44layer, over a reliable transport layer. Currently the GnuTLS library implements
45the proposed standards by the IETF's TLS working group.
46#'
47
48%package devel
49Summary:        Development files for the GnuTLS package.
50Summary(ja):    GnuTLS の開発用ファイル
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       libgcrypt-devel, zlib-devel, pkgconfig
54Requires:       libtasn1-devel, nettle-devel
55Requires(post,preun): /sbin/install-info
56
57%description devel
58GnuTLS is a project that aims to develop a library which provides a secure
59layer, over a reliable transport layer. Currently the GnuTLS library implements
60the proposed standards by the IETF's TLS working group.
61
62This package contains files needed for developing applications with the GnuTLS
63library.
64#'
65
66%package utils
67Summary:        Command line tools for TLS protocol.
68Summary(ja):    GnuTLS のコマンドラインツール
69Group:          Applications/System
70Requires:       %{name} = %{version}-%{release}
71
72%description utils
73GnuTLS is a project that aims to develop a library which provides a secure
74layer, over a reliable transport layer. Currently the GnuTLS library implements
75the proposed standards by the IETF's TLS working group.
76
77This package contains command line TLS client and server and certificate
78manipulation tools.
79#'
80
81%package guile
82Summary: Guile bindings for the GNUTLS library
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: guile
86
87%description guile
88GnuTLS is a project that aims to develop a library which provides a secure
89layer, over a reliable transport layer. Currently the GnuTLS library implements
90the proposed standards by the IETF's TLS working group.
91This package contains Guile bindings for the library.
92#'
93
94%package c++
95Summary: The C++ interface to GnuTLS
96Group: System Environment/Libraries
97Requires: %{name} = %{version}-%{release}
98
99%description c++
100GnuTLS is a project that aims to develop a library which provides a secure
101layer, over a reliable transport layer. Currently the GnuTLS library implements
102the proposed standards by the IETF's TLS working group.
103This package contains the C++ interface for the GnuTLS library.
104#'
105
106%package -n compat32-%{name}
107Summary:        GNU TLS Library
108Summary(ja):    GNU TLS ライブラリ
109Group:          System Environment/Libraries
110Requires:       %{name} = %{version}-%{release}
111
112%description -n compat32-%{name}
113GnuTLS is a project that aims to develop a library which provides a secure
114layer, over a reliable transport layer. Currently the GnuTLS library implements
115the proposed standards by the IETF's TLS working group.
116#'
117
118%package -n compat32-%{name}-devel
119Summary:        Development files for the GnuTLS package.
120Summary(ja):    GnuTLS の開発用ファイル
121Group:          Development/Libraries
122Requires:       compat32-%{name} = %{version}-%{release}
123Requires:       %{name}-devel = %{version}-%{release}
124Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
125Requires(post,preun): /sbin/install-info
126
127%description -n compat32-%{name}-devel
128GnuTLS is a project that aims to develop a library which provides a secure
129layer, over a reliable transport layer. Currently the GnuTLS library implements
130the proposed standards by the IETF's TLS working group.
131
132This package contains files needed for developing applications with the GnuTLS
133library.
134#'
135
136%package -n compat32-%{name}-guile
137Summary: Guile bindings for the GNUTLS library
138Group: Development/Libraries
139Requires: compat32-%{name} = %{version}-%{release}
140Requires: %{name}-guile = %{version}-%{release}
141
142%description -n compat32-%{name}-guile
143GnuTLS is a project that aims to develop a library which provides a secure
144layer, over a reliable transport layer. Currently the GnuTLS library implements
145the proposed standards by the IETF's TLS working group.
146This package contains Guile bindings for the library.
147#'
148
149%prep
150%setup -q
151
152%patch1 -p1 -b .rpath
153%patch3 -p1 -b .nosrp
154
155%patch100 -p1 -b .cert-test
156
157%build
158export LDFLAGS="-Wl,--no-add-needed"
159# autoreconf -fi
160%configure \
161        --disable-openssl-compatibility \
162        --disable-srp-authentication \
163        --disable-static \
164        --disable-srp-authentication \
165        --disable-non-suiteb-curves \
166        --disable-rpath \
167        --enable-guile
168#       --with-libgcrypt
169#       --with-lzo \
170#       --with-included-libcfg \
171#       --with-libtasn1-prefix=%{_prefix} \
172#       --with-included-libtasn1 \
173#       --with-included-opencdk \
174#       --with-included-lzo \
175make %{?_smp_mflags}
176# cp lib/COPYING COPYING.LIB
177
178%install
179%__rm -rf %{buildroot}
180# makeinstall macro causes build error, why?
181make install DESTDIR=%{buildroot}
182
183rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
184rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
185rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
186# replace libgnutls*-config
187%__install -d %{buildroot}%{_bindir}
188%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
189# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
190
191rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
192rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
193rm -f $RPM_BUILD_ROOT%{_infodir}/dir
194rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
195rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
196rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
197
198# remove unneeded files
199%__rm -f %{buildroot}%{_libdir}/*.la
200%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
201
202%find_lang gnutls
203
204%check
205make check
206
207%clean
208rm -rf %{buildroot}
209
210%post -p /sbin/ldconfig
211
212%postun -p /sbin/ldconfig
213
214%post devel
215if [ -f %{_infodir}/gnutls.info.gz ]; then
216    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
217fi
218
219%preun devel
220if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
221   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
222fi
223
224%post guile -p /sbin/ldconfig
225
226%postun guile -p /sbin/ldconfig
227
228%post -n compat32-%{name} -p /sbin/ldconfig
229
230%postun -n compat32-%{name} -p /sbin/ldconfig
231
232%post -n compat32-%{name}-guile -p /sbin/ldconfig
233
234%postun -n compat32-%{name}-guile -p /sbin/ldconfig
235
236%files -f gnutls.lang
237%defattr(-,root,root,-)
238%{_libdir}/libgnutls.so.30*
239# %{_libdir}/libgnutls-xssl.so.0*
240%doc README AUTHORS NEWS THANKS
241
242%files devel
243%defattr(-,root,root,-)
244%{_bindir}/libgnutls*-config
245%{_includedir}/*
246%{_libdir}/libgnutls*.so
247%{_libdir}/pkgconfig/*.pc
248%{_mandir}/man3/*
249%{_infodir}/gnutls*
250%{_infodir}/pkcs11-vision.png.gz
251
252%files utils
253%defattr(-,root,root,-)
254%{_bindir}/certtool
255%{_bindir}/psktool
256%{_bindir}/p11tool
257%{_bindir}/ocsptool
258%{_bindir}/gnutls*
259%{_mandir}/man1/*
260%doc doc/certtool.cfg
261
262%files guile
263%defattr(-,root,root,-)
264%{_libdir}/guile/2.0/guile*.so*
265%{_datadir}/guile/site/gnutls
266%{_datadir}/guile/site/gnutls.scm
267
268%files c++
269%{_libdir}/libgnutlsxx.so.*
270
271%if %{build_compat32}
272%files -n compat32-%{name}
273%defattr(-,root,root,-)
274%{_libdir}/libgnutls.so.30*
275# %{_libdir}/libgnutls-xssl.so.0*
276
277%files -n compat32-%{name}-devel
278%defattr(-,root,root,-)
279#%{_libdir}/libgnutls*.a
280%{_libdir}/libgnutls*.so
281%{_libdir}/pkgconfig/*.pc
282
283%files -n compat32-%{name}-guile
284%defattr(-,root,root,-)
285%{_libdir}/guile/2.0/guile*.so*
286%endif
287
288%changelog
289* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
290- new upstream release 3.4.13.
291- added Patch100: workaround of failing cert-test (The certificate was expired).
292
293* Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
294- new upstream release 3.4.9
295
296* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
297- rebuilt to marge changelog
298
299* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
300- new upstream release 3.4.7
301
302* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
303- rebuild with nettls-3.1.1
304
305* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
306- BR: libtasn1-devel >= 3.9
307
308* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
309- built for release
310
311* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
312- rm libgnutls-xssl.so.0* in files list
313
314* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
315- for test
316
317* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
318- add patch1000 for fix SA-2015-3
319
320* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
321- rebuilt with guile 2.0.11
322
323* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
324- new upstream release with security fix   
325
326* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
327- new upstream release with security fix 
328
329* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
330- new upstream release with security fix
331
332* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
333- new upstream release with security fix
334
335* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
336- fix R: in compat32
337
338* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
339- fix BR:, R: (drop unneeded dependency)
340
341* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
342- new upstream release 3.2.10
343- update patches / drop old patches
344- add BR: nettle
345
346* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
347- added Patch100 from upstream to fix CVE-2013-2116
348
349* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
350- new upstream release
351- fixed a day of the week in %%changelog
352
353* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
354- new upstream release
355
356* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
357- new upstream release
358
359* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
360- new upstream release
361
362* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
363- new upstream release
364
365* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
366- new upstream release
367- changed BuildRequires: p11-kit-devel >= 0.11
368
369* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
370- new upstream release
371
372* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
373- new upstream release
374
375* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
376- added BuildRequires: p11-kit-devel
377
378* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
379- deleted BuildRequires: nettle-devel
380  - mistake.. fixed.
381
382* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
383- new upstream release
384- synced Fedora development package
385- add new sub-package: c++
386
387* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
388- add Requires: libtasn1-devel for devel subpackage
389
390* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
391- new upstream release
392
393* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
394- new upstream release
395
396* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
397- new upstream release
398- dropt patch1
399
400* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
401- new upstream release
402- added patch1,2,3,4 from Fedora development
403- added BuildRequires: gettext readline-devel libtool
404- added configure option
405  --disable-static,--disable-srp-authentication
406  - dropt *.a files from -devel package again
407
408* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
409- build with rpm-4.8.1-1 for pkg-config file
410
411* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
412- new upstream release
413- applied new naming policy to spec
414
415* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
416- new upstream release
417
418* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
419- new upstream release
420
421* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
422- new upstream release
423
424* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
425- new upstream release with security fix (handling X.509 CN or SAN fields)
426
427* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
428- added compat32 package for x86_64 arch support
429
430* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
431- new upstream release
432- added autoreconf
433- deleted libguile*.a
434- dropt Patch3
435- added %post guile, %postun guile
436
437* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
438- drop *.a files from -devel package
439- build with system lzo
440
441* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
442- new upstream release with security fixes (CVE-2009-1415,1416,1417)
443
444* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
445- update to 2.6.5
446
447* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
448- spec in UTF-8
449
450* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
451- update to 2.6.4
452- modifeid Source0
453
454* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
455- add BuildRequires: guile-devel >= 1.8.6
456
457* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
458- update to 2.6.3
459- import from fedora developing's 2.6.3
460  - License tag fixed
461- dropped patch0, patch1, patch2
462- added patch3
463- added BuildRequires: gmp-devel
464- add new sub-package: guile
465  - added %package guile, %description guile, %files guile
466
467* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
468- used %%{?_dist_release} macro
469
470* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
471- update to 1.6.3 (use no-SRP source)
472- import from fedora core's 1.6.3-2
473  - nosrc.tar.bz2 (source0)
474  - license tag fix
475- build with system libtasn1
476
477* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
478- update to 1.4.5 (use no-SRP source)
479- import from fedora core's 1.4.5-1
480  - nosrc.tar.bz2 (source0)
481- drop obsolete cve-2006-4790.patch (patch3)
482
483* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
484- [SECURITY] update to 1.4.1 (use no-SRP source)
485- import from fedora core's 1.4.1-2
486  - nosrp.tar.bz2 (source0)
487  - libgnutls-config (source1)
488  - nosrc.patch (patch0)
489  - enable-psk.patch (patch1)
490  - cve-2006-4790.patch (patch3)
491- update required version of libgcrypt (>= 1.2.2)
492- add Requires: pkgconfig to -devel package
493- add %%check section
494- update %%files
495- add new sub-package: utils
496
497* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
498- [SECURITY FIX] upstream release
499  - record packet parsing denial of service (CAN-2005-1431)
500
501* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
502- initial build for Vine Linux
503- upstream release
504
505* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
506- gcc4 rebuild
507
508* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
509- add gnutls Requires zlib-devel (#144069)
510
511* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
512- Make gnutls-devel Require libgcrypt-devel
513
514* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
515- rebuild with release++, otherwise unchanged.
516
517* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
518- patent tainted SRP code removed.
519
520* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
521- update to 1.0.20.
522- add --with-included-opencdk --with-included-libtasn1
523- add --with-included-libcfg --with-included-lzo
524- add --disable-srp-authentication.
525- do "make check" after build.
526
527* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
528- upgrade to 0.9.2
529
530* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
531- update to 0.4.4.
532
533* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
534- automated rebuild
535
536* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
537- update to 0.4.3.
538
539* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
540- update to 0.4.2.
541- change license to LGPL.
542- include splint annotations patch.
543
544* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
545- update to 0.4.0
546
547* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
548- update to 0.3.2
549
550* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
551- add a URL
552
553* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
554- initial package
Note: See TracBrowser for help on using the repository browser.