source: projects/specs/trunk/g/gnutls/gnutls-vl.spec @ 10028

Revision 10028, 16.2 KB checked in by iwamoto, 8 years ago (diff)

gnutls: update to 3.4.9

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        GNU TLS Library
4Summary(ja):    GNU TLS ライブラリ
5Name:           gnutls
6Version:        3.4.9
7Release:        1%{?_dist_release}
8License:        GPLv3+ and LGPLv2+
9# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
10Group:          System Environment/Libraries
11URL:            http://www.gnutls.org/
12Source0:        %{name}-%{version}.tar.xz
13Source1:        libgnutls-config
14
15#patches from fedora development
16Patch1: gnutls-3.2.7-rpath.patch
17Patch3: gnutls-3.1.11-nosrp.patch
18
19# Vine Patches
20# Patch100: gnutls-3.2.10_guile_build.patch
21# Security fixes
22# Nothing...
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  libtasn1-devel >= 4.3
26BuildRequires:  gmp-devel
27BuildRequires:  gettext readline-devel libtool
28BuildRequires:  guile-devel >= 1.8.6
29BuildRequires:  p11-kit-devel >= 0.21.3
30BuildRequires:  nettle-devel >= 3.1.1
31BuildRequires:  texinfo, autogen
32BuildRequires:  zlib-devel
33Requires:      zlib
34
35Requires(post):   ldconfig
36Requires(postun): ldconfig
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40
41%description
42GnuTLS is a project that aims to develop a library which provides a secure
43layer, over a reliable transport layer. Currently the GnuTLS library implements
44the proposed standards by the IETF's TLS working group.
45#'
46
47%package devel
48Summary:        Development files for the GnuTLS package.
49Summary(ja):    GnuTLS の開発用ファイル
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       libgcrypt-devel, zlib-devel, pkgconfig
53Requires:       libtasn1-devel, nettle-devel
54Requires(post,preun): /sbin/install-info
55
56%description devel
57GnuTLS is a project that aims to develop a library which provides a secure
58layer, over a reliable transport layer. Currently the GnuTLS library implements
59the proposed standards by the IETF's TLS working group.
60
61This package contains files needed for developing applications with the GnuTLS
62library.
63#'
64
65%package utils
66Summary:        Command line tools for TLS protocol.
67Summary(ja):    GnuTLS のコマンドラインツール
68Group:          Applications/System
69Requires:       %{name} = %{version}-%{release}
70
71%description utils
72GnuTLS is a project that aims to develop a library which provides a secure
73layer, over a reliable transport layer. Currently the GnuTLS library implements
74the proposed standards by the IETF's TLS working group.
75
76This package contains command line TLS client and server and certificate
77manipulation tools.
78#'
79
80%package guile
81Summary: Guile bindings for the GNUTLS library
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: guile
85
86%description guile
87GnuTLS is a project that aims to develop a library which provides a secure
88layer, over a reliable transport layer. Currently the GnuTLS library implements
89the proposed standards by the IETF's TLS working group.
90This package contains Guile bindings for the library.
91#'
92
93%package c++
94Summary: The C++ interface to GnuTLS
95Group: System Environment/Libraries
96Requires: %{name} = %{version}-%{release}
97
98%description c++
99GnuTLS is a project that aims to develop a library which provides a secure
100layer, over a reliable transport layer. Currently the GnuTLS library implements
101the proposed standards by the IETF's TLS working group.
102This package contains the C++ interface for the GnuTLS library.
103#'
104
105%package -n compat32-%{name}
106Summary:        GNU TLS Library
107Summary(ja):    GNU TLS ライブラリ
108Group:          System Environment/Libraries
109Requires:       %{name} = %{version}-%{release}
110
111%description -n compat32-%{name}
112GnuTLS is a project that aims to develop a library which provides a secure
113layer, over a reliable transport layer. Currently the GnuTLS library implements
114the proposed standards by the IETF's TLS working group.
115#'
116
117%package -n compat32-%{name}-devel
118Summary:        Development files for the GnuTLS package.
119Summary(ja):    GnuTLS の開発用ファイル
120Group:          Development/Libraries
121Requires:       compat32-%{name} = %{version}-%{release}
122Requires:       %{name}-devel = %{version}-%{release}
123Requires:       compat32-libgcrypt-devel, compat32-zlib-devel
124Requires(post,preun): /sbin/install-info
125
126%description -n compat32-%{name}-devel
127GnuTLS is a project that aims to develop a library which provides a secure
128layer, over a reliable transport layer. Currently the GnuTLS library implements
129the proposed standards by the IETF's TLS working group.
130
131This package contains files needed for developing applications with the GnuTLS
132library.
133#'
134
135%package -n compat32-%{name}-guile
136Summary: Guile bindings for the GNUTLS library
137Group: Development/Libraries
138Requires: compat32-%{name} = %{version}-%{release}
139Requires: %{name}-guile = %{version}-%{release}
140
141%description -n compat32-%{name}-guile
142GnuTLS is a project that aims to develop a library which provides a secure
143layer, over a reliable transport layer. Currently the GnuTLS library implements
144the proposed standards by the IETF's TLS working group.
145This package contains Guile bindings for the library.
146#'
147
148%prep
149%setup -q
150
151%patch1 -p1 -b .rpath
152%patch3 -p1 -b .nosrp
153
154# %patch100 -p1
155# %patch1000 -p1 -b .SA-2015-3
156
157%build
158export LDFLAGS="-Wl,--no-add-needed"
159# autoreconf -fi
160%configure \
161        --disable-openssl-compatibility \
162        --disable-srp-authentication \
163        --disable-static \
164        --disable-srp-authentication \
165        --disable-non-suiteb-curves \
166        --disable-rpath \
167        --enable-guile
168#       --with-libgcrypt
169#       --with-lzo \
170#       --with-included-libcfg \
171#       --with-libtasn1-prefix=%{_prefix} \
172#       --with-included-libtasn1 \
173#       --with-included-opencdk \
174#       --with-included-lzo \
175make %{?_smp_mflags}
176# cp lib/COPYING COPYING.LIB
177
178%install
179%__rm -rf %{buildroot}
180# makeinstall macro causes build error, why?
181make install DESTDIR=%{buildroot}
182
183rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
184rm -f $RPM_BUILD_ROOT%{_bindir}/danetool
185rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
186# replace libgnutls*-config
187%__install -d %{buildroot}%{_bindir}
188%__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
189# %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
190
191rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
192rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
193rm -f $RPM_BUILD_ROOT%{_infodir}/dir
194rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
195rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
196rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gnutls-dane.pc
197
198# remove unneeded files
199%__rm -f %{buildroot}%{_libdir}/*.la
200%__rm -f %{buildroot}%{_libdir}/guile/2.0/*.la
201
202%find_lang gnutls
203
204%check
205make check
206
207%clean
208rm -rf %{buildroot}
209
210%post -p /sbin/ldconfig
211
212%postun -p /sbin/ldconfig
213
214%post devel
215if [ -f %{_infodir}/gnutls.info.gz ]; then
216    /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
217fi
218
219%preun devel
220if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
221   /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
222fi
223
224%post guile -p /sbin/ldconfig
225
226%postun guile -p /sbin/ldconfig
227
228%post -n compat32-%{name} -p /sbin/ldconfig
229
230%postun -n compat32-%{name} -p /sbin/ldconfig
231
232%post -n compat32-%{name}-guile -p /sbin/ldconfig
233
234%postun -n compat32-%{name}-guile -p /sbin/ldconfig
235
236%files -f gnutls.lang
237%defattr(-,root,root,-)
238%{_libdir}/libgnutls.so.30*
239# %{_libdir}/libgnutls-xssl.so.0*
240%doc README AUTHORS NEWS THANKS
241
242%files devel
243%defattr(-,root,root,-)
244%{_bindir}/libgnutls*-config
245%{_includedir}/*
246%{_libdir}/libgnutls*.so
247%{_libdir}/pkgconfig/*.pc
248%{_mandir}/man3/*
249%{_infodir}/gnutls*
250%{_infodir}/pkcs11-vision.png.gz
251
252%files utils
253%defattr(-,root,root,-)
254%{_bindir}/certtool
255%{_bindir}/psktool
256%{_bindir}/p11tool
257%{_bindir}/ocsptool
258%{_bindir}/gnutls*
259%{_mandir}/man1/*
260%doc doc/certtool.cfg
261
262%files guile
263%defattr(-,root,root,-)
264%{_libdir}/guile/2.0/guile*.so*
265%{_datadir}/guile/site/gnutls
266%{_datadir}/guile/site/gnutls.scm
267
268%files c++
269%{_libdir}/libgnutlsxx.so.*
270
271%if %{build_compat32}
272%files -n compat32-%{name}
273%defattr(-,root,root,-)
274%{_libdir}/libgnutls.so.30*
275# %{_libdir}/libgnutls-xssl.so.0*
276
277%files -n compat32-%{name}-devel
278%defattr(-,root,root,-)
279#%{_libdir}/libgnutls*.a
280%{_libdir}/libgnutls*.so
281%{_libdir}/pkgconfig/*.pc
282
283%files -n compat32-%{name}-guile
284%defattr(-,root,root,-)
285%{_libdir}/guile/2.0/guile*.so*
286%endif
287
288%changelog
289* Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
290- new upstream release 3.4.9
291
292* Fri Jan  1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
293- rebuilt to marge changelog
294
295* Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
296- new upstream release 3.4.7
297
298* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
299- rebuild with nettls-3.1.1
300
301* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
302- BR: libtasn1-devel >= 3.9
303
304* Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
305- built for release
306
307* Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
308- rm libgnutls-xssl.so.0* in files list
309
310* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
311- for test
312
313* Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
314- add patch1000 for fix SA-2015-3
315
316* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
317- rebuilt with guile 2.0.11
318
319* Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
320- new upstream release with security fix   
321
322* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
323- new upstream release with security fix 
324
325* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
326- new upstream release with security fix
327
328* Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
329- new upstream release with security fix
330
331* Sun Feb  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
332- fix R: in compat32
333
334* Wed Feb  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
335- fix BR:, R: (drop unneeded dependency)
336
337* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
338- new upstream release 3.2.10
339- update patches / drop old patches
340- add BR: nettle
341
342* Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
343- added Patch100 from upstream to fix CVE-2013-2116
344
345* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
346- new upstream release
347- fixed a day of the week in %%changelog
348
349* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
350- new upstream release
351
352* Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
353- new upstream release
354
355* Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
356- new upstream release
357
358* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
359- new upstream release
360
361* Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
362- new upstream release
363- changed BuildRequires: p11-kit-devel >= 0.11
364
365* Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
366- new upstream release
367
368* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
369- new upstream release
370
371* Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
372- added BuildRequires: p11-kit-devel
373
374* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
375- deleted BuildRequires: nettle-devel
376  - mistake.. fixed.
377
378* Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
379- new upstream release
380- synced Fedora development package
381- add new sub-package: c++
382
383* Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
384- add Requires: libtasn1-devel for devel subpackage
385
386* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
387- new upstream release
388
389* Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
390- new upstream release
391
392* Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
393- new upstream release
394- dropt patch1
395
396* Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
397- new upstream release
398- added patch1,2,3,4 from Fedora development
399- added BuildRequires: gettext readline-devel libtool
400- added configure option
401  --disable-static,--disable-srp-authentication
402  - dropt *.a files from -devel package again
403
404* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
405- build with rpm-4.8.1-1 for pkg-config file
406
407* Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
408- new upstream release
409- applied new naming policy to spec
410
411* Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
412- new upstream release
413
414* Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
415- new upstream release
416
417* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
418- new upstream release
419
420* Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
421- new upstream release with security fix (handling X.509 CN or SAN fields)
422
423* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
424- added compat32 package for x86_64 arch support
425
426* Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
427- new upstream release
428- added autoreconf
429- deleted libguile*.a
430- dropt Patch3
431- added %post guile, %postun guile
432
433* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
434- drop *.a files from -devel package
435- build with system lzo
436
437* Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
438- new upstream release with security fixes (CVE-2009-1415,1416,1417)
439
440* Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
441- update to 2.6.5
442
443* Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
444- spec in UTF-8
445
446* Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
447- update to 2.6.4
448- modifeid Source0
449
450* Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
451- add BuildRequires: guile-devel >= 1.8.6
452
453* Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
454- update to 2.6.3
455- import from fedora developing's 2.6.3
456  - License tag fixed
457- dropped patch0, patch1, patch2
458- added patch3
459- added BuildRequires: gmp-devel
460- add new sub-package: guile
461  - added %package guile, %description guile, %files guile
462
463* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
464- used %%{?_dist_release} macro
465
466* Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
467- update to 1.6.3 (use no-SRP source)
468- import from fedora core's 1.6.3-2
469  - nosrc.tar.bz2 (source0)
470  - license tag fix
471- build with system libtasn1
472
473* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
474- update to 1.4.5 (use no-SRP source)
475- import from fedora core's 1.4.5-1
476  - nosrc.tar.bz2 (source0)
477- drop obsolete cve-2006-4790.patch (patch3)
478
479* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
480- [SECURITY] update to 1.4.1 (use no-SRP source)
481- import from fedora core's 1.4.1-2
482  - nosrp.tar.bz2 (source0)
483  - libgnutls-config (source1)
484  - nosrc.patch (patch0)
485  - enable-psk.patch (patch1)
486  - cve-2006-4790.patch (patch3)
487- update required version of libgcrypt (>= 1.2.2)
488- add Requires: pkgconfig to -devel package
489- add %%check section
490- update %%files
491- add new sub-package: utils
492
493* Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
494- [SECURITY FIX] upstream release
495  - record packet parsing denial of service (CAN-2005-1431)
496
497* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
498- initial build for Vine Linux
499- upstream release
500
501* Wed Mar  2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
502- gcc4 rebuild
503
504* Tue Jan  4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
505- add gnutls Requires zlib-devel (#144069)
506
507* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
508- Make gnutls-devel Require libgcrypt-devel
509
510* Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
511- rebuild with release++, otherwise unchanged.
512
513* Tue Sep  7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
514- patent tainted SRP code removed.
515
516* Sun Sep  5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
517- update to 1.0.20.
518- add --with-included-opencdk --with-included-libtasn1
519- add --with-included-libcfg --with-included-lzo
520- add --disable-srp-authentication.
521- do "make check" after build.
522
523* Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
524- upgrade to 0.9.2
525
526* Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
527- update to 0.4.4.
528
529* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
530- automated rebuild
531
532* Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
533- update to 0.4.3.
534
535* Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
536- update to 0.4.2.
537- change license to LGPL.
538- include splint annotations patch.
539
540* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
541- update to 0.4.0
542
543* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
544- update to 0.3.2
545
546* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
547- add a URL
548
549* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
550- initial package
Note: See TracBrowser for help on using the repository browser.