source: projects/specs/trunk/g/gnuplot/gnuplot-vl.spec @ 9547

Revision 9547, 10.6 KB checked in by inagaki, 9 years ago (diff)

2015-05-07 Ryoichi INAGAKI <ryo1@…>

  • gnuplot: updated


Line 
1%global major 5
2%global minor 0
3%global patchlevel 0
4
5%global x11_app_defaults_dir %{_datadir}/X11/app-defaults
6
7Summary: A program for plotting mathematical expressions and data.
8Summary(ja):  数学系の関数やデータのプロット・プログラム
9Name: gnuplot
10Version: %{major}.%{minor}.%{patchlevel}
11Release: 1%{?_dist_release}
12
13# MIT .. term/PostScript/aglfn.txt
14License: gnuplot and MIT
15Group: Applications/Engineering
16URL: http://www.gnuplot.info/
17
18Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
19
20Patch0: gnuplot-4.2.0-refers_to.patch
21#Patch1: gnuplot-4.2.0-fonts.patch
22# resolves: #812225
23# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
24Patch3: gnuplot-4.6.1-plot-sigsegv.patch
25Patch4: gnuplot-4.6.4-singlethread.patch
26Patch5: gnuplot-5.0.0-lua_checkint.patch
27
28# Vine Patches (replaces Patch1)
29Patch70: gnuplot-5.0.0-fonts.patch
30
31BuildRoot: %{_tmppath}/%{name}-root
32#libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
33BuildRequires: cairo-devel
34BuildRequires: gd-devel >= 2.0.27
35BuildRequires: giflib-devel
36BuildRequires: libX11-devel
37BuildRequires: libXt-devel
38BuildRequires: libXpm-devel
39BuildRequires: libjpeg-turbo-devel
40BuildRequires: libpng-devel
41BuildRequires: lua-devel
42BuildRequires: m17n-lib
43BuildRequires: pango-devel
44BuildRequires: wxGTK-devel
45BuildRequires: zlib-devel
46
47BuildRequires: texlive
48BuildRequires: texlive-common
49BuildRequires: texlive-collection-latexextra
50BuildRequires: texlive-collection-htmlxml
51BuildRequires: texinfo
52BuildRequires: latex2html
53BuildRequires: emacs
54
55Requires: TrueType-dejavu
56Requires(post): install-info
57Requires(preun): install-info
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: daisuke, inagaki, shaolin
62
63%description
64Gnuplot is a command-line driven, interactive function plotting
65program especially suited for scientific data representation.  Gnuplot
66can be used to plot functions and data points in both two and three
67dimensions and in many different formats.
68
69Install gnuplot if you need a graphics package for scientific data
70representation.
71
72%description -l ja
73Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
74操作によるインタラクティブな関数プロット・プログラムです。
75Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
76まな形式で表現するのに利用することができます。
77
78科学データプレゼンテーション用のグラフィック・パッケージが必要な
79場合、gnuplotをインストールしてください。
80
81%package doc
82Summary: Documentation for the gnuplot main application
83Group: Applications/Documentation
84BuildArch: noarch
85Requires: %{name} = %{version}-%{release}
86
87%description doc
88The gnuplot-doc package contains the documentation related to gnuplot
89plotting tool
90
91%package latex
92Summary: Configuration for LaTeX typesetting using gnuplot
93Group: Applications/Engineering
94BuildArch: noarch
95Requires: %{name} = %{version}-%{release}
96Requires: texlive-collection-latexextra
97Requires: texlive-collection-fontsrecommended
98
99%description latex
100The gnuplot-latex package contains LaTeX configuration file related to gnuplot
101plotting tool.
102
103
104%prep
105%setup -q
106%patch0 -p1 -b .refto
107#patch1 -p1 -b .font
108%patch3 -p1 -b .plot-sigsegv
109%patch4 -p1 -b .isinglethread
110%patch5 -p1 -b .checkint
111sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
112iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
113mv ChangeLog.aux ChangeLog
114chmod 644 src/getcolor.h
115chmod 644 demo/html/webify.pl
116chmod 644 demo/html/webify_svg.pl
117chmod 644 demo/html/webify_canvas.pl
118
119%patch70 -p1 -b .font
120
121%build
122#remove binaries from source tarball
123rm -rf demo/plugin/*.so demo/plugin/*.o
124rm -rf docs_to_include
125mkdir -p docs_to_include
126cp -pr demo docs_to_include
127
128%configure --with-readline=builtin --without-linux-vga --enable-history-file --with-tutorial --without-qt
129
130make %{?_smp_mflags}
131
132make -C docs html info
133export GNUPLOT_PS_DIR=../../term/PostScript
134make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
135rm -rf docs/htmldocs/images.idx
136make -C tutorial
137
138%install
139rm -rf %{buildroot}
140make install DESTDIR=%{buildroot}
141make -C docs install-info DESTDIR=%{buildroot} INSTALL='install -p'
142
143#rm -f demo/Makefile* tutorial/Makefile*
144#packaged by info package, updated by post-installation script, do not package here
145rm -f $RPM_BUILD_ROOT%{_infodir}/dir
146
147mkdir -p $RPM_BUILD_ROOT%{x11_app_defaults_dir}
148mv $RPM_BUILD_ROOT%{_datadir}/gnuplot/%{major}.%{minor}/app-defaults/Gnuplot $RPM_BUILD_ROOT%{x11_app_defaults_dir}/Gnuplot
149rm -rf $RPM_BUILD_ROOT%{_libdir}/
150
151mkdir -p $RPM_BUILD_ROOT/%{_mandir}/ja/man1
152mv $RPM_BUILD_ROOT%{_mandir}/man1/gnuplot-ja.1 $RPM_BUILD_ROOT/%{_mandir}/ja/man1/gnuplot.1
153
154%clean
155rm -rf %{buildroot}
156
157
158%post
159if [ -f %{_infodir}/gnuplot.info* ]; then
160    /sbin/install-info %{_infodir}/gnuplot.info %{_infodir}/dir || :
161fi
162
163%preun
164if [ $1 = 0 ] ; then
165    if [ -f %{_infodir}/gnuplot.info* ]; then
166        /sbin/install-info --delete %{_infodir}/gnuplot.info %{_infodir}/dir || :
167    fi
168fi
169
170
171%files
172%defattr(-,root,root)
173%doc BUGS ChangeLog Copyright NEWS README
174%{_bindir}/gnuplot
175%dir %{_libexecdir}/gnuplot/%{major}.%{minor}
176%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
177%dir %{_datadir}/gnuplot/%{major}.%{minor}
178%dir %{_datadir}/gnuplot/%{major}.%{minor}/PostScript
179%dir %{_datadir}/gnuplot/%{major}.%{minor}/js
180%dir %{_datadir}/gnuplot/%{major}.%{minor}/lua
181%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/*.ps
182%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/aglfn.txt
183%{_datadir}/gnuplot/%{major}.%{minor}/js/*
184%{_datadir}/gnuplot/%{major}.%{minor}/lua/gnuplot-tikz.lua
185%{_datadir}/gnuplot/%{major}.%{minor}/colors_*
186%{_datadir}/gnuplot/%{major}.%{minor}/gnuplot.gih
187%{_datadir}/gnuplot/%{major}.%{minor}/gnuplotrc
188%{x11_app_defaults_dir}/Gnuplot
189%{_infodir}/gnuplot.info.gz
190%{_mandir}/man1/gnuplot.*
191%{_mandir}/ja/man1/gnuplot.*
192
193%files doc
194%defattr(-,root,root)
195%doc ChangeLog Copyright
196%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.ps
197%doc tutorial/tutorial.dvi docs/psdoc/ps_file.doc
198%doc docs/psdoc/ps_fontfile_doc.pdf docs/htmldocs tutorial/eg7.eps
199%doc docs_to_include/demo
200
201%files latex
202%defattr(-,root,root)
203%doc ChangeLog Copyright
204%{_datadir}/texmf/tex/latex/gnuplot/
205
206%changelog
207* Thu May  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.0.0-1
208- new upstream release
209- libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
210  https://bugzilla.redhat.com/show_bug.cgi?id=1039102
211- split documents and latex-related files into subpackages
212
213* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.6.6-1
214- update to 4.6.6
215
216* Thu Jan 16 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.4-1
217- new upstream release
218- add Patch0, Patch1 and Patch2 (font paths, upstream fixes)
219- modify spec to build/install docs correctly
220
221* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
222- changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
223- added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
224
225* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
226- update to gnuplot-4.4.3
227- use BR: texlive instead of tetex
228
229* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
230- update to gnuplot-4.2.5
231- drop plus patch (merged in upstream)
232- update URL: to new upstream homepage
233- fix License:
234- build with wxGTK
235- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
236
237* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
238- applied new versioning policy, spec in utf-8
239
240* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
241- add BuildRequires: texinfo, emacsen
242
243* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
244- rebuild with readline-5.1
245
246* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
247- update Patch0 to fix 'Invalid char in eps file'
248  (thanks to HANAWA Toshihiro)
249- add BuildRequires: autoconf, automake
250
251* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
252- enabled history-file
253
254* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
255- source update
256
257* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
258- source update
259- patch update and modified
260- add info
261
262* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
263- rebuild
264- fix license
265- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
266
267* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
268- rebuild with readline-4.3
269
270* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
271- syncd with RH 3.7.3-2
272- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
273
274* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
275- added pathes (patch1,2) from RH
276
277* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
278- syncd rawhide
279- updated to 3.7.1-1.2.0
280
281* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
282- updated to 3.7.1
283- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
284- remake SPEC from rawhide.
285
286* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
287- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
288
289* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
290- build for 7.0
291
292* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
293- use gnu readline, not built-in version
294
295* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
296- add latex tutorial, demo files, other docs (#10508)
297
298* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
299- update to 3.7.1. Oops.
300
301* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
302- handle compressed man pages
303
304* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
305- update to 3.7.1
306
307* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
308- ship some docs.
309
310* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
311- add a patch to fix postscript output from Bernd Kischnick
312 (kisch@die-herrmanns.de)
313
314* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
315- fix license
316
317* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
318- rebuild without svgalib
319
320* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
321- update to 3.7.0.1
322
323* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
324- auto rebuild in the new build environment (release 2)
325
326* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
327- update to 3.7.
328
329* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
330- built package for 6.0
331
332* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
333- update to 2.6beta347
334
335* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
336- build root
337
338* Thu May 07 1998 Prospector System <bugs@redhat.com>
339- translations modified for de, fr, tr
340
341* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
342- spec file cleanups
343
344* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
345- built against glibc
Note: See TracBrowser for help on using the repository browser.