source: projects/specs/trunk/g/gnuplot/gnuplot-vl.spec @ 8194

Revision 8194, 7.6 KB checked in by shaolin, 10 years ago (diff)
  • gnuplot: new upstream release
Line 
1%define gpmainver 4.6
2%define gpver %{gpmainver}.4
3
4Summary: A program for plotting mathematical expressions and data.
5Summary(ja):  数学系の関数やデータのプロット・プログラム
6Name: gnuplot
7Version: %{gpver}
8Release: 1%{?_dist_release}
9
10License: gnuplot and GPLv2
11Group: Applications/Engineering
12URL: http://gnuplot.sourceforge.net/
13
14Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
15
16Patch0: gnuplot-4.6.4-font.patch
17# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558970&group_id=2055&atid=302055
18Patch1: gnuplot-4.6.1-xcopygc-sigsegv.patch
19# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
20Patch2: gnuplot-4.6.1-plot-sigsegv.patch
21
22
23BuildRoot: %{_tmppath}/%{name}-root
24BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
25BuildRequires: libX11-devel, libXt-devel, wxGTK-devel
26BuildRequires: readline-devel
27BuildRequires: lua-devel cairo-devel pango-devel
28BuildRequires: libXpm-devel libjpeg-turbo-devel
29
30BuildRequires: texlive
31BuildRequires: texlive-common
32BuildRequires: texlive-collection-latexextra
33BuildRequires: texlive-collection-htmlxml
34BuildRequires: texinfo, emacsen
35Requires(post): install-info
36Requires(preun): install-info
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: daisuke, inagaki, shaolin
41
42%description
43Gnuplot is a command-line driven, interactive function plotting
44program especially suited for scientific data representation.  Gnuplot
45can be used to plot functions and data points in both two and three
46dimensions and in many different formats.
47
48Install gnuplot if you need a graphics package for scientific data
49representation.
50
51%description -l ja
52Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
53操作によるインタラクティブな関数プロット・プログラムです。
54Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
55まな形式で表現するのに利用することができます。
56
57科学データプレゼンテーション用のグラフィック・パッケージが必要な
58場合、gnuplotをインストールしてください。
59
60%prep
61%setup -q
62%patch0 -p1 -b .font
63%patch1 -p1 -b .xcopygc
64%patch2 -p1 -b .plot-sigsegv
65
66%build
67#autoreconf -f -i
68%ifarch alpha
69%define optflags -O0
70%endif
71%configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file --with-tutorial
72
73make %{?_smp_mflags}
74
75make -C docs html info
76export GNUPLOT_PS_DIR=../../term/PostScript
77make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
78rm -rf docs/htmldocs/images.idx
79make -C tutorial
80
81%install
82rm -rf %{buildroot}
83make install DESTDIR=%{buildroot}
84make -C docs install-info DESTDIR=%{buildroot} INSTALL='install -p'
85
86rm -f demo/Makefile* tutorial/Makefile*
87
88# move app-dafaults to %%_datadir
89#mv %{buildroot}%{_libdir}/X11 %{buildroot}%{_datadir}/
90
91# move texmf config
92#mv %{buildroot}%{_datadir}/texmf-local %{buildroot}%{_datadir}/texmf
93
94# remove unneeded files
95rm -f %{buildroot}%{_infodir}/dir
96
97%clean
98rm -rf %{buildroot}
99
100%post
101/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
102
103%preun
104if [ $1 = 0 ]; then
105    /sbin/install-info --quiet --info-dir=%{_infodir} \
106        --delete %{_infodir}/gnuplot.info.gz
107fi
108
109%files
110%defattr(-,root,root)
111%doc demo tutorial
112%doc README README.1ST INSTALL Copyright
113%doc PATCHLEVEL VERSION BUGS ChangeLog
114%{_bindir}/gnuplot
115%{_libexecdir}/gnuplot/%{gpmainver}/*
116%{_datadir}/gnuplot/%{gpmainver}/*
117#{_datadir}/X11/app-defaults/Gnuplot
118%{_datadir}/texmf/tex/latex/gnuplot
119%{_datadir}/emacs/site-lisp/*
120%{_infodir}/gnuplot.info*
121%{_mandir}/man1/gnuplot.*
122
123%changelog
124* Thu Jan 16 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.4-1
125- new upstream release
126- add Patch0, Patch1 and Patch2 (font paths, upstream fixes)
127- modify spec to build/install docs correctly
128
129* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
130- changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
131- added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
132
133* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
134- update to gnuplot-4.4.3
135- use BR: texlive instead of tetex
136
137* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
138- update to gnuplot-4.2.5
139- drop plus patch (merged in upstream)
140- update URL: to new upstream homepage
141- fix License:
142- build with wxGTK
143- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
144
145* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
146- applied new versioning policy, spec in utf-8
147
148* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
149- add BuildRequires: texinfo, emacsen
150
151* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
152- rebuild with readline-5.1
153
154* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
155- update Patch0 to fix 'Invalid char in eps file'
156  (thanks to HANAWA Toshihiro)
157- add BuildRequires: autoconf, automake
158
159* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
160- enabled history-file
161
162* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
163- source update
164
165* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
166- source update
167- patch update and modified
168- add info
169
170* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
171- rebuild
172- fix license
173- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
174
175* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
176- rebuild with readline-4.3
177
178* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
179- syncd with RH 3.7.3-2
180- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
181
182* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
183- added pathes (patch1,2) from RH
184
185* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
186- syncd rawhide
187- updated to 3.7.1-1.2.0
188
189* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
190- updated to 3.7.1
191- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
192- remake SPEC from rawhide.
193
194* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
195- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
196
197* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
198- build for 7.0
199
200* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
201- use gnu readline, not built-in version
202
203* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
204- add latex tutorial, demo files, other docs (#10508)
205
206* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
207- update to 3.7.1. Oops.
208
209* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
210- handle compressed man pages
211
212* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
213- update to 3.7.1
214
215* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
216- ship some docs.
217
218* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
219- add a patch to fix postscript output from Bernd Kischnick
220 (kisch@die-herrmanns.de)
221
222* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
223- fix license
224
225* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
226- rebuild without svgalib
227
228* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
229- update to 3.7.0.1
230
231* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
232- auto rebuild in the new build environment (release 2)
233
234* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
235- update to 3.7.
236
237* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
238- built package for 6.0
239
240* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
241- update to 2.6beta347
242
243* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
244- build root
245
246* Thu May 07 1998 Prospector System <bugs@redhat.com>
247- translations modified for de, fr, tr
248
249* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
250- spec file cleanups
251
252* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
253- built against glibc
Note: See TracBrowser for help on using the repository browser.