source: projects/specs/trunk/g/gnuplot/gnuplot-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gpmainver 4.2
2%define gpver %{gpmainver}.5
3
4Summary: A program for plotting mathematical expressions and data.
5Summary(ja):  数学系の関数やデータのプロット・プログラム
6Name: gnuplot
7Version: %{gpver}
8Release: 1%{?_dist_release}
9License: gnuplot and GPLv2
10Group: Applications/Engineering
11URL: http://gnuplot.sourceforge.net/
12
13Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: gd-devel >= 2.0.27, libpng-devel, tetex, zlib-devel
17BuildRequires: libX11-devel, libXt-devel, wx-gtk2-devel
18BuildRequires: readline-devel
19BuildRequires: autoconf, automake
20BuildRequires: texinfo, emacsen
21Requires(post): install-info
22Requires(preun): install-info
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: daisuke
27
28%description
29Gnuplot is a command-line driven, interactive function plotting
30program especially suited for scientific data representation.  Gnuplot
31can be used to plot functions and data points in both two and three
32dimensions and in many different formats.
33
34Install gnuplot if you need a graphics package for scientific data
35representation.
36
37%description -l ja
38Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
39操作によるインタラクティブな関数プロット・プログラムです。
40Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
41まな形式で表現するのに利用することができます。
42
43科学データプレゼンテーション用のグラフィック・パッケージが必要な
44場合、gnuplotをインストールしてください。
45
46%prep
47%setup -q
48
49%build
50autoreconf -f -i
51%ifarch alpha
52%define optflags -O0
53%endif
54%configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
55
56make %{?_smp_mflags}
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61make install DESTDIR=$RPM_BUILD_ROOT
62
63rm -f demo/Makefile* tutorial/Makefile*
64
65# move app-dafaults to %%_datadir
66mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
67
68# move texmf config
69mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
70
71# remove unneeded files
72rm -f $RPM_BUILD_ROOT%{_infodir}/dir
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post
78/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
79
80%preun
81if [ $1 = 0 ]; then
82  /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/gnuplot.info.gz
83fi
84
85%files
86%defattr(-,root,root)
87%doc demo tutorial
88%doc README README.1ST README.exp INSTALL Copyright TODO
89%doc PATCHLEVEL VERSION BUGS ChangeLog FAQ
90%{_bindir}/gnuplot
91%{_libexecdir}/gnuplot/%{gpmainver}/*
92%{_datadir}/gnuplot/%{gpmainver}/*
93%{_datadir}/X11/app-defaults/Gnuplot
94%{_datadir}/texmf/tex/latex/gnuplot
95%{_datadir}/emacs/site-lisp/*
96%{_infodir}/gnuplot.info*
97%{_mandir}/man1/gnuplot.*
98
99%changelog
100* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
101- update to gnuplot-4.2.5
102- drop plus patch (merged in upstream)
103- update URL: to new upstream homepage
104- fix License:
105- build with wxGTK
106- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
107
108* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
109- applied new versioning policy, spec in utf-8
110
111* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
112- add BuildRequires: texinfo, emacsen
113
114* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
115- rebuild with readline-5.1
116
117* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
118- update Patch0 to fix 'Invalid char in eps file'
119  (thanks to HANAWA Toshihiro)
120- add BuildRequires: autoconf, automake
121
122* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
123- enabled history-file
124
125* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
126- source update
127
128* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
129- source update
130- patch update and modified
131- add info
132
133* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
134- rebuild
135- fix license
136- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
137
138* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
139- rebuild with readline-4.3
140
141* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
142- syncd with RH 3.7.3-2
143- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
144
145* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
146- added pathes (patch1,2) from RH
147
148* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
149- syncd rawhide
150- updated to 3.7.1-1.2.0
151
152* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
153- updated to 3.7.1
154- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
155- remake SPEC from rawhide.
156
157* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
158- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
159
160* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
161- build for 7.0
162
163* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
164- use gnu readline, not built-in version
165
166* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
167- add latex tutorial, demo files, other docs (#10508)
168
169* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
170- update to 3.7.1. Oops.
171
172* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
173- handle compressed man pages
174
175* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
176- update to 3.7.1
177
178* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
179- ship some docs.
180
181* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
182- add a patch to fix postscript output from Bernd Kischnick
183 (kisch@die-herrmanns.de)
184
185* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
186- fix license
187
188* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
189- rebuild without svgalib
190
191* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
192- update to 3.7.0.1
193
194* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
195- auto rebuild in the new build environment (release 2)
196
197* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
198- update to 3.7.
199
200* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
201- built package for 6.0
202
203* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
204- update to 2.6beta347
205
206* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
207- build root
208
209* Thu May 07 1998 Prospector System <bugs@redhat.com>
210- translations modified for de, fr, tr
211
212* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
213- spec file cleanups
214
215* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
216- built against glibc
Note: See TracBrowser for help on using the repository browser.