source: projects/specs/trunk/g/gnuplot/gnuplot-vl.spec @ 6551

Revision 6551, 6.7 KB checked in by kudoh, 12 years ago (diff)
Line 
1%define gpmainver 4.4
2%define gpver %{gpmainver}.3
3
4Summary: A program for plotting mathematical expressions and data.
5Summary(ja):  数学系の関数やデータのプロット・プログラム
6Name: gnuplot
7Version: %{gpver}
8Release: 2%{?_dist_release}
9
10License: gnuplot and GPLv2
11Group: Applications/Engineering
12URL: http://gnuplot.sourceforge.net/
13
14Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-root
17BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
18BuildRequires: libX11-devel, libXt-devel, wxGTK-devel
19BuildRequires: readline-devel
20BuildRequires: lua-devel cairo-devel pango-devel
21BuildRequires: libXpm-devel libjpeg-turbo-devel
22
23BuildRequires: texlive
24BuildRequires: texlive-common
25BuildRequires: texlive-collection-latexextra
26BuildRequires: texinfo, emacsen
27Requires(post): install-info
28Requires(preun): install-info
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: daisuke, inagaki
33
34%description
35Gnuplot is a command-line driven, interactive function plotting
36program especially suited for scientific data representation.  Gnuplot
37can be used to plot functions and data points in both two and three
38dimensions and in many different formats.
39
40Install gnuplot if you need a graphics package for scientific data
41representation.
42
43%description -l ja
44Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
45操作によるインタラクティブな関数プロット・プログラムです。
46Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
47まな形式で表現するのに利用することができます。
48
49科学データプレゼンテーション用のグラフィック・パッケージが必要な
50場合、gnuplotをインストールしてください。
51
52%prep
53%setup -q
54
55%build
56#autoreconf -f -i
57%ifarch alpha
58%define optflags -O0
59%endif
60%configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
61
62make %{?_smp_mflags}
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f demo/Makefile* tutorial/Makefile*
70
71# move app-dafaults to %%_datadir
72#mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
73
74# move texmf config
75mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
76
77# remove unneeded files
78rm -f $RPM_BUILD_ROOT%{_infodir}/dir
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post
84/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
85
86%preun
87if [ $1 = 0 ]; then
88    /sbin/install-info --quiet --info-dir=%{_infodir} \
89        --delete %{_infodir}/gnuplot.info.gz
90fi
91
92%files
93%defattr(-,root,root)
94%doc demo tutorial
95%doc README README.1ST INSTALL Copyright TODO
96%doc PATCHLEVEL VERSION BUGS ChangeLog
97%{_bindir}/gnuplot
98%{_libexecdir}/gnuplot/%{gpmainver}/*
99%{_datadir}/gnuplot/%{gpmainver}/*
100#{_datadir}/X11/app-defaults/Gnuplot
101%{_datadir}/texmf/tex/latex/gnuplot
102%{_datadir}/emacs/site-lisp/*
103%{_infodir}/gnuplot.info*
104%{_mandir}/man1/gnuplot.*
105
106%changelog
107* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
108- changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
109- added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
110
111* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
112- update to gnuplot-4.4.3
113- use BR: texlive instead of tetex
114
115* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
116- update to gnuplot-4.2.5
117- drop plus patch (merged in upstream)
118- update URL: to new upstream homepage
119- fix License:
120- build with wxGTK
121- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
122
123* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
124- applied new versioning policy, spec in utf-8
125
126* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
127- add BuildRequires: texinfo, emacsen
128
129* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
130- rebuild with readline-5.1
131
132* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
133- update Patch0 to fix 'Invalid char in eps file'
134  (thanks to HANAWA Toshihiro)
135- add BuildRequires: autoconf, automake
136
137* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
138- enabled history-file
139
140* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
141- source update
142
143* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
144- source update
145- patch update and modified
146- add info
147
148* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
149- rebuild
150- fix license
151- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
152
153* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
154- rebuild with readline-4.3
155
156* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
157- syncd with RH 3.7.3-2
158- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
159
160* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
161- added pathes (patch1,2) from RH
162
163* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
164- syncd rawhide
165- updated to 3.7.1-1.2.0
166
167* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
168- updated to 3.7.1
169- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
170- remake SPEC from rawhide.
171
172* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
173- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
174
175* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
176- build for 7.0
177
178* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
179- use gnu readline, not built-in version
180
181* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
182- add latex tutorial, demo files, other docs (#10508)
183
184* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
185- update to 3.7.1. Oops.
186
187* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
188- handle compressed man pages
189
190* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
191- update to 3.7.1
192
193* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
194- ship some docs.
195
196* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
197- add a patch to fix postscript output from Bernd Kischnick
198 (kisch@die-herrmanns.de)
199
200* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
201- fix license
202
203* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
204- rebuild without svgalib
205
206* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
207- update to 3.7.0.1
208
209* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
210- auto rebuild in the new build environment (release 2)
211
212* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
213- update to 3.7.
214
215* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
216- built package for 6.0
217
218* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
219- update to 2.6beta347
220
221* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
222- build root
223
224* Thu May 07 1998 Prospector System <bugs@redhat.com>
225- translations modified for de, fr, tr
226
227* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
228- spec file cleanups
229
230* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
231- built against glibc
Note: See TracBrowser for help on using the repository browser.