source: projects/specs/trunk/g/gnuplot/gnuplot-vl.spec @ 10821

Revision 10821, 10.9 KB checked in by ara_t, 7 years ago (diff)

-update to 5.0.5

Line 
1%global major 5
2%global minor 0
3%global patchlevel 5
4
5%global x11_app_defaults_dir %{_datadir}/X11/app-defaults
6
7Summary: A program for plotting mathematical expressions and data.
8Summary(ja):  数学系の関数やデータのプロット・プログラム
9Name: gnuplot
10Version: %{major}.%{minor}.%{patchlevel}
11Release: 1%{?_dist_release}
12
13# MIT .. term/PostScript/aglfn.txt
14License: gnuplot and MIT
15Group: Applications/Engineering
16URL: http://www.gnuplot.info/
17
18Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
19
20Patch0: gnuplot-4.2.0-refers_to.patch
21#Patch1: gnuplot-4.2.0-fonts.patch
22# resolves: #812225
23# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
24Patch3: gnuplot-4.6.1-plot-sigsegv.patch
25Patch4: gnuplot-4.6.4-singlethread.patch
26Patch5: gnuplot-5.0.0-lua_checkint.patch
27
28# Vine Patches (replaces Patch1)
29Patch70: gnuplot-5.0.0-fonts.patch
30
31BuildRoot: %{_tmppath}/%{name}-root
32#libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
33BuildRequires: cairo-devel
34BuildRequires: gd-devel >= 2.0.27
35BuildRequires: giflib-devel
36BuildRequires: libX11-devel
37BuildRequires: libXt-devel
38BuildRequires: libXpm-devel
39BuildRequires: libjpeg-turbo-devel
40BuildRequires: libpng-devel
41BuildRequires: lua-devel
42BuildRequires: m17n-lib
43BuildRequires: pango-devel
44BuildRequires: wxGTK-devel
45BuildRequires: zlib-devel
46
47BuildRequires: texlive
48BuildRequires: texlive-common
49BuildRequires: texlive-collection-latexextra
50BuildRequires: texlive-collection-htmlxml
51BuildRequires: texinfo
52BuildRequires: latex2html
53BuildRequires: emacs
54
55Requires: TrueType-dejavu
56Requires(post): install-info
57Requires(preun): install-info
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: daisuke, inagaki, shaolin
62
63%description
64Gnuplot is a command-line driven, interactive function plotting
65program especially suited for scientific data representation.  Gnuplot
66can be used to plot functions and data points in both two and three
67dimensions and in many different formats.
68
69Install gnuplot if you need a graphics package for scientific data
70representation.
71
72%description -l ja
73Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
74操作によるインタラクティブな関数プロット・プログラムです。
75Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
76まな形式で表現するのに利用することができます。
77
78科学データプレゼンテーション用のグラフィック・パッケージが必要な
79場合、gnuplotをインストールしてください。
80
81%package doc
82Summary: Documentation for the gnuplot main application
83Group: Applications/Documentation
84BuildArch: noarch
85Requires: %{name} = %{version}-%{release}
86
87%description doc
88The gnuplot-doc package contains the documentation related to gnuplot
89plotting tool
90
91%package latex
92Summary: Configuration for LaTeX typesetting using gnuplot
93Group: Applications/Engineering
94BuildArch: noarch
95Requires: %{name} = %{version}-%{release}
96Requires: texlive-collection-latexextra
97Requires: texlive-collection-fontsrecommended
98
99%description latex
100The gnuplot-latex package contains LaTeX configuration file related to gnuplot
101plotting tool.
102
103
104%prep
105%setup -q
106%patch0 -p1 -b .refto
107#patch1 -p1 -b .font
108%patch3 -p1 -b .plot-sigsegv
109%patch4 -p1 -b .isinglethread
110%patch5 -p1 -b .checkint
111sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
112iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
113mv ChangeLog.aux ChangeLog
114chmod 644 src/getcolor.h
115chmod 644 demo/html/webify.pl
116chmod 644 demo/html/webify_svg.pl
117chmod 644 demo/html/webify_canvas.pl
118
119%patch70 -p1 -b .font
120
121%build
122#remove binaries from source tarball
123rm -rf demo/plugin/*.so demo/plugin/*.o
124rm -rf docs_to_include
125mkdir -p docs_to_include
126cp -pr demo docs_to_include
127
128%configure --with-readline=builtin --without-linux-vga --enable-history-file --with-tutorial --without-qt
129
130make %{?_smp_mflags}
131
132make -C docs html info
133export GNUPLOT_PS_DIR=../../term/PostScript
134make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
135rm -rf docs/htmldocs/images.idx
136make -C tutorial
137
138%install
139rm -rf %{buildroot}
140make install DESTDIR=%{buildroot}
141make -C docs install-info DESTDIR=%{buildroot} INSTALL='install -p'
142
143#rm -f demo/Makefile* tutorial/Makefile*
144#packaged by info package, updated by post-installation script, do not package here
145rm -f $RPM_BUILD_ROOT%{_infodir}/dir
146
147mkdir -p $RPM_BUILD_ROOT%{x11_app_defaults_dir}
148mv $RPM_BUILD_ROOT%{_datadir}/gnuplot/%{major}.%{minor}/app-defaults/Gnuplot $RPM_BUILD_ROOT%{x11_app_defaults_dir}/Gnuplot
149rm -rf $RPM_BUILD_ROOT%{_libdir}/
150
151mkdir -p $RPM_BUILD_ROOT/%{_mandir}/ja/man1
152mv $RPM_BUILD_ROOT%{_mandir}/man1/gnuplot-ja.1 $RPM_BUILD_ROOT/%{_mandir}/ja/man1/gnuplot.1
153
154%clean
155rm -rf %{buildroot}
156
157
158%post
159if [ -f %{_infodir}/gnuplot.info* ]; then
160    /sbin/install-info %{_infodir}/gnuplot.info %{_infodir}/dir || :
161fi
162
163%preun
164if [ $1 = 0 ] ; then
165    if [ -f %{_infodir}/gnuplot.info* ]; then
166        /sbin/install-info --delete %{_infodir}/gnuplot.info %{_infodir}/dir || :
167    fi
168fi
169
170
171%files
172%defattr(-,root,root)
173%doc BUGS ChangeLog Copyright NEWS README
174%{_bindir}/gnuplot
175%dir %{_libexecdir}/gnuplot/%{major}.%{minor}
176%{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
177%dir %{_datadir}/gnuplot/%{major}.%{minor}
178%dir %{_datadir}/gnuplot/%{major}.%{minor}/PostScript
179%dir %{_datadir}/gnuplot/%{major}.%{minor}/js
180%dir %{_datadir}/gnuplot/%{major}.%{minor}/lua
181%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/*.ps
182%{_datadir}/gnuplot/%{major}.%{minor}/PostScript/aglfn.txt
183%{_datadir}/gnuplot/%{major}.%{minor}/js/*
184%{_datadir}/gnuplot/%{major}.%{minor}/lua/gnuplot-tikz.lua
185%{_datadir}/gnuplot/%{major}.%{minor}/colors_*
186%{_datadir}/gnuplot/%{major}.%{minor}/gnuplot.gih
187%{_datadir}/gnuplot/%{major}.%{minor}/gnuplotrc
188%{x11_app_defaults_dir}/Gnuplot
189%{_infodir}/gnuplot.info.gz
190%{_mandir}/man1/gnuplot.*
191%{_mandir}/ja/man1/gnuplot.*
192
193%files doc
194%defattr(-,root,root)
195%doc ChangeLog Copyright
196%doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.ps
197%doc tutorial/tutorial.dvi docs/psdoc/ps_file.doc
198%doc docs/psdoc/ps_fontfile_doc.pdf docs/htmldocs tutorial/eg7.eps
199%doc docs_to_include/demo
200
201%files latex
202%defattr(-,root,root)
203%doc ChangeLog Copyright
204%{_datadir}/texmf/tex/latex/gnuplot/
205
206%changelog
207* Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> - 5.0.5-1
208- new upstream release
209
210* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 5.0.1-2
211- rebuild with gcc-5.4.0
212
213* Mon Aug 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.0.1-1
214- new upstream release
215
216* Thu May  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.0.0-1
217- new upstream release
218- libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
219  https://bugzilla.redhat.com/show_bug.cgi?id=1039102
220- split documents and latex-related files into subpackages
221
222* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.6.6-1
223- update to 4.6.6
224
225* Thu Jan 16 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.4-1
226- new upstream release
227- add Patch0, Patch1 and Patch2 (font paths, upstream fixes)
228- modify spec to build/install docs correctly
229
230* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
231- changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
232- added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
233
234* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
235- update to gnuplot-4.4.3
236- use BR: texlive instead of tetex
237
238* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
239- update to gnuplot-4.2.5
240- drop plus patch (merged in upstream)
241- update URL: to new upstream homepage
242- fix License:
243- build with wxGTK
244- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
245
246* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
247- applied new versioning policy, spec in utf-8
248
249* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
250- add BuildRequires: texinfo, emacsen
251
252* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
253- rebuild with readline-5.1
254
255* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
256- update Patch0 to fix 'Invalid char in eps file'
257  (thanks to HANAWA Toshihiro)
258- add BuildRequires: autoconf, automake
259
260* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
261- enabled history-file
262
263* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
264- source update
265
266* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
267- source update
268- patch update and modified
269- add info
270
271* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
272- rebuild
273- fix license
274- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
275
276* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
277- rebuild with readline-4.3
278
279* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
280- syncd with RH 3.7.3-2
281- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
282
283* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
284- added pathes (patch1,2) from RH
285
286* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
287- syncd rawhide
288- updated to 3.7.1-1.2.0
289
290* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
291- updated to 3.7.1
292- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
293- remake SPEC from rawhide.
294
295* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
296- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
297
298* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
299- build for 7.0
300
301* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
302- use gnu readline, not built-in version
303
304* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
305- add latex tutorial, demo files, other docs (#10508)
306
307* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
308- update to 3.7.1. Oops.
309
310* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
311- handle compressed man pages
312
313* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
314- update to 3.7.1
315
316* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
317- ship some docs.
318
319* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
320- add a patch to fix postscript output from Bernd Kischnick
321 (kisch@die-herrmanns.de)
322
323* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
324- fix license
325
326* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
327- rebuild without svgalib
328
329* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
330- update to 3.7.0.1
331
332* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
333- auto rebuild in the new build environment (release 2)
334
335* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
336- update to 3.7.
337
338* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
339- built package for 6.0
340
341* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
342- update to 2.6beta347
343
344* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
345- build root
346
347* Thu May 07 1998 Prospector System <bugs@redhat.com>
348- translations modified for de, fr, tr
349
350* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
351- spec file cleanups
352
353* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
354- built against glibc
Note: See TracBrowser for help on using the repository browser.