source: projects/specs/trunk/g/gnupg/gnupg-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU utility for secure communication and data storage.
2Summary(ja): GNU 版の RFC2440 (OpenPGP) 公開鍵暗号プログラム
3Name: gnupg
4Version: 1.4.9
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2
9Source1: ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2.sig
10Source2: gnupg-1.4.5-ja.po
11Patch3: gnupg-1.4.6-dir.patch
12# Security
13# Patch100: gnupg-1.4.5-CVE-2006-6169.patch
14
15URL: http://www.gnupg.org/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Vendor: Project Vine
18Distribution: Vine Linux
19
20Provides: gpg, openpgp
21PreReq: install-info
22Requires: zlib
23BuildPreReq: zlib-devel
24BuildPreReq: autoconf
25
26
27%description
28GnuPG (GNU Privacy Guard) is a GNU utility for encrypting data and
29creating digital signatures. GnuPG has advanced key management
30capabilities and is compliant with the proposed OpenPGP Internet
31standard described in RFC2440. Since GnuPG does not use any patented
32algorithm, it is not compatible with any version of PGP2 (PGP2.x uses
33only IDEA for symmetric-key encryption, which is patented worldwide).
34
35%description -l ja
36GnuPG (GNU プライバシーガード) は、データを暗号化したりデジタル署名を
37作成したりする GNU ユーティリティです。GnuPG は優れた鍵管理機能を有し、
38RFC2440 に規定された OpenPGP 規格に準拠しています。GnuPG は特許化された
39アルゴリズムを一切用いていないので、何の制限もなく使用することが出来ま
40すが、全てのバージョンの PGP2 とは互換性がありません。(PGP2.x は世界
41中で特許化されている IDEA を対称暗合鍵のために用います。)
42
43%prep
44%setup -q
45
46%patch3 -p1 -b .dir
47# %patch100 -p0 -b .CVE-2006-6169
48
49mv po/ja.po po/ja.po.orig
50cp -f %{SOURCE2} po/ja.po
51autoreconf
52
53%build
54%configure --enable-shared --disable-ldap --disable-mailto \
55        --without-libcurl \
56        --program-transform-name='' --program-prefix='' --program-suffix='' \
57        --libexecdir=%{_libdir}
58make
59(cd po; make ja.gmo)
60make check
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall libexecdir=%{buildroot}%{_libdir}
65# install -m644 doc/gpg.info doc/gpgv.info $RPM_BUILD_ROOT/%{_infodir}
66install -m644 doc/gnupg1.info $RPM_BUILD_ROOT/%{_infodir}
67sed 's^\.\./g[0-9\.]*/^^g' tools/lspgpot > lspgpot
68install -m755 lspgpot $RPM_BUILD_ROOT%{_bindir}/lspgpot
69rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
70%find_lang %name
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%post
77if test -s %{_infodir}/gnupg1.info.gz ; then
78    /sbin/install-info %{_infodir}/gnupg1.info.gz %{_infodir}/dir 2> /dev/null
79fi
80if ! test -s %{_infodir}/gpg.info.gz ; then
81    /sbin/install-info --delete %{_infodir}/gpg.info.gz %{_infodir}/dir 2> /dev/null
82fi
83if ! test -s %{_infodir}/gpgv.info.gz ; then
84    /sbin/install-info --delete %{_infodir}/gpgv.info.gz %{_infodir}/dir 2> /dev/null
85fi
86exit 0
87
88%preun
89if [ $1 = 0 ]; then
90    /sbin/install-info --delete %{_infodir}/gpgv.info.gz %{_infodir}/dir
91    /sbin/install-info --delete %{_infodir}/gpg.info.gz %{_infodir}/dir
92fi
93
94
95%files -f %{name}.lang
96%defattr(-,root,root)
97%doc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO
98%doc doc/DETAILS doc/HACKING doc/OpenPGP doc/samplekeys.asc
99%{_bindir}/*
100%dir %{_datadir}/%{name}
101%{_datadir}/%{name}/FAQ
102%{_datadir}/%{name}/faq.html
103%{_datadir}/%{name}/options.skel
104%{_libdir}/%{name}
105%{_infodir}/*
106%{_mandir}/man1/*
107%{_mandir}/man7/*
108
109
110%changelog
111* Tue Jul 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-1
112- new upstream release
113
114* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-1vl5
115- applied new versioning policy, spec in utf-8
116
117* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.6-0vl4
118- add --without-libcurl option for configure,
119  instead of "rebuilding without curl" as shown below
120
121* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.6-0vl3
122- rebuild without curl
123
124* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-0vl2
125- rebuilt for VineSeed
126
127* Sat Dec 09 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.6-0vl1
128- new upstream release incorporating fixes for CVE-2006-6169, 6235
129- drop Patch100 (included in new upstream)
130- add patch3 from redhat
131
132* Sat Dec 02 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.5-0vl1.1
133- add patch100 for fix CVE-2006-6169
134
135* Mon Sep  4 2006 IWAI, Masaharu <iwai@alib.jp> 1.4.5-0vl1
136- new upstream release
137- update ja.po ( but, it has many fuzzy )
138
139* Sun May  7 2006 IWAI, Masaharu <iwai@alib.jp> 1.4.3-0vl1
140- drop CVE-2006-0455 ( Patch10 ) and CVE-2006-0049 ( Patch11 ) patches
141    - upstream fixed
142- update ja.po ( but, it has many fuzzy )
143- drop unnecessary libexec patch ( Patch0 )
144
145* Sun Apr  9 2006 IWAI, Masaharu <iwai@alib.jp> 1.2.6-0vl5
146- build for VineSeed
147
148* Sun Mar 19 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.6-0vl4
149- added a security patch for CVE-2006-0049.
150
151* Mon Feb 20 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.6-0vl3
152- added a security patch for CVE-2006-0455.
153
154* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl2
155- update ja.po
156
157* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
158- new upstream release
159
160* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
161- rebuilt
162
163* Mon Dec 29 2003 IWAI, Masaharu <iwai@alib.jp> 1.2.4-0vl1
164- new upstream release
165
166* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
167- new upstream release
168
169* Tue May  6 2003 IWAI Masaharu <iwai@alib.jp> 1.2.2-0vl1
170- upstream releace
171- update libexec.patch (Patch0)
172- drop trustfix.patch (Patch10)
173
174* Tue May  6 2003 IWAI Masaharu <iwai@alib.jp> 1.2.1-3vl3
175- SECURITY FIX - Key validity bug
176    - http://lists.gnupg.org/pipermail/gnupg-announce/2003q2/000268.html
177    - add trustfix.patch (Patch10) from Vine-2.6 updates 1.0.7-6vl2.1
178
179* Fri Mar  7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3vl2
180- update ja.po
181
182* Fri Mar  7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3vl1
183- new upstream release
184- merged with rawhide version 1.2.1-3
185  * Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.2.1-3
186  - modify g10defs to look for helpers in libexecdir, because that's where they
187    get installed, per gnupg-users
188  - actually drop updates for 1.0.7 which are no longer needed for 1.2.1
189  * Mon Oct 28 2002 Nalin Dahyabhai <nalin@redhat.com> 1.2.1-1
190  - update to 1.2.1
191  * Tue Sep 24 2002 Nalin Dahyabhai <nalin@redhat.com> 1.2.0-1
192  - update to 1.2.0
193  - stop stripping files manually, let the buildroot policies handle it
194  - add translations updates ca and fr
195
196* Tue Oct  1 2002 IWAI Masaharu <iwai@alib.jp> 1.0.7-6vl2
197- added --disable-{ldap,mailto} options for configure script
198- added zlib in Requires tag
199- added zlib-devel in BuildRequires tag
200
201* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 1.0.7-6vl1
202- sync with Rawhide gnupg-1.0.7-6
203    - added --program-{transform-name,prefix,suffix} options for configure script
204    - added Source1(signature for the GnuPG 1.0.7 tarball)
205    - added BUGS and doc/samplekeys.asc in %%doc
206    - eliminated g*/OPTIONS and g*/pubring.asc in %%doc
207    - stopped patching Patch0(codeset.patch)
208    -
209- droped Source3(ja.po)
210- added Patch1 (gnupg-1.0.7-ja.po.patch)
211
212* Fri Jan 25 2002 Toru Sagami <sagami@vinelinux.org> 1.0.6-3vl1
213- sync with 1.0.6-3
214  * set message output encoding to match the message encoding, based on a
215    patch by goeran@uddeborg.pp.se (#49182)
216- fixed ja.po
217
218* Thu Jun 07 2001 <sagami@vinelinux.org>
219- update to 1.0.6: follow up with RHSA's 1.0.5 package
220- changed Group/Description
221- stop replacing/overriding man page (new one is out there)
222
223* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl2
224- fixed typo in spec file.
225
226* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl1
227- update to 1.0.5
228- update ja.po.
229
230* Mon Oct 23 2000 KAJIKI Yoshihiro <kajiki@ylug.org>
231- update to 1.0.4 for a security reason
232- add Japanese summary and description
233
234* Thu Aug 17 2000 KAJIKI Yoshihiro <kajiki@ylug.org>
235- rebuild for Vine-2.0/VineSeed
236
237* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
238- update to 1.0.2
239
240* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
241- rebuild to cope with glibc locale binary incompatibility
242
243* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
244- automatic rebuild
245
246* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
247- include lspgpot (#13772)
248
249* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
250- rebuild in new build environment
251
252* Fri Feb 18 2000 Bill Nottingham <notting@redhat.com>
253- build of 1.0.1
254
255* Fri Sep 10 1999 Cristian Gafton <gafton@redhat.com>
256- version 1.0.0 build for 6.1us
Note: See TracBrowser for help on using the repository browser.