source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 9791

Revision 9791, 14.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.24
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.24
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21Packager: Takemikaduchi
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77desktop-file-install --vendor gnome --delete-original                   \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
79  --add-category Office                                                 \
80  --add-category Application                                            \
81  --add-category Spreadsheet                                            \
82  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
83  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
84
85%find_lang %{name}-%{version}
86%find_lang %{name}-%{version}-functions
87cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
90
91rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
92rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
93rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
94
95%clean
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98%post
99/sbin/ldconfig
100scrollkeeper-update > /dev/null 2>&1 || :
101touch --no-create %{_datadir}/icons/hicolor || :
102if [ -x %{_bindir}/gtk-update-icon-cache ]; then
103   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
104fi
105update-desktop-database -q &> /dev/null || :
106
107%postun
108/sbin/ldconfig
109scrollkeeper-update > /dev/null 2>&1 || :
110touch --no-create %{_datadir}/icons/hicolor || :
111if [ -x %{_bindir}/gtk-update-icon-cache ]; then
112   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
113fi
114update-desktop-database -q &> /dev/null || :
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117%posttrans
118glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119
120
121%files -f %{name}-%{version}.lang
122%defattr (-, root, root)
123%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
124%{_bindir}/*
125%{_libdir}/libspreadsheet*.so
126%{_libdir}/%{name}
127%{_libdir}/goffice/0.10/plugins/%{name}
128%{_datadir}/appdata/gnumeric.appdata.xml
129%{_datadir}/applications/*.desktop
130%{_datadir}/glib-2.0/schemas/*.xml
131%{_datadir}/gnome/help/%{name}
132%{_datadir}/%{name}
133%{_datadir}/pixmaps/*
134%{_datadir}/omf/*
135%{_datadir}/icons/hicolor/*
136%{_mandir}/man*/*
137%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
138
139
140%changelog
141* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.24-1
142- new upstream release
143
144* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.23-1
145- new upstream release
146
147* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.22-1
148- new upstream release
149
150* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.21-1
151- new upstream release
152
153* Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.20-1
154- new upstream release
155
156* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.19-1
157- new upstream release
158
159* Wed Oct 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
160- new upstream release
161
162* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.17-1
163- new upstream release
164
165* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
166- new upstream release
167
168* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.15-1
169- new upstream release
170
171* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
172- new upstream release
173
174* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
175- new upstream release
176
177* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
178- new upstream release
179
180* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
181- new upstream release
182
183* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
184- new upstream release
185
186* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
187- new upstream release
188
189* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
190- new upstream release
191
192* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
193- new upstream release
194
195* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
196- new upstream release
197
198* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
199- new upstream release
200
201* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
202- new upstream release
203- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
204- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
205
206* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
207- rebuild with libgsf-1.14.22
208- add Patch1 (gnumeric-1.10.17-libgsf.patch)
209
210* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
211- new upstream release
212- update Patch0
213
214* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
215- new upstream release
216
217* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
218- new upstream release
219- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
220
221* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
222- new upstream release
223
224* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
225- new upstream release
226
227* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
228- new upstream release
229
230* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
231- new upstream release
232- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
233   (fix error of MIME type)
234
235* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
236- new upstream release
237
238* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
239- new upstream release
240
241* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
242- new upstream release
243- fix %post and %postun
244
245* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
246- new upstream release
247
248* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
249- new upstream release
250- add BuildRequires: libSM-devel
251- fix BuildRequires: goffice-devel >= 0.8.1
252
253* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
254- spec in UTF-8 (fixed)
255
256* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
257- spec in UTF-8
258- added BuildRequires: libffi-devel
259- added %%pre, %%preun section
260
261* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
262- new upstream release
263- built with libgda-3.1.4, libgnomedb-3.1.2
264- applied new versioning policy
265
266* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
267- new upstream release
268
269* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
270- rebuild
271
272* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
273- new upstream release
274
275* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
276- new upstream release
277- updated build dependancies
278- rebuilt with libgsf-1.14.0
279- built with libgda and libgnomedb again
280
281* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
282- new upstream release
283- updated build dependancies
284- not compile with libgda and libgnomedb in this version
285
286* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
287- new upstream release
288
289* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
290- rebuild with libgda 1.2.0 and libgnome 1.2.0
291
292* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
293- new upstream release
294
295* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
296- new upstream release
297
298* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
299- new upstream release
300
301* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
302- rebuild with gnome-2.8 environment and libgsf-1.10.1
303
304* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
305- new upstream release
306- added BuildRequires: desktop-file-utils
307
308* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
309- new upstream release
310- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
311
312* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
313- new upstream release
314
315* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
316- new upstream release
317
318* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
319- new upstream release
320
321* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
322- new upstream release
323
324* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
325- new upstream release
326- clean up spec file (a little bit!)
327
328* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
329- new upstream release
330
331* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
332- new upstream release
333- to use intltool-0.28
334
335* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
336- new upstream release
337- rebuild with new toolchains
338
339* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
340- new upstream release
341- build with new libgnomeprint, libgnomeprintui
342
343* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
344- new upstream release
345
346* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
347- rebuild with newer libgda, libgnomedb
348
349* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
350- updated to 1.2.0 (stable release)
351- guile support is temporarily off this version.
352
353* Tue Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
354- update to 1.1.20 (gtk+-2 port)
355- based on Redhat Rawhide 1.1.20-1
356
357* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
358- update to 1.0.13
359- rebuild with gal 0.24
360
361* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
362- guile support on
363- rebuild with new gal, bonobo, libgda
364
365* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
366- New upstream release, remove xmliobackward.patch
367
368* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
369- xml-io back to 1.0.10 because japanese corrups with new xml_parser
370
371* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
372- New upstream release, fix for xml importing files with non ASCII characters.
373- Without guile, changelog.archive, requires, build scripts, description
374
375* Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
376- files: add gnumericConf.sh, which was missing
377
378* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
379- New upstream release.
380- BuildPrereq oaf-devel
381
382* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
383- New upstream release.
384
385* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
386- New upstream release.
387- Default font and Japanese fonts in excel
388- requires
389
390* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
391- New upstream release.
392- fixed plugins, apply patch2, remove patch3
393- files - no longer devel package
394- function-reference.html in help file
395
396* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
397- New upstream release.
398
399* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
400- New upstream release.
401- Fixed several owner dir.
402
403* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
404- Build against with new gal
405
406* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
407- New upstream release.
408
409* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
410- New upstream release.
411
412* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
413- New upstream release.
414- Applied XIM over-the-spot patch.
415- Fixed directories owner.
416
417* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
418- New upstream release.
419- Enable Bonobo.
420- Merged several RH patches.
421- Added BuildPreReq tags.
422
423* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
424- Fixed packaging mistake.
425
426* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
427- Rebuild for GAL 0.7
428
429* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
430- New upstream release.
431- Use rpmmacros.
432
433* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
434- 0.56-0vl2
435- update ja.po
436- avoid core dump when inserting a row
437
438* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
439- updated to 0.56
440- remake spec with the orginal gnumeric spec file.
441- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
442
443* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
444- updated to 0.53
445- remake SPEC based on gnumeric original.
446- added libxml183 patch for libxml 1.8.3
447
448* Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
449- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
450- Added --without-bonobo and --without-gb.
451- Added %define for sysconfdir
452
453* Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
454- Updated version requirements for gnome-print, and gnome-libs.
455
456* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
457- Added in some auto-detect the language files logic (rpm 3.0.xx only)
458
459* Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
460- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
461
462* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
463- Updated to 0.47
464
465* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
466- Updated the libglade dependancy.
467- Remove req for guile.  We can build without it.
468
469* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
470- Added small fix so glade generated dialogs appear.
471
472* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
473- Added the gnome-print requirement.
474- Updated the file list to try and quiet down the updating.
475- added the sysconfdir
476
477* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
478- Updated the spec file.
479
480* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
481- Version 0.2
482
Note: See TracBrowser for help on using the repository browser.