source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 9520

Revision 9520, 14.7 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.16.1

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.22
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.22
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21Packager: Takemikaduchi
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77desktop-file-install --vendor gnome --delete-original                   \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
79  --add-category Office                                                 \
80  --add-category Application                                            \
81  --add-category Spreadsheet                                            \
82  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
83  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
84
85%find_lang %{name}-%{version}
86%find_lang %{name}-%{version}-functions
87cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
90
91rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
92rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
93rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
94
95%clean
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98%post
99/sbin/ldconfig
100scrollkeeper-update > /dev/null 2>&1 || :
101touch --no-create %{_datadir}/icons/hicolor || :
102if [ -x %{_bindir}/gtk-update-icon-cache ]; then
103   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
104fi
105update-desktop-database -q &> /dev/null || :
106
107%postun
108/sbin/ldconfig
109scrollkeeper-update > /dev/null 2>&1 || :
110touch --no-create %{_datadir}/icons/hicolor || :
111if [ -x %{_bindir}/gtk-update-icon-cache ]; then
112   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
113fi
114update-desktop-database -q &> /dev/null || :
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117%posttrans
118glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119
120
121%files -f %{name}-%{version}.lang
122%defattr (-, root, root)
123%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
124%{_bindir}/*
125%{_libdir}/libspreadsheet*.so
126%{_libdir}/%{name}
127%{_libdir}/goffice/0.10/plugins/%{name}
128%{_datadir}/appdata/gnumeric.appdata.xml
129%{_datadir}/applications/*.desktop
130%{_datadir}/glib-2.0/schemas/*.xml
131%{_datadir}/gnome/help/%{name}
132%{_datadir}/%{name}
133%{_datadir}/pixmaps/*
134%{_datadir}/omf/*
135%{_datadir}/icons/hicolor/*
136%{_mandir}/man*/*
137%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
138
139
140%changelog
141* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.22-1
142- new upstream release
143
144* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.21-1
145- new upstream release
146
147* Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.20-1
148- new upstream release
149
150* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.19-1
151- new upstream release
152
153* Wed Oct 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
154- new upstream release
155
156* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.17-1
157- new upstream release
158
159* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
160- new upstream release
161
162* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.15-1
163- new upstream release
164
165* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
166- new upstream release
167
168* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
169- new upstream release
170
171* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
172- new upstream release
173
174* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
175- new upstream release
176
177* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
178- new upstream release
179
180* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
181- new upstream release
182
183* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
184- new upstream release
185
186* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
187- new upstream release
188
189* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
190- new upstream release
191
192* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
193- new upstream release
194
195* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
196- new upstream release
197- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
198- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
199
200* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
201- rebuild with libgsf-1.14.22
202- add Patch1 (gnumeric-1.10.17-libgsf.patch)
203
204* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
205- new upstream release
206- update Patch0
207
208* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
209- new upstream release
210
211* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
212- new upstream release
213- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
214
215* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
216- new upstream release
217
218* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
219- new upstream release
220
221* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
222- new upstream release
223
224* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
225- new upstream release
226- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
227   (fix error of MIME type)
228
229* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
230- new upstream release
231
232* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
233- new upstream release
234
235* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
236- new upstream release
237- fix %post and %postun
238
239* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
240- new upstream release
241
242* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
243- new upstream release
244- add BuildRequires: libSM-devel
245- fix BuildRequires: goffice-devel >= 0.8.1
246
247* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
248- spec in UTF-8 (fixed)
249
250* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
251- spec in UTF-8
252- added BuildRequires: libffi-devel
253- added %%pre, %%preun section
254
255* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
256- new upstream release
257- built with libgda-3.1.4, libgnomedb-3.1.2
258- applied new versioning policy
259
260* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
261- new upstream release
262
263* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
264- rebuild
265
266* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
267- new upstream release
268
269* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
270- new upstream release
271- updated build dependancies
272- rebuilt with libgsf-1.14.0
273- built with libgda and libgnomedb again
274
275* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
276- new upstream release
277- updated build dependancies
278- not compile with libgda and libgnomedb in this version
279
280* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
281- new upstream release
282
283* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
284- rebuild with libgda 1.2.0 and libgnome 1.2.0
285
286* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
287- new upstream release
288
289* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
290- new upstream release
291
292* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
293- new upstream release
294
295* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
296- rebuild with gnome-2.8 environment and libgsf-1.10.1
297
298* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
299- new upstream release
300- added BuildRequires: desktop-file-utils
301
302* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
303- new upstream release
304- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
305
306* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
307- new upstream release
308
309* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
310- new upstream release
311
312* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
313- new upstream release
314
315* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
316- new upstream release
317
318* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
319- new upstream release
320- clean up spec file (a little bit!)
321
322* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
323- new upstream release
324
325* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
326- new upstream release
327- to use intltool-0.28
328
329* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
330- new upstream release
331- rebuild with new toolchains
332
333* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
334- new upstream release
335- build with new libgnomeprint, libgnomeprintui
336
337* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
338- new upstream release
339
340* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
341- rebuild with newer libgda, libgnomedb
342
343* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
344- updated to 1.2.0 (stable release)
345- guile support is temporarily off this version.
346
347* Tue Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
348- update to 1.1.20 (gtk+-2 port)
349- based on Redhat Rawhide 1.1.20-1
350
351* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
352- update to 1.0.13
353- rebuild with gal 0.24
354
355* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
356- guile support on
357- rebuild with new gal, bonobo, libgda
358
359* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
360- New upstream release, remove xmliobackward.patch
361
362* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
363- xml-io back to 1.0.10 because japanese corrups with new xml_parser
364
365* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
366- New upstream release, fix for xml importing files with non ASCII characters.
367- Without guile, changelog.archive, requires, build scripts, description
368
369* Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
370- files: add gnumericConf.sh, which was missing
371
372* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
373- New upstream release.
374- BuildPrereq oaf-devel
375
376* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
377- New upstream release.
378
379* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
380- New upstream release.
381- Default font and Japanese fonts in excel
382- requires
383
384* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
385- New upstream release.
386- fixed plugins, apply patch2, remove patch3
387- files - no longer devel package
388- function-reference.html in help file
389
390* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
391- New upstream release.
392
393* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
394- New upstream release.
395- Fixed several owner dir.
396
397* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
398- Build against with new gal
399
400* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
401- New upstream release.
402
403* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
404- New upstream release.
405
406* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
407- New upstream release.
408- Applied XIM over-the-spot patch.
409- Fixed directories owner.
410
411* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
412- New upstream release.
413- Enable Bonobo.
414- Merged several RH patches.
415- Added BuildPreReq tags.
416
417* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
418- Fixed packaging mistake.
419
420* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
421- Rebuild for GAL 0.7
422
423* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
424- New upstream release.
425- Use rpmmacros.
426
427* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
428- 0.56-0vl2
429- update ja.po
430- avoid core dump when inserting a row
431
432* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
433- updated to 0.56
434- remake spec with the orginal gnumeric spec file.
435- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
436
437* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
438- updated to 0.53
439- remake SPEC based on gnumeric original.
440- added libxml183 patch for libxml 1.8.3
441
442* Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
443- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
444- Added --without-bonobo and --without-gb.
445- Added %define for sysconfdir
446
447* Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
448- Updated version requirements for gnome-print, and gnome-libs.
449
450* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
451- Added in some auto-detect the language files logic (rpm 3.0.xx only)
452
453* Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
454- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
455
456* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
457- Updated to 0.47
458
459* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
460- Updated the libglade dependancy.
461- Remove req for guile.  We can build without it.
462
463* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
464- Added small fix so glade generated dialogs appear.
465
466* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
467- Added the gnome-print requirement.
468- Updated the file list to try and quiet down the updating.
469- added the sysconfdir
470
471* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
472- Updated the spec file.
473
474* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
475- Version 0.2
476
Note: See TracBrowser for help on using the repository browser.