source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 9073

Revision 9073, 14.4 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.14.1

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.18
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.18
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77desktop-file-install --vendor gnome --delete-original                   \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
79  --add-category Office                                                 \
80  --add-category Application                                            \
81  --add-category Spreadsheet                                            \
82  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
83  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
84
85%find_lang %{name}-%{version}
86%find_lang %{name}-%{version}-functions
87cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
88
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
90
91rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
92rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
93rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
94
95%clean
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98%post
99/sbin/ldconfig
100scrollkeeper-update > /dev/null 2>&1 || :
101touch --no-create %{_datadir}/icons/hicolor || :
102if [ -x %{_bindir}/gtk-update-icon-cache ]; then
103   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
104fi
105update-desktop-database -q &> /dev/null || :
106
107%postun
108/sbin/ldconfig
109scrollkeeper-update > /dev/null 2>&1 || :
110touch --no-create %{_datadir}/icons/hicolor || :
111if [ -x %{_bindir}/gtk-update-icon-cache ]; then
112   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
113fi
114update-desktop-database -q &> /dev/null || :
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117%posttrans
118glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119
120
121%files -f %{name}-%{version}.lang
122%defattr (-, root, root)
123%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
124%{_bindir}/*
125%{_libdir}/libspreadsheet*.so
126%{_libdir}/%{name}
127%{_libdir}/goffice/0.10/plugins/%{name}
128%{_datadir}/appdata/gnumeric.appdata.xml
129%{_datadir}/applications/*.desktop
130%{_datadir}/glib-2.0/schemas/*.xml
131%{_datadir}/gnome/help/%{name}
132%{_datadir}/%{name}
133%{_datadir}/pixmaps/*
134%{_datadir}/omf/*
135%{_datadir}/icons/hicolor/*
136%{_mandir}/man*/*
137%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
138
139
140%changelog
141* Wed Oct 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
142- new upstream release
143
144* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.17-1
145- new upstream release
146
147* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
148- new upstream release
149
150* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.15-1
151- new upstream release
152
153* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
154- new upstream release
155
156* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.9-1
157- new upstream release
158
159* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
160- new upstream release
161
162* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.7-1
163- new upstream release
164
165* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
166- new upstream release
167
168* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.5-1
169- new upstream release
170
171* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
172- new upstream release
173
174* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
175- new upstream release
176
177* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
178- new upstream release
179
180* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
181- new upstream release
182
183* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
184- new upstream release
185- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
186- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
187
188* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
189- rebuild with libgsf-1.14.22
190- add Patch1 (gnumeric-1.10.17-libgsf.patch)
191
192* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
193- new upstream release
194- update Patch0
195
196* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
197- new upstream release
198
199* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
200- new upstream release
201- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
202
203* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
204- new upstream release
205
206* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
207- new upstream release
208
209* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
210- new upstream release
211
212* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
213- new upstream release
214- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
215   (fix error of MIME type)
216
217* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
218- new upstream release
219
220* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
221- new upstream release
222
223* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
224- new upstream release
225- fix %post and %postun
226
227* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
228- new upstream release
229
230* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
231- new upstream release
232- add BuildRequires: libSM-devel
233- fix BuildRequires: goffice-devel >= 0.8.1
234
235* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
236- spec in UTF-8 (fixed)
237
238* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
239- spec in UTF-8
240- added BuildRequires: libffi-devel
241- added %%pre, %%preun section
242
243* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
244- new upstream release
245- built with libgda-3.1.4, libgnomedb-3.1.2
246- applied new versioning policy
247
248* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
249- new upstream release
250
251* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
252- rebuild
253
254* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
255- new upstream release
256
257* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
258- new upstream release
259- updated build dependancies
260- rebuilt with libgsf-1.14.0
261- built with libgda and libgnomedb again
262
263* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
264- new upstream release
265- updated build dependancies
266- not compile with libgda and libgnomedb in this version
267
268* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
269- new upstream release
270
271* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
272- rebuild with libgda 1.2.0 and libgnome 1.2.0
273
274* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
275- new upstream release
276
277* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
278- new upstream release
279
280* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
281- new upstream release
282
283* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
284- rebuild with gnome-2.8 environment and libgsf-1.10.1
285
286* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
287- new upstream release
288- added BuildRequires: desktop-file-utils
289
290* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
291- new upstream release
292- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
293
294* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
295- new upstream release
296
297* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
298- new upstream release
299
300* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
301- new upstream release
302
303* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
304- new upstream release
305
306* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
307- new upstream release
308- clean up spec file (a little bit!)
309
310* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
311- new upstream release
312
313* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
314- new upstream release
315- to use intltool-0.28
316
317* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
318- new upstream release
319- rebuild with new toolchains
320
321* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
322- new upstream release
323- build with new libgnomeprint, libgnomeprintui
324
325* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
326- new upstream release
327
328* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
329- rebuild with newer libgda, libgnomedb
330
331* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
332- updated to 1.2.0 (stable release)
333- guile support is temporarily off this version.
334
335* Tue Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
336- update to 1.1.20 (gtk+-2 port)
337- based on Redhat Rawhide 1.1.20-1
338
339* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
340- update to 1.0.13
341- rebuild with gal 0.24
342
343* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
344- guile support on
345- rebuild with new gal, bonobo, libgda
346
347* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
348- New upstream release, remove xmliobackward.patch
349
350* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
351- xml-io back to 1.0.10 because japanese corrups with new xml_parser
352
353* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
354- New upstream release, fix for xml importing files with non ASCII characters.
355- Without guile, changelog.archive, requires, build scripts, description
356
357* Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
358- files: add gnumericConf.sh, which was missing
359
360* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
361- New upstream release.
362- BuildPrereq oaf-devel
363
364* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
365- New upstream release.
366
367* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
368- New upstream release.
369- Default font and Japanese fonts in excel
370- requires
371
372* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
373- New upstream release.
374- fixed plugins, apply patch2, remove patch3
375- files - no longer devel package
376- function-reference.html in help file
377
378* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
379- New upstream release.
380
381* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
382- New upstream release.
383- Fixed several owner dir.
384
385* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
386- Build against with new gal
387
388* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
389- New upstream release.
390
391* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
392- New upstream release.
393
394* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
395- New upstream release.
396- Applied XIM over-the-spot patch.
397- Fixed directories owner.
398
399* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
400- New upstream release.
401- Enable Bonobo.
402- Merged several RH patches.
403- Added BuildPreReq tags.
404
405* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
406- Fixed packaging mistake.
407
408* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
409- Rebuild for GAL 0.7
410
411* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
412- New upstream release.
413- Use rpmmacros.
414
415* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
416- 0.56-0vl2
417- update ja.po
418- avoid core dump when inserting a row
419
420* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
421- updated to 0.56
422- remake spec with the orginal gnumeric spec file.
423- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
424
425* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
426- updated to 0.53
427- remake SPEC based on gnumeric original.
428- added libxml183 patch for libxml 1.8.3
429
430* Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
431- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
432- Added --without-bonobo and --without-gb.
433- Added %define for sysconfdir
434
435* Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
436- Updated version requirements for gnome-print, and gnome-libs.
437
438* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
439- Added in some auto-detect the language files logic (rpm 3.0.xx only)
440
441* Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
442- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
443
444* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
445- Updated to 0.47
446
447* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
448- Updated the libglade dependancy.
449- Remove req for guile.  We can build without it.
450
451* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
452- Added small fix so glade generated dialogs appear.
453
454* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
455- Added the gnome-print requirement.
456- Updated the file list to try and quiet down the updating.
457- added the sysconfdir
458
459* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
460- Updated the spec file.
461
462* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
463- Version 0.2
464
Note: See TracBrowser for help on using the repository browser.