source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 623

Revision 623, 13.4 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.1
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.1
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Distribution: Vine Linux
17Vendor: Project Vine
18
19BuildRequires: gtk2-devel >= 2.10.0
20BuildRequires: libglade2-devel >= 2.3.6
21BuildRequires: libgnomeprint-devel >= 2.8.2
22BuildRequires: libgnomeprintui-devel >= 2.8.2
23BuildRequires: libart_lgpl-devel >= 2.3.11
24BuildRequires: libxml2-devel >= 2.4.12
25BuildRequires: libgsf-devel >= 1.13.2
26BuildRequires: goffice-devel >= %{goffice_version}
27BuildRequires: libbonobo-devel libgnomeui-devel
28BuildRequires: libffi-devel
29#BuildPreReq: libgda-devel >= 1.9.100
30#BuildPreReq: libgnomedb-devel >= 1.9.100
31BuildRequires: perl python-devel
32BuildRequires: automake autoconf libtool docbook-utils
33BuildRequires: intltool >= 0.28 desktop-file-utils
34BuildRequires: libSM-devel
35Requires:    gtk2 >= 2.10.0
36Requires:    libglade2 >= 2.3.6
37Requires:    libgnomeprint >= 2.8.2
38Requires:    libgnomeprintui >= 2.8.2
39Requires:    libgsf >= 1.14.6
40Requires:    perl python
41Requires:    GConf2 scrollkeeper
42
43# no longer devel package
44#Provides:   %{name}-devel
45Obsoletes:  %{name}-devel
46
47%description
48GNOME (GNU Network Object Model Environment) is a user-friendly set of
49applications and desktop tools to be used in conjunction with a window
50manager for the X Window System.
51
52This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
53replacement for commercial spreadsheets.  It provides import/export from
54MS Excel files and many other formats (csv, latex, xbase, applix).
55
56%description -l ja
57GNOME (GNU Network Object Model Environment)は
58Xウィンドウシステム用の、ウィンドウマネージャと連結した
59GUIアプリケーションおよびデスクトップツールのセットです。
60
61これは Gnumeric, GNOMEスプレッドシート・プログラムです。
62商用のスプレッドシート・プログラムを代替できるものを目指しています。
63MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
64を読込み、出力できます.
65
66
67# %package devel
68#Summary:       Files necessary to develop gnumeric-based applications.
69#Group:         Development/Libraries
70#Requires:      %{name} = %{PACKAGE_VERSION}
71
72#%#description devel
73#The gnumeric-devel package includes files necessary to develop gnumeric-based
74#applications.
75
76#Install gnumeric-devel if you want to develop programs which will use gnumeric.
77
78%prep
79%setup -q
80
81# fix desktop file Icon path
82sed -i -e "s/Icon=/Icon=\/usr\/share\/pixmaps\//" \
83    gnumeric.desktop.in
84
85%build
86%ifarch alpha
87        MYARCH_FLAGS="--host=alpha-redhat-linux"
88%endif
89export mllibname=%{_lib}
90%configure --with-gnome \
91    --with-gda --without-gb --with-perl --with-python \
92    --disable-schemas-install
93make
94
95%install
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
99make DESTDIR=$RPM_BUILD_ROOT install
100unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
101
102./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
103desktop-file-install --vendor gnome --delete-original                   \
104  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
105  --add-category X-Red-Hat-Extra                                        \
106  --add-category Office                                                 \
107  --add-category Application                                            \
108  --add-category Spreadsheet                                            \
109  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
110
111%find_lang %{name}
112%find_lang %{name}-functions
113cat %{name}-functions.lang >> %{name}.lang
114
115rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
116rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
117rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
118rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
119rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
120
121%clean
122[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
123
124%post
125/sbin/ldconfig
126
127scrollkeeper-update > /dev/null 2>&1 || :
128export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
129gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
130
131%pre
132if [ "$1" -gt 1 ]; then
133    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
134    gconftool-2 --makefile-uninstall-rule \
135        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
136fi
137
138%preun
139if [ "$1" -eq 0 ]; then
140    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
141    gconftool-2 --makefile-uninstall-rule \
142        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
143fi
144
145%postun
146/sbin/ldconfig
147scrollkeeper-update > /dev/null 2>&1 || :
148
149%files -f %{name}.lang
150%defattr (-, root, root)
151%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
152%config %{_sysconfdir}/gconf/schemas/*
153%{_bindir}/*
154%{_libdir}/lib*.so*
155%{_libdir}/gnumeric
156%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
157#{_libdir}/bonobo/servers/*
158%{_datadir}/applications/*.desktop
159%{_datadir}/gnome/help/gnumeric
160%{_datadir}/gnumeric
161%{_datadir}/pixmaps/*
162#{_datadir}/mime-info/*
163#{_datadir}/mc/templates/*
164%{_datadir}/omf/*
165%{_datadir}/icons/hicolor/*
166%{_mandir}/man*/*
167%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
168
169#%{_libexecdir}/gnumeric-component
170#%#dir %{_libdir}/gnumeric
171#%#dir %{_libdir}/gnumeric/%{bonobover}
172#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
173#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
174# This is really silly.  The .la files are useless for plugins.
175#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
176#%#{_libdir}/gnumericConf.sh
177#%#if %{bonobo}
178#%#dir %{_datadir}/gnumeric
179#%#dir %{_datadir}/gnumeric/%{bonobover}
180#%#{_datadir}/gnumeric/%{bonobover}/idl
181#%#endif
182
183
184%changelog
185* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
186- new upstream release
187- add BuildRequires: libSM-devel
188- fix BuildRequires: goffice-devel >= 0.8.1
189
190* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
191- spec in UTF-8 (fixed)
192
193* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
194- spec in UTF-8
195- added BuildRequires: libffi-devel
196- added %%pre, %%preun section
197
198* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
199- new upstream release
200- built with libgda-3.1.4, libgnomedb-3.1.2
201- applied new versioning policy
202
203* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
204- new upstream release
205
206* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
207- rebuild
208
209* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
210- new upstream release
211
212* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
213- new upstream release
214- updated build dependancies
215- rebuilt with libgsf-1.14.0
216- built with libgda and libgnomedb again
217
218* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
219- new upstream release
220- updated build dependancies
221- not compile with libgda and libgnomedb in this version
222
223* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
224- new upstream release
225
226* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
227- rebuild with libgda 1.2.0 and libgnome 1.2.0
228
229* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
230- new upstream release
231
232* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
233- new upstream release
234
235* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
236- new upstream release
237
238* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
239- rebuild with gnome-2.8 environment and libgsf-1.10.1
240
241* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
242- new upstream release
243- added BuildRequires: desktop-file-utils
244
245* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
246- new upstream release
247- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
248
249* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
250- new upstream release
251
252* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
253- new upstream release
254
255* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
256- new upstream release
257
258* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
259- new upstream release
260
261* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
262- new upstream release
263- clean up spec file (a little bit!)
264
265* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
266- new upstream release
267
268* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
269- new upstream release
270- to use intltool-0.28
271
272* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
273- new upstream release
274- rebuild with new toolchains
275
276* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
277- new upstream release
278- build with new libgnomeprint, libgnomeprintui
279
280* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
281- new upstream release
282
283* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
284- rebuild with newer libgda, libgnomedb
285
286* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
287- updated to 1.2.0 (stable release)
288- guile support is temporarily off this version.
289
290* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
291- update to 1.1.20 (gtk+-2 port)
292- based on Redhat Rawhide 1.1.20-1
293
294* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
295- update to 1.0.13
296- rebuild with gal 0.24
297
298* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
299- guile support on
300- rebuild with new gal, bonobo, libgda
301
302* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
303- New upstream release, remove xmliobackward.patch
304
305* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
306- xml-io back to 1.0.10 because japanese corrups with new xml_parser
307
308* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
309- New upstream release, fix for xml importing files with non ASCII characters.
310- Without guile, changelog.archive, requires, build scripts, description
311
312* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
313- files: add gnumericConf.sh, which was missing
314
315* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
316- New upstream release.
317- BuildPrereq oaf-devel
318
319* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
320- New upstream release.
321
322* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
323- New upstream release.
324- Default font and Japanese fonts in excel
325- requires
326
327* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
328- New upstream release.
329- fixed plugins, apply patch2, remove patch3
330- files - no longer devel package
331- function-reference.html in help file
332
333* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
334- New upstream release.
335
336* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
337- New upstream release.
338- Fixed several owner dir.
339
340* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
341- Build against with new gal
342
343* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
344- New upstream release.
345
346* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
347- New upstream release.
348
349* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
350- New upstream release.
351- Applied XIM over-the-spot patch.
352- Fixed directories owner.
353
354* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
355- New upstream release.
356- Enable Bonobo.
357- Merged several RH patches.
358- Added BuildPreReq tags.
359
360* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
361- Fixed packaging mistake.
362
363* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
364- Rebuild for GAL 0.7
365
366* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
367- New upstream release.
368- Use rpmmacros.
369
370* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
371- 0.56-0vl2
372- update ja.po
373- avoid core dump when inserting a row
374
375* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
376- updated to 0.56
377- remake spec with the orginal gnumeric spec file.
378- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
379
380* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
381- updated to 0.53
382- remake SPEC based on gnumeric original.
383- added libxml183 patch for libxml 1.8.3
384
385* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
386- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
387- Added --without-bonobo and --without-gb.
388- Added %define for sysconfdir
389
390* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
391- Updated version requirements for gnome-print, and gnome-libs.
392
393* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
394- Added in some auto-detect the language files logic (rpm 3.0.xx only)
395
396* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
397- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
398
399* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
400- Updated to 0.47
401
402* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
403- Updated the libglade dependancy.
404- Remove req for guile.  We can build without it.
405
406* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
407- Added small fix so glade generated dialogs appear.
408
409* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
410- Added the gnome-print requirement.
411- Updated the file list to try and quiet down the updating.
412- added the sysconfdir
413
414* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
415- Updated the spec file.
416
417* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
418- Version 0.2
419
Note: See TracBrowser for help on using the repository browser.