source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 7280

Revision 7280, 13.2 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.10.0
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.12.0
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.11/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
78desktop-file-install --vendor gnome --delete-original                   \
79  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
80  --add-category Office                                                 \
81  --add-category Application                                            \
82  --add-category Spreadsheet                                            \
83  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
84  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
85
86%find_lang %{name}
87%find_lang %{name}-functions
88cat %{name}-functions.lang >> %{name}.lang
89
90find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
93rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
94rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/ldconfig
101scrollkeeper-update > /dev/null 2>&1 || :
102touch --no-create %{_datadir}/icons/hicolor || :
103if [ -x %{_bindir}/gtk-update-icon-cache ]; then
104   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
105fi
106update-desktop-database -q &> /dev/null || :
107
108%postun
109/sbin/ldconfig
110scrollkeeper-update > /dev/null 2>&1 || :
111touch --no-create %{_datadir}/icons/hicolor || :
112if [ -x %{_bindir}/gtk-update-icon-cache ]; then
113   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114fi
115update-desktop-database -q &> /dev/null || :
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121
122%files -f %{name}.lang
123%defattr (-, root, root)
124%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
125%{_bindir}/*
126%{_libdir}/libspreadsheet*.so
127%{_libdir}/%{name}
128%{_libdir}/goffice/0.10/plugins/%{name}
129%{_datadir}/applications/*.desktop
130%{_datadir}/glib-2.0/schemas/*.xml
131%{_datadir}/gnome/help/%{name}
132%{_datadir}/%{name}
133%{_datadir}/pixmaps/*
134%{_datadir}/omf/*
135%{_datadir}/icons/hicolor/*
136%{_mandir}/man*/*
137%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
138
139
140%changelog
141* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
142- new upstream release
143
144* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
145- new upstream release
146- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
147- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
148
149* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
150- rebuild with libgsf-1.14.22
151- add Patch1 (gnumeric-1.10.17-libgsf.patch)
152
153* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
154- new upstream release
155- update Patch0
156
157* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
158- new upstream release
159
160* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
161- new upstream release
162- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
163
164* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
165- new upstream release
166
167* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
168- new upstream release
169
170* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
171- new upstream release
172
173* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
174- new upstream release
175- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
176   (fix error of MIME type)
177
178* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
179- new upstream release
180
181* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
182- new upstream release
183
184* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
185- new upstream release
186- fix %post and %postun
187
188* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
189- new upstream release
190
191* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
192- new upstream release
193- add BuildRequires: libSM-devel
194- fix BuildRequires: goffice-devel >= 0.8.1
195
196* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
197- spec in UTF-8 (fixed)
198
199* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
200- spec in UTF-8
201- added BuildRequires: libffi-devel
202- added %%pre, %%preun section
203
204* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
205- new upstream release
206- built with libgda-3.1.4, libgnomedb-3.1.2
207- applied new versioning policy
208
209* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
210- new upstream release
211
212* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
213- rebuild
214
215* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
216- new upstream release
217
218* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
219- new upstream release
220- updated build dependancies
221- rebuilt with libgsf-1.14.0
222- built with libgda and libgnomedb again
223
224* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
225- new upstream release
226- updated build dependancies
227- not compile with libgda and libgnomedb in this version
228
229* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
230- new upstream release
231
232* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
233- rebuild with libgda 1.2.0 and libgnome 1.2.0
234
235* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
236- new upstream release
237
238* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
239- new upstream release
240
241* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
242- new upstream release
243
244* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
245- rebuild with gnome-2.8 environment and libgsf-1.10.1
246
247* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
248- new upstream release
249- added BuildRequires: desktop-file-utils
250
251* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
252- new upstream release
253- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
254
255* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
256- new upstream release
257
258* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
259- new upstream release
260
261* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
262- new upstream release
263
264* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
265- new upstream release
266
267* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
268- new upstream release
269- clean up spec file (a little bit!)
270
271* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
272- new upstream release
273
274* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
275- new upstream release
276- to use intltool-0.28
277
278* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
279- new upstream release
280- rebuild with new toolchains
281
282* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
283- new upstream release
284- build with new libgnomeprint, libgnomeprintui
285
286* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
287- new upstream release
288
289* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
290- rebuild with newer libgda, libgnomedb
291
292* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
293- updated to 1.2.0 (stable release)
294- guile support is temporarily off this version.
295
296* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
297- update to 1.1.20 (gtk+-2 port)
298- based on Redhat Rawhide 1.1.20-1
299
300* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
301- update to 1.0.13
302- rebuild with gal 0.24
303
304* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
305- guile support on
306- rebuild with new gal, bonobo, libgda
307
308* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
309- New upstream release, remove xmliobackward.patch
310
311* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
312- xml-io back to 1.0.10 because japanese corrups with new xml_parser
313
314* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
315- New upstream release, fix for xml importing files with non ASCII characters.
316- Without guile, changelog.archive, requires, build scripts, description
317
318* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
319- files: add gnumericConf.sh, which was missing
320
321* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
322- New upstream release.
323- BuildPrereq oaf-devel
324
325* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
326- New upstream release.
327
328* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
329- New upstream release.
330- Default font and Japanese fonts in excel
331- requires
332
333* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
334- New upstream release.
335- fixed plugins, apply patch2, remove patch3
336- files - no longer devel package
337- function-reference.html in help file
338
339* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
340- New upstream release.
341
342* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
343- New upstream release.
344- Fixed several owner dir.
345
346* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
347- Build against with new gal
348
349* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
350- New upstream release.
351
352* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
353- New upstream release.
354
355* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
356- New upstream release.
357- Applied XIM over-the-spot patch.
358- Fixed directories owner.
359
360* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
361- New upstream release.
362- Enable Bonobo.
363- Merged several RH patches.
364- Added BuildPreReq tags.
365
366* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
367- Fixed packaging mistake.
368
369* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
370- Rebuild for GAL 0.7
371
372* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
373- New upstream release.
374- Use rpmmacros.
375
376* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
377- 0.56-0vl2
378- update ja.po
379- avoid core dump when inserting a row
380
381* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
382- updated to 0.56
383- remake spec with the orginal gnumeric spec file.
384- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
385
386* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
387- updated to 0.53
388- remake SPEC based on gnumeric original.
389- added libxml183 patch for libxml 1.8.3
390
391* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
392- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
393- Added --without-bonobo and --without-gb.
394- Added %define for sysconfdir
395
396* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
397- Updated version requirements for gnome-print, and gnome-libs.
398
399* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
400- Added in some auto-detect the language files logic (rpm 3.0.xx only)
401
402* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
403- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
404
405* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
406- Updated to 0.47
407
408* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
409- Updated the libglade dependancy.
410- Remove req for guile.  We can build without it.
411
412* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
413- Added small fix so glade generated dialogs appear.
414
415* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
416- Added the gnome-print requirement.
417- Updated the file list to try and quiet down the updating.
418- added the sysconfdir
419
420* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
421- Updated the spec file.
422
423* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
424- Version 0.2
425
Note: See TracBrowser for help on using the repository browser.