source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 6581

Revision 6581, 13.1 KB checked in by Takemikaduchi, 12 years ago (diff)

cogl: bug fix
others: new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.9.5
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.11.5
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source0:  ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.11/%{name}-%{version}.tar.xz
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.11.5-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22
23BuildRequires: bison
24BuildRequires: flex
25BuildRequires: goffice-devel >= %{goffice_version}
26BuildRequires: pygobject3-devel
27BuildRequires: perl python-devel
28BuildRequires: automake
29BuildRequires: gnome-doc-utils
30BuildRequires: desktop-file-utils
31
32Requires(postun,posttrans): glib2
33Requires(post,postun): desktop-file-utils
34
35Obsoletes:  %{name}-devel
36
37%description
38GNOME (GNU Network Object Model Environment) is a user-friendly set of
39applications and desktop tools to be used in conjunction with a window
40manager for the X Window System.
41
42This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
43replacement for commercial spreadsheets.  It provides import/export from
44MS Excel files and many other formats (csv, latex, xbase, applix).
45
46%description -l ja
47GNOME (GNU Network Object Model Environment)は
48Xウィンドウシステム用の、ウィンドウマネージャと連結した
49GUIアプリケーションおよびデスクトップツールのセットです。
50
51これは Gnumeric, GNOMEスプレッドシート・プログラムです。
52商用のスプレッドシート・プログラムを代替できるものを目指しています。
53MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
54を読込み、出力できます.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .vlgothic
60
61%build
62%ifarch alpha
63        MYARCH_FLAGS="--host=alpha-redhat-linux"
64%endif
65
66%configure \
67        --without-gda \
68        --with-perl \
69        --with-python
70make
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74
75make DESTDIR=$RPM_BUILD_ROOT install
76
77./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
78desktop-file-install --vendor gnome --delete-original                   \
79  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
80  --add-category Office                                                 \
81  --add-category Application                                            \
82  --add-category Spreadsheet                                            \
83  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
84  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
85
86%find_lang %{name}
87%find_lang %{name}-functions
88cat %{name}-functions.lang >> %{name}.lang
89
90find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
93rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
94rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/ldconfig
101scrollkeeper-update > /dev/null 2>&1 || :
102touch --no-create %{_datadir}/icons/hicolor || :
103if [ -x %{_bindir}/gtk-update-icon-cache ]; then
104   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
105fi
106update-desktop-database -q &> /dev/null || :
107
108%postun
109/sbin/ldconfig
110scrollkeeper-update > /dev/null 2>&1 || :
111touch --no-create %{_datadir}/icons/hicolor || :
112if [ -x %{_bindir}/gtk-update-icon-cache ]; then
113   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114fi
115update-desktop-database -q &> /dev/null || :
116glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117
118%posttrans
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121
122%files -f %{name}.lang
123%defattr (-, root, root)
124%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
125%{_bindir}/*
126%{_libdir}/libspreadsheet*.so
127%{_libdir}/%{name}
128%{_libdir}/goffice/0.10/plugins/%{name}
129%{_datadir}/applications/*.desktop
130%{_datadir}/glib-2.0/schemas/*.xml
131%{_datadir}/gnome/help/%{name}
132%{_datadir}/%{name}
133%{_datadir}/pixmaps/*
134%{_datadir}/omf/*
135%{_datadir}/icons/hicolor/*
136%{_mandir}/man*/*
137%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
138
139
140%changelog
141* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
142- new upstream release
143- add Patch0 (gnumeric-1.11.5-vlgothic.patch)
144- remove Patch1 (gnumeric-1.10.17-libgsf.patch)
145
146* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
147- rebuild with libgsf-1.14.22
148- add Patch1 (gnumeric-1.10.17-libgsf.patch)
149
150* Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
151- new upstream release
152- update Patch0
153
154* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
155- new upstream release
156
157* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
158- new upstream release
159- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
160
161* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
162- new upstream release
163
164* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
165- new upstream release
166
167* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
168- new upstream release
169
170* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
171- new upstream release
172- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
173   (fix error of MIME type)
174
175* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
176- new upstream release
177
178* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
179- new upstream release
180
181* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
182- new upstream release
183- fix %post and %postun
184
185* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
186- new upstream release
187
188* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
189- new upstream release
190- add BuildRequires: libSM-devel
191- fix BuildRequires: goffice-devel >= 0.8.1
192
193* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
194- spec in UTF-8 (fixed)
195
196* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
197- spec in UTF-8
198- added BuildRequires: libffi-devel
199- added %%pre, %%preun section
200
201* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
202- new upstream release
203- built with libgda-3.1.4, libgnomedb-3.1.2
204- applied new versioning policy
205
206* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
207- new upstream release
208
209* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
210- rebuild
211
212* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
213- new upstream release
214
215* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
216- new upstream release
217- updated build dependancies
218- rebuilt with libgsf-1.14.0
219- built with libgda and libgnomedb again
220
221* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
222- new upstream release
223- updated build dependancies
224- not compile with libgda and libgnomedb in this version
225
226* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
227- new upstream release
228
229* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
230- rebuild with libgda 1.2.0 and libgnome 1.2.0
231
232* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
233- new upstream release
234
235* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
236- new upstream release
237
238* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
239- new upstream release
240
241* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
242- rebuild with gnome-2.8 environment and libgsf-1.10.1
243
244* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
245- new upstream release
246- added BuildRequires: desktop-file-utils
247
248* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
249- new upstream release
250- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
251
252* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
253- new upstream release
254
255* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
256- new upstream release
257
258* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
259- new upstream release
260
261* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
262- new upstream release
263
264* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
265- new upstream release
266- clean up spec file (a little bit!)
267
268* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
269- new upstream release
270
271* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
272- new upstream release
273- to use intltool-0.28
274
275* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
276- new upstream release
277- rebuild with new toolchains
278
279* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
280- new upstream release
281- build with new libgnomeprint, libgnomeprintui
282
283* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
284- new upstream release
285
286* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
287- rebuild with newer libgda, libgnomedb
288
289* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
290- updated to 1.2.0 (stable release)
291- guile support is temporarily off this version.
292
293* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
294- update to 1.1.20 (gtk+-2 port)
295- based on Redhat Rawhide 1.1.20-1
296
297* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
298- update to 1.0.13
299- rebuild with gal 0.24
300
301* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
302- guile support on
303- rebuild with new gal, bonobo, libgda
304
305* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
306- New upstream release, remove xmliobackward.patch
307
308* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
309- xml-io back to 1.0.10 because japanese corrups with new xml_parser
310
311* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
312- New upstream release, fix for xml importing files with non ASCII characters.
313- Without guile, changelog.archive, requires, build scripts, description
314
315* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
316- files: add gnumericConf.sh, which was missing
317
318* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
319- New upstream release.
320- BuildPrereq oaf-devel
321
322* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
323- New upstream release.
324
325* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
326- New upstream release.
327- Default font and Japanese fonts in excel
328- requires
329
330* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
331- New upstream release.
332- fixed plugins, apply patch2, remove patch3
333- files - no longer devel package
334- function-reference.html in help file
335
336* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
337- New upstream release.
338
339* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
340- New upstream release.
341- Fixed several owner dir.
342
343* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
344- Build against with new gal
345
346* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
347- New upstream release.
348
349* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
350- New upstream release.
351
352* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
353- New upstream release.
354- Applied XIM over-the-spot patch.
355- Fixed directories owner.
356
357* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
358- New upstream release.
359- Enable Bonobo.
360- Merged several RH patches.
361- Added BuildPreReq tags.
362
363* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
364- Fixed packaging mistake.
365
366* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
367- Rebuild for GAL 0.7
368
369* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
370- New upstream release.
371- Use rpmmacros.
372
373* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
374- 0.56-0vl2
375- update ja.po
376- avoid core dump when inserting a row
377
378* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
379- updated to 0.56
380- remake spec with the orginal gnumeric spec file.
381- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
382
383* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
384- updated to 0.53
385- remake SPEC based on gnumeric original.
386- added libxml183 patch for libxml 1.8.3
387
388* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
389- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
390- Added --without-bonobo and --without-gb.
391- Added %define for sysconfdir
392
393* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
394- Updated version requirements for gnome-print, and gnome-libs.
395
396* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
397- Added in some auto-detect the language files logic (rpm 3.0.xx only)
398
399* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
400- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
401
402* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
403- Updated to 0.47
404
405* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
406- Updated the libglade dependancy.
407- Remove req for guile.  We can build without it.
408
409* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
410- Added small fix so glade generated dialogs appear.
411
412* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
413- Added the gnome-print requirement.
414- Updated the file list to try and quiet down the updating.
415- added the sysconfdir
416
417* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
418- Updated the spec file.
419
420* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
421- Version 0.2
422
Note: See TracBrowser for help on using the repository browser.