source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 3400

Revision 3400, 14.8 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.14
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.14
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16# default font: VL Gothic
17Patch0: gnumeric-1.10.13-vlgothic.patch
18
19Distribution: Vine Linux
20Vendor: Project Vine
21
22BuildRequires: gtk2-devel >= 2.10.0
23BuildRequires: libglade2-devel >= 2.3.6
24BuildRequires: libgnomeprint-devel >= 2.8.2
25BuildRequires: libgnomeprintui-devel >= 2.8.2
26BuildRequires: libart_lgpl-devel >= 2.3.11
27BuildRequires: libxml2-devel >= 2.4.12
28BuildRequires: libgsf-devel >= 1.13.2
29BuildRequires: goffice-devel >= %{goffice_version}
30BuildRequires: libbonobo-devel libgnomeui-devel
31BuildRequires: libffi-devel
32#BuildPreReq: libgda-devel >= 1.9.100
33#BuildPreReq: libgnomedb-devel >= 1.9.100
34BuildRequires: perl python-devel
35BuildRequires: automake autoconf libtool docbook-utils
36BuildRequires: intltool >= 0.28 desktop-file-utils
37BuildRequires: libSM-devel
38Requires:    gtk2 >= 2.10.0
39Requires:    libglade2 >= 2.3.6
40Requires:    libgnomeprint >= 2.8.2
41Requires:    libgnomeprintui >= 2.8.2
42Requires:    libgsf >= 1.14.6
43Requires:    perl python
44Requires:    GConf2 scrollkeeper
45
46# no longer devel package
47#Provides:   %{name}-devel
48Obsoletes:  %{name}-devel
49
50%description
51GNOME (GNU Network Object Model Environment) is a user-friendly set of
52applications and desktop tools to be used in conjunction with a window
53manager for the X Window System.
54
55This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
56replacement for commercial spreadsheets.  It provides import/export from
57MS Excel files and many other formats (csv, latex, xbase, applix).
58
59%description -l ja
60GNOME (GNU Network Object Model Environment)は
61Xウィンドウシステム用の、ウィンドウマネージャと連結した
62GUIアプリケーションおよびデスクトップツールのセットです。
63
64これは Gnumeric, GNOMEスプレッドシート・プログラムです。
65商用のスプレッドシート・プログラムを代替できるものを目指しています。
66MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
67を読込み、出力できます.
68
69
70# %package devel
71#Summary:       Files necessary to develop gnumeric-based applications.
72#Group:         Development/Libraries
73#Requires:      %{name} = %{PACKAGE_VERSION}
74
75#%#description devel
76#The gnumeric-devel package includes files necessary to develop gnumeric-based
77#applications.
78
79#Install gnumeric-devel if you want to develop programs which will use gnumeric.
80
81%prep
82%setup -q
83%patch0 -p1 -b vlgothic
84
85%build
86%ifarch alpha
87        MYARCH_FLAGS="--host=alpha-redhat-linux"
88%endif
89export mllibname=%{_lib}
90%configure --with-gnome \
91    --with-gda --without-gb --with-perl --with-python \
92    --disable-schemas-install
93make
94
95%install
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
99make DESTDIR=$RPM_BUILD_ROOT install
100unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
101
102./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
103desktop-file-install --vendor gnome --delete-original                   \
104  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
105  --add-category Office                                                 \
106  --add-category Application                                            \
107  --add-category Spreadsheet                                            \
108  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
109  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
110
111%find_lang %{name}
112%find_lang %{name}-functions
113cat %{name}-functions.lang >> %{name}.lang
114
115rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
116rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
117rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
118rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
119rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
120
121%clean
122[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
123
124%post
125/sbin/ldconfig
126
127scrollkeeper-update > /dev/null 2>&1 || :
128export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
129gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
130
131touch --no-create %{_datadir}/icons/hicolor || :
132if [ -x %{_bindir}/gtk-update-icon-cache ]; then
133   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
134fi
135
136%pre
137if [ "$1" -gt 1 ]; then
138    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
139    gconftool-2 --makefile-uninstall-rule \
140        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
141fi
142
143%preun
144if [ "$1" -eq 0 ]; then
145    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
146    gconftool-2 --makefile-uninstall-rule \
147        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
148fi
149
150%postun
151/sbin/ldconfig
152scrollkeeper-update > /dev/null 2>&1 || :
153
154touch --no-create %{_datadir}/icons/hicolor || :
155if [ -x %{_bindir}/gtk-update-icon-cache ]; then
156   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
157fi
158
159
160%files -f %{name}.lang
161%defattr (-, root, root)
162%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
163%config %{_sysconfdir}/gconf/schemas/*
164%{_bindir}/*
165%{_libdir}/lib*.so*
166%{_libdir}/gnumeric
167%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
168#{_libdir}/bonobo/servers/*
169%{_datadir}/applications/*.desktop
170%{_datadir}/glib-2.0/schemas/*.xml
171%{_datadir}/gnome/help/gnumeric
172%{_datadir}/gnumeric
173%{_datadir}/pixmaps/*
174#{_datadir}/mime-info/*
175#{_datadir}/mc/templates/*
176%{_datadir}/omf/*
177%{_datadir}/icons/hicolor/*
178%{_mandir}/man*/*
179%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
180
181#%{_libexecdir}/gnumeric-component
182#%#dir %{_libdir}/gnumeric
183#%#dir %{_libdir}/gnumeric/%{bonobover}
184#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
185#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
186# This is really silly.  The .la files are useless for plugins.
187#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
188#%#{_libdir}/gnumericConf.sh
189#%#if %{bonobo}
190#%#dir %{_datadir}/gnumeric
191#%#dir %{_datadir}/gnumeric/%{bonobover}
192#%#{_datadir}/gnumeric/%{bonobover}/idl
193#%#endif
194
195
196%changelog
197* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
198- new upstream release
199
200* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
201- new upstream release
202- add Patch0 (gnumeric-1.10.13-vlgothic.patch)
203
204* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
205- new upstream release
206
207* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
208- new upstream release
209
210* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
211- new upstream release
212
213* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
214- new upstream release
215- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
216   (fix error of MIME type)
217
218* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
219- new upstream release
220
221* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
222- new upstream release
223
224* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
225- new upstream release
226- fix %post and %postun
227
228* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
229- new upstream release
230
231* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
232- new upstream release
233- add BuildRequires: libSM-devel
234- fix BuildRequires: goffice-devel >= 0.8.1
235
236* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
237- spec in UTF-8 (fixed)
238
239* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
240- spec in UTF-8
241- added BuildRequires: libffi-devel
242- added %%pre, %%preun section
243
244* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
245- new upstream release
246- built with libgda-3.1.4, libgnomedb-3.1.2
247- applied new versioning policy
248
249* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
250- new upstream release
251
252* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
253- rebuild
254
255* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
256- new upstream release
257
258* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
259- new upstream release
260- updated build dependancies
261- rebuilt with libgsf-1.14.0
262- built with libgda and libgnomedb again
263
264* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
265- new upstream release
266- updated build dependancies
267- not compile with libgda and libgnomedb in this version
268
269* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
270- new upstream release
271
272* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
273- rebuild with libgda 1.2.0 and libgnome 1.2.0
274
275* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
276- new upstream release
277
278* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
279- new upstream release
280
281* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
282- new upstream release
283
284* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
285- rebuild with gnome-2.8 environment and libgsf-1.10.1
286
287* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
288- new upstream release
289- added BuildRequires: desktop-file-utils
290
291* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
292- new upstream release
293- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
294
295* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
296- new upstream release
297
298* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
299- new upstream release
300
301* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
302- new upstream release
303
304* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
305- new upstream release
306
307* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
308- new upstream release
309- clean up spec file (a little bit!)
310
311* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
312- new upstream release
313
314* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
315- new upstream release
316- to use intltool-0.28
317
318* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
319- new upstream release
320- rebuild with new toolchains
321
322* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
323- new upstream release
324- build with new libgnomeprint, libgnomeprintui
325
326* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
327- new upstream release
328
329* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
330- rebuild with newer libgda, libgnomedb
331
332* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
333- updated to 1.2.0 (stable release)
334- guile support is temporarily off this version.
335
336* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
337- update to 1.1.20 (gtk+-2 port)
338- based on Redhat Rawhide 1.1.20-1
339
340* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
341- update to 1.0.13
342- rebuild with gal 0.24
343
344* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
345- guile support on
346- rebuild with new gal, bonobo, libgda
347
348* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
349- New upstream release, remove xmliobackward.patch
350
351* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
352- xml-io back to 1.0.10 because japanese corrups with new xml_parser
353
354* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
355- New upstream release, fix for xml importing files with non ASCII characters.
356- Without guile, changelog.archive, requires, build scripts, description
357
358* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
359- files: add gnumericConf.sh, which was missing
360
361* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
362- New upstream release.
363- BuildPrereq oaf-devel
364
365* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
366- New upstream release.
367
368* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
369- New upstream release.
370- Default font and Japanese fonts in excel
371- requires
372
373* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
374- New upstream release.
375- fixed plugins, apply patch2, remove patch3
376- files - no longer devel package
377- function-reference.html in help file
378
379* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
380- New upstream release.
381
382* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
383- New upstream release.
384- Fixed several owner dir.
385
386* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
387- Build against with new gal
388
389* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
390- New upstream release.
391
392* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
393- New upstream release.
394
395* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
396- New upstream release.
397- Applied XIM over-the-spot patch.
398- Fixed directories owner.
399
400* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
401- New upstream release.
402- Enable Bonobo.
403- Merged several RH patches.
404- Added BuildPreReq tags.
405
406* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
407- Fixed packaging mistake.
408
409* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
410- Rebuild for GAL 0.7
411
412* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
413- New upstream release.
414- Use rpmmacros.
415
416* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
417- 0.56-0vl2
418- update ja.po
419- avoid core dump when inserting a row
420
421* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
422- updated to 0.56
423- remake spec with the orginal gnumeric spec file.
424- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
425
426* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
427- updated to 0.53
428- remake SPEC based on gnumeric original.
429- added libxml183 patch for libxml 1.8.3
430
431* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
432- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
433- Added --without-bonobo and --without-gb.
434- Added %define for sysconfdir
435
436* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
437- Updated version requirements for gnome-print, and gnome-libs.
438
439* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
440- Added in some auto-detect the language files logic (rpm 3.0.xx only)
441
442* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
443- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
444
445* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
446- Updated to 0.47
447
448* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
449- Updated the libglade dependancy.
450- Remove req for guile.  We can build without it.
451
452* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
453- Added small fix so glade generated dialogs appear.
454
455* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
456- Added the gnome-print requirement.
457- Updated the file list to try and quiet down the updating.
458- added the sysconfdir
459
460* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
461- Updated the spec file.
462
463* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
464- Version 0.2
465
Note: See TracBrowser for help on using the repository browser.