source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 2080

Revision 2080, 14.4 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.11
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.11
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Distribution: Vine Linux
17Vendor: Project Vine
18
19BuildRequires: gtk2-devel >= 2.10.0
20BuildRequires: libglade2-devel >= 2.3.6
21BuildRequires: libgnomeprint-devel >= 2.8.2
22BuildRequires: libgnomeprintui-devel >= 2.8.2
23BuildRequires: libart_lgpl-devel >= 2.3.11
24BuildRequires: libxml2-devel >= 2.4.12
25BuildRequires: libgsf-devel >= 1.13.2
26BuildRequires: goffice-devel >= %{goffice_version}
27BuildRequires: libbonobo-devel libgnomeui-devel
28BuildRequires: libffi-devel
29#BuildPreReq: libgda-devel >= 1.9.100
30#BuildPreReq: libgnomedb-devel >= 1.9.100
31BuildRequires: perl python-devel
32BuildRequires: automake autoconf libtool docbook-utils
33BuildRequires: intltool >= 0.28 desktop-file-utils
34BuildRequires: libSM-devel
35Requires:    gtk2 >= 2.10.0
36Requires:    libglade2 >= 2.3.6
37Requires:    libgnomeprint >= 2.8.2
38Requires:    libgnomeprintui >= 2.8.2
39Requires:    libgsf >= 1.14.6
40Requires:    perl python
41Requires:    GConf2 scrollkeeper
42
43# no longer devel package
44#Provides:   %{name}-devel
45Obsoletes:  %{name}-devel
46
47%description
48GNOME (GNU Network Object Model Environment) is a user-friendly set of
49applications and desktop tools to be used in conjunction with a window
50manager for the X Window System.
51
52This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
53replacement for commercial spreadsheets.  It provides import/export from
54MS Excel files and many other formats (csv, latex, xbase, applix).
55
56%description -l ja
57GNOME (GNU Network Object Model Environment)は
58Xウィンドウシステム用の、ウィンドウマネージャと連結した
59GUIアプリケーションおよびデスクトップツールのセットです。
60
61これは Gnumeric, GNOMEスプレッドシート・プログラムです。
62商用のスプレッドシート・プログラムを代替できるものを目指しています。
63MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
64を読込み、出力できます.
65
66
67# %package devel
68#Summary:       Files necessary to develop gnumeric-based applications.
69#Group:         Development/Libraries
70#Requires:      %{name} = %{PACKAGE_VERSION}
71
72#%#description devel
73#The gnumeric-devel package includes files necessary to develop gnumeric-based
74#applications.
75
76#Install gnumeric-devel if you want to develop programs which will use gnumeric.
77
78%prep
79%setup -q
80
81%build
82%ifarch alpha
83        MYARCH_FLAGS="--host=alpha-redhat-linux"
84%endif
85export mllibname=%{_lib}
86%configure --with-gnome \
87    --with-gda --without-gb --with-perl --with-python \
88    --disable-schemas-install
89make
90
91%install
92[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
93
94export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
95make DESTDIR=$RPM_BUILD_ROOT install
96unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
97
98./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
99desktop-file-install --vendor gnome --delete-original                   \
100  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
101  --add-category Office                                                 \
102  --add-category Application                                            \
103  --add-category Spreadsheet                                            \
104  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
105  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
106
107%find_lang %{name}
108%find_lang %{name}-functions
109cat %{name}-functions.lang >> %{name}.lang
110
111rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
112rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
113rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
115rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
116
117%clean
118[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122
123scrollkeeper-update > /dev/null 2>&1 || :
124export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
126
127touch --no-create %{_datadir}/icons/hicolor || :
128if [ -x %{_bindir}/gtk-update-icon-cache ]; then
129   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132%pre
133if [ "$1" -gt 1 ]; then
134    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135    gconftool-2 --makefile-uninstall-rule \
136        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
137fi
138
139%preun
140if [ "$1" -eq 0 ]; then
141    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142    gconftool-2 --makefile-uninstall-rule \
143        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
144fi
145
146%postun
147/sbin/ldconfig
148scrollkeeper-update > /dev/null 2>&1 || :
149
150touch --no-create %{_datadir}/icons/hicolor || :
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
153fi
154
155
156%files -f %{name}.lang
157%defattr (-, root, root)
158%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
159%config %{_sysconfdir}/gconf/schemas/*
160%{_bindir}/*
161%{_libdir}/lib*.so*
162%{_libdir}/gnumeric
163%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
164#{_libdir}/bonobo/servers/*
165%{_datadir}/applications/*.desktop
166%{_datadir}/gnome/help/gnumeric
167%{_datadir}/gnumeric
168%{_datadir}/pixmaps/*
169#{_datadir}/mime-info/*
170#{_datadir}/mc/templates/*
171%{_datadir}/omf/*
172%{_datadir}/icons/hicolor/*
173%{_mandir}/man*/*
174%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
175
176#%{_libexecdir}/gnumeric-component
177#%#dir %{_libdir}/gnumeric
178#%#dir %{_libdir}/gnumeric/%{bonobover}
179#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
180#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
181# This is really silly.  The .la files are useless for plugins.
182#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
183#%#{_libdir}/gnumericConf.sh
184#%#if %{bonobo}
185#%#dir %{_datadir}/gnumeric
186#%#dir %{_datadir}/gnumeric/%{bonobover}
187#%#{_datadir}/gnumeric/%{bonobover}/idl
188#%#endif
189
190
191%changelog
192* Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
193- new upstream release
194
195* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
196- new upstream release
197
198* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
199- new upstream release
200- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
201   (fix error of MIME type)
202
203* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
204- new upstream release
205
206* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
207- new upstream release
208
209* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
210- new upstream release
211- fix %post and %postun
212
213* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
214- new upstream release
215
216* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
217- new upstream release
218- add BuildRequires: libSM-devel
219- fix BuildRequires: goffice-devel >= 0.8.1
220
221* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
222- spec in UTF-8 (fixed)
223
224* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
225- spec in UTF-8
226- added BuildRequires: libffi-devel
227- added %%pre, %%preun section
228
229* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
230- new upstream release
231- built with libgda-3.1.4, libgnomedb-3.1.2
232- applied new versioning policy
233
234* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
235- new upstream release
236
237* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
238- rebuild
239
240* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
241- new upstream release
242
243* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
244- new upstream release
245- updated build dependancies
246- rebuilt with libgsf-1.14.0
247- built with libgda and libgnomedb again
248
249* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
250- new upstream release
251- updated build dependancies
252- not compile with libgda and libgnomedb in this version
253
254* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
255- new upstream release
256
257* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
258- rebuild with libgda 1.2.0 and libgnome 1.2.0
259
260* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
261- new upstream release
262
263* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
264- new upstream release
265
266* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
267- new upstream release
268
269* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
270- rebuild with gnome-2.8 environment and libgsf-1.10.1
271
272* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
273- new upstream release
274- added BuildRequires: desktop-file-utils
275
276* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
277- new upstream release
278- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
279
280* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
281- new upstream release
282
283* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
284- new upstream release
285
286* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
287- new upstream release
288
289* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
290- new upstream release
291
292* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
293- new upstream release
294- clean up spec file (a little bit!)
295
296* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
297- new upstream release
298
299* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
300- new upstream release
301- to use intltool-0.28
302
303* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
304- new upstream release
305- rebuild with new toolchains
306
307* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
308- new upstream release
309- build with new libgnomeprint, libgnomeprintui
310
311* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
312- new upstream release
313
314* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
315- rebuild with newer libgda, libgnomedb
316
317* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
318- updated to 1.2.0 (stable release)
319- guile support is temporarily off this version.
320
321* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
322- update to 1.1.20 (gtk+-2 port)
323- based on Redhat Rawhide 1.1.20-1
324
325* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
326- update to 1.0.13
327- rebuild with gal 0.24
328
329* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
330- guile support on
331- rebuild with new gal, bonobo, libgda
332
333* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
334- New upstream release, remove xmliobackward.patch
335
336* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
337- xml-io back to 1.0.10 because japanese corrups with new xml_parser
338
339* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
340- New upstream release, fix for xml importing files with non ASCII characters.
341- Without guile, changelog.archive, requires, build scripts, description
342
343* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
344- files: add gnumericConf.sh, which was missing
345
346* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
347- New upstream release.
348- BuildPrereq oaf-devel
349
350* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
351- New upstream release.
352
353* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
354- New upstream release.
355- Default font and Japanese fonts in excel
356- requires
357
358* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
359- New upstream release.
360- fixed plugins, apply patch2, remove patch3
361- files - no longer devel package
362- function-reference.html in help file
363
364* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
365- New upstream release.
366
367* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
368- New upstream release.
369- Fixed several owner dir.
370
371* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
372- Build against with new gal
373
374* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
375- New upstream release.
376
377* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
378- New upstream release.
379
380* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
381- New upstream release.
382- Applied XIM over-the-spot patch.
383- Fixed directories owner.
384
385* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
386- New upstream release.
387- Enable Bonobo.
388- Merged several RH patches.
389- Added BuildPreReq tags.
390
391* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
392- Fixed packaging mistake.
393
394* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
395- Rebuild for GAL 0.7
396
397* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
398- New upstream release.
399- Use rpmmacros.
400
401* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
402- 0.56-0vl2
403- update ja.po
404- avoid core dump when inserting a row
405
406* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
407- updated to 0.56
408- remake spec with the orginal gnumeric spec file.
409- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
410
411* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
412- updated to 0.53
413- remake SPEC based on gnumeric original.
414- added libxml183 patch for libxml 1.8.3
415
416* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
417- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
418- Added --without-bonobo and --without-gb.
419- Added %define for sysconfdir
420
421* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
422- Updated version requirements for gnome-print, and gnome-libs.
423
424* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
425- Added in some auto-detect the language files logic (rpm 3.0.xx only)
426
427* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
428- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
429
430* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
431- Updated to 0.47
432
433* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
434- Updated the libglade dependancy.
435- Remove req for guile.  We can build without it.
436
437* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
438- Added small fix so glade generated dialogs appear.
439
440* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
441- Added the gnome-print requirement.
442- Updated the file list to try and quiet down the updating.
443- added the sysconfdir
444
445* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
446- Updated the spec file.
447
448* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
449- Version 0.2
450
Note: See TracBrowser for help on using the repository browser.