source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 1820

Revision 1820, 14.3 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.10
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.10
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Distribution: Vine Linux
17Vendor: Project Vine
18
19BuildRequires: gtk2-devel >= 2.10.0
20BuildRequires: libglade2-devel >= 2.3.6
21BuildRequires: libgnomeprint-devel >= 2.8.2
22BuildRequires: libgnomeprintui-devel >= 2.8.2
23BuildRequires: libart_lgpl-devel >= 2.3.11
24BuildRequires: libxml2-devel >= 2.4.12
25BuildRequires: libgsf-devel >= 1.13.2
26BuildRequires: goffice-devel >= %{goffice_version}
27BuildRequires: libbonobo-devel libgnomeui-devel
28BuildRequires: libffi-devel
29#BuildPreReq: libgda-devel >= 1.9.100
30#BuildPreReq: libgnomedb-devel >= 1.9.100
31BuildRequires: perl python-devel
32BuildRequires: automake autoconf libtool docbook-utils
33BuildRequires: intltool >= 0.28 desktop-file-utils
34BuildRequires: libSM-devel
35Requires:    gtk2 >= 2.10.0
36Requires:    libglade2 >= 2.3.6
37Requires:    libgnomeprint >= 2.8.2
38Requires:    libgnomeprintui >= 2.8.2
39Requires:    libgsf >= 1.14.6
40Requires:    perl python
41Requires:    GConf2 scrollkeeper
42
43# no longer devel package
44#Provides:   %{name}-devel
45Obsoletes:  %{name}-devel
46
47%description
48GNOME (GNU Network Object Model Environment) is a user-friendly set of
49applications and desktop tools to be used in conjunction with a window
50manager for the X Window System.
51
52This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
53replacement for commercial spreadsheets.  It provides import/export from
54MS Excel files and many other formats (csv, latex, xbase, applix).
55
56%description -l ja
57GNOME (GNU Network Object Model Environment)は
58Xウィンドウシステム用の、ウィンドウマネージャと連結した
59GUIアプリケーションおよびデスクトップツールのセットです。
60
61これは Gnumeric, GNOMEスプレッドシート・プログラムです。
62商用のスプレッドシート・プログラムを代替できるものを目指しています。
63MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
64を読込み、出力できます.
65
66
67# %package devel
68#Summary:       Files necessary to develop gnumeric-based applications.
69#Group:         Development/Libraries
70#Requires:      %{name} = %{PACKAGE_VERSION}
71
72#%#description devel
73#The gnumeric-devel package includes files necessary to develop gnumeric-based
74#applications.
75
76#Install gnumeric-devel if you want to develop programs which will use gnumeric.
77
78%prep
79%setup -q
80
81%build
82%ifarch alpha
83        MYARCH_FLAGS="--host=alpha-redhat-linux"
84%endif
85export mllibname=%{_lib}
86%configure --with-gnome \
87    --with-gda --without-gb --with-perl --with-python \
88    --disable-schemas-install
89make
90
91%install
92[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
93
94export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
95make DESTDIR=$RPM_BUILD_ROOT install
96unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
97
98./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
99desktop-file-install --vendor gnome --delete-original                   \
100  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
101  --add-category Office                                                 \
102  --add-category Application                                            \
103  --add-category Spreadsheet                                            \
104  --remove-mime-type="zz-application/zz-winassoc-xls"                   \
105  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
106
107%find_lang %{name}
108%find_lang %{name}-functions
109cat %{name}-functions.lang >> %{name}.lang
110
111rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
112rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
113rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
115rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
116
117%clean
118[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122
123scrollkeeper-update > /dev/null 2>&1 || :
124export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
126
127touch --no-create %{_datadir}/icons/hicolor || :
128if [ -x %{_bindir}/gtk-update-icon-cache ]; then
129   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132%pre
133if [ "$1" -gt 1 ]; then
134    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135    gconftool-2 --makefile-uninstall-rule \
136        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
137fi
138
139%preun
140if [ "$1" -eq 0 ]; then
141    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142    gconftool-2 --makefile-uninstall-rule \
143        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
144fi
145
146%postun
147/sbin/ldconfig
148scrollkeeper-update > /dev/null 2>&1 || :
149
150touch --no-create %{_datadir}/icons/hicolor || :
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
153fi
154
155
156%files -f %{name}.lang
157%defattr (-, root, root)
158%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
159%config %{_sysconfdir}/gconf/schemas/*
160%{_bindir}/*
161%{_libdir}/lib*.so*
162%{_libdir}/gnumeric
163%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
164#{_libdir}/bonobo/servers/*
165%{_datadir}/applications/*.desktop
166%{_datadir}/gnome/help/gnumeric
167%{_datadir}/gnumeric
168%{_datadir}/pixmaps/*
169#{_datadir}/mime-info/*
170#{_datadir}/mc/templates/*
171%{_datadir}/omf/*
172%{_datadir}/icons/hicolor/*
173%{_mandir}/man*/*
174%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
175
176#%{_libexecdir}/gnumeric-component
177#%#dir %{_libdir}/gnumeric
178#%#dir %{_libdir}/gnumeric/%{bonobover}
179#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
180#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
181# This is really silly.  The .la files are useless for plugins.
182#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
183#%#{_libdir}/gnumericConf.sh
184#%#if %{bonobo}
185#%#dir %{_datadir}/gnumeric
186#%#dir %{_datadir}/gnumeric/%{bonobover}
187#%#{_datadir}/gnumeric/%{bonobover}/idl
188#%#endif
189
190
191%changelog
192* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
193- new upstream release
194
195* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
196- new upstream release
197- add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
198   (fix error of MIME type)
199
200* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
201- new upstream release
202
203* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
204- new upstream release
205
206* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
207- new upstream release
208- fix %post and %postun
209
210* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
211- new upstream release
212
213* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
214- new upstream release
215- add BuildRequires: libSM-devel
216- fix BuildRequires: goffice-devel >= 0.8.1
217
218* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
219- spec in UTF-8 (fixed)
220
221* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
222- spec in UTF-8
223- added BuildRequires: libffi-devel
224- added %%pre, %%preun section
225
226* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
227- new upstream release
228- built with libgda-3.1.4, libgnomedb-3.1.2
229- applied new versioning policy
230
231* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
232- new upstream release
233
234* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
235- rebuild
236
237* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
238- new upstream release
239
240* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
241- new upstream release
242- updated build dependancies
243- rebuilt with libgsf-1.14.0
244- built with libgda and libgnomedb again
245
246* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
247- new upstream release
248- updated build dependancies
249- not compile with libgda and libgnomedb in this version
250
251* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
252- new upstream release
253
254* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
255- rebuild with libgda 1.2.0 and libgnome 1.2.0
256
257* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
258- new upstream release
259
260* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
261- new upstream release
262
263* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
264- new upstream release
265
266* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
267- rebuild with gnome-2.8 environment and libgsf-1.10.1
268
269* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
270- new upstream release
271- added BuildRequires: desktop-file-utils
272
273* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
274- new upstream release
275- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
276
277* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
278- new upstream release
279
280* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
281- new upstream release
282
283* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
284- new upstream release
285
286* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
287- new upstream release
288
289* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
290- new upstream release
291- clean up spec file (a little bit!)
292
293* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
294- new upstream release
295
296* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
297- new upstream release
298- to use intltool-0.28
299
300* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
301- new upstream release
302- rebuild with new toolchains
303
304* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
305- new upstream release
306- build with new libgnomeprint, libgnomeprintui
307
308* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
309- new upstream release
310
311* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
312- rebuild with newer libgda, libgnomedb
313
314* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
315- updated to 1.2.0 (stable release)
316- guile support is temporarily off this version.
317
318* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
319- update to 1.1.20 (gtk+-2 port)
320- based on Redhat Rawhide 1.1.20-1
321
322* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
323- update to 1.0.13
324- rebuild with gal 0.24
325
326* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
327- guile support on
328- rebuild with new gal, bonobo, libgda
329
330* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
331- New upstream release, remove xmliobackward.patch
332
333* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
334- xml-io back to 1.0.10 because japanese corrups with new xml_parser
335
336* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
337- New upstream release, fix for xml importing files with non ASCII characters.
338- Without guile, changelog.archive, requires, build scripts, description
339
340* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
341- files: add gnumericConf.sh, which was missing
342
343* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
344- New upstream release.
345- BuildPrereq oaf-devel
346
347* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
348- New upstream release.
349
350* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
351- New upstream release.
352- Default font and Japanese fonts in excel
353- requires
354
355* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
356- New upstream release.
357- fixed plugins, apply patch2, remove patch3
358- files - no longer devel package
359- function-reference.html in help file
360
361* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
362- New upstream release.
363
364* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
365- New upstream release.
366- Fixed several owner dir.
367
368* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
369- Build against with new gal
370
371* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
372- New upstream release.
373
374* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
375- New upstream release.
376
377* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
378- New upstream release.
379- Applied XIM over-the-spot patch.
380- Fixed directories owner.
381
382* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
383- New upstream release.
384- Enable Bonobo.
385- Merged several RH patches.
386- Added BuildPreReq tags.
387
388* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
389- Fixed packaging mistake.
390
391* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
392- Rebuild for GAL 0.7
393
394* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
395- New upstream release.
396- Use rpmmacros.
397
398* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
399- 0.56-0vl2
400- update ja.po
401- avoid core dump when inserting a row
402
403* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
404- updated to 0.56
405- remake spec with the orginal gnumeric spec file.
406- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
407
408* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
409- updated to 0.53
410- remake SPEC based on gnumeric original.
411- added libxml183 patch for libxml 1.8.3
412
413* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
414- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
415- Added --without-bonobo and --without-gb.
416- Added %define for sysconfdir
417
418* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
419- Updated version requirements for gnome-print, and gnome-libs.
420
421* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
422- Added in some auto-detect the language files logic (rpm 3.0.xx only)
423
424* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
425- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
426
427* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
428- Updated to 0.47
429
430* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
431- Updated the libglade dependancy.
432- Remove req for guile.  We can build without it.
433
434* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
435- Added small fix so glade generated dialogs appear.
436
437* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
438- Added the gnome-print requirement.
439- Updated the file list to try and quiet down the updating.
440- added the sysconfdir
441
442* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
443- Updated the spec file.
444
445* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
446- Version 0.2
447
Note: See TracBrowser for help on using the repository browser.