source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 1583

Revision 1583, 14.0 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release and NEW:libpanelappletmm

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.8
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.8
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Distribution: Vine Linux
17Vendor: Project Vine
18
19BuildRequires: gtk2-devel >= 2.10.0
20BuildRequires: libglade2-devel >= 2.3.6
21BuildRequires: libgnomeprint-devel >= 2.8.2
22BuildRequires: libgnomeprintui-devel >= 2.8.2
23BuildRequires: libart_lgpl-devel >= 2.3.11
24BuildRequires: libxml2-devel >= 2.4.12
25BuildRequires: libgsf-devel >= 1.13.2
26BuildRequires: goffice-devel >= %{goffice_version}
27BuildRequires: libbonobo-devel libgnomeui-devel
28BuildRequires: libffi-devel
29#BuildPreReq: libgda-devel >= 1.9.100
30#BuildPreReq: libgnomedb-devel >= 1.9.100
31BuildRequires: perl python-devel
32BuildRequires: automake autoconf libtool docbook-utils
33BuildRequires: intltool >= 0.28 desktop-file-utils
34BuildRequires: libSM-devel
35Requires:    gtk2 >= 2.10.0
36Requires:    libglade2 >= 2.3.6
37Requires:    libgnomeprint >= 2.8.2
38Requires:    libgnomeprintui >= 2.8.2
39Requires:    libgsf >= 1.14.6
40Requires:    perl python
41Requires:    GConf2 scrollkeeper
42
43# no longer devel package
44#Provides:   %{name}-devel
45Obsoletes:  %{name}-devel
46
47%description
48GNOME (GNU Network Object Model Environment) is a user-friendly set of
49applications and desktop tools to be used in conjunction with a window
50manager for the X Window System.
51
52This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
53replacement for commercial spreadsheets.  It provides import/export from
54MS Excel files and many other formats (csv, latex, xbase, applix).
55
56%description -l ja
57GNOME (GNU Network Object Model Environment)は
58Xウィンドウシステム用の、ウィンドウマネージャと連結した
59GUIアプリケーションおよびデスクトップツールのセットです。
60
61これは Gnumeric, GNOMEスプレッドシート・プログラムです。
62商用のスプレッドシート・プログラムを代替できるものを目指しています。
63MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
64を読込み、出力できます.
65
66
67# %package devel
68#Summary:       Files necessary to develop gnumeric-based applications.
69#Group:         Development/Libraries
70#Requires:      %{name} = %{PACKAGE_VERSION}
71
72#%#description devel
73#The gnumeric-devel package includes files necessary to develop gnumeric-based
74#applications.
75
76#Install gnumeric-devel if you want to develop programs which will use gnumeric.
77
78%prep
79%setup -q
80
81%build
82%ifarch alpha
83        MYARCH_FLAGS="--host=alpha-redhat-linux"
84%endif
85export mllibname=%{_lib}
86%configure --with-gnome \
87    --with-gda --without-gb --with-perl --with-python \
88    --disable-schemas-install
89make
90
91%install
92[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
93
94export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
95make DESTDIR=$RPM_BUILD_ROOT install
96unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
97
98./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
99desktop-file-install --vendor gnome --delete-original                   \
100  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
101  --add-category X-Red-Hat-Extra                                        \
102  --add-category Office                                                 \
103  --add-category Application                                            \
104  --add-category Spreadsheet                                            \
105  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
106
107%find_lang %{name}
108%find_lang %{name}-functions
109cat %{name}-functions.lang >> %{name}.lang
110
111rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
112rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
113rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
115rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
116
117%clean
118[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122
123scrollkeeper-update > /dev/null 2>&1 || :
124export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
126
127touch --no-create %{_datadir}/icons/hicolor || :
128if [ -x %{_bindir}/gtk-update-icon-cache ]; then
129   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132%pre
133if [ "$1" -gt 1 ]; then
134    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135    gconftool-2 --makefile-uninstall-rule \
136        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
137fi
138
139%preun
140if [ "$1" -eq 0 ]; then
141    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142    gconftool-2 --makefile-uninstall-rule \
143        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
144fi
145
146%postun
147/sbin/ldconfig
148scrollkeeper-update > /dev/null 2>&1 || :
149
150touch --no-create %{_datadir}/icons/hicolor || :
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
153fi
154
155
156%files -f %{name}.lang
157%defattr (-, root, root)
158%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
159%config %{_sysconfdir}/gconf/schemas/*
160%{_bindir}/*
161%{_libdir}/lib*.so*
162%{_libdir}/gnumeric
163%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
164#{_libdir}/bonobo/servers/*
165%{_datadir}/applications/*.desktop
166%{_datadir}/gnome/help/gnumeric
167%{_datadir}/gnumeric
168%{_datadir}/pixmaps/*
169#{_datadir}/mime-info/*
170#{_datadir}/mc/templates/*
171%{_datadir}/omf/*
172%{_datadir}/icons/hicolor/*
173%{_mandir}/man*/*
174%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
175
176#%{_libexecdir}/gnumeric-component
177#%#dir %{_libdir}/gnumeric
178#%#dir %{_libdir}/gnumeric/%{bonobover}
179#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
180#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
181# This is really silly.  The .la files are useless for plugins.
182#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
183#%#{_libdir}/gnumericConf.sh
184#%#if %{bonobo}
185#%#dir %{_datadir}/gnumeric
186#%#dir %{_datadir}/gnumeric/%{bonobover}
187#%#{_datadir}/gnumeric/%{bonobover}/idl
188#%#endif
189
190
191%changelog
192* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
193- new upstream release
194
195* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
196- new upstream release
197
198* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
199- new upstream release
200- fix %post and %postun
201
202* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
203- new upstream release
204
205* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
206- new upstream release
207- add BuildRequires: libSM-devel
208- fix BuildRequires: goffice-devel >= 0.8.1
209
210* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
211- spec in UTF-8 (fixed)
212
213* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
214- spec in UTF-8
215- added BuildRequires: libffi-devel
216- added %%pre, %%preun section
217
218* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
219- new upstream release
220- built with libgda-3.1.4, libgnomedb-3.1.2
221- applied new versioning policy
222
223* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
224- new upstream release
225
226* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
227- rebuild
228
229* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
230- new upstream release
231
232* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
233- new upstream release
234- updated build dependancies
235- rebuilt with libgsf-1.14.0
236- built with libgda and libgnomedb again
237
238* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
239- new upstream release
240- updated build dependancies
241- not compile with libgda and libgnomedb in this version
242
243* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
244- new upstream release
245
246* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
247- rebuild with libgda 1.2.0 and libgnome 1.2.0
248
249* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
250- new upstream release
251
252* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
253- new upstream release
254
255* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
256- new upstream release
257
258* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
259- rebuild with gnome-2.8 environment and libgsf-1.10.1
260
261* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
262- new upstream release
263- added BuildRequires: desktop-file-utils
264
265* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
266- new upstream release
267- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
268
269* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
270- new upstream release
271
272* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
273- new upstream release
274
275* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
276- new upstream release
277
278* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
279- new upstream release
280
281* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
282- new upstream release
283- clean up spec file (a little bit!)
284
285* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
286- new upstream release
287
288* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
289- new upstream release
290- to use intltool-0.28
291
292* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
293- new upstream release
294- rebuild with new toolchains
295
296* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
297- new upstream release
298- build with new libgnomeprint, libgnomeprintui
299
300* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
301- new upstream release
302
303* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
304- rebuild with newer libgda, libgnomedb
305
306* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
307- updated to 1.2.0 (stable release)
308- guile support is temporarily off this version.
309
310* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
311- update to 1.1.20 (gtk+-2 port)
312- based on Redhat Rawhide 1.1.20-1
313
314* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
315- update to 1.0.13
316- rebuild with gal 0.24
317
318* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
319- guile support on
320- rebuild with new gal, bonobo, libgda
321
322* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
323- New upstream release, remove xmliobackward.patch
324
325* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
326- xml-io back to 1.0.10 because japanese corrups with new xml_parser
327
328* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
329- New upstream release, fix for xml importing files with non ASCII characters.
330- Without guile, changelog.archive, requires, build scripts, description
331
332* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
333- files: add gnumericConf.sh, which was missing
334
335* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
336- New upstream release.
337- BuildPrereq oaf-devel
338
339* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
340- New upstream release.
341
342* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
343- New upstream release.
344- Default font and Japanese fonts in excel
345- requires
346
347* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
348- New upstream release.
349- fixed plugins, apply patch2, remove patch3
350- files - no longer devel package
351- function-reference.html in help file
352
353* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
354- New upstream release.
355
356* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
357- New upstream release.
358- Fixed several owner dir.
359
360* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
361- Build against with new gal
362
363* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
364- New upstream release.
365
366* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
367- New upstream release.
368
369* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
370- New upstream release.
371- Applied XIM over-the-spot patch.
372- Fixed directories owner.
373
374* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
375- New upstream release.
376- Enable Bonobo.
377- Merged several RH patches.
378- Added BuildPreReq tags.
379
380* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
381- Fixed packaging mistake.
382
383* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
384- Rebuild for GAL 0.7
385
386* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
387- New upstream release.
388- Use rpmmacros.
389
390* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
391- 0.56-0vl2
392- update ja.po
393- avoid core dump when inserting a row
394
395* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
396- updated to 0.56
397- remake spec with the orginal gnumeric spec file.
398- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
399
400* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
401- updated to 0.53
402- remake SPEC based on gnumeric original.
403- added libxml183 patch for libxml 1.8.3
404
405* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
406- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
407- Added --without-bonobo and --without-gb.
408- Added %define for sysconfdir
409
410* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
411- Updated version requirements for gnome-print, and gnome-libs.
412
413* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
414- Added in some auto-detect the language files logic (rpm 3.0.xx only)
415
416* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
417- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
418
419* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
420- Updated to 0.47
421
422* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
423- Updated the libglade dependancy.
424- Remove req for guile.  We can build without it.
425
426* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
427- Added small fix so glade generated dialogs appear.
428
429* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
430- Added the gnome-print requirement.
431- Updated the file list to try and quiet down the updating.
432- added the sysconfdir
433
434* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
435- Updated the spec file.
436
437* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
438- Version 0.2
439
Note: See TracBrowser for help on using the repository browser.