source: projects/specs/trunk/g/gnumeric/gnumeric-vl.spec @ 1401

Revision 1401, 13.9 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define gnumeric_version %{version}-bonobo
2%define goffice_version  0.8.7
3
4Summary:     A spreadsheet program for GNOME.
5Summary(ja): GNOME スプレッドシート
6Name:        gnumeric
7Version:     1.10.7
8Release:     1%{?_dist_release}
9License:     GPLv2
10Group:       Applications/Productivity
11
12URL:      http://www.gnome.org/projects/gnumeric
13Source:   ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.8/%{name}-%{version}.tar.bz2
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16Distribution: Vine Linux
17Vendor: Project Vine
18
19BuildRequires: gtk2-devel >= 2.10.0
20BuildRequires: libglade2-devel >= 2.3.6
21BuildRequires: libgnomeprint-devel >= 2.8.2
22BuildRequires: libgnomeprintui-devel >= 2.8.2
23BuildRequires: libart_lgpl-devel >= 2.3.11
24BuildRequires: libxml2-devel >= 2.4.12
25BuildRequires: libgsf-devel >= 1.13.2
26BuildRequires: goffice-devel >= %{goffice_version}
27BuildRequires: libbonobo-devel libgnomeui-devel
28BuildRequires: libffi-devel
29#BuildPreReq: libgda-devel >= 1.9.100
30#BuildPreReq: libgnomedb-devel >= 1.9.100
31BuildRequires: perl python-devel
32BuildRequires: automake autoconf libtool docbook-utils
33BuildRequires: intltool >= 0.28 desktop-file-utils
34BuildRequires: libSM-devel
35Requires:    gtk2 >= 2.10.0
36Requires:    libglade2 >= 2.3.6
37Requires:    libgnomeprint >= 2.8.2
38Requires:    libgnomeprintui >= 2.8.2
39Requires:    libgsf >= 1.14.6
40Requires:    perl python
41Requires:    GConf2 scrollkeeper
42
43# no longer devel package
44#Provides:   %{name}-devel
45Obsoletes:  %{name}-devel
46
47%description
48GNOME (GNU Network Object Model Environment) is a user-friendly set of
49applications and desktop tools to be used in conjunction with a window
50manager for the X Window System.
51
52This is the Gnumeric, a spreadsheet for GNOME.  It aims to be a drop in
53replacement for commercial spreadsheets.  It provides import/export from
54MS Excel files and many other formats (csv, latex, xbase, applix).
55
56%description -l ja
57GNOME (GNU Network Object Model Environment)は
58Xウィンドウシステム用の、ウィンドウマネージャと連結した
59GUIアプリケーションおよびデスクトップツールのセットです。
60
61これは Gnumeric, GNOMEスプレッドシート・プログラムです。
62商用のスプレッドシート・プログラムを代替できるものを目指しています。
63MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
64を読込み、出力できます.
65
66
67# %package devel
68#Summary:       Files necessary to develop gnumeric-based applications.
69#Group:         Development/Libraries
70#Requires:      %{name} = %{PACKAGE_VERSION}
71
72#%#description devel
73#The gnumeric-devel package includes files necessary to develop gnumeric-based
74#applications.
75
76#Install gnumeric-devel if you want to develop programs which will use gnumeric.
77
78%prep
79%setup -q
80
81%build
82%ifarch alpha
83        MYARCH_FLAGS="--host=alpha-redhat-linux"
84%endif
85export mllibname=%{_lib}
86%configure --with-gnome \
87    --with-gda --without-gb --with-perl --with-python \
88    --disable-schemas-install
89make
90
91%install
92[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
93
94export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
95make DESTDIR=$RPM_BUILD_ROOT install
96unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
97
98./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
99desktop-file-install --vendor gnome --delete-original                   \
100  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
101  --add-category X-Red-Hat-Extra                                        \
102  --add-category Office                                                 \
103  --add-category Application                                            \
104  --add-category Spreadsheet                                            \
105  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
106
107%find_lang %{name}
108%find_lang %{name}-functions
109cat %{name}-functions.lang >> %{name}.lang
110
111rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
112rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
113rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
115rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
116
117%clean
118[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
119
120%post
121/sbin/ldconfig
122
123scrollkeeper-update > /dev/null 2>&1 || :
124export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
126
127touch --no-create %{_datadir}/icons/hicolor || :
128if [ -x %{_bindir}/gtk-update-icon-cache ]; then
129   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
130fi
131
132%pre
133if [ "$1" -gt 1 ]; then
134    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135    gconftool-2 --makefile-uninstall-rule \
136        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
137fi
138
139%preun
140if [ "$1" -eq 0 ]; then
141    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142    gconftool-2 --makefile-uninstall-rule \
143        %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
144fi
145
146%postun
147/sbin/ldconfig
148scrollkeeper-update > /dev/null 2>&1 || :
149
150touch --no-create %{_datadir}/icons/hicolor || :
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
153fi
154
155
156%files -f %{name}.lang
157%defattr (-, root, root)
158%doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
159%config %{_sysconfdir}/gconf/schemas/*
160%{_bindir}/*
161%{_libdir}/lib*.so*
162%{_libdir}/gnumeric
163%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
164#{_libdir}/bonobo/servers/*
165%{_datadir}/applications/*.desktop
166%{_datadir}/gnome/help/gnumeric
167%{_datadir}/gnumeric
168%{_datadir}/pixmaps/*
169#{_datadir}/mime-info/*
170#{_datadir}/mc/templates/*
171%{_datadir}/omf/*
172%{_datadir}/icons/hicolor/*
173%{_mandir}/man*/*
174%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
175
176#%{_libexecdir}/gnumeric-component
177#%#dir %{_libdir}/gnumeric
178#%#dir %{_libdir}/gnumeric/%{bonobover}
179#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
180#%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
181# This is really silly.  The .la files are useless for plugins.
182#%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
183#%#{_libdir}/gnumericConf.sh
184#%#if %{bonobo}
185#%#dir %{_datadir}/gnumeric
186#%#dir %{_datadir}/gnumeric/%{bonobover}
187#%#{_datadir}/gnumeric/%{bonobover}/idl
188#%#endif
189
190
191%changelog
192* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
193- new upstream release
194
195* Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
196- new upstream release
197- fix %post and %postun
198
199* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
200- new upstream release
201
202* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
203- new upstream release
204- add BuildRequires: libSM-devel
205- fix BuildRequires: goffice-devel >= 0.8.1
206
207* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
208- spec in UTF-8 (fixed)
209
210* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
211- spec in UTF-8
212- added BuildRequires: libffi-devel
213- added %%pre, %%preun section
214
215* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
216- new upstream release
217- built with libgda-3.1.4, libgnomedb-3.1.2
218- applied new versioning policy
219
220* Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
221- new upstream release
222
223* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
224- rebuild
225
226* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
227- new upstream release
228
229* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
230- new upstream release
231- updated build dependancies
232- rebuilt with libgsf-1.14.0
233- built with libgda and libgnomedb again
234
235* Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
236- new upstream release
237- updated build dependancies
238- not compile with libgda and libgnomedb in this version
239
240* Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
241- new upstream release
242
243* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
244- rebuild with libgda 1.2.0 and libgnome 1.2.0
245
246* Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
247- new upstream release
248
249* Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
250- new upstream release
251
252* Thu Dec  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
253- new upstream release
254
255* Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
256- rebuild with gnome-2.8 environment and libgsf-1.10.1
257
258* Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
259- new upstream release
260- added BuildRequires: desktop-file-utils
261
262* Thu May  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
263- new upstream release
264- Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
265
266* Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
267- new upstream release
268
269* Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
270- new upstream release
271
272* Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
273- new upstream release
274
275* Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
276- new upstream release
277
278* Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
279- new upstream release
280- clean up spec file (a little bit!)
281
282* Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
283- new upstream release
284
285* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
286- new upstream release
287- to use intltool-0.28
288
289* Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
290- new upstream release
291- rebuild with new toolchains
292
293* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
294- new upstream release
295- build with new libgnomeprint, libgnomeprintui
296
297* Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
298- new upstream release
299
300* Thu Oct  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
301- rebuild with newer libgda, libgnomedb
302
303* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
304- updated to 1.2.0 (stable release)
305- guile support is temporarily off this version.
306
307* Mon Sep  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
308- update to 1.1.20 (gtk+-2 port)
309- based on Redhat Rawhide 1.1.20-1
310
311* Thu May  1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
312- update to 1.0.13
313- rebuild with gal 0.24
314
315* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
316- guile support on
317- rebuild with new gal, bonobo, libgda
318
319* Fri Feb  7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
320- New upstream release, remove xmliobackward.patch
321
322* Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
323- xml-io back to 1.0.10 because japanese corrups with new xml_parser
324
325* Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
326- New upstream release, fix for xml importing files with non ASCII characters.
327- Without guile, changelog.archive, requires, build scripts, description
328
329* Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
330- files: add gnumericConf.sh, which was missing
331
332* Mon Nov  4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
333- New upstream release.
334- BuildPrereq oaf-devel
335
336* Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
337- New upstream release.
338
339* Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
340- New upstream release.
341- Default font and Japanese fonts in excel
342- requires
343
344* Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
345- New upstream release.
346- fixed plugins, apply patch2, remove patch3
347- files - no longer devel package
348- function-reference.html in help file
349
350* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
351- New upstream release.
352
353* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
354- New upstream release.
355- Fixed several owner dir.
356
357* Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
358- Build against with new gal
359
360* Mon Jan  7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
361- New upstream release.
362
363* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
364- New upstream release.
365
366* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
367- New upstream release.
368- Applied XIM over-the-spot patch.
369- Fixed directories owner.
370
371* Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
372- New upstream release.
373- Enable Bonobo.
374- Merged several RH patches.
375- Added BuildPreReq tags.
376
377* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
378- Fixed packaging mistake.
379
380* Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
381- Rebuild for GAL 0.7
382
383* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
384- New upstream release.
385- Use rpmmacros.
386
387* Mon Feb  5 2001 Jun Nishii <jun@vinelinux.org>
388- 0.56-0vl2
389- update ja.po
390- avoid core dump when inserting a row
391
392* Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
393- updated to 0.56
394- remake spec with the orginal gnumeric spec file.
395- added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
396
397* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
398- updated to 0.53
399- remake SPEC based on gnumeric original.
400- added libxml183 patch for libxml 1.8.3
401
402* Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
403- Removed gnome-gnumeric-xl.png since it is nowhere to be found.
404- Added --without-bonobo and --without-gb.
405- Added %define for sysconfdir
406
407* Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
408- Updated version requirements for gnome-print, and gnome-libs.
409
410* Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
411- Added in some auto-detect the language files logic (rpm 3.0.xx only)
412
413* Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
414- Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
415
416* Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
417- Updated to 0.47
418
419* Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
420- Updated the libglade dependancy.
421- Remove req for guile.  We can build without it.
422
423* Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
424- Added small fix so glade generated dialogs appear.
425
426* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
427- Added the gnome-print requirement.
428- Updated the file list to try and quiet down the updating.
429- added the sysconfdir
430
431* Tue Mar 9  1999 Gregory McLean <gregm@comstar.net>
432- Updated the spec file.
433
434* Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
435- Version 0.2
436
Note: See TracBrowser for help on using the repository browser.