source: projects/specs/trunk/g/gnucash/gnucash-vl.spec @ 9487

Revision 9487, 8.3 KB checked in by Takemikaduchi, 9 years ago (diff)

libgit2: add BR
libgit2-glib: rebuild
gitg, http-parser: new package
audit: create compat32 package
others: new upstream release

Line 
1%define ver 2.6.6
2%define rel 1%{?_dist_release}
3%define __libtoolize /bin/true
4
5Name:           gnucash
6Summary:        GnuCash is an application to keep track of your finances.
7Summary(ja):    個人用財務管理アプリケーション
8Version:        %{ver}
9Release:        %{rel}
10
11License:        GPL/LGPL/GFDL
12Group:          Applications/Productivity
13URL:            http://www.gnucash.org/
14
15Source:         %{name}-%{version}.tar.bz2
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires: aqbanking-devel >= 3.7.2
19BuildRequires: bzip2-devel
20BuildRequires: expat-devel
21BuildRequires: gettext
22BuildRequires: goffice08-devel >= 0.8
23BuildRequires: gtk2-devel
24BuildRequires: WebKit-gtk-devel
25BuildRequires: guile-devel
26BuildRequires: libofx-devel
27BuildRequires: libgnomeui-devel
28BuildRequires: libdbi-devel
29BuildRequires: libjpeg-devel
30BuildRequires: libtool-ltdl-devel
31BuildRequires: pcre-devel
32BuildRequires: popt-devel
33BuildRequires: swig
34#BuildRequires: slib
35BuildRequires: gwenhywfar-devel
36BuildRequires: desktop-file-utils
37
38BuildRequires: libdbi-dbd-pgsql
39BuildRequires: libdbi-dbd-mysql
40BuildRequires: libdbi-dbd-sqlite
41
42Requires:      aqbanking
43Requires:      perl-DateManip
44Requires:      yelp
45Requires(post,postun): gtk2
46Requires(postun,posttrans): glib2
47Obsoletes:     gnucash-backend-postgres
48
49Vendor:        Project Vine
50Distribution:  Vine Linux
51Packager:      kenta, inagaki
52
53
54%description
55GnuCash is a personal finance manager. A check-book like
56register GUI allows you to enter and track bank accounts,
57stocks, income and even currency trades. The interface is
58designed to be simple and easy to use, but is backed with
59double-entry accounting principles to ensure balanced books.
60
61%description -l ja
62GnuCashは 個人用財務管理をするアプリケーションです.
63預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
64グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
65使用できるようにデザインされています.
66
67%prep
68%setup -q
69
70%build
71%configure \
72                --enable-error-on-warning=no \
73                --disable-sql \
74                --enable-ofx  \
75                --enable-aqbanking \
76                --disable-static \
77                --enable-dbi \
78                --with-html-engine=webkit \
79                --docdir=%{_datadir}/doc/gnucash-%{version}
80
81make LIBTOOL=%{_bindir}/libtool
82
83%configure
84make
85
86
87%install
88[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
89
90make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
91
92%find_lang %name
93
94# vfolder desktop file install stuff
95mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
96desktop-file-install --vendor gnome --delete-original \
97  --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
98  --add-category X-Red-Hat-Extra                      \
99  --add-category Application                          \
100  --add-category Office                               \
101  $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
102echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
103
104rm -rf $RPM_BUILD_ROOT/%{_infodir} \
105       $RPM_BUILD_ROOT/%{_includedir} \
106       $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
107       $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
108
109%clean
110[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
111
112
113%post
114/sbin/ldconfig
115touch --no-create %{_datadir}/icons/hicolor || :
116gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
117
118%postun
119if [ $1 -eq 0 ] ; then
120        /sbin/ldconfig
121        touch --no-create %{_datadir}/icons/hicolor || :
122        gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
123        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
124fi
125
126%posttrans
127glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
128
129%files -f %{name}.lang
130%defattr(-,root,root,755)
131%config %{_sysconfdir}/%{name}
132%{_bindir}/*
133%{_libexecdir}/%{name}
134%{_libdir}/*
135%{_datadir}/appdata/%{name}.appdata.xml
136%{_datadir}/applications/*
137%{_datadir}/glib-2.0/schemas/*.xml
138%{_datadir}/%{name}
139%{_datadir}/icons/hicolor/*/apps/*
140%{_docdir}/%{name}
141%{_mandir}/man*/*
142%doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
143%doc doc/README.german doc/README.francais doc/guile-hackers.txt
144%doc doc/README.OFX
145
146%changelog
147* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
148- new upstream release
149- add BuildRequires: libtool-ltdl-devel
150
151* Mon Mar  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
152- rebuilt with libofx 0.9.10
153- added Vendor and Distribution tag
154
155* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
156- update to 2.6.5
157- remove old patches
158- add BuildRequires: libdbi-devel
159- change BuildRequires: goffice08-devel instead of goffice-devel
160
161* Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
162- rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
163- added Patch1 for building with aqbanking-4.2.4
164- added Patch2 for building with goffice-0.8.10
165
166* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
167- added slib to BuildRequires: and Requires:
168
169* Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
170- new upstream release
171
172* Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
173- new upstream release
174
175* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
176- rebuild with guile-1.8.6
177- add BuildRequires: gwenhywfar-devel
178
179* Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
180- new upstream release
181- applied new versioning policy
182- built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
183
184* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
185- new upstream release
186- rebuilt with goffice-0.6.0
187
188* Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
189- new upstream release
190
191* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
192- new upstream release
193- enable HBCI (Home Banking Computer Interface)
194
195* Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
196- rebuild with libofx-0.8.3 (libofx.so.3)
197
198* Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
199- new upstream release
200- disable postgresql backend, as it is unmaintained upstream
201- added Patch0: gnucash-2.2.0-quiet.patch
202
203* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
204- new upstream release
205- remove BuildRequiers: autoconf213
206- update ja.po
207
208* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
209- new upstream release
210- added BuildPrereq: libtool-ltdl-devel
211
212* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
213- rebuild with new toolchains
214- update ja.po
215
216* Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
217- new upstream release
218
219* Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
220- merged gnucash-docs-1.8.3
221- added patch from Redhat Rawhide 1.8.7-1
222- changed Group, License
223
224* Mon Oct  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
225- updated to 1.8.7
226- updated print.patch
227- overwrite prefs.scm
228- s/Copyright/License/
229
230* Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
231- updated to 1.8.3
232- added datelength.patch
233- separated devel packages
234  (and ofx, hbci, backend-postgres. But default is off)
235
236* Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
237- Build against with new gal.
238
239* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
240- Fixed printing issue.
241
242* Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
243- New upstream release.
244
245* Thu Jul 26 2001 <sagami@vinelinux.org>
246- 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
247
248* Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
249- %%make line is now commented out (bash2 complains it)
250  (BTW, what the hell is the macro %%make anyway? I don't even know...)
251
252* Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
253- update to 1.6.0 (stable release version)
254
255* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
256- update to 1.5.96 ( pre beta for 1.6.0 )
257
258* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
259- added japanese patch for reporting and printing (thanx tagoh-san)
260
261* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
262- updated to 1.5.6
263
264* Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
265- added translation messages to ja.po
266- enable guppi
267
268* Mon Apr  2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
269- upstream update
270- fixed broken ja.po
271
272* Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
273- fixed registor window cursor position problem(gnucash-cursor_pos.patch)
274
275* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
276- initial relese package
Note: See TracBrowser for help on using the repository browser.